The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"2 провайдера, через route-map. Где грабли?"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]

"2 провайдера, через route-map. Где грабли?"  +/
Сообщение от vdenxv (ok) on 25-Апр-10, 06:57 
Есть Cisco 2821
В сети есть две группы пользователей, их надо выпускать наружу по разным каналам.
Делаю все как по инструкции (в том числе и с этого форума):

interface Giga 0/0
ip address 192.168.0.1 255.255.255.0
ip nat inside
!
interface vlan 101
ip address ISP1
ip nat outside
!
interface vlan 102
ip address ISP2
ip nat outside
!
ip route 0.0.0.0 0.0.0.0 ISP1_GW
!
ip nat pool ISP1ADDR ISP1ADDR 255.255.255.252
ip nat pool ISP2ADDR ISP2ADDR 255.255.255.252
ip nat inside source route-map TO_ISP1 pool ISP1ADDR overload
ip nat inside source route-map TO_ISP2 pool ISP2ADDR overload
!
route-map TO_ISP1
match ip address Test1
set ip default next-hop ISP1_GW
!
route-map TO_ISP2
match ip address Test2
set ip default next-hop ISP2_GW

Списки доступа Test1 и Test2 соответственно группы клиентов для первого и второго провайдера.

Так вот NAT отрабатывает нормально, создаются правильные трансляции.
НО! все что предназначено первому провайдеру работает нормально. А вот клиенты из списка для второго провайдера не могут выйти в интернет.
При анализе трафика выяснилось что после NAT на pool TO_ISP2 пакет с адресом ISP2 отправляется на дефольтный маршрут (то есть на ISP1_GW).
Получается что set ip default next-hop ISP2_GW не срабатывает.
Вот собственно и вопрос - ПОЧЕМУ??? что нужно сделать чтобы эта схема заработала?

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "2 провайдера, через route-map. Где грабли?"  +/
Сообщение от Pve1 (ok) on 25-Апр-10, 22:50 
1.) Роутмап должен быть один, и выглядеть примерно так:

route-map TO_ISP permit 10
  match ip address Test1
  set ip default next-hop ISP1_GW
route-map TO_ISP permit 20
  match ip address Test2
  set ip default next-hop ISP2_GW

2.) Роутмап, как и аксесс-лист - мало написать. Его еще надо и как то применить.
В вашем случае так:

interface Giga 0/0     // Т.е. входящий интерфейс.
  ip policy route-map TO_ISP


Как то так)

Здесь можно почитать как привязать к роутмапам ip sla - для автоматического трекинга доступности провайдеров и аварийного переключения:
http://www.anticisco.ru/pubs/DualISPRouter.pdf

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "2 провайдера, через route-map. Где грабли?"  +/
Сообщение от vdenxv (ok) on 26-Апр-10, 02:23 
>1.) Роутмап должен быть один, и выглядеть примерно так:

Не совсем верно. Получается что их два, один полноценный применяемый для Интерфейса и один ущербный, применяемый в ip nat inside.
>
>route-map TO_ISP permit 10
>  match ip address Test1
>  set ip default next-hop ISP1_GW
>route-map TO_ISP permit 20
>  match ip address Test2
>  set ip default next-hop ISP2_GW

Да, после такой реализации все пошло куда надо!
>
>Здесь можно почитать как привязать к роутмапам ip sla - для автоматического
>трекинга доступности провайдеров и аварийного переключения:
>http://www.anticisco.ru/pubs/DualISPRouter.pdf

Очень полезный мануал, а главное ничего лишнего, очень помогло! Спасибо!
Наткнулся бы раньше и вопросов не возникло-бы.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру