The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Резервирование канала"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]

"Резервирование канала"  +/
Сообщение от walterwest7 (ok) on 24-Май-10, 08:07 
Здравсвтуйте,
делаю резервирование канала
track 1 ip sla 10 reachability
track 2 ip sla 20 reachability
ip route 0.0.0.0 0.0.0.0 10.10.10.1 track 1
ip route 0.0.0.0 0.0.0.0 10.10.20.1 track 2
ip sla 10
icmp-echo 10.10.10.1 source-ip 10.10.10.2
frequency 20
ip sla schedule 10 life forever start-time now
ip sla 20
icmp-echo 10.10.20.1 source-ip 10.10.20.2
frequency 20
ip sla schedule 20 life forever start-time now
Если один канал падает, второй поднимается, подскажите пожалуйста как сделать чтобы в случае востанавления первого, он становился основным,
Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Резервирование канала"  +/
Сообщение от druidman (ok) on 24-Май-10, 08:24 
>[оверквотинг удален]
>ip sla 10
> icmp-echo 10.10.10.1 source-ip 10.10.10.2
> frequency 20
>ip sla schedule 10 life forever start-time now
>ip sla 20
> icmp-echo 10.10.20.1 source-ip 10.10.20.2
> frequency 20
>ip sla schedule 20 life forever start-time now
>Если один канал падает, второй поднимается, подскажите пожалуйста как сделать чтобы в
>случае востанавления первого, он становился основным,

Пропиши AD в маршрутах


ip route 0.0.0.0 0.0.0.0 10.10.10.1 50 track 1
ip route 0.0.0.0 0.0.0.0 10.10.20.1 100 track 2

Маршрут с меньшим AD приоритетнее

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "Резервирование канала"  +/
Сообщение от sh_ email(ok) on 24-Май-10, 12:15 
Да. И по-моему достаточно одного track.
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "Резервирование канала"  +/
Сообщение от walterwest7 (ok) on 25-Май-10, 07:06 
Спасибо, работает.
А как правильно сделать переключение NAT с одного пула на другое в таком случае?
Если через #clear ip nat translation * рвуться существующие конекты.
Предлагают еще по событию менять route mapы.
Может быть есть более правильный метод?


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

4. "Резервирование канала"  +/
Сообщение от druidman (ok) on 25-Май-10, 07:46 
>Спасибо, работает.
>А как правильно сделать переключение NAT с одного пула на другое в
>таком случае?
>Если через #clear ip nat translation * рвуться существующие конекты.
>Предлагают еще по событию менять route mapы.
>Может быть есть более правильный метод?

Коннекты в любом случае будут рваться ... потому что, меняется ip адрес. А на удаленной машине процедура tcp рукопожатия уже пройдена для этого ip.

Nat не должен переключатся от смены роута ... точнее трансляция должна зависеть от того, через какой интерфейс уходит пакет...а решение об этом принимается в таблице маршрутизации.

делается это через route map:


ip nat source route-map ISP1-NAT interface FastEthernet0/0 overload
ip nat source route-map ISP2-NAT interface FastEthernet0/1 overload


ip access-list extended ACL-FOR-NAT
permit ip "local-net and local mask" any


route-map ISP1-NAT permit 10
match ip address ACL-FOR-NAT
match interface FastEthernet0/0
!
route-map ISP2-NAT permit 10
match ip address ACL-FOR-NAT
match interface FastEthernet0/1

список доступа ACL-FOR-NAT - может быть более детален - в зависимости от потребностей

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

5. "Резервирование канала"  +/
Сообщение от walterwest7 (ok) on 25-Май-10, 08:09 

>[оверквотинг удален]
>route-map ISP1-NAT permit 10
> match ip address ACL-FOR-NAT
> match interface FastEthernet0/0
>!
>route-map ISP2-NAT permit 10
> match ip address ACL-FOR-NAT
> match interface FastEthernet0/1
>
>список доступа ACL-FOR-NAT - может быть более детален - в зависимости от
>потребностей

А как сюда привязать пул адресов, с которым должна натится внутреняя сеть?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

6. "Резервирование канала"  +/
Сообщение от druidman (ok) on 25-Май-10, 08:46 
>[оверквотинг удален]
>>!
>>route-map ISP2-NAT permit 10
>> match ip address ACL-FOR-NAT
>> match interface FastEthernet0/1
>>
>>список доступа ACL-FOR-NAT - может быть более детален - в зависимости от
>>потребностей
>
>А как сюда привязать пул адресов, с которым должна натится внутреняя сеть?
>

ВЫ совершенно не хотите думать...почитайте про NAT и PAT хоть немного.
Такой подход неверный...учитесь простому самостоятельно...примеров куча


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

7. "Резервирование канала"  +/
Сообщение от walterwest7 (ok) on 25-Май-10, 09:44 
>[оверквотинг удален]
>>> match interface FastEthernet0/1
>>>
>>>список доступа ACL-FOR-NAT - может быть более детален - в зависимости от
>>>потребностей
>>
>>А как сюда привязать пул адресов, с которым должна натится внутреняя сеть?
>>
>
>ВЫ совершенно не хотите думать...почитайте про NAT и PAT хоть немного.
>Такой подход неверный...учитесь простому самостоятельно...примеров куча

Решил сделать так.

ip nat pool POOL_1 10.10.10.10 10.10.10.10 netmask 255.255.255.0
ip nat pool POOL_2 10.10.20.10 10.10.20.10 netmask 255.255.255.0
ip nat inside source route-map RM_NAT_1 pool POOL_1
ip nat inside source route-map RM_NAT_2 pool POOL_2
ip access-list extended ACL_NAT_1
permit ip 192.168.1.0 0.0.0.255 any
ip access-list extended ACL_NAT_2
permit ip 192.168.1.0 0.0.0.255 any

route-map RM_NAT_1 permit 10
match ip address ACL_NAT_1
match interface FastEthernet0/0

route-map RM_NAT_2 permit 10
match ip address ACL_NAT_2
match interface FastEthernet0/1

event manager applet 1_DOWN
event track 1 state down
action 1.0 cli command "clear ip nat translation *"
event manager applet 1_UP
event track 1 state up
action 1.0 cli command "clear ip nat translation *"

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

8. "Резервирование канала"  +/
Сообщение от walterwest7 (ok) on 25-Май-10, 09:44 
>[оверквотинг удален]
>>> match interface FastEthernet0/1
>>>
>>>список доступа ACL-FOR-NAT - может быть более детален - в зависимости от
>>>потребностей
>>
>>А как сюда привязать пул адресов, с которым должна натится внутреняя сеть?
>>
>
>ВЫ совершенно не хотите думать...почитайте про NAT и PAT хоть немного.
>Такой подход неверный...учитесь простому самостоятельно...примеров куча

СПАСИБО за помощь.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру