The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Маршрутизация через Циску, нат через сервер."
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]

"Маршрутизация через Циску, нат через сервер."  +/
Сообщение от shadyflash email(ok) on 25-Май-10, 14:05 
Добрый день. Помогите разобраться в вопросе. Сейчас попробую все расписать:
Есть Cisco 7206, в один из портов на неё транком подается сеть 10.96.0.1 с /12 маской, порт имеет ип адрес 10.96.0.1/24, надо чтоб нат осуществлялся на другом сервере, а циска просто пробрасывала все пакеты на этот сервер, ип сервера который соединен с циской, я прописал 10.96.2.2, а ип циски 10.96.2.1/24. Подскажите пожалуйста, как настроить маршрутизацию в данном случае?

interface GigabitEthernet0/1
ip address 10.96.0.1 255.255.255.0
interface FastEthernet1/1
ip address 10.96.2.1 255.255.255.0
ip route 0.0.0.0 0.0.0.0 FastEthernet1/1 10.96.2.2

Квалификации не хватает решить такой вопрос, а сделать это необходимо:)
Спасибо!

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Маршрутизация через Циску, нат через сервер."  +/
Сообщение от Дмитрий (??) on 25-Май-10, 14:19 
Что-то не вяжется это
>10.96.0.1 с /12

с этим
>interface GigabitEthernet0/1
>ip address 10.96.0.1 255.255.255.0

И вообще, зачем вы так сурово с сетью провайдера обошлись?
Такое вообще работать не будет. У вас пересекающиеся сети, разброд масок.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "Маршрутизация через Циску, нат через сервер."  +/
Сообщение от shadyflash email(ok) on 25-Май-10, 14:38 
>Что-то не вяжется это
>>10.96.0.1 с /12
>
>с этим
>>interface GigabitEthernet0/1
>>ip address 10.96.0.1 255.255.255.0
>
>И вообще, зачем вы так сурово с сетью провайдера обошлись?
>Такое вообще работать не будет. У вас пересекающиеся сети, разброд масок.

У провайдера последний шлюз 10.96.0.254 с которого он все подсети с /12 маской кидает на 10.96.0.1, сейчас все натится на циске и все замечательно работает, а надо чтоб нат происходил на "следующей" железяке.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "Маршрутизация через Циску, нат через сервер."  +/
Сообщение от Дмитрий (??) on 25-Май-10, 14:39 
А как у вас сейчас сеть на Cisco настроена?


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

4. "Маршрутизация через Циску, нат через сервер."  +/
Сообщение от shadyflash email(ok) on 25-Май-10, 14:59 
>А как у вас сейчас сеть на Cisco настроена?

interface GigabitEthernet0/1
ip address 10.96.0.1 255.255.255.0
ip nat inside

interface GigabitEthernet0/1
ip address 99.99.4.2 255.255.255.0
ip nat outside

ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/1 99.99.4.1

ip nat pool pooldz 99.99.4.3 99.99.4.9 netmask 255.255.255.0
ip nat inside source list 37 pool pooldz overload

и в данной конфигурации натится сетка 10.96.0.1/12

tcp 99.99.4.4:63969    10.103.255.11:63969 84.39.40.1:445    84.39.40.1:445


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

5. "Маршрутизация через Циску, нат через сервер."  +/
Сообщение от shadyflash email(ok) on 26-Май-10, 12:11 
в общем нада было на железяке с натом маску прописать /12 и все заработало.. а столько времени убил.. )) спасибо!
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2023 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру