The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Передать от PPPoE во внутретреннюю сеть IP DNS провайдера "
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]

"Передать от PPPoE во внутретреннюю сеть IP DNS провайдера "  +/
Сообщение от NordOwl (ok) on 27-Май-10, 15:50 
Подскажите пожалуйста, что необходимо прописать в конфиге, чтобы Dialer1 получал от провайдера адреса его DNS серверов и передавал их клиентам внутренней сети?

Cisco 1841, IOS 12.4 + модуль расширения HWIC-4ESW (4-ч портовый свитч).
на FE 0/1 - интернет (PPPoE через Dialer1);
Dialer1 получает динамический адрес от провайдера;
на портах HWIC-4ESW - внутренняя локальная сеть (10.2.2.0) (через VLAN).

На клиентах (WinXP), подключенных к портам HWIC-4ESW (IP статический), интернет появляется только при условии указания IP основного шлюза (10.2.2.1 - VLAN) и IP DNS серверов провайдера.

У провайдера IP DNS серверов нередко меняются. Менять их на хоть и не многочисленных клиентах иногда не хватает времени.

   ip name-server [IP DNS провайдера] - не помогает.

Заранее благодарен
Ногами прошу не пинать, у всего существует начало, даже у опыта.

==========================================

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Rout9
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
ip cef
!
!
!
!
vpdn enable
!
!
username ****
!
!
interface FastEthernet0/0
description Ethernet port0
no ip address
ip tcp adjust-mss 1360
shutdown
speed 100
full-duplex
no cdp enable
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
pppoe enable
pppoe-client dial-pool-number 1
no cdp enable
!
interface FastEthernet0/0/0
switchport access vlan 2
duplex full
speed 100
!
interface FastEthernet0/0/1
switchport access vlan 2
duplex full
speed 100
!
interface FastEthernet0/0/2
switchport access vlan 2
duplex full
speed 100
!
interface FastEthernet0/0/3
switchport access vlan 2
duplex full
speed 100
!
interface Vlan1
no ip address
!
interface Vlan2
ip address 10.2.2.1 255.255.255.0
ip nat inside
ip tcp adjust-mss 1360
!
interface Dialer1
description Point Access to provider net
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
no ip mroute-cache
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname szt
ppp chap password 0 szt
ppp pap sent-username szt password 0 szt
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
!
ip http server
ip http access-class 23
ip http authentication local
ip nat translation tcp-timeout 200
ip nat translation pptp-timeout 20
ip nat translation udp-timeout 50
ip nat translation finrst-timeout 5
ip nat translation syn-timeout 10
ip nat translation dns-timeout 10
ip nat translation icmp-timeout 10
ip nat inside source list NAT_Internet interface Dialer1 overload
!
ip access-list extended NAT_Internet
permit ip 0.0.0.5 255.255.255.0 any
!
access-list 23 permit 10.10.10.0 0.0.0.7
dialer-list 1 protocol ip permit
!
end

=========================================

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Передать от PPPoE во внутретреннюю сеть IP DNS провайдера "  +/
Сообщение от Дмитрий (??) on 27-Май-10, 17:07 
Предлагаю настроить DHCP на рутере. И сделать его DNS релеем. Это облегчит Вам жизнь.

Еще на диалере пропишите
ppp ipcp dns request

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "Предлагаю настроить DHCP на рутере"  +/
Сообщение от NordOwl (ok) on 27-Май-10, 17:23 
> И сделать его DNS релеем.

Подскажите как? буду благодарен

>Еще на диалере пропишите
>ppp ipcp dns request

это делал - не помогает
насколько понимаю, эта команда позволяет получать IP DNS от провайдера
а как их потом передать во внутр.сеть?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

4. "Предлагаю настроить DHCP на рутере"  +/
Сообщение от Дмитрий (??) on 27-Май-10, 17:56 
>> И сделать его DNS релеем.
>
>Подскажите как? буду благодарен

Прописываете сервера в конфиге.
затем ip dns server
вроде как-то так. У меня правда на 871 дома не заработало... )))

>>Еще на диалере пропишите
>>ppp ipcp dns request
>
>это делал - не помогает
>насколько понимаю, эта команда позволяет получать IP DNS от провайдера
>а как их потом передать во внутр.сеть?

В настройках DHCP пула попробуйте прописать
import all

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "Передать от PPPoE во внутретреннюю сеть IP DNS провайдера "  +/
Сообщение от Дмитрий (??) on 27-Май-10, 17:08 
http://skirda.net/info/about-computers/nachinajuschim-poznav...
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру