The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

В дерево исходных текстов PHP 5.3 внесены патчи для отслеживания источника спама

11.01.2009 10:09

В дерево исходных текстов PHP 5.3 интегрированы патчи для ведения подробного лога отправки почты через функцию mail(). Возможность позволяет выявить источник спама в системах хостинга, на которых нередко пытаются рассылать спам через взломанные скрипты пользователей. Кроме ведения лога предусмотрена возможность включения в тело письма заголовка с уточнением из какого именно скрипта и от какого пользователя осуществлена отправка.

Для ветки PHP 5.2 патчи можно установить отдельно.

  1. Главная ссылка к новости (http://ilia.ws/archives/190-Ma...)
  2. Каталог ПО: Mail logging for PHP
Лицензия: CC-BY
Тип: К сведению
Ключевые слова: mail, spam, patch, php
При перепечатке указание ссылки на opennet.ru обязательно
Обсуждение (7) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.1, SubGun (ok), 11:08, 11/01/2009 [ответить]  
  • +/
    Лучше бы скорей поправили 5.2.8 Я вчера просто аху, когда php5-gd при сборке послал меня, сказав, что это вызовет "неопределенные множественные уязвимости памяти", а в багрепортах написано, что эти уязвимости вообще критичны. И пока я пребываю в состоянии "аху", они клепают патчики для функции mail().
     
     
  • 2.2, Аноним (-), 11:17, 11/01/2009 [^] [^^] [^^^] [ответить]  
  • +/
    Такой умный? Возьми и исправь...
     
  • 2.4, anonymous (??), 14:43, 11/01/2009 [^] [^^] [^^^] [ответить]  
  • +/
    Какой-то набор закорючек. У меня стоит 5.2.8 с включенным gd. Что не так?
     
     
  • 3.7, Zula (?), 02:11, 12/01/2009 [^] [^^] [^^^] [ответить]  
  • +/
    Ничего хорошего :)

    # portaudit -Fda
    auditfile.tbz                                 100% of   53 kB   50 kBps
    New database installed.
    Database created: Mon Jan 12 00:40:06 EET 2009

    Affected package: php5-gd-5.2.8
    Type of problem: php5-gd -- uninitialized memory information disclosure vulnerability.
    Reference: <http://www.FreeBSD.org/ports/portaudit/58a3c266-db01-11dd-ae30-001cc0377035.h

    1 problem(s) in your installed packages found.

    You are advised to update or deinstall the affected package(s) immediately.

     
     
  • 4.9, SubGun (ok), 10:41, 12/01/2009 [^] [^^] [^^^] [ответить]  
  • +/
    Это еще что. У меня не собирается в принципе.

    ===>  php5-gd-5.2.8 has known vulnerabilities:
    => php5-gd -- uninitialized memory information disclosure vulnerability.
       Reference: <http://www.FreeBSD.org/ports/portaudit/58a3c266-db01-11dd-ae30-001cc0377035.h
    => Please update your ports tree and try again.
    *** Error code 1

    И это с последним деревом портов.

     
     
  • 5.10, Zula (?), 11:23, 12/01/2009 [^] [^^] [^^^] [ответить]  
  • +/
    На свой страх и риск можно так :)
    # make -DDISABLE_VULNERABILITIES install
     
  • 2.8, none (??), 06:50, 12/01/2009 [^] [^^] [^^^] [ответить]  
  • +/
    все то не привыкли к корявым ручкам пхп-строителей? привыкайте быстрее, для здоровья безопастнее.
     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    Слёрм
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2020 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру