The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Вышел релиз Linux дистрибутива openSUSE 11.2

12.11.2009 17:30

Официально представлен релиз Linux дистрибутива openSUSE 11.2, первый выпуск в рамках нового восьмимесячного цикла подготовки релизов. По сравнению с прошлыми версиями время поддержки дистрибутива (выпуска обновлений) openSUSE 11.2 сокращено с 24 до 18 месяцев.

Обзор основных улучшений:

  • Пользовательские улучшения
    • В качестве десктоп-окружения по умолчанию, при установке с DVD, используется KDE 4.3.1. В настоящий момент разработчики KDE выпустили версию 4.3.3, но это не должно смущать пользователей openSUSE, так как в дистрибутив импортированы все важные исправления, доступные для ветки KDE 4.3. В качестве второго десткоп-окружения доступен GNOME 2.28.
    • Для GNOME и KDE обновлены визуальные темы, причем для KDE проведена большая работа по обеспечению бесшовной интеграции в рабочее окружение таких приложений, как Firefox и OpenOffice.org;
    • В интерфейсе для настройки параметров дисплея gnome-display-properties добавлена поддержка автоматического сброса настроек в случае проблем.
    • Улучшение поддержки субноутбуков.
  • Обновление входящих в комплект программ
    • Пользовательские приложения: SeaMonkey 2.0, Firefox 3.5.5, xorg-x11-server 1.6.5, Banshee 1.5.1, K3b 1.68 Alpha 3, Evolution 2.28, X.Org драйвер radeonhd 1.3, Blender 2.49a, OpenOffice.org 3.1.1, Gnumeric 1.9.12, KTorrent 3.2.4, Pidgin 2.6.2, Thunderbird 3.0 Beta 4, VirtualBox 3.0.6, Wine 1.1.28, GIMP 2.6.7;
    • Серверные и системные приложения: Linux ядро 2.6.31.5, Samba 3.4.2, Bluez 4.56, Alsa 1.0.21, PulseAudio 0.9.19, GCC 4.4.1, RPM 4.7.1;
    • Программы для разработчиков: Subversion 1.6.6, Qt 4.5.3, PostgreSQL 8.4.1, php 5.3.0, Apache 2.2.13, Python 3.1;
    • В состав LiveCD с GNOME добавлен Midnight Commander, Bittorrent-клиент Transmission и Gimp.
    • В состав LiveCD с KDE добавлены новые программы: Choqok, KNode, Kompare, KSystemlog, Okteta, YaKuake.
    • В комплект включены приложения для работы с десктопа в социальных сетях, подобных Facebook, Twitter и identi.ca. Например: choqok (Twitter и identi.ca клиент для KDE), gwibber (Twitter, Facebook и identi.ca клиент для GNOME), поддержка Facebook в kopete, дополнительные KDE4 плазмойды для общения в Twitter и identi.ca;
  • Установка и управление пакетами
    • При установке в качестве файловой системы по умолчанию задействована Ext4. Более того, в YaST добавлена возможность полного шифрования всего диска. В менеджер дисковых разделов YaST добавлена поддержка файловой системы Btrfs и переработан интерфейс;
    • Новое визуальное оформление инсталлятора YaST2;
    • Образ LiveCD теперь может быть использован и на USB Flash. В состав интегрированы средства для подготовки собственных LiveCD образов. Для сжатия данных на LiveCD отныне используется алгоритм сжатия LZMA;
    • По умолчанию LiveCD содержит переводы для немецкого, французского, итальянского, польского и русского языков;
  • Настройка и управление пакетами
    • Добавлена функция совершения обновления в Live-режиме с минимальным временем простоя, позволяющая целиком обновить работающую систему с версии 11.1 до 11.2 методом напоминающим dist-upgrade в Debian, с фоновой загрузкой пакетов перед непосредственным началом проведения обновления;
    • Разработан web-интерфейс к YaST для осуществления удаленного управления дистрибутивом;
    • Для YaST создан новый центр управления конфигурацией (YaST Control Center) с интерфейсом на базе Qt4;
    • В Qt версии конфигуратора YaST появилась поддержка настраиваемого внешнего вида. В YaST добавлены средства работы с кешем пакетов;
    • Пакеты дистрибутива собраны GCC 4.4.1. Пакеты сформированы с использование RPM версии 4.7.1;
    • В zypper добавлена опция "--download-only", позволяющая осуществить только загрузку компонент, без выполнения действи. Опцию можно использовать совместно с командами install, update, patch, dup и verify. Улучшены средства работы с зеркалами репозиториев пакетов. Улучшена производительность операций индексации и поиска в zypper.;


  1. Главная ссылка к новости (http://news.opensuse.org/2009/...)
Лицензия: CC-BY
Тип: Программы
Короткая ссылка: https://opennet.ru/24238-opensuse
Ключевые слова: opensuse, novell, linux
Поддержать дальнейшую публикацию новостей на OpenNET.


Обсуждение (42) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.1, Аноним (-), 18:10, 12/11/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    "Улучшение поддержки субноутбуков"
    Щито такое субноутбуков? Аля субмарины?
     
     
  • 2.2, Поросеночек (?), 18:22, 12/11/2009 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Ну если субмарина - это кастрированная марина, то примерно да :)
    А вообще, субноутбук - это первое название класса ноутов. Это потом прибежали маркетоиды, и сказали, что нетбук - звучит лучше.
     
     
  • 3.3, Аноним (-), 18:31, 12/11/2009 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Субноутбоки == Нетбуки?
    Я правильно Вас понял? Т.е. Lenovo S10-2 будет пищать и радоваться при использование OpenSuse? Для заметки - в леново Intel Atom .
     
     
  • 4.5, ононим (?), 19:07, 12/11/2009 [^] [^^] [^^^] [ответить]  
  • +/
    https://wiki.ubuntu.com/HardwareSupport/Machines/Netbooks#Lenovo%20S10

    статус работы вашего ноута в UNR

     
  • 4.6, fi (ok), 19:30, 12/11/2009 [^] [^^] [^^^] [ответить]  
  • +1 +/
    >Субноутбоки == Нетбуки?

    Субноутбоки != Нетбуки

    У них общее только размер :) субноутбоки с топовым процессором с экономном питанием, работает не меньше 7 часов, но есть и более 10. с крутой картой, бывает и с двумя. Вобщем маленький, но очень дорогой ноут.

     
  • 4.10, Аноним (-), 00:59, 13/11/2009 [^] [^^] [^^^] [ответить]  
  • +/
    У меня S10-1 с предыдущей сусей пищит и радуется, единственная засада - тормозящий флеш.
     
  • 3.42, Michael Shigorin (ok), 12:57, 17/11/2009 [^] [^^] [^^^] [ответить]  
  • +/
    >Ну если субмарина - это кастрированная марина, то примерно да :)
    >А вообще, субноутбук - это первое название класса ноутов. Это потом прибежали
    >маркетоиды, и сказали, что нетбук - звучит лучше.

    Всё переврали (c)

    marine -- морской, sub -- ниже; "под"-"водный"

    Сабноуты -- это отдельный и довольно давно (и успешно) существующий премиум-класс ноутов, обычно 10"--12", тонких и лёгких.  Цены отличались обычно раза в два-три вверх по сравнению с трёхкиловым гробиком схожей внешне комплектации.  Могут работать единственным ноутбуком.

    Нетбуки -- самостоятельный low-end класс, появившийся относительно недавно (причём не только из-за маркетингового толчка, а и по объективным причинам) и помимо ещё более скромных массогабаритных характеристик (7"--10", до ~1 кг) отличающийся и скромными мощностными, ориентированными не на "традиционные десктопные" (tm) прибамбасы, а на "погоду посмотреть, почту почитать".  Разница с сабноутами -- предполагается, что это не единственный девайс у владельца, поскольку особенно в случае совсем мелких моделек вроде EeePC 701 клавиатура сильно на любителя (и размеры пальцев).

    PS: по теме -- зеркало есть и на ftp://ftp.linux.kiev.ua/pub/Linux/openSUSE/ [UA-IX]

     

  • 1.4, immka (?), 18:32, 12/11/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Хм, только у меня после апдейта фаерфокс и тандерберд начали бешено жрать проц? вместо пары процентов по 30-50% каждый из них, в топе на первом месте..
     
     
  • 2.7, Аноним (-), 20:27, 12/11/2009 [^] [^^] [^^^] [ответить]  
  • +/
    Смени тему GTK. Если обновлял частично - обнови до конца.
     

  • 1.8, Zenitur (?), 23:41, 12/11/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    В Linux Format всегда писали, что openSuSE - один из лучших дистрибутивов для ноутбуков. Так и есть!
    Ура! Наконец-то можно скачать кодеки с packman.links2linux.org! А то для беты их не выкладывали...
    Жду редакции с KDE 3.5, если, конечно, будет.
     
     
  • 2.11, ZaWertun (ok), 01:11, 13/11/2009 [^] [^^] [^^^] [ответить]  
  • +1 +/
    """
    желающие установить KDE3 могут подключить репозитарий download.opensuse.org/repositories/KDE:/KDE3/openSUSE_11.2/ и получить отличные третьекеды. в этом репозитарии есть все необзодимые пакеты, и они совместимы с KDE4(можно держать одновременно утсановленными KDE3 и KDE4)
    """
    (from http://habrahabr.ru/blogs/suse/74925/)
     
     
  • 3.41, GoSha (?), 12:15, 17/11/2009 [^] [^^] [^^^] [ответить]  
  • +1 +/
    шо за фигня, эти 4-е кеды с их глюкаво-падающими рюшечками-плазмоидами!!! 3,5 можно поставить, да вот жаль, что дальше только 4-е кеды. А где же выбор? Получается как в винДОСе.
    Ну в общем: "Колхоз дело добровольное. Хочешь, вступай. Не хочешь, расстрел"
     
     
  • 4.44, szh (ok), 22:01, 17/11/2009 [^] [^^] [^^^] [ответить]  
  • +/
    > 3,5 можно поставить, да вот жаль, что дальше только 4-е кеды. А где же выбор?

    сам себе противоречишь.

    кроме того никто не мешает тебе брать сорсы или делать альтернативный дистриб на основе opensuse с kde3.5

    свобода != халява

     
     
  • 5.46, Zenitur (?), 03:12, 18/11/2009 [^] [^^] [^^^] [ответить]  
  • +/
    Хмм... Ну так и говорили везде. "Когда выйдет четвёртый КДЕ, никто не помешает компилировать старый из исходного кода в случае, если в дистрибутиве его нет. Это ж open source! А не проприетарщина какая-нибудь". А как наступило нужное время, так вопить супротив здравого смысла, "Ой как всё плохо, ой новые компиляторы не компилируют наверно, (честно, бред. Всё компилируют), ой в дистрибутивы не вкладывают - значит не нужно и если ты это используешь - это плохо". Слышал такое. "Ой там наверно последние программы не идут, и вообще, у меня новый комп и для полной фичастости надо новое KDE. Пусть мощности не простаивают просто так - с новым KDE компьютер будет использовать свою мощь всё время! И это приятно"
     
  • 2.14, Hober (?), 08:07, 13/11/2009 [^] [^^] [^^^] [ответить]  
  • –4 +/
    >В Linux Format всегда писали, что openSuSE - один из лучших дистрибутивов
    >для ноутбуков. Так и есть!

    Наверное, все таки - ОДИН из ХУДШИХ дистрибутивов.
    И самая главная его гадость - YAST


     
     
  • 3.19, Alpi (?), 09:49, 13/11/2009 [^] [^^] [^^^] [ответить]  
  • +1 +/
    >>В Linux Format всегда писали, что openSuSE - один из лучших дистрибутивов
    >>для ноутбуков. Так и есть!
    >
    >Наверное, все таки - ОДИН из ХУДШИХ дистрибутивов.
    >И самая главная его гадость - YAST

    Вы лично сделали нечто лучше? И уж совершенно точно, что вместо YAST Вы можете предложить что то совершенно уникальное СОБСТВЕННОЙ разработки :)
    Скорее всего ни того ни другого нет. Тогда аргументируйте хотя бы свое столь категоричное и столь необьективное суждение.


     
     
  • 4.20, letsmac (?), 10:11, 13/11/2009 [^] [^^] [^^^] [ответить]  
  • +1 +/
    А что у кого-то ещё появились автоскрипты для установки одним кликом и нормальный гайды от поставщика дистра? YaST один из лучших инсталяторов для новичков.
     
  • 3.21, Аноним (-), 10:24, 13/11/2009 [^] [^^] [^^^] [ответить]  
  • +/
    А вас кто-то принуждает его использовать? Можно пожаловаться мне.
     
     
  • 4.47, Zenitur (?), 03:15, 18/11/2009 [^] [^^] [^^^] [ответить]  
  • +/
    >А вас кто-то принуждает его использовать? Можно пожаловаться мне.

    Мне просто не понравился четвёртый релиз. Я держу оба KDE и периодически обновляю четвёртые. Всё плохо и судя по всему, чуда не произойдёт. Vista вот попытались реабилитировать - только потому, что ничего другого не оставалось. А будут ли реабилитировать KDE - сомневаюсь. Опять горы софта переписывать?!
    Пусть пятое KDE будет на Qt4.

     

  • 1.9, Аноним (-), 23:52, 12/11/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    K3b 1.68 Alpha 3
    Thunderbird 3.0 Beta 4

    Это все зачем? Оно хоть работает?

     
     
  • 2.16, MisterFog (?), 08:54, 13/11/2009 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Затем же, зачем OpenSUSE и придуман - тестировать пакеты, для дальнейшего включения в SUSE Enterprise
     
  • 2.22, Iv945n (ok), 10:51, 13/11/2009 [^] [^^] [^^^] [ответить]  
  • +/
    Про K3b не знаю, и как Thunderbird поведёт себя под этой конкретной ОС тоже, но под виндами у меня Thunderbird 3.0 Beta (не помню какая именно) работала абсолютно без видимых багов на базах по несколько гигов, импортированых из Outlook 2007.
     

  • 1.12, Аноним (-), 02:23, 13/11/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    альфа k3b отлично работала еще в  rc1
     
  • 1.13, sardigital (ok), 06:52, 13/11/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Очень много вкусного добавили в Thunderbird 3-й ветки, по сравнению со второй - просто шоколадка...
     
     
  • 2.23, Iv945n (ok), 10:58, 13/11/2009 [^] [^^] [^^^] [ответить]  
  • +/
    >Очень много вкусного добавили в Thunderbird 3-й ветки, по сравнению со второй
    >- просто шоколадка...

    Не добавили (или я не нашёл?), однако, фичи, которую я надеялся увидеть - такого режима, при котором бы корректно распозновались (и отображались и в тексте и в предпросмотре и в заголовках в таблице и в цитировании) все кодировки входящих писем, а все исходящие независимо ни от чего (кроме корректировки ad-hoc в письме) отправлялись бы в UTF-8 (мне это объективно надо, да и вообще imho пора бы уже дефолтами legacy кодировки со свта выживать...). А могли бы добавить в честь увелечения первой цифры версии-то.

     

  • 1.15, Sergey (??), 08:11, 13/11/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    тундрабёрд.... ну... на любителя...имо -- память непропорционально улучшениям жрёт
     
  • 1.17, netc (??), 09:19, 13/11/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • –2 +/
    а как же MONO ? по дефолту ставиться ?

    хочу моно ;) ;) ;) - шутка

    если "ДА", то можно даже не смотреть

     
     
  • 2.24, anonymous (??), 11:09, 13/11/2009 [^] [^^] [^^^] [ответить]  
  • +/
    нет
     
     
  • 3.28, pavlinux (ok), 11:49, 13/11/2009 [^] [^^] [^^^] [ответить]  
  • +/
    >>а как же MONO ? по дефолту ставиться ?
    >>
    >>хочу моно ;) ;) ;) - шутка
    >>
    >>если "ДА", то можно даже не смотреть
    >
    >.NET рулит. На работе нет возможности VS погонять. Слава Mono! Поставлю опенсусю
    >с mono и monodevelop, поразбираюсь в C#, почитаю об отличиях.

    А зачем Вам C# в Linux?

    Хотите много бабла в Linux -> C++/QT, PL-SQL/Oracle, Java/Netbeans, Python (если не стошнит)

     
     
     
    Часть нити удалена модератором

  • 5.35, pavlinux (ok), 20:32, 13/11/2009 [^] [^^] [^^^] [ответить]  
  • +/
    >>А зачем Вам C# в Linux?
    >
    >Потому что у меня пробел в знаниях

    Ну, за знаниями это точно не в C#,

    Ruby, Scheme, PostScript, Prolog, ML, Haskell, Erlang

    http://dobbscodetalk.com/index.php?option=com_myblog&show=Learn-as-Many-Langu


     
  • 2.27, pavlinux (ok), 11:44, 13/11/2009 [^] [^^] [^^^] [ответить]  
  • +/
    ДА. Но чудно удаляется командами:

    # for i in 'rpm -qa | grep -i mono'; do rpm -e --nodeps --force $i; done;
    # for i in 'rpm -qa | grep -i sharp'; do rpm -e --nodeps --force $i; done;


     
     
  • 3.32, 4yjoy (?), 20:10, 13/11/2009 [^] [^^] [^^^] [ответить]  
  • +/
    Не надо вводить в заблуждение. Моно по дефолту ставился в 11.1. В 11.2 - нет.
     
     
  • 4.33, pavlinux (ok), 20:16, 13/11/2009 [^] [^^] [^^^] [ответить]  
  • +/
    >Не надо вводить в заблуждение. Моно по дефолту ставился в 11.1. В
    >11.2 - нет.

    Не знаю что для вас МОНО, а для меня любая тварь с этим словом.

    А пакет mono-core ставится!!!


     
     
  • 5.34, 4yjoy (?), 20:26, 13/11/2009 [^] [^^] [^^^] [ответить]  
  • +/
    Вот только поставил с нуля.

    # rpm -qa | grep -i mono - ничего не находит
    # rpm -qa | grep -i sharp - аналогично ничего

     
     
  • 6.36, pavlinux (ok), 20:37, 13/11/2009 [^] [^^] [^^^] [ответить]  
  • +/
    >Вот только поставил с нуля.
    >
    ># rpm -qa | grep -i mono - ничего не находит
    ># rpm -qa | grep -i sharp - аналогично ничего

    Ну вполне может быть, у меня просто есть плохая привычка - по дефолту ничего не ставить, вот он видимо к чему-то и прилип.

     

  • 1.18, netc (??), 09:26, 13/11/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    да и если честно, то со всем моим уважением к кедам, стартовое меню гнома и панель задач выглядит естетичнее и удобно в работе ИМХО
     
  • 1.29, Аноним Я (?), 11:56, 13/11/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    чето даже желания не возникает посмотреть.. совершенно я в ней разочаровался.
     
  • 1.37, Аноним (-), 11:17, 14/11/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    openSuSe конечно хороший дистрибутив, но от него пришлось отказаться. По той причине, что в оффициальных репозиториях отсутсвуют некоторые программы, а ставить проги из например пакманов и подобных источников считаю плохой идеей
     
     
  • 2.38, 4yjoy (?), 14:30, 14/11/2009 [^] [^^] [^^^] [ответить]  
  • +/
    Закладок боитесь? =)
     
     
  • 3.39, Аноним (-), 23:13, 14/11/2009 [^] [^^] [^^^] [ответить]  
  • +/
    >Закладок боитесь? =)

    Дело не сколько в закладках, а сколько в том что не очень люблю ставить программы не из оф. репозиториев. А для сборки из исходников есть генту =)

     
     
  • 4.43, Vitalij (?), 16:20, 17/11/2009 [^] [^^] [^^^] [ответить]  
  • +/
    С таким же успехом можете собирать проги из исходников и в openSUSE.
     

  • 1.45, szh (ok), 22:04, 17/11/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    накололся с тем что grub не поддерживает btrfs.
    И с загрузкой btrfs.ko из initrd глюк (unresolved symbol).
     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:
    При перепечатке указание ссылки на opennet.ru обязательно



    Спонсоры:
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2022 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру