The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Новая версия интегрированной среды разработки приложений Codelite 2.1

04.01.2010 13:59

Вышла версия 2.1 IDE Codelite, кроссплатформенной интегрированной среды для разработки приложений на языках C/C++. CodeLite написана с использованием wxWidgets и распространяется под лицензией GPLv2.

Из изменений в версии 2.1 стоит отметить:

  • Полностью переписан плагин для работы с svn
  • Поддержка глобального пространства в автодополнении кода, возможность задания директорий с заголовочными файлами для каждого проекта в отдельности (для автодополнения)
  • Дополнительные опции рефакторинга
  • Обновлен статический анализатор CppCheck до версии 1.39

Основные возможности CodeLite:

  • Поддержка SVN, интеграция с программами для поиска cscope и тестовым фреймворком UnitTest++;
  • Автодополнение кода, рефакторинг, подсветка синтаксиса для C/C++, XML, Makefile, Diff file и других языков;
  • Встроенная система генерации документации Doxygen;
  • Импорт проектов из Visual Studio;
  • Поддержка отладчика GDB;
  • Автогенерация make-файлов, возможность использования системы сборки qmake;
  • Встроенная система статического анализа С/C++ кода CppCheck.



  1. Главная ссылка к новости (http://codelite.org/forum/view...)
  2. OpenNews: CodeLite 2.0 - IDE для C/C++
  3. Страница для загрузки
Автор новости: croster
Тип: Программы
Короткая ссылка: https://opennet.ru/24889-Codelite
Ключевые слова: Codelite, ide, gcc
При перепечатке указание ссылки на opennet.ru обязательно
Обсуждение (21) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.1, Карбофос (ok), 17:48, 04/01/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    надо будет сравнить с kdevelop...
     
  • 1.2, Аноним (-), 18:29, 04/01/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Что-то в последнее время много инструментов для разработки выходит. Как бы намекают: всем - кодить! Может и правда пришла пора что ни будь написать.
     
     
  • 2.8, Iv945n (ok), 21:10, 04/01/2010 [^] [^^] [^^^] [ответить]  
  • +/
    >Что-то в последнее время много инструментов для разработки выходит. Как бы намекают:
    >всем - кодить! Может и правда пришла пора что ни будь
    >написать.

    Как насчёт IDE?

     
     
  • 3.9, Аноним (-), 21:39, 04/01/2010 [^] [^^] [^^^] [ответить]  
  • +1 +/
    >Как насчёт IDE?

    Это не круто. Лучше написать свой hello world с синхронизацией в svn, строками в XML, сборкой через Makefile, Web интерфейсом, описанием в Doxygen, импортированный из Visual Studio, отлаженный в GDB, проанализированный CppCheck.

     

  • 1.3, Аноним (-), 18:51, 04/01/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +2 +/
    Может немного не по теме. Но с прочтения чего нужно начинать изучать программирование на С++ под Unix?
     
     
  • 2.5, ЛеХа (?), 18:57, 04/01/2010 [^] [^^] [^^^] [ответить]  
  • +1 +/
    С прочтения "Руководства FreeBSD для разработчиков":
    http://freebsd.org.ua/doc/ru_RU.KOI8-R/books/developers-handbook/index.html
     
     
  • 3.12, User294 (ok), 02:25, 05/01/2010 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Уж послали так послали. "Не выиграл а проиграл, не в лотерею а в карты..."
     
  • 2.21, DeadMustdie (??), 22:02, 06/01/2010 [^] [^^] [^^^] [ответить]  
  • +/
    > Может немного не по теме. Но с прочтения чего нужно начинать изучать программирование на С++ под Unix?

    http://www.parashift.com/c++-faq-lite/

     

  • 1.4, Voviandr (??), 18:56, 04/01/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    попробовал установить, выдаёт
    voviandr@voviandr-desktop:/usr/lib$ codelite
    codelite: /usr/lib/libstdc++.so.6: version 'GLIBCXX_3.4.11' not found (required by /usr/lib/codelite/libcodeliteu.so)

    первый раз такое вижу. никто не подскажет, как решить ? у меня убунту 9.04. установил из деба, скачанного с сайта.

     
     
  • 2.14, Voviandr (ok), 05:13, 05/01/2010 [^] [^^] [^^^] [ответить]  
  • +/
    >попробовал установить, выдаёт
    > voviandr@voviandr-desktop:/usr/lib$ codelite
    >codelite: /usr/lib/libstdc++.so.6: version 'GLIBCXX_3.4.11' not found (required by /usr/lib/codelite/libcodeliteu.so)
    >
    >первый раз такое вижу. никто не подскажет, как решить ? у меня
    >убунту 9.04. установил из деба, скачанного с сайта.

    уже решено. забил на деб, собрал из исходников.


     

  • 1.6, VarLog (ok), 20:15, 04/01/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    А у меня и вовсе не собирается :(
     
     
  • 2.13, Voviandr (??), 03:47, 05/01/2010 [^] [^^] [^^^] [ответить]  
  • +/
    >А у меня и вовсе не собирается :(

    попробуйте перед сборкой поставить пакеты  libwxgtk2.8-dev libwxgtk2.8-dbg
    я успешно собрал из исходников и установил после того, как потерпел неудачу с установкой из деба.


     
     
  • 3.16, VarLog (ok), 08:50, 06/01/2010 [^] [^^] [^^^] [ответить]  
  • +/
    >>А у меня и вовсе не собирается :(
    >
    >попробуйте перед сборкой поставить пакеты  libwxgtk2.8-dev libwxgtk2.8-dbg
    >я успешно собрал из исходников и установил после того, как потерпел неудачу
    >с установкой из деба.

    У меня собственная уютная, ламповая LFS. WxWidgets установлены. Не получается собрать именно из-за ошибок компиляции. Причём они порой довольно бредовые.
    Написано в .cpp файле:
    #include <unistd.h>
    Но пока тупо не напишешь прототип:
    extern read(int fd, void *buf, size_t count);
    компилятор упорно будет утверждать, что функции с таким идентификатором (read) не найдено..

    Пробовал и из svn, и из тарболов.. Хрень какая-то.

     
     
  • 4.17, del (??), 12:59, 06/01/2010 [^] [^^] [^^^] [ответить]  
  • +/
    Мммм, похоже на косяк скорее компилятора, чем исходников.
     
     
  • 5.19, VarLog (ok), 18:49, 06/01/2010 [^] [^^] [^^^] [ответить]  
  • +/
    >Мммм, похоже на косяк скорее компилятора, чем исходников.

    Ну не знаю..
    g++ (GCC) 4.4.0
    Ранее такого не наблюдалось.

     
     
  • 6.20, VarLog (ok), 19:08, 06/01/2010 [^] [^^] [^^^] [ответить]  
  • +/
    >>Мммм, похоже на косяк скорее компилятора, чем исходников.

    varlog:·> grep wxDrag_DefaultMove /usr/X11R6/include/wx-2.8/wx/dnd.h
        wxDrag_DefaultMove = 3  // the default operation is move, not copy
        // allowed, if it contains wxDrag_DefaultMove (which includes the previous
    varlog:·> grep /usr/X11R6/include/wx-2.8/wx/dnd.h ./sdk/wxscintilla/include/wx/wxscintilla.h
    #include "/usr/X11R6/include/wx-2.8/wx/dnd.h"

    ./sdk/wxscintilla/include/wx/wxscintilla.h: In member function ‘bool wxScintillaEvent::GetDragAllowMove()’:
    ./sdk/wxscintilla/include/wx/wxscintilla.h:3549: ошибка: нет декларации ‘wxDrag_DefaultMove’ в этой области видимости
    make: *** [Release_gcc_unicode/PlatWX.o] Ошибка 1

    Как это объяснить?

     

  • 1.7, Аноним (-), 20:57, 04/01/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    реально круче чем Visual studio
     
  • 1.10, Ursadon (?), 22:13, 04/01/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Он у меня ассоциируется с Code::Blocks. Да же значки приложений схожи. Миграция разработчиков?
     
  • 1.11, del (??), 00:55, 05/01/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Не нашел на сайте вменяемого руководства.

    В чем там выражается интеграция с SVN?

    В интерфейсе там где эту интеграцию можно посмотреть?

    Ну а так, приятная IDE. Ради интереса наваял там один внутренний проект на C - впечатления приятные.

     
  • 1.15, del (??), 20:58, 05/01/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    x86_64 deb не ставится на Debian testing:

    $ sudo dpkg -i ./codelite_2.1.0.3584-ubuntu0_amd64.deb
    (Reading database ... 165329 files and directories currently installed.)
    Unpacking codelite (from .../codelite_2.1.0.3584-ubuntu0_amd64.deb) ...
    dpkg-deb (subprocess): short read in buffer_copy (failed to write to pipe in copy)
    dpkg-deb: subprocess paste returned error exit status 2
    dpkg: error processing ./codelite_2.1.0.3584-ubuntu0_amd64.deb (--install):
    short read in buffer_copy (backend dpkg-deb during './usr/lib/codelite/libpluginu.so')
    Processing triggers for desktop-file-utils ...
    Processing triggers for menu ...
    Errors were encountered while processing:
    ./codelite_2.1.0.3584-ubuntu0_amd64.deb


    Собирать впадлу пока)

     
     
  • 2.18, Карбофос (ok), 14:24, 06/01/2010 [^] [^^] [^^^] [ответить]  
  • +/
    кстати, сборку на мультипроцессорном компе можно ускорить:
    make -j2
     
     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2021 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру