The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

В видеодрайвере Nouveau обеспечена поддержка 2D-акселерации для карт GeForce 400/500 "Fermi"

17.01.2011 16:26

Бен Скегс (Ben Skeggs) из компании Red Hat завершил интеграцию в кодовую базу свободного X.Org драйвера Nouveau (xf86-video-nouveau) патча, размером около 5000 строк, в котором реализована поддержка 2D EXA-акселерации для карт NVIDIA GeForce 400/500 "Fermi". Видеоакселерация X-Video еще не поддерживается, но разработчики уже работают над ее реализацией. Работа выполнена на основе обратного инжиниринга проприетарных драйверов NVIDIA.

Поддержка переключения видеорежимов на уровне ядра для карт "Fermi" была реализована в выпуске Linux-ядра 2.6.37, но пока не поддерживает акселерацию (ожидается в ядре 2.6.38). Для работы драйвера также необходима загрузка прошивки, которая пока не поставляется в составе ядра.

  1. Главная ссылка к новости (http://www.phoronix.com/scan.p...)
  2. OpenNews: Компания NVIDIA выпустила для Linux CUDA Toolkit 3.2
  3. OpenNews: Релиз проприетарного видеодрайвера NVIDIA 260.19.12
  4. OpenNews: NVIDIA отказывается от дальнейшего развития открытого драйвера nv
  5. OpenNews: nVidia Fermi сможет выполнять Linux
  6. Обзор возможностей драйвера Nouveau
Лицензия: CC-BY
Тип: Программы
Короткая ссылка: https://opennet.ru/29293-Fermi
Ключевые слова: Fermi, nvidia
При перепечатке указание ссылки на opennet.ru обязательно
Обсуждение (15) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.1, Аноним (-), 16:47, 17/01/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Круто! У меня GTX465 и с nouveau были некоторые небольшие проблемки, а это пофиксят, что радует.
    Что насчет акселерации 3D? Через Gallium? Оно хотя бы в 5 раз медленнее будет, не в 25?
     
     
  • 2.13, User294 (ok), 12:01, 18/01/2011 [^] [^^] [^^^] [ответить]  
  • +/
    > Круто!

    Очень! Аццкая фигня с турбинами теперь вполне может заменить S3 Trio :)

     

  • 1.2, pavlinux (ok), 16:52, 17/01/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    А nouveau, TwinView уже умеет?

     
     
  • 2.11, mma (?), 06:05, 18/01/2011 [^] [^^] [^^^] [ответить]  
  • +/
    А XRandr разве открытые двроа не поддерживают?
     
  • 2.15, Alrond (??), 12:37, 18/01/2011 [^] [^^] [^^^] [ответить]  
  • +/
    У меня Nouveau и мой монитор очень часто в вертикальном положении
     

  • 1.4, Аноним (-), 17:32, 17/01/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Использую nouveau
    полет нормальный.
    после смены конигурации экранов не надо иксы перезагружать в отличие от.
     
     
  • 2.5, анонимный_обыватель (?), 17:59, 17/01/2011 [^] [^^] [^^^] [ответить]  
  • –8 +/
    да, перезагрузка иксов - это серьёзный и ответственный процесс, требующий колоссальных временных затрат
     
     
  • 3.6, Кракен (ok), 18:53, 17/01/2011 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Требует, наприер, все приложения закрыть. В случае докстанции, например, это существенно снижает ее ценность.
     
  • 3.14, User294 (ok), 12:25, 18/01/2011 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > да, перезагрузка иксов - это серьёзный и ответственный процесс, требующий колоссальных
    > временных затрат

    Да, без особых ухищрений весь графический софт при рестарте иксов вылетает, знаете ли. Что мало кому по вкусу.

     
  • 2.7, Аноним (-), 19:52, 17/01/2011 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Ребят вы о чём? У меня GF 8600 и уже давненько не приходится ребутать иксы при смене конфигурации экрана.
     

  • 1.8, Толстый_ (?), 20:09, 17/01/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Купил radeon hd 6950, а надо было geforce gtx 570, для нее уже доступны проприетарные драйвера которые даже успели реверс-инжинирить. В то время как для АМД кукиш с маслом.
    По сабжу - пусть живут, хотя без спеков они далеко не уедут. А нефункциональный драйвер для мощной карты, главное назначение которой - акселерация 3D не нужен.
     
     
  • 2.9, pavlinux (ok), 21:47, 17/01/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Дык меняй, вроде как две недели возврат без вопросов, а уж тем более на обмен.
     
     
  • 3.10, Толстый_ (?), 02:23, 18/01/2011 [^] [^^] [^^^] [ответить]  
  • +/
    ну вроде как АМД более "открыта" чтоли, да и у меня винда в дуал-буте :) думаю оставить и надеяться на лучшее, в любом случае если на чистоту - играть в игры с такой картой надо на винде, wine не годится, так как даже еще и directx 10 полностью не реализовал не говоря уже об 11.
     
  • 2.12, ошмонимус (?), 06:19, 18/01/2011 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Если бы вам были известны отличия в архитектурном плане, то вопросы о сроках реализации открытых драйверов отпали сами собой. 4xx\5xx - одна архитектура, 69xx совершенно отличная от предыдущих - VLIW4.
     
     
  • 3.16, Толстый (ok), 18:05, 18/01/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Это я знаю. На открытые драйвера мне глубоко наплевать, а закрытые для винды и линукса разделяют одну и ту же кодовую базу, поэтому я ожидал почти одновременного появления. Но пока еще Каталист для 69хх не выпущен. Хотя как пишут можно хакнуть существующий драйвер чтобы работало с этими картами, только мне влом, посему винда.
     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2020 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру