The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Релиз медиаплеера VLC 1.1.12

07.10.2011 12:44

Вышла новая версия медиаплеера VLC 1.1.12, в которой улучшена поддержка вывода звука с использованием PulseAudio, а также решены некоторые проблемы при работе на платформе Mac OS X. Отдельно отмечается устранение уязвимости в серверных компонентах, обеспечивающих поддержку протоколов HTTP и RTSP. Проблема вызвана возможностью разыменования указателя NULL в функции "httpd_ClientRecv()", что может привести к инициированию краха при обработке специально оформленных HTTP- или RTSP-запросов (включая обращения через web-интерфейс и системы потокового вещания). Возможность организации выполнения кода оценивается как маловероятная.

  1. Главная ссылка к новости (http://www.videolan.org/news.h...)
  2. OpenNews: Проект VideoLAN объявил о решении перевести libVLC на лицензию LGPL
  3. OpenNews: В рамках премии Bossie Awards 2011 отмечено лучшее открытое ПО
Лицензия: CC-BY
Тип: Проблемы безопасности
Короткая ссылка: https://opennet.ru/31971-videolan
Ключевые слова: videolan, vlc
При перепечатке указание ссылки на opennet.ru обязательно
Обсуждение (82) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.1, Suberjin (ok), 13:17, 07/10/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Эх, когда же он уже начнет нормально поддерживать закладки.
     
     
  • 2.20, СуперАноним (?), 15:39, 07/10/2011 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Ээ, а чьи бы закладки Вы там хотели видеть/иметь? ;)
     
     
  • 3.33, vlivyur (ok), 17:57, 07/10/2011 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Адреса потоковых вещателей?
     
  • 3.64, Suberjin (ok), 22:17, 08/10/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Закладку на то место, на котором остановился просмотр или просто интересных мест в фиьме
     
  • 2.52, koloboid (ok), 06:46, 08/10/2011 [^] [^^] [^^^] [ответить]  
  • +/
    плюсую. а еще хочу закладки как в амароке, на конкретную минуту микса, и запоминание эквалайзера
     

  • 1.2, RazrFalcon (?), 13:20, 07/10/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Как только научится запоминать позицию и не виснуть - сразу перейду с UMP
     
     
  • 2.3, ктото (?), 13:56, 07/10/2011 [^] [^^] [^^^] [ответить]  
  • +2 +/
    память плохая?
     

  • 1.5, ua9oas (?), 14:09, 07/10/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • –3 +/
    У меня стоит "10.04.3". Менеджер обновлений сейчас нашел два обновления для flashplayer. А на vlc не нашел (уже давно как стоит "1.0.6". Сейчас зашел на сайт. Он сам определил, что у меня стоит линукс но не определил какой. На кнопке "скачать" написано, что версия "1.1.11". Нажимаешь- переводит на список большого количества дистрибутивов (Puppy и еще целого ряда там нет). Нажимаю что убунту- пишет что под каждую версию этой ОС требуются разные версии этого проигрывателя. Интересно, а почему под мою тогда ничего новаго нет? Если нет под Puppy то какой и как под него подогнать?
     
     
  • 2.27, CityAceE (?), 16:28, 07/10/2011 [^] [^^] [^^^] [ответить]  
  • +/
    sudo add-apt-repository ppa:lucid-bleed/ppa    
    sudo apt-get update
    sudo apt-get install vlc mozilla-plugin-vlc
     

  • 1.6, ua9oas (?), 14:13, 07/10/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    Возможно ли под мою "10.04.3" подогнать другие версии этого проигрывателя? (и стоит ли?). Почему под разные дистрибутивы требуются разные его версии? Но тогда почему под любую винду существует и одинаково хорошо подходит (достаточно) всего одна версия?
     
     
  • 2.7, Анонимнез (?), 14:18, 07/10/2011 [^] [^^] [^^^] [ответить]  
  • +1 +/
    сорцы
       @
    компиль

    Решетки у всех стандартные. Пингвин птица свободная.

     
  • 2.8, гость (?), 14:23, 07/10/2011 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Потому что сидите не на роллинг релизе, его не собирали под устаревшую ось. Так же как и в винде(вантус-вей, что значит жить без репов) вы можете взять более новый собранный для новой убунту или дебиан и поставить, но в репы его врядли кто-то добавлять будет.

    Читайте и обновляйте http://www.videolan.org/vlc/download-ubuntu.html

     
  • 2.14, Мимо шел (?), 15:13, 07/10/2011 [^] [^^] [^^^] [ответить]  
  • +/
    https://launchpad.net/~n-muench/+archive/vlc2
     
  • 2.30, lucentcode (ok), 17:00, 07/10/2011 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Вы знакомы с понятием зависимостей в Linux В оффтопе каждая программа тянет с с... большой текст свёрнут, показать
     
     
  • 3.90, Michael Shigorin (ok), 02:53, 05/11/2011 [^] [^^] [^^^] [ответить]  
  • +/
    > Так, как разным версиям ПО нужны разные версии библиотек, то был создан механизм,
    > предотвращающий dll hell

    Всё перепутали...

    А спрашивавшему мог бы пригодиться ответ "взять/сделать (полу)статическую сборку", но свободный мультимедийный стек -- очень быстро движущаяся мишень и как раз с ним это совет о двух концах.

     

  • 1.9, гость (?), 14:26, 07/10/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Нет, я пожалуй останусь с мплеером и его новым личиком - умплеером. Работает намного шустрее.
     
  • 1.10, ua9oas (?), 14:51, 07/10/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Сейчас столкнулся с еще одной проблемой- аудиофайлы с разширением vqf он не воспроизводит. Но его виндовая версия без проблем это воспроизводит! Почему так? (у меня под "10.04.3" стоит штук 15 всяких проигрывателей. Ни один это не воспроизводит! Как заставить? Еще для этих целей существует плагин под winamp. Ставил я его у разных пользователей. У одних без проблем ставится. Но чаще- ошибку какую то выдает).
     
     
  • 2.43, Michael Shigorin (ok), 21:09, 07/10/2011 [^] [^^] [^^^] [ответить]  
  • +/
    >  Сейчас столкнулся с еще одной проблемой- аудиофайлы с разширением vqf он
    > не воспроизводит. Но его виндовая версия без проблем это воспроизводит!

    Спрашивайте у сборщика пакета -- возможно, какие-нить патентные проблемы, это ж убунта.

    В самом vlc поддержка довольно давно уже есть:
    http://git.videolan.org/gitweb.cgi?p=vlc.git;a=commitdiff;h=ff600b4fa68c3438d

     

  • 1.11, Аноним (-), 15:03, 07/10/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +2 +/
    Ребят - ПОМОГИТЕ Реально xрeнь какая-то с этим плеером Не может нормально прои... большой текст свёрнут, показать
     
     
  • 2.12, Jarex (?), 15:04, 07/10/2011 [^] [^^] [^^^] [ответить]  
  • +6 +/
    Я честно читал форумы VLC, но все что ни пробовал... вобщем ничего не вышло.
     
  • 2.15, Анонимайзер (?), 15:18, 07/10/2011 [^] [^^] [^^^] [ответить]  
  • –2 +/
    Вам даже компьютер намекает что много мультиков вредно! Особенно таких размеров.
     
     
  • 3.17, Jarex (?), 15:25, 07/10/2011 [^] [^^] [^^^] [ответить]  
  • –1 +/
    А кто сказал, что я смотрю много? По делу есть что сказать, трепло?
     
     
  • 4.18, jijojim (?), 15:30, 07/10/2011 [^] [^^] [^^^] [ответить]  
  • +/
    1. Чем пожато?
    2. Чем еще пробовали смотреть?
    3. В влц ну ооочень много настроек касаемо декодирования.
     
     
  • 5.21, Jarex (?), 15:40, 07/10/2011 [^] [^^] [^^^] [ответить]  
  • +1 +/
    1 Рипы в основном от профессионалов этого дела, 100 дело не в рипах Вот напри... большой текст свёрнут, показать
     
     
  • 6.22, xanten (?), 15:46, 07/10/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Сколько пользуюсь VLC, проблемы с MKV были всегда. То картинка сыпется, проигрыватель зависает или вообще падает. Не любит он MKV, мой совет пользуйтесь Mplayer.
     
     
  • 7.23, Анон (?), 15:52, 07/10/2011 [^] [^^] [^^^] [ответить]  
  • –2 +/
    Вообще странный подход - вместо того, чтобы допиливать известные косяки, разрабы VLC гонятся за новыми фишками. В 1.2 собираются поддержку Blu-ray дисков добавить. Но зато MKV сыпится в квадраты и их это не парит.

    Насчет Mplayer хотел бы спросить. В системе он стоит, но в списке программ что-то не нашел... Он консольный? Как вызвать?

     
     
  • 8.24, grayich (ok), 16:00, 07/10/2011 [^] [^^] [^^^] [ответить]  
  • +1 +/
    gmplayer - gtk гуй smplayer - qt4 гуй umplayer - qt4 гуй хотя консольного вполне... текст свёрнут, показать
     
     
  • 9.26, Анон (?), 16:19, 07/10/2011 [^] [^^] [^^^] [ответить]  
  • +/
    В umplayer не помню что не понравилось, а sm не хотел проигрывать MKV, рылся на ... текст свёрнут, показать
     
  • 9.28, Анон (?), 16:28, 07/10/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Еще вопрос насчет UMPlayer Решил скачать еще раз попробовать На сайте последня... текст свёрнут, показать
     
     
  • 10.29, grayich (ok), 16:48, 07/10/2011 [^] [^^] [^^^] [ответить]  
  • +/
    не нашёл, где какая ось ... текст свёрнут, показать
     
     
  • 11.31, Анон (?), 17:36, 07/10/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Все верно последняя версия 1 0 - еще в апреле вышла В первом посте написал - K... текст свёрнут, показать
     
     
  • 12.34, Anonplus (?), 18:23, 07/10/2011 [^] [^^] [^^^] [ответить]  
  • +1 +/
    http www it-obzor com node 199 ... текст свёрнут, показать
     
  • 12.49, grayich (ok), 03:37, 08/10/2011 [^] [^^] [^^^] [ответить]  
  • +/
    что-то 1 0 не вижу, 0 98 последняя ... текст свёрнут, показать
     
     
  • 13.50, Анон (?), 04:32, 08/10/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Верно 0 9 - это файл пакета назывался 1 0 ... текст свёрнут, показать
     
  • 2.19, Jarex (?), 15:31, 07/10/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Есть мысль, что аппаратное декодирование не работает... Может такое быть? Как проверить? Драйвер nVidia Current.

    И еще такой вопрос. В программе "Дополнительные драйвера" возле строки "nVidia Current" стоит зеленый кружок, а внизу сноска - этот драйвер активирован, но СЕЙЧАС НЕ ИСПОЛЬЗУЕТСЯ. Как понимать? Я же с ним в Oilrush играл, нормально используется. Что не так?

     
     
  • 3.53, koloboid (ok), 06:53, 08/10/2011 [^] [^^] [^^^] [ответить]  
  • +/
    > Есть мысль, что аппаратное декодирование не работает... Может такое быть? Как проверить?

    sudo apt-get install libvdpau1

    и выхлоп vlc, а лучше mplayer - сюда

     
     
  • 4.59, Анон (?), 14:29, 08/10/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Этот пакет уже стоит...
     
  • 2.36, Zenitur (ok), 18:32, 07/10/2011 [^] [^^] [^^^] [ответить]  
  • –4 +/
    > Не может нормально проигрывать на мощном компе.
    > i2500K, GTX 560 Ti, 4GB памяти, HDD 7200 и 32 мб.
    > Kubuntu 11.04

    Anonus, залогинься!

     
     
  • 3.41, Jarex (?), 20:10, 07/10/2011 [^] [^^] [^^^] [ответить]  
  • +5 +/
    Это ты мне? Чтобы залогиниться под кого-то, надо сначала зарегаться.
     
  • 2.37, dq0s4y71 (??), 19:00, 07/10/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Подтверждаю. У меня такое было и на линуксе и на Венде. В результате MKV я проигрываю другим плеером, благо этого добра сейчас завались.
     
  • 2.44, Michael Shigorin (ok), 21:21, 07/10/2011 [^] [^^] [^^^] [ответить]  
  • +/
    > Ребят - ПОМОГИТЕ!

    <thresh> gvy: да откуда ж понять, надо больше информации
    <thresh> используется ли аппаратное декодирование или нет
    <thresh> может и не хватать одного ядра
    <thresh> а аниме потому, что там кодируют на максимальном H264 profile, который наиболее тяжел для процессора
    <thresh> в любом случае на такой карте я бы декодировал аппаратно
    <thresh> ну и пробовал версию 1.2
    <thresh> интересно почему эти люди не приходят к нам на форумы?
    <thresh> а сидят непонятно где
    <gvy> thresh, передать туда и попросить зафайлить?
    <thresh> файлить тут нечего, насколько я вижу
    <thresh> передать можешь, если непонятно пусть приходит на форум
    <gvy> ok

     
     
  • 3.45, Jarex (?), 23:15, 07/10/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Не понял, что тут происходит? Диалог 2х человек в одном посте?

    Вы разработчик VLC? Что за форум? Кому чего передать? Какая еще информация требуется? Если Вы в силах помочь с моей проблемой, то скажите что мне сделать? Очень хочу нормально заставить работать VLC, мой любимый плеер все-таки всегда был...

    А насчет аппаратного декодирования видеокартой - такое ощущение что оно вообще не работает, просто галочка...

     
     
  • 4.46, Michael Shigorin (ok), 00:35, 08/10/2011 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Не понял, что тут происходит? Диалог 2х человек в одном посте?

    Да, копипаст переписки на #altlinux по поводу #11.  Решил было закинуть туда ссылку на случай, если в итоге полезный багрепорт нарисуется.

    > Вы разработчик VLC?

    Нет, а вот thresh@altlinux -- да.

    > Что за форум?

    Видимо, http://forum.videolan.org.

    > Кому чего передать? Какая еще информация требуется? Если Вы в силах помочь
    > с моей проблемой, то скажите что мне сделать?

    Я вряд ли (не интересуюсь особо HD и VAAPI/VDPAU), но попробовать изложить в более профильном месте проблему с указанием версий и того, какие именно аппаратные средства используются для декодирования (CPU или CPU+GPU), может оказаться более продуктивным.

    > А насчет аппаратного декодирования видеокартой - такое ощущение что оно вообще не
    > работает, просто галочка...

    Видимо, действительно почему-то не работает у Вас.  О том, что при каких-то условиях оно конкретно в vlc работает -- я знаю, но опять же не моя тема.

     
     
  • 5.47, Анон (?), 02:59, 08/10/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Тогда зарегаюсь на досуге на форуме VLC и попытаемся разобраться.
     
  • 5.48, Аноним (-), 03:23, 08/10/2011 [^] [^^] [^^^] [ответить]  
  • +/
    > Видимо, http://forum.videolan.org.

    А смысл туда ходить если там нет русскоязычного раздела?

     
     
  • 6.51, Анон (?), 04:34, 08/10/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Вообще с английским напряг, придется переводчиком пользоваться, жаль.
     
     
  • 7.58, Michael Shigorin (ok), 12:31, 08/10/2011 [^] [^^] [^^^] [ответить]  
  • +2 +/
    > Вообще с английским напряг, придется переводчиком пользоваться, жаль.

    Если совсем не поймут -- пишите почтой, постараюсь перевести.

     
     
  • 8.60, Jarex (?), 14:30, 08/10/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Благодарю конечно Надеюсь все-же получится своими силами ... текст свёрнут, показать
     
  • 2.62, Maresias (ok), 16:20, 08/10/2011 [^] [^^] [^^^] [ответить]  
  • +/
    > Реально xрeнь какая-то с этим плеером.
    > Не может нормально проигрывать на мощном компе.

    У меня была аналогичная проблема с VLC. Перешёл на SMPLayer. И друзьям-знакомым порекомендовал перейти, пока все довольны.

     
     
  • 3.63, Jarex (?), 19:23, 08/10/2011 [^] [^^] [^^^] [ответить]  
  • +1 +/
    При смене дорожек моментально зависает и перестает что-либо проигрывать. В UMPlayer при подключении внешней дорожки во время просмотра - видео начинает лагать.

    Вот бы в Dragon Player добавили сабы и дорожки - больше ничего не надо. Хотя если все эти плееры юзают одну и ту же библиотеку, то не факт что Dragon Player не залагает при подключении внешней дорожки. Вобщем придется таки написать на форум VLC, реально аналогов этому плееру я не вижу.

    Еще конечно консольный mplayer попробую.

     
     
  • 4.77, Piter_Ring (ok), 03:39, 10/10/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Аналог ему есть - это ВЛЦ под винду.
    И я тут не оговорился, это действительно работающий аналог.
    На сколько универсален и функционален он в винде, на столько же кривой и глючный он в линуксе.
    И линукс тут не причем (ну почти не причем).
    Что касается глюков выборочно в аниме - так тут тебе верно подсказали.
    Это особенность работы алгоритмов сжатия.
    Так как аниме - это набор простых примитивов с монотонной заливкой -
    то и коэфф. сжатия у такого контента бешенный.
    По хорошему, аниме жать надо в гиф-ы, этот алгоритм самое то для такой продукции.

     
  • 4.78, Аноним (-), 11:33, 10/10/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Вы используете Kubuntu - значит KDE А KDE - KDE4 А KDE4 ой какая непростая ш... большой текст свёрнут, показать
     
     
  • 5.79, Аноним (-), 11:39, 10/10/2011 [^] [^^] [^^^] [ответить]  
  • +/
    А вообще для анимешных дел я использую mplayer/smplayer. Мне они более удобными и простыми кажутся, ИМХО. Я извиняюсь за то, что пост адресовал немного не туда (нужно было прямо на первый отвечать).
     
  • 4.84, Piter_Ring (ok), 04:35, 11/10/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Вот не поленился, проверил свою теорию...
    результаты не однозначные.
    По причине отсутствия нативного линукса на железяке запустил все это чудо в виртуалке.
    Результат на картинке.
    https://picasaweb.google.com/lh/photo/Ac_DvxA8WGgUephWU3lBxJNCgQyeG_qTgmxSncRE

    Интел Ы3-530 4-ОЗУ
    Винда7х64
    виртуалкоробка оракловская сборка + экст-пак
    В ней на одном вирт-проце дебиан х32
    Влц 1.1.3
    Аватар 12Гб мкв (1080р)

    Тормоза (можно сказать и артефакты) появляются только если включить звук 5+1.)
    Но тут нужно смотреть в сторону подсистемы звука в винде7 которую вполне успешно
    умудрились сломать индусские ГУРУ.

    С другой стороны я вполне допускаю, что все красиво работает только в виртуалке.
    В случае установки того-же дебиана непосредственно на железо - можно получить
    непредсказуемый результат в плане быстродействия/воспроизведения видео.

    Кстати, во время работы всей этой кухни, одно ядро проца вообще ушло в спячку.
    В таскменеджере эо хорошо видно

     
  • 2.80, Ryoken (ok), 12:03, 10/10/2011 [^] [^^] [^^^] [ответить]  
  • +/
    >[оверквотинг удален]
    > Реально xрeнь какая-то с этим плеером.
    > Не может нормально проигрывать на мощном компе.
    > i2500K, GTX 560 Ti, 4GB памяти, HDD 7200 и 32 мб.
    > Kubuntu 11.04
    > Есть 2 проблемы - обе с проигрыванием MKV в Full HD:
    > 1) Почти все аниме (ПОЧЕМУ АНИМЕ?) в 1920x1080 рассыпаются каждые 1-2 минуты
    > в квадратики.
    > 2) Каждый 3-4й фильм в MKV 1920x1080 так же сыпется временами в
    > квадраты.
    > КАК ТАКОЕ ВООБЩЕ ВОЗМОЖНО на таком железе?

    (Просьба уважаемому сообществу ногами не пинать :) ). Дома C2Q 9300 GeForce 9600Gt (NV проприетарный драйвер), звук M-Audio Revolution 7.1 (ALSA), 8Гб Рам, винт под Debian Unstable + отдельный под аниме (2Тб, специально на то выделенный, исторически так получилось, что он под GPT+NTFS). SMPlayer жрёт почти любое видео на ура, видеовывод стоит vdpau, аниме в mkv спокойно проигрывается, сабы есть, что встроенные, что навесные из файлов. Если уважаемое сообщество подскажет, как посмотреть, какие пакеты по зависимостям нужны для smplayer (я пока что не особо разбираюсь), ИМХО может и поможем товарищу. (На этом компе в Дебиане как-то вообще не испытывал необходимости в VLC).

     

  • 1.13, grayich (ok), 15:10, 07/10/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    >> VLC 1.1.12

    машина времени? на сайте 1.1.11

     
     
  • 2.16, 17 (??), 15:24, 07/10/2011 [^] [^^] [^^^] [ответить]  
  • +/
    http://www.videolan.org/vlc/download-sources.html
     

  • 1.35, Zenitur (ok), 18:24, 07/10/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    > Вышла новая версия медиаплеера VLC 1.1.12, в которой улучшена поддержка вывода звука с использованием PulseAudio, а также решены некоторые проблемы при работе на платформе Mac OS X.

    Значит обновляться не обязательно?

     
  • 1.38, dq0s4y71 (??), 19:02, 07/10/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    А он уже научился в венде правильно открывать папки VIDE_TS если в пути к ним есть русские буквы?
     
     
  • 2.39, dq0s4y71 (??), 19:03, 07/10/2011 [^] [^^] [^^^] [ответить]  
  • +/
    *VIDEO_TS
     
  • 2.40, Аноним (-), 19:32, 07/10/2011 [^] [^^] [^^^] [ответить]  
  • +/
    > в венде правильно открывать папки VIDE_TS если в пути к ним есть русские буквы

    Вот это я и называю кривым чесанием левой ноги через правое ухо...

     
     
  • 3.54, Square (ok), 10:00, 08/10/2011 [^] [^^] [^^^] [ответить]  
  • +1 +/
    неспособность открыть папку  с названием на национальном языке?
    Да за это вообще расстреливать надо!!!
     
     
  • 4.56, Клыкастый (ok), 11:11, 08/10/2011 [^] [^^] [^^^] [ответить]  
  • +3 +/
    > неспособность открыть папку  с названием на национальном языке?
    > Да за это вообще расстреливать надо!!!

    вы, батенька, спохватились поздно. Расстреливать надобно было за зоопарк кодировок в венде. Местами utf, местами cp1251, а где-то для совместимости cp866. В общем я бы даже рекомендовал на расстрел, а что-то более продуманное и эпичное. В особенности за cp1251.

     
     
  • 5.57, Square (ok), 11:27, 08/10/2011 [^] [^^] [^^^] [ответить]  
  • +/
    >> неспособность открыть папку  с названием на национальном языке?
    >> Да за это вообще расстреливать надо!!!
    > вы, батенька, спохватились поздно. Расстреливать надобно было за зоопарк кодировок в венде.
    > Местами utf, местами cp1251, а где-то для совместимости cp866. В общем
    > я бы даже рекомендовал на расстрел, а что-то более продуманное и
    > эпичное. В особенности за cp1251.

    И тут все вспомнили как юникод внедрялся в линух, и досих пор внедряется во фрю :)

     
     
  • 6.61, Клыкастый (ok), 15:27, 08/10/2011 [^] [^^] [^^^] [ответить]  
  • +4 +/
    > И тут все вспомнили как юникод внедрялся в линух,

    вы так говорите, как будто за этим стоит трагедия с человеческими жертвами.

    > и досих пор внедряется во фрю :)

    пишу из-под фри. использую koi8-r. зуда срочного перехода на utf8 не ощущаю, хотя под линуксом использую utf.

    вы вправду не видите разницу между зоопарком кодировок и медленным внедрением новой кодировки?


     
     
  • 7.65, anonymous vulgaris (?), 02:08, 09/10/2011 [^] [^^] [^^^] [ответить]  
  • +/
    > пишу из-под фри. использую koi8-r. зуда срочного перехода на utf8 не ощущаю, хотя под линуксом использую utf.

    utf и koi8-r

    utf, cp1251, а где-то для совместимости cp866.

    итого на одну кодировку больше

    а вообще то конечно странно - ваша ось не поддерживает ни старой самой распространенной кодировки, ни новой самой распространенной кодировки

     
     
  • 8.68, Клыкастый (ok), 21:10, 09/10/2011 [^] [^^] [^^^] [ответить]  
  • +/
    в винегрете locale -m ARMSCII-8 Big5 Big5HKSCS CP1131 CP1251 -- раз CP8... текст свёрнут, показать
     
  • 5.70, dq0s4y71 (??), 23:10, 09/10/2011 [^] [^^] [^^^] [ответить]  
  • +/
    > Расстреливать надобно было за зоопарк кодировок в венде.

    А причём здесь зоопарк кодировок? Плеер открывает файл в ТОЙ ЖЕ кодировке, в како

     
  • 5.71, dq0s4y71 (??), 23:17, 09/10/2011 [^] [^^] [^^^] [ответить]  
  • +/
    > Расстреливать надобно было за зоопарк кодировок в венде.

    А причём здесь зоопарк кодировок? Плеер открывает файл с именем в ТОЙ ЖЕ кодировке, в какой он видит его на диске. Я вообще не понимаю, что нужно сделать чтобы его НЕ открыть! Это же задача для студента-первокурсника!

     
     
  • 6.74, Клыкастый (ok), 01:40, 10/10/2011 [^] [^^] [^^^] [ответить]  
  • –1 +/
    >> Расстреливать надобно было за зоопарк кодировок в венде.
    > А причём здесь зоопарк кодировок?

    Кодовая страница в системе 1251. Кодировка имён файлов NTFS - utf. Откуда человеку, работавшему с нормальной ОС знать что них ВОТ ТАК.

    > Я вообще не понимаю

    Это очевидно

    > что нужно сделать чтобы его НЕ открыть! Это же задача для студента-первокурсника!

    Не заставляйте меня искать примеры. вы просто ненаблюдательны. вот только один достаточно свежий пример. например в XP заведён пользователь Пупкин (кириллицей). например ставим игру EVE Online. В каталоге Documents and settings тут же появляется каталог с фееричным названием P?P?P?ё?C? и т.д., в котором мы узнаём "Пупкин" в адски изувеченой кодировке. Там уже лежат всякие данные, но не об этом речь. EVE что по графике, что по замыслу написана явно не первокурсниками. Она писалась под одну-единственную платформу - Win*. И тем не менее проблема есть. Повторюсь, человек легко может не знать, что оно у вас ТАК.

     
     
  • 7.81, dq0s4y71 (??), 14:14, 10/10/2011 [^] [^^] [^^^] [ответить]  
  • +/
    > Кодовая страница в системе 1251. Кодировка имён файлов NTFS - utf. Откуда человеку, работавшему с нормальной ОС знать что них ВОТ ТАК.

    Я вам открою секрет: человеку об этом знать и не надо :) Винда сама знает, в какой кодировке у неё работает приложение, и при необходимости конвертирует имя. Если вы вводите имя файла в диалоговом окне, а потом берёте полученную строку, и КАК ЕСТЬ передаёте её в CreateFile, то никаких проблем не возникает. Сюрприз? :)

    > Не заставляйте меня искать примеры. вы просто ненаблюдательны. вот только один достаточно свежий пример. например в XP заведён пользователь Пупкин (кириллицей). например ставим игру EVE Online. В каталоге Documents and settings тут же появляется каталог с фееричным названием P?P?P?ё?C? и т.д., в котором мы узнаём "Пупкин" в адски изувеченой кодировке. Там уже лежат всякие данные, но не об этом речь. EVE что по графике, что по замыслу написана явно не первокурсниками. Она писалась под одну-единственную платформу - Win*. И тем не менее проблема есть. Повторюсь, человек легко может не знать, что оно у вас ТАК.

    У вас явно проблемы с логикой :) Вы пытаетесь ошибки приложений представить как проблему венды. Поймите, если бы это была проблема венды, то подобные косяки наблюдались бы ВСЕГДА, во ВСЕХ приложениях. Но у подавляющего большинства приложений нет проблем с кодировками имён файлов. Следовательно, это ошибки КОНКРЕТНЫХ приложений, в данном случае ВЛЦ и вашей игрушки. А то, что их пишут "явно не первокурсники", - вообще не аргумент. Откуда вы знаете КТО их пишет? :)

     
     
  • 8.88, Клыкастый (ok), 22:54, 12/10/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Чтобы прикрыть ваше непонимание ситуации вам срочно надо продвигать гипотезу о т... текст свёрнут, показать
     
  • 3.69, dq0s4y71 (??), 23:08, 09/10/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Вообще-то открывать папки, скопированные с DVD диска, умеют все вменяемые плееры. Не знал, что в мире "свободного программного обеспечения" это такая экзотика :)
     
     
  • 4.89, Клыкастый (ok), 00:03, 13/10/2011 [^] [^^] [^^^] [ответить]  
  • +/
    > Вообще-то открывать папки, скопированные с DVD диска, умеют все вменяемые плееры. Не  знал, что в мире "свободного программного обеспечения" это такая экзотика :)

    повторяю: в нормальных ОС всё работает ;)


     
  • 2.55, Клыкастый (ok), 11:04, 08/10/2011 [^] [^^] [^^^] [ответить]  
  • +/
    я сочуствую вам и вашей венде
     
     
  • 3.72, dq0s4y71 (??), 23:19, 09/10/2011 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Спасибо, конечно. Правда я свои проблемы давно решил. А вот ВЛЦ как был кривым красноглазым поделием, так и остаётся. Так что лучше выразите своё сочувствие его разработчикам.
     
     
  • 4.75, Клыкастый (ok), 01:42, 10/10/2011 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Спасибо, конечно. Правда я свои проблемы давно решил.

    А у меня их и не возникло.

    > А вот ВЛЦ как был кривым красноглазым поделием, так и остаётся.

    В нормальных ОС таких проблем не возникает ;)

    > Так что лучше выразите  своё сочувствие его разработчикам.

    Им респект. А вот вам посочувствовать дважды ;)


     
     
  • 5.86, Square (ok), 12:11, 11/10/2011 [^] [^^] [^^^] [ответить]  
  • +/
    >> Спасибо, конечно. Правда я свои проблемы давно решил.
    > А у меня их и не возникло.

    Вы его не запускали что-ли?

    >> А вот ВЛЦ как был кривым красноглазым поделием, так и остаётся.
    > В нормальных ОС таких проблем не возникает ;)

    Например в каких?

     
     
  • 6.87, Клыкастый (ok), 22:43, 12/10/2011 [^] [^^] [^^^] [ответить]  
  • +1 +/
    >>> Спасибо, конечно. Правда я свои проблемы давно решил.
    >> А у меня их и не возникло.
    > Вы его не запускали что-ли?

    gentoo, vlc. только что запустил DVD из %home%/Новая папка/VIDEO_TS. могу поделиться скриншотом.

    >>> А вот ВЛЦ как был кривым красноглазым поделием, так и остаётся.
    >> В нормальных ОС таких проблем не возникает ;)
    > Например в каких?

    gentoo, ~amd64. могу поспорить, что во FreeBSD всё так же будет работать.

     

  • 1.66, ua9oas (?), 05:47, 09/10/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    а вот у меня с кодировками тоже проблема есть- все текстовые файлы, сохраненные в винде моя "10.04.3" не понимает (крокозябры выдает). Однако все что там url и на английском языке- отображает правильно. (Текстовые файлы, созданные в убунте можно нормально открыть "Word"ом). Это почему так и что мне сделать чтобы ее "заставить" то понимать? (сейчас у меня менеджер обновлений нашел 6 обновлений language pack GNOME и KDE translation updates. В описании версии написано "Automatic update to latest translation data". Сейчас установлю. Интересно, а что это такое? Оно в той проблеме поможет?)
     
     
  • 2.67, Michael Shigorin (ok), 20:47, 09/10/2011 [^] [^^] [^^^] [ответить]  
  • +/
    > а вот у меня с кодировками тоже проблема есть- все текстовые
    > файлы, сохраненные в винде моя "10.04.3" не понимает (крокозябры выдает).

    Пользуйтесь редакторами, умеющими кодировки (вероятно, там cp866 или cp1251).  Или уже осваивайте iconv, recode, enca/enconv.

    > (сейчас у меня менеджер обновлений нашел 6 обновлений language pack GNOME и KDE
    > translation updates. В описании версии написано "Automatic update to latest translation
    > data". Сейчас установлю. Интересно, а что это такое? Оно в той проблеме поможет?)

    Это хлам, который никакой проблеме не поможет.  Называется "криворукие переводы UI".

     

  • 1.83, ua9oas (?), 17:23, 10/10/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Да похоже что написанием его под линукс просто внимания заметно меньше уделяется. Там даже и цифры в названии версии то другие (совпадают с цифрами виндовых версий. Но- их давних устаревших).
      А ведь winamp под линукс- так вообще не пишут.
      Что будет если виндовый VLC запускать из под wine? (раз обновлениям и исправлениям виндоваго я так понял намного больше внимания уделяется. А с "Винампом" если так поэкспериментировать то тогда что будет?). Вдруг лучше работать будет? (а то я людям под винду сколько VLC ни ставил- никто не жаловался! (заметил что многие пользователи винды все слышали слово "Линукс". Но большинство- не знают что это такое!)) Интересно если линуксовую версию VLC как следует допилить то сколько это стоит? (а кому это надо если их других под линукс полно?)
     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2020 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру