The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Выпуск видеодрайверов xf86-video-amdgpu 1.0.0 и xf86-video-ati 7.6.0

19.11.2015 19:54

Представлен первый релиз X.org-драйвера xf86-video-amdgpu, который является форком драйвера xf86-video-ati, адаптированным для работы поверх интегрированного в состав ядра Linux модуля AMDGPU, который также послужит основой для будущих выпусков драйвера Catalyst. Драйвер xf86-video-amdgpu ориентирован на использование с новыми семействами GPU, такими как Tonga, Carrizo, Iceland, Fiji и Stoney. Код для поддержки старых GPU, которые не могут работать с модулем amdgpu исключён из кодовой базы драйвера.

Пользователям старых GPU рекомендовано продолжить использование драйвера xf86-video-ati, свежий выпуск 7.6.0 которого был опубликован на прошлой неделе. В новой версии появилась поддержка расширений DRI3 и Present, добавлена опция "TearFree" для подавления появления разрывов картинки (tearing), добавлена опция "ShadowPrimary", позволяющая увеличить производительность для некоторых видов 2D-операций, реализована поддержка DisplayPort 1.2 MST, обеспечена возможность запуска в режиме "Xorg -background none", добавлена поддержка новых GPU Bonaire и Oland.

  1. Главная ссылка к новости (http://lists.freedesktop.org/a...)
  2. OpenNews: В состав ядра Linux 4.2 принят драйвер AMDGPU
  3. OpenNews: Релиз ядра Linux 4.2
  4. OpenNews: Компания AMD представила новую стратегию разработки графических драйверов для Linux
  5. OpenNews: AMD опубликовал код AMDGPU с воплощением новой концепции построения графических драйверов
  6. OpenNews: Релиз свободного видеодрайвера xf86-video-ati 7.5.0
Лицензия: CC-BY
Тип: Программы
Короткая ссылка: https://opennet.ru/43356-amdgpu
Ключевые слова: amdgpu, amd
При перепечатке указание ссылки на opennet.ru обязательно
Обсуждение (35) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.1, pavlinux (ok), 20:13, 19/11/2015 [ответить] [﹢﹢﹢] [ · · · ]  
  • +5 +/
    > GPU Oland....

    GPU Merkel, GPU Obama и GPU Putin будут? =)

     
     
  • 2.2, Аноним (-), 20:34, 19/11/2015 [^] [^^] [^^^] [ответить]  
  • –6 +/
    GPU Putin будет от разработчика CPU Baikal
     
  • 2.5, Аноним (-), 20:54, 19/11/2015 [^] [^^] [^^^] [ответить]  
  • –14 +/
    ещё не поздно купить острова и так их назвать..
     
  • 2.13, Аноним (-), 22:31, 19/11/2015 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Будет GPU Potroshenko
     

  • 1.3, Аноним (-), 20:40, 19/11/2015 [ответить] [﹢﹢﹢] [ · · · ]  
  • –2 +/
    Этот TearFree активен по умолчанию или нет?
     
     
  • 2.10, equeim (ok), 21:31, 19/11/2015 [^] [^^] [^^^] [ответить]  
  • +9 +/
    Нет. Чтобы его включить, надо добавить Option "TearFree" "1" в /etc/X11/xorg.conf.d/ и отключить vsync в композитном менеджере (есть используется).
    Также стоит включить DRI3.

    cat /etc/X11/xorg.conf.d/radeon.conf



    Section "Device"
        Identifier "Radeon"
        Driver "radeon"
        Option "DRI3" "1"
        Option "TearFree" "1"
    EndSection



     
     
  • 3.12, Анонимусс (?), 22:31, 19/11/2015 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Спасибо тебе, добрый человек.
     
  • 3.19, John (??), 09:14, 20/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    Только DRI3 включается так (man radeon)

    Option "DRI" "3"

     
  • 3.52, ._. (?), 21:19, 22/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    >[оверквотинг удален]
    > Также стоит включить DRI3.
    > cat /etc/X11/xorg.conf.d/radeon.conf
    >


    > Section "Device"
    >     Identifier "Radeon"
    >     Driver "radeon"
    >     Option "DRI3" "1"
    >     Option "TearFree" "1"
    > EndSection
    >

    это чо и есть Freesync ?

     
  • 2.23, Аноним (-), 11:45, 20/11/2015 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Alt-F2, compton --vsync drm

    И никакого /etc/X11/xorg.conf не надо!

    Для проприетарного драйвера: compton --vsync opengl. Галочки "Sync to VBlank" в NVIDIA X Server Settings или в Catalyst надо убрать.

     

  • 1.4, orgkhnargh (ok), 20:49, 19/11/2015 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    А для гибридной HD6630m для ноутов какой драйвер нужен?
     
     
  • 2.6, commiethebeastie (ok), 20:58, 19/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    R600g
     
  • 2.7, Ano (?), 21:09, 19/11/2015 [^] [^^] [^^^] [ответить]  
  • +2 +/
    xf86-video-ati
     

  • 1.8, Константавр (ok), 21:10, 19/11/2015 [ответить] [﹢﹢﹢] [ · · · ]  
  • +3 +/
    >Код для поддержки старых GPU, которые не могут работать с модулем amdgpu исключён из кодовой базы драйвера.

    Афигеть...

     
     
  • 2.11, fa9483789 (?), 22:12, 19/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    А что "афигеть"? Помоему, глупо было ожидать, что они начнут переписывать кривой старый драйвер для новых видеокарт, и заодно перепишут для старых. Тем более, на это сразу указали. Это, конечно, плохо, так кидать пользователей, пользователи могут только перестать покупать карты AMD, но из альтерантив только nVidia. Если не для игр, то встроенный Intel подойдет.
     
     
  • 3.14, Аноним (-), 22:35, 19/11/2015 [^] [^^] [^^^] [ответить]  
  • +5 +/
    Но не сказано же, что на старый xf86-video-ati ваще забьют.
     
     
  • 4.29, fa93847398 (?), 15:44, 20/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    Так речь вообще не про него.
     
  • 3.15, Аноним (-), 23:12, 19/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    Почему дропнули 6xxx это понятно, но карточки на GCN 1.0 и 1.1 могли бы добавить в драйвер, что им мешало то?
     
     
  • 4.16, fi (ok), 00:44, 20/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    написано же: «поверх интегрированного в состав ядра Linux модуля AMDGPU» - что amd туда впихнуло то и будет работать.
     
     
  • 5.17, Аноним (-), 02:06, 20/11/2015 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Дык меня интересует почему амд старые gcn дропнули.
     
     
  • 6.20, Аноним (-), 09:50, 20/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    может они планируют amdgpu доработать, кто знает
    HD6980 дропать вообще не красиво, она с 2 гигами на борту многие современные не TOP заменит с лихвой, правда и по свисту турбины тоже :)
     
     
  • 7.21, Аноним (-), 10:24, 20/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    HD 69[b]70[/b]
     
  • 6.32, Аноним (-), 18:41, 20/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    Всегда так делали. И будут делать.
     
  • 4.25, pkunk (ok), 12:47, 20/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    Для них уже есть работающий драйвер - radeon.
     
  • 3.24, Аноним (-), 12:46, 20/11/2015 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Ubuntu 15.04 + GeForce GT 630 - тиринг никуда не делся.
     
     
  • 4.30, Sluggard (ok), 17:23, 20/11/2015 [^] [^^] [^^^] [ответить]  
  • +2 +/
    После обновления драйвера AMD никуда не делся тиринг на Nvidia? Странно, да.
     
  • 4.33, Аноним (-), 19:12, 20/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    Alt-F2, compton --vsync opengl

    Компизитинг в KWin или в GNOME перед этим отключить.

     

  • 1.9, Ano (?), 21:23, 19/11/2015 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    тс , с разморозкой ... xf86-video-ati-7.6.1 :)
     
     
  • 2.27, Ilya Indigo (ok), 14:00, 20/11/2015 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Арч?
    В Сюзе до сих пор 7.5.0, хотя ядро уже 4.3.0. :-(
     
     
  • 3.28, Аноним (-), 14:13, 20/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    гена
     
  • 3.31, Sluggard (ok), 17:28, 20/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    > Арч?
    > В Сюзе до сих пор 7.5.0, хотя ядро уже 4.3.0. :-(

    Реп X11 подключи. Идёшь на http://download.opensuse.org/repositories/X11:/XOrg/ выбираешь версию дистра, если надо свежак. Сегодня как раз обновы прилетели, включая вышеуказанную 7.6.1 для ati.

     

  • 1.18, Александр (??), 08:22, 20/11/2015 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    В начале анонса указано:

    >It was forked from the xf86-video-ati radeon driver and modified to
    >support the amdgpu kernel driver via libdrm_amdgpu, and by extension
    >the latest AMD GPU families Tonga, Carrizo, Iceland, Fiji and Stoney.

    а ниже:

    >Marek Olšák (3):
    >      ddx: enable acceleration by default on Hawaii

    Как это понимать?

     
     
  • 2.26, pkunk (ok), 12:59, 20/11/2015 [^] [^^] [^^^] [ответить]  
  • +/
    > В начале анонса указано:
    >>It was forked from the xf86-video-ati radeon driver and modified to
    >>support the amdgpu kernel driver via libdrm_amdgpu, and by extension
    >>the latest AMD GPU families Tonga, Carrizo, Iceland, Fiji and Stoney.
    > а ниже:
    >>Marek Olšák (3):
    >>      ddx: enable acceleration by default on Hawaii
    > Как это понимать?

    amdgpu неофициально поддерживает Sea Islands, изначально это было сделано чтобы было на чем тестить новый драйвер до появления Volcanic Islands.

     

  • 1.22, Аноним (-), 11:40, 20/11/2015 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    Кинули пользователей RHEL. AMD никогда не иметь прибылей с Linux, какую имеет NVIDIA с их рендер-фермами для киностудий.
     
  • 1.51, alex (??), 19:48, 20/11/2015 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Catalyst прекратит поддержку старых карт уровня R7 2xx? Теперь только opensource?
     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2020 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру