The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Выпуск пользовательского окружения Moksha 0.2, форка Enlightenment 17

16.01.2016 12:49

Представлен второй выпуск пользовательского окружения Moksha, развиваемого разработчиками дистрибутива Bodhi Linux. Исходные тексты проекта размещены на GitHub, для оценки работы окружения можно использовать свежие Live-сборки от дистрибутива Bodhi Linux. Для работы достаточно ПК с процессором 300 Mhz и 128 Мб ОЗУ. Дополнительно распространяется подборка модулей-расширений, например, рекомендуется установить модуль Pulse Mixer для управления звуком и Places для монтирования накопителей.

Moksha является форком окружения Enlightenment 17, созданным из-за недовольства политикой развития Enlightenment, в частности потери некоторой функциональности (например, встраивание в системный лоток с использованием протокола Xembed), раздувания кодовой базы, сосредоточения усилий на переработке внутренних подсистем вместо полировки существующих возможностей для конечных пользователей, отсутствие должного внимания поддержке уже сформированных релизов.

В новом выпуске завершена работа по чистке модулей E17 и удалению лишней функциональности, осуществлён перевод репозиториев с Subversion на Git, расширена функциональность команды enlightenment_remote, реализована возможность запуска программ на этапе загрузки окружения без создания отдельных .desktop-файлов, улучшена панель управления Swami.



  1. Главная ссылка к новости (http://it.toolbox.com/blogs/en...)
  2. OpenNews: Релиз дистрибутива Bodhi Linux 3.1, предлагающего десктоп-окружение Moksha
  3. OpenNews: Представлен Moksha, форк пользовательского окружения Enlightenment 17
  4. OpenNews: Выпуск пользовательского окружения Enlightenment E18
  5. OpenNews: Выпуск пользовательского окружения Enlightenment 19
  6. OpenNews: Выпуск пользовательского окружения Enlightenment 0.20 с полноценной поддержкой Wayland
Лицензия: CC-BY
Тип: Программы
Ключевые слова: moksha, desktop, enlightenment
При перепечатке указание ссылки на opennet.ru обязательно
Обсуждение (66) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.1, Аноним (-), 13:48, 16/01/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • –2 +/
    Косяк - черный текст на темном фоне в названиях вкладок в терминале.
    В остальном неплохо, надеюсь в скором времени допилят до годного состояния.
     
     
  • 2.37, Аноним (-), 13:05, 17/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Первый скрин самый адекватный ))
     

  • 1.3, Аноним (-), 13:59, 16/01/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +4 +/
    HAL заменил hotplug, udev libudev udisks upower заменил HAL, udisks2 заменил udi... большой текст свёрнут, показать
     
     
  • 2.4, Аноним (-), 14:00, 16/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > можно было сделать спин с RT-ядром и подборкой софта для дизайнеров и звукарей

    Тогда мы бы увидели профессиональный дорогой софт и для этого тоже, как сейчас мы видим рендер-фермы и рабочие станции для создания эффектов и 3D-графики в фильмах.

     
     
  • 3.47, Alexey Vanzhula (ok), 04:10, 18/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    >> можно было сделать спин с RT-ядром и подборкой софта для дизайнеров и звукарей
    > Тогда мы бы увидели профессиональный дорогой софт и для этого тоже, как
    > сейчас мы видим рендер-фермы и рабочие станции для создания эффектов и
    > 3D-графики в фильмах.

    Ниочем. Поинтересуйтесь о наличии профессионального линуксового 3д-софта. И именно в линуксовые их версии работают лучше виндов и этих ваших "дизайнерских" маков. Проверено

     
     
  • 4.72, Аноним (-), 07:05, 19/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    О чём я и говорю. Каким бы хорошим ни был 64 Studio, профессиональному софту не суждено было под него появиться. А в точности такой же продукт от Red Hat - с крутым микшером, GUI-шками для JACK, RT-ядром и всё такое прочее - был бы хорошей платформой для дорогого софта.
     
  • 4.73, Аноним (-), 07:58, 19/01/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    точно? gimp уже можно стало пользоваться без слез ?
     
     
  • 5.77, Alexey Vanzhula (ok), 19:39, 20/01/2016 [^] [^^] [^^^] [ответить]  
  • –2 +/
    > точно? gimp уже можно стало пользоваться без слез ?

    Я про 3д проприетарщину. И о том что она всегда круче работает на том же железе под линуксом нежели под виндой как минимум.

    А гимп да УГ. Отсутствие конкурентно способного растрового редактора камень в огород линуксов. Сидел в ФШ очень долго и мне жалко тех кто говорит что гимпа хватает или, что еще страшнее, гимп-конкурент ФШ.

     
     
  • 6.78, arisu (ok), 07:17, 22/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    использую GNU/Linux как основную, чуть позже — единственную ОС. GIMP завсегда хватало. ЧЯДНТ?

    хотя, я понял, что делаю не так: не выдвигаю свои личные хотелки и претензии в качестве всеобщих. и ещё не использую краденое нелицензионное ПО (а иначе откуда у тебя PhotoShop? ты таки платил за него бешеные бабки? бугогашеньки).

     
  • 6.85, Аноним (-), 22:57, 24/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > А гимп да УГ. Отсутствие конкурентно способного растрового редактора камень в огород линуксов.

    Вот не надо. Я пользовался и фотошопом и гимпом. Для обычных пользователей гимпа более чем. Отредактировать фото или даже арт нарисовать - за глаза. Кому не нравится - покупает фотошоп, пишет лучше или идет на север.

     
  • 2.5, Nicknnn (ok), 14:28, 16/01/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > HAL заменил hotplug, udev+libudev+udisks+upower заменил HAL, udisks2 заменил udisks. PulseAudio заменил ALSA. И так далее, и так далее.

    Всё это очень положительные замены, улучшившие, и расширившие функциональность. И пульс не заменил alsa.

    > В теории, у старых системных служб уже был раскрыт потенциал на 90%, и развиваться было трудно. А в новых службах, когда приделали весь старый функционал, стало раскрыто только 10%, поэтому есть куда стремиться.

    А примеры есть, однозначно подтверждающие это заявление?


    > спин с RT-ядром и подборкой софта для дизайнеров и звукарей

    Редхат не про это. Такого не случится.

     
     
  • 3.46, Alexey Vanzhula (ok), 04:04, 18/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > Редхат не про это. Такого не случится.

    Внезапно в профессиональном 3д софте именно редхат (иногда CentOS) всегда ставят в system requirements

     
     
  • 4.58, Аноним (-), 18:38, 18/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    >> Редхат не про это. Такого не случится.
    >  Внезапно в профессиональном 3д софте именно редхат (иногда CentOS) всегда ставят
    > в system requirements

    Пруфы или сам знаешь кто ты.


     
     
  • 5.59, Alexey Vanzhula (ok), 18:47, 18/01/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    >>> Редхат не про это. Такого не случится.
    >>  Внезапно в профессиональном 3д софте именно редхат (иногда CentOS) всегда ставят
    >> в system requirements
    > Пруфы или сам знаешь кто ты.

    1. http://www.sidefx.com/index.php?option=com_content&task=view&id=3151&Itemid=4
    2. https://knowledge.autodesk.com/support/maya/troubleshooting/caas/sfdcarticles/
    3. https://www.thefoundry.co.uk/products/mari/system-requirements/
    4. https://www.thefoundry.co.uk/products/modo/sys-reqs/
    5. https://www.thefoundry.co.uk/products/nuke/sys-reqs/

     
     
  • 6.63, Аноним (-), 20:01, 18/01/2016 [^] [^^] [^^^] [ответить]  
  • –3 +/
    Если ты о том, что Линукс (продакшен-линукс) тоже поддерживается, то да - он тоже поддерживается. Но ни о каком его доминировании и речи нет.
     
     
  • 7.64, Alexey Vanzhula (ok), 20:09, 18/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > Если ты о том, что Линукс (продакшен-линукс) тоже поддерживается, то да -
    > он тоже поддерживается. Но ни о каком его доминировании и речи
    > нет.

    Я о том что в системных требованиях всегда есть RHEL

     
     
  • 8.86, Аноним (-), 23:00, 24/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Всегда Стим так считает что есть убунта и все остальное ... текст свёрнут, показать
     
  • 2.12, ya_w_teme (?), 15:22, 16/01/2016 [^] [^^] [^^^] [ответить]  
  • +6 +/
    Pulse не может заменить Alsa по определению. Учи матчасть
     
     
  • 3.20, Аноним (-), 16:28, 16/01/2016 [^] [^^] [^^^] [ответить]  
  • –3 +/
    Приложения работают напрямую с Pulse. Даже старые приложения, которые не умеют ничего, кроме ALSA/ESD/OSS, общаются всё равно с Pulse. Где ж тут "не заменил"?

    Хорошо что гейм-девелоперы используют OpenAL, а не PulseAudio напрямую! А вот если бы не набралась критическая масса тех, кто отключает пульсу, то жизнь без пульсы стала бы как минимум некомфортной.

     
     
  • 4.29, Stax (ok), 22:30, 16/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Утверждение просто составлено слишком провокационно Правильно - libpulse замени... большой текст свёрнут, показать
     
     
  • 5.48, Аноним (-), 09:15, 18/01/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > А приложения, которые умеют только alsa или только pulse, это какие-то выродки, исключительно неудобный вариант.

    Вспомни 2007-й. Представь себе что ты выпускаешь LinDVD или Cedega. Через что пустишь звук? Ответ очевиден - через ALSA. А что, разве есть варианты? Пульсы ещё нет, а OpenAL - он для игр. Короче, выбор - один.

    Это теперь у 70% пульса, у 30% ALSA, и ещё у 1% Jack или OSS v.4. Или поддерживай зоопарк, или используй библиотеку-прослойку вроде Portaudio.

     
     
  • 6.70, Led (ok), 01:59, 19/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > Вспомни 2007-й. Представь себе что ты выпускаешь LinDVD или Cedega. Через что
    > пустишь звук? Ответ очевиден - через ALSA. А что, разве есть
    > варианты? Пульсы ещё нет,

    Уже есть.

    > а OpenAL - он для игр. Короче, выбор - один.

    У тупого школьника выбора вобще нет.

     
     
  • 7.75, Коля (?), 18:15, 20/01/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > У тупого школьника выбора вобще нет.

    У глупого школьника. Тупость характерна взрослым особям.

     
  • 4.81, arisu (ok), 07:24, 22/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > Приложения работают напрямую с Pulse. Даже старые приложения, которые не умеют ничего,
    > кроме ALSA/ESD/OSS, общаются всё равно с Pulse. Где ж тут "не
    > заменил"?

    (внимательно осмотрел свою систему) неа, не работает никто с пшшшш. нету тут пшшшшш. а звук есть. и даже отдельные громкости для mpv и остальных есть. опять я что‐то не так сделал, видимо…

     
  • 2.18, Аноним (-), 16:24, 16/01/2016 [^] [^^] [^^^] [ответить]  
  • +/

    В теории, у старых системных служб уже были исправлены косяки на >90% и дальше делать было нечего. А в новых службах, когда приделали весь старый функционал, стало раскрыто только 10%, поэтому есть куда стремиться.

    :)

     
  • 2.22, ZloySergant (ok), 16:45, 16/01/2016 [^] [^^] [^^^] [ответить]  
  • –2 +/
    >PulseAudio заменил ALSA.

    А теперь, солнышко, расскажи как без альсы/осс/etc заставить читсый Pulse проигрывать хотя-бы wav.

    UPD: BTW, еще из ядра снеси всю поддержку ALSA и прочих.

     
     
  • 3.82, arisu (ok), 07:26, 22/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    >>PulseAudio заменил ALSA.
    > А теперь, солнышко, расскажи как без альсы/осс/etc заставить читсый Pulse проигрывать хотя-бы
    > wav.
    > UPD: BTW, еще из ядра снеси всю поддержку ALSA и прочих.

    он знает. но из принципа не скажет всяким ретроградам. вот так.

     
  • 2.32, rshadow (ok), 23:51, 16/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > На практике ни один раз я почему-то не видел новых фич и удобств

    Да в линуксе вообще-то новых фич с каждым днем хоть отбавляй. А вот с удобством стабильно никак.

     
     
  • 3.49, Аноним (-), 09:26, 18/01/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Я перешёл на SLED 11 Доволен как слон GNOME 2 28, и никаких тебе вырвиглазных ... большой текст свёрнут, показать
     
     
  • 4.53, M i M (?), 17:13, 18/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Вот же некромант!
     
     
  • 5.66, Аноним (-), 21:53, 18/01/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > Вот же некромант!

    Реально, как-будто на ХР без первого сервис-пака засел =)


     
  • 5.71, Аноним (-), 06:32, 19/01/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    LTS вообще-то. Можно спокойно выходить в интернет и открывать порты, не боясь что поломают через уязвимость.

    А ещё проприетарные драйверы для SLED хостятся на nvidia.com и ati.com. Я офигел - пакеты на NVIDIA! Не run-файл! Для NVIDIA доступна каждая ветка, от G01 до G04. Для ATI - только начиная с G02 (но для неё нужно сделать даунгрейд ядра, которое в репо есть). То есть, эта система ещё и хороший выбор для старых компов.

     
  • 2.33, Аноним (-), 02:27, 17/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Ну выкоси из ядра ALSA, посмотрим как тебе пульс ее заменил.
     
  • 2.80, arisu (ok), 07:20, 22/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > Ред Хату (или другой энтерпрайзной конторе) можно было сделать
    > спин с RT-ядром и подборкой софта для дизайнеров и звукарей.

    и дальше? вот ты вложил кучу денег, сделал. дальше что? как деньги отбивать собираешься?

    > Но нет же - давайте лучше перепишем инит!

    конечно, это лучше. потому что банально *выгодней*.

     

  • 1.6, Аноним (-), 14:45, 16/01/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    похоже на помесь гнома2 + гигантизм кед.
     
  • 1.9, Аноним (-), 15:07, 16/01/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • –2 +/
    Если б Pentium III не сдох бы, то поставил Moksha, а то у Кубунту ядро расшаренное, и процессор еле тянет эту Кубунту. А так остается надеятся, что эта ось кому-нибудь пригодится :)

    P.S. Кстати, а какое у нее ядро? Какая версия?

     
  • 1.14, username (??), 15:38, 16/01/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    А там есть docker?
     
  • 1.21, Аноним (-), 16:40, 16/01/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +4 +/
    Мокша???
    Автор случаем не мордвин?
     
     
  • 2.24, anonymous (??), 17:50, 16/01/2016 [^] [^^] [^^^] [ответить]  
  • +6 +/
    Erzya
     
  • 2.25, saf (?), 17:54, 16/01/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Муахаха, у моего знакомого пробабка была мокшанка)))
     
     
  • 3.28, Аноним (-), 22:20, 16/01/2016 [^] [^^] [^^^] [ответить]  
  • +3 +/
    >пробабка

    бабка 1.0 PRO Edition ?

     
  • 3.35, SENIORMASTERCHIEFDEVELOPER (?), 08:56, 17/01/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    А ты прикинь у меня родители - мордва, они постоянно переходят на свой мордорский язык когда когда хотят что-то утаить.
     
     
     
    Часть нити удалена модератором

  • 5.69, 123 (??), 22:32, 18/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Ну да Табаков такой противный театр возглавляет.
     
  • 2.50, aurved (?), 09:37, 18/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Мокша в индуизме и буддизме (внезапно Бодхи (просветление) Линукс) -- это освобождение от круговорота смертей-и-рождений.


     

  • 1.23, Саша (??), 17:43, 16/01/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    ТоваГисчи а как локализацию русскую сделать?
    (dpkg-reconfigure locales тут не работает - вернее как-то странно работает...нет выбора локали)
     
     
  • 2.26, Аноним (-), 18:36, 16/01/2016 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Форкни локаль!
     
     
  • 3.27, Саша (??), 20:50, 16/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    больше толковых советов не будет?
     
     
  • 4.31, Аноним (-), 23:27, 16/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > больше толковых советов не будет?

    Ну а ты чо в СПО хотел-то? Тут тебе никто ничего не обязан.

     
  • 2.36, Кир (?), 10:57, 17/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    http://forums.bodhilinux.com/
     
  • 2.38, Геймер (?), 14:47, 17/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    http://www.bodhilinux.com/w/change-systemlanguage/
     

  • 1.34, Анонимчикчик (?), 08:40, 17/01/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Чем Это лучше\юзабельней опен-Бокса? Бокс заливаешь и вперед с песней.
     
  • 1.41, Аноним (-), 16:37, 17/01/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Я могу себе представить пользователя гнома, кед, юнити, тайловых вм и прочего зоопарка десктопов.
    Но кто такие - пользователи e17? Чем он их привлекает? Сие мне неведомо.
     
     
  • 2.42, Teocally (?), 17:07, 17/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > Я могу себе представить пользователя гнома, кед, юнити, тайловых вм и прочего
    > зоопарка десктопов.
    > Но кто такие - пользователи e17? Чем он их привлекает? Сие мне
    > неведомо.

    Сие никому неведомо…это нормально;).
    Хотя - по неподтвержденным данным разведки, Е17 нравится некоторым представительницам прекрасной половины человечества.

     
     
  • 3.43, Led (ok), 19:30, 17/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > некоторым представительницам прекрасной половины человечества.

    Котекам?

     
  • 2.44, Аноним (-), 22:24, 17/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Шигорин же.
     
  • 2.83, arisu (ok), 07:28, 22/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > Я могу себе представить пользователя гнома, кед, юнити, тайловых вм и прочего
    > зоопарка десктопов.
    > Но кто такие - пользователи e17? Чем он их привлекает? Сие мне
    > неведомо.

    извини: видимо, мир забыл тебе об этом отчитаться. мерзкий мир такой.

     

  • 1.45, Xasd (ok), 23:09, 17/01/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    > Moksha является форком окружения Enlightenment 17, созданным из-за недовольства политикой развития Enlightenment, в частности *потери некоторой функциональности* ...

    ...так.. читаем дальше...

    > ...В новом выпуске завершена работа по чистке модулей E17 и *удалению лишней функциональности*, ...

    o_0

     
     
  • 2.52, Аноним (-), 13:58, 18/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Разработчики Е просто участвуют в каких-то тараканьих бегах, выпустив пару релизов, начинают пилить новую версию, бросая поддержку старого. Темы, к примеру, становятся несовместимыми уже между младшими версиями и т.п. Пилить что-то стабильное на базе Enlightment просто нереально. Честно говоря, я вообще не понимаю за счёт чего у разработчиков берётся на это моджо, скорее всего, эта DE побочный продукт чего-то там.

    Из плюсов что я отметил есть скриншотилка экрана с возможностью заливки скрина в интернеты. Такого почти ни у кого нет, разве что у xfce появилось, но и то недавно.

     
     
  • 3.56, Аноним (-), 18:35, 18/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > Из плюсов что я отметил есть скриншотилка экрана с возможностью заливки скрина в интернеты.

    Так он и сделан только для того, чтобы свои скрины в интернеты лепить. Как тупая вирусня, которая кроме как себя любимое плодить больше ничего не умеет.

     
  • 3.84, arisu (ok), 07:29, 22/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > скорее всего, эта DE побочный продукт чего-то там.

    не «чего‐то там», а самсунга. как самсунг решил им дать денег — так всё и покатилось…

     

  • 1.51, Анономс (?), 10:35, 18/01/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Вот уж чего чего, а форк Ешки увидеть не ожидал)
     
  • 1.54, Аноним (-), 18:26, 18/01/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • –2 +/
    Ну и мерзость судя по скринам.
    Постыдились бы в 2016 году такое выпускать...
     
  • 1.62, Аноним (-), 19:31, 18/01/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    > Для работы достаточно ПК с процессором 300 Mhz и 128 Мб ОЗУ.

    Особенно для Хрома, иконку которого можно видеть на панельке.

     
     
  • 2.68, Мордва (?), 22:11, 18/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    >> Для работы достаточно ПК с процессором 300 Mhz и 128 Мб ОЗУ.
    > Особенно для Хрома, иконку которого можно видеть на панельке.

    Это Мокша-Хром!


     
  • 2.74, Аноним (-), 14:06, 19/01/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Попробуй Opera 12.16. С каждым годом всё хуже и хуже, но пока можно пользоваться
     

  • 1.79, arisu (ok), 07:18, 22/01/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    молодцы. E17 был последним нормальным релизом, если от чего и плясать — то от него.
     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    Слёрм
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2020 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру