The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]



"Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +/
Сообщение от opennews (ok), 16-Июн-20, 11:57 
После десяти месяцев разработки доступен мультимедиа-пакет FFmpeg 4.3, включающий набор приложений и коллекцию библиотек для операций над различными мультимедиа-форматами (запись, преобразование и декодирование звуковых и видеоформатов). Пакет распространяется под лицензиями LGPL и GPL, разработка FFmpeg ведётся смежно с проектом MPlayer...

Подробнее: https://www.opennet.ru/opennews/art.shtml?num=53162

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения [Сортировка по времени | RSS]


1. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  –2 +/
Сообщение от Zenitur (ok), 16-Июн-20, 11:57 
> sierpinski - генерирует видеопоток с фракталами Серпинского;

Это же трайфорс!

Ответить | Правка | Наверх | Cообщить модератору

2. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  –16 +/
Сообщение от Аноним (2), 16-Июн-20, 11:59 
Больше раста!!!
" Добавлена возможность кодирования видео AV1 с использованием библиотеки librav1e, написанной на на языке Rust и развиваемой сообществами Xiph и Mozilla; "
Ответить | Правка | Наверх | Cообщить модератору

23. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +2 +/
Сообщение от пох. (?), 16-Июн-20, 17:48 
не ссы - в ffmpeg уже лет десять не добавляются свои кодеки, не считая какой-нибудь никому ненужной херни типа видосиков в игруле двадцатилетней давности. Беллард давным-давно не участник проекта.

Добавляются готовые либы кодеков - и пофиг, на хрусте они или вообще на gwbasic

Ответить | Правка | Наверх | Cообщить модератору

32. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +3 +/
Сообщение от devl547email (ok), 16-Июн-20, 19:43 
>ffmpeg уже лет десять не добавляются свои кодеки

Декодеры добавляют.
ffvp9 выкатили 6 лет назад и уделали по скорости декода остальных.
ffhevc тоже был, правда особо в бенчмарках не светился.
dav1d пишется совместными силами ffmpeg и vlc.

Энкодеры писать (особенно качественные) куда сложнее, этим пусть лучше специалисты занимаются

Ответить | Правка | Наверх | Cообщить модератору

33. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  –1 +/
Сообщение от Аноним (33), 16-Июн-20, 22:26 
> Добавляются готовые либы кодеков

Их надо добавлять сборщику. А это такой гемор.

Ответить | Правка | К родителю #23 | Наверх | Cообщить модератору

34. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +/
Сообщение от Аноним (33), 16-Июн-20, 22:54 
Вот этих модулей (кодировщиков) по умолчанию нет (и много чего еще):
libass libbluray libmp3lame libopus libpulse libsoxr libspeex libtheora libtwolame libvorbis libvpx libwavpack libwebp libx264 libx265 libxvid

Есть следующие кодировщики (с пометкой native):
mpeg4 srt pcm aac ac3 dvvideo ffv1 opus truehd ffvhuff huffyuv utvideo flac png prores flv gif vorbis (bad) alac wavpack webvtt apng wmv wma ass ssa jpeg2000 mjpeg bmp mp2 mpeg1video mpeg2video dca

Имеется ключ --enable-vapoursynth. Требует установленный VapourSynth с /Include/VapourSynth.h
Я так полагаю, это позволит импортировать py скрипты напрямую. Собираю сейчас, собирается долго, даже без сторонних зависимостей.

Ответить | Правка | Наверх | Cообщить модератору

35. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +/
Сообщение от Аноним (33), 17-Июн-20, 00:22 
> Я так полагаю, это позволит импортировать py скрипты напрямую

Не позволяет.

Ответить | Правка | Наверх | Cообщить модератору

48. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +/
Сообщение от Аноним (48), 20-Июн-20, 23:50 
> Не позволяет

Это потому что по умолчанию vpy скрипты не обрабатываются. Нужно предварительно указать демультиплекстор -f vapoursynth ПЕРЕД -i
Но тут появляется другая проблема. В таком режиме ffmpeg совсем не выводит прогресс. Заставить его выводить хоть какую-то информацию о скорости и прогрессе можно добавив опцию -progress pipe:1
Таким образом, скрипт получается:
ffmpeg -f vapoursynth -i script.vpy -vcodec mpeg2video -q:v 1 -progress pipe:1 output.mkv
Интересно, что при открытии vpy скриптов напрямую (не через vspipe) передается информация об аспекте (если он анаморфный).
Это же касается и mpv, собранного с поддержкой vapoursynth. Так собирал я https://pastebin.com/raw/qdhf4rEu (у меня уже был собран свежий ffmpeg 4.3, поэтому я удалил старые ffmpeg dev либы)
mpv нужно запускать с опцией --demuxer-lavf-format=vapoursynth взято отсюда https://forum.doom9.org/showthread.php?t=180433
То есть, команда получается:
mpvvs --demuxer-lavf-format=vapoursynth ~/script.vpy
Чтобы не писать так каждый раз, можно добавить в ~./config/mpv/mpv.conf
[extension.vpy]
demuxer-lavf-format=vapoursynth
mpv получает информацию не только об аспекте, но и о длительности, потому можно попробовать подгружать внешние звуковые дорожки. Но вроде бы в январе 2020 года разработчик vapoursynth сделал встроенную поддержку звука и в версии R51 обещает ее доработать.

Ответить | Правка | Наверх | Cообщить модератору

51. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +/
Сообщение от Аноним (48), 21-Июн-20, 06:17 
Интересное наблюдение. Проверка ldd ~/path_to_mpv-binary дебиановского mpv пакета (из buster, там версия 0.29) показала, что бинарник слинкован с libvapoursynth-script.so.0, хотя дефолтные репозитории Debian не содержат ни vapoursynth, ни zimg (в отличии от репозитория deb-multimedia). Кстати, собранный мной mpv 0.32 с поддержкой vapoursynth показывает в ldd также. Похоже, это самодеятельность самого mpv, при наличии libvapoursynth-script.so.0 (как у меня) он к ней обращается, но явно не требует. А вот mpv 0.14 эту библиотеку не ищет. Есть надежда, что собирать mpv специально с поддержкой vapoursynth не требуется и, если он установлен, новые версии mpv смогут обрабатывать vpy скрипты (с опцией --demuxer-lavf-format=vapoursynth, конечно). На это намекает также тот факт, что официальный пакет mpv из archlinux тоже не требует vapoursynth в зависимостях, хотя в арче обычно собирают со всеми флагами.

А вот mpv 0.29 из deb-multimedia для Buster явно требует vapoursynth http://deb-multimedia.org/dists/stable/main/binary-i386/pack... (он собран с 47 версией). И ldd показывает в зависимостях не только libvapoursynth-script.so.0, но и libvapoursynth.so и эта последняя зависимость строгая. Видимо такую отвязку сделали, чтобы vapoursynth не требовался при установке mpv (а соответственно и python вместе с ним). А то в Debian 10 (Buster) с репозиторием deb-multimedia, я помню удивился, vapoursynth норовил установиться практически сразу (хотя, мне это и надо было), по зависимостям кодеки>mpv.

Ответить | Правка | Наверх | Cообщить модератору

53. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +/
Сообщение от Аноним (48), 21-Июн-20, 07:12 
ldd показывает зависимости зависимостей. mpv зависит от libavdevice.so.58, а libavdevice.so.58 зависит от libvapoursynth-script.so.0 и libpng12.so.0, хотя libpng12 в Debian Buster тоже нет. При просмотре в двоичном редакторе дебиановского mpv, я не нашел никаких упоминаний vapousynth. А в собранном мной бинарнике упоминания были. Короче, сбил меня с толку ldd. Соответственно, в посте выше я чушь написал.
Ответить | Правка | Наверх | Cообщить модератору

54. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +/
Сообщение от Аноним (48), 21-Июн-20, 07:16 
> mpv 0.14 эту библиотеку не ищет

Потому что он собран с системным /usr/lib/libavdevice-ffmpeg.so.56, который про vapoursynth ничего не знает.

Ответить | Правка | Наверх | Cообщить модератору

55. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +/
Сообщение от Аноним (48), 21-Июн-20, 07:22 
> libavdevice.so.58 зависит от libvapoursynth-script.so.0

Потому что ffmpeg 4.3 я собрал с поддержкой vapoursynth. Развел слаку из убунты. Кто-то скажет "есть же гента" (или арч), но я не люблю роллинг, потому что там нет постоянства.

Ответить | Правка | К родителю #53 | Наверх | Cообщить модератору

56. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +/
Сообщение от Аноним (56), 21-Июн-20, 22:14 
Съел vapoursynth мне мозг в очередной раз. Возвращаюсь на старый добрый avisynth. Все-таки не тянет линукс десктоп даже в 2020 году...
Ответить | Правка | К родителю #48 | Наверх | Cообщить модератору

36. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +/
Сообщение от Аноним (36), 17-Июн-20, 01:46 
> это такой гемор

То есть, надо поставить dev пакеты этих библиотек. Тогда, если делать shared сборку, ffmpeg бинарник будет зависеть от системных библиотек. Если делать static сборку, в старую систему можно поставить и свежие внешние библиотеки, они слинкуются в единый ffmpeg бинарник, у которого почти не будет внешних зависимостей (после сборки их можно будет удалить).

Ответить | Правка | К родителю #33 | Наверх | Cообщить модератору

41. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +/
Сообщение от пох. (?), 17-Июн-20, 12:54 
ну насчет хрустолибы - возможно и гемор (небось опять собирается только той версией хруста, которая сама еще не собирается, недокомитили последнюю правку)

остальное - если для сборщика "гемор" поставить includes от пачки вполне стандартных библиотек - то может ему вообще лучше в макдак пойти поработать? Там уже открылись, очереди шо п-ц, вакансий должно бы быть.

другое дело - а зачем оно нам такое вообще, у всех этих либ обычно какой-то примитивный cli враппер и так есть, если кому очень уж хочется покодировать свою нетленку именно в самый модный тормозной формат.


Ответить | Правка | К родителю #33 | Наверх | Cообщить модератору

3. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  –7 +/
Сообщение от BSD_Cucks_BTFO (?), 16-Июн-20, 12:02 
>На базе Vulkan для Linux реализован кодировщик, использующий для ускорения движки AMD AMF/VCE

Это гевогюция, тогарищи!

Ответить | Правка | Наверх | Cообщить модератору

4. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +/
Сообщение от Анонимemail (4), 16-Июн-20, 12:13 
О, интересно, vp9 на хасвелах заработает или нет.
Ответить | Правка | Наверх | Cообщить модератору

5. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +2 +/
Сообщение от Аноним (5), 16-Июн-20, 12:37 
не заработает, там нет аппаратной поддержки
Ответить | Правка | Наверх | Cообщить модератору

6. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +2 +/
Сообщение от iPony129412 (?), 16-Июн-20, 12:54 
> хасвел - 2013 год

Без шансов

Ответить | Правка | К родителю #4 | Наверх | Cообщить модератору

7. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +1 +/
Сообщение от НяшМяш (ok), 16-Июн-20, 12:56 
VP9 только в скайлейках появился. VP8 в броадвеллах.
Ответить | Правка | К родителю #4 | Наверх | Cообщить модератору

8. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +1 +/
Сообщение от Owlet (?), 16-Июн-20, 13:32 
> Добавлена поддержка протоколов ZeroMQ и RabbitMQ (AMQP 0-9-1);

И ведь никто не ноет, что комбайн и не юникс-вей!

Ответить | Правка | Наверх | Cообщить модератору

11. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +4 +/
Сообщение от Аноним (11), 16-Июн-20, 14:00 
Он в каком-то роде юниксвэй, делает всего 1 вещь: "работает с видео"
Ответить | Правка | Наверх | Cообщить модератору

13. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +/
Сообщение от Аноним (13), 16-Июн-20, 14:17 
ZeroMQ работает только с видео? А чего он делает в области IoT?
Ответить | Правка | Наверх | Cообщить модератору

29. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +/
Сообщение от Аноним (29), 16-Июн-20, 18:40 
Кодоредактор пока в FFmpeg не вставили.
Ответить | Правка | К родителю #8 | Наверх | Cообщить модератору

9. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +/
Сообщение от ua9oasemail (ok), 16-Июн-20, 13:54 
И а когда и в убунты придут такие апдейты? (У меня в "20.04" нет этого пока (не запуская менеджера обновлений я на ubuntuupdates.org смотрю, что там туда "завозят").
Ответить | Правка | Наверх | Cообщить модератору

10. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +/
Сообщение от iPony129412 (?), 16-Июн-20, 13:56 
В 20.10 осенью
Ответить | Правка | Наверх | Cообщить модератору

24. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +/
Сообщение от Аноним (24), 16-Июн-20, 17:59 
> а когда и в убунты придут такие апдейты?

Как здесь соберут https://ffmpeg.org/download.html > https://johnvansickle.com/ffmpeg можешь закинуть в ~/.local/bin

Ответить | Правка | К родителю #9 | Наверх | Cообщить модератору

45. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +/
Сообщение от Аноним (24), 18-Июн-20, 04:55 
В этом ppa собрали 4.3 для 16.04 и 18.04
https://launchpad.net/~jonathonf/+archive/ubuntu/ffmpeg-4
http://ppa.launchpad.net/jonathonf/ffmpeg-4/ubuntu/pool/main.../
Только надо иметь в виду, что системный софт (плееры и прочее) его использовать не будут, а будут дергать старые системные ffmpeg либы, с которыми слинкованы.
Ответить | Правка | К родителю #9 | Наверх | Cообщить модератору

46. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +/
Сообщение от Аноним (24), 18-Июн-20, 04:57 
Причем, в отличии от static сборки, многие кодеры (x264, opus и прочее) тоже будут старыми системными. Так что лучше static, если только не нужен софт, использующий ffmpeg 4.3 shared либы (а он обычно тоже из ppa).
Ответить | Правка | Наверх | Cообщить модератору

12. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +1 +/
Сообщение от YetAnotherOnanym (ok), 16-Июн-20, 14:01 
> Добавлена поддержка протоколов ZeroMQ и RabbitMQ (AMQP 0-9-1)

Хммм... А для чего? (Да, мне лень ходить по ссылкам)

Ответить | Правка | Наверх | Cообщить модератору

14. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +1 +/
Сообщение от Gemorroj (ok), 16-Июн-20, 14:26 
эту херню (ффмпег) можно запустить как подписчика этих очередей. и конвертить видео на лету, а не запуская через консоль.
Ответить | Правка | Наверх | Cообщить модератору

16. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  –6 +/
Сообщение от Аноним (16), 16-Июн-20, 15:25 
Херня у тебя в штанах, а это шляпа. Что значит "на лету", ты имеешь в виду сказать дядя будет выставлять параметры с фильтрами? По-моему ты не понимаешь, как оно работает.
Ответить | Правка | Наверх | Cообщить модератору

15. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +/
Сообщение от Аноним (15), 16-Июн-20, 15:25 
Великолепный релиз. Только chromium умирает на любом видеохостинге.
Ответить | Правка | Наверх | Cообщить модератору

26. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  –1 +/
Сообщение от Michael Shigorinemail (ok), 16-Июн-20, 18:16 
Пересоберите.
Ответить | Правка | Наверх | Cообщить модератору

17. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  –1 +/
Сообщение от Аноним (17), 16-Июн-20, 15:38 
> хО, интересно, vp9 на хасвелах заработает или нет.

У меня на Хасвеле вроде работает на ютубчике.)
Video ID / sCPN
V1Cx079qm2E / 7XQ9 94RJ N5M3
Viewport / Frames
1209x680 / 0 dropped of 69
Current / Optimal Res
1920x1080@25 / 1920x1080@25
Volume / Normalized
30% / 19% (content loudness 3.9dB)
Codecs
vp09.00.51.08.01.01.01.01.00 (248) / opus (251)
Color
bt709 / bt709

Ответить | Правка | Наверх | Cообщить модератору

19. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +/
Сообщение от Аноним (16), 16-Июн-20, 16:35 
Как насчёт 4к?
Ответить | Правка | Наверх | Cообщить модератору

25. Скрыто модератором  +2 +/
Сообщение от Аноним (25), 16-Июн-20, 17:59 
Ответить | Правка | К родителю #17 | Наверх | Cообщить модератору

37. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +/
Сообщение от Валик (?), 17-Июн-20, 04:48 
> У меня на Хасвеле вроде работает на ютубчике.)

Ты странный что ли??? Он у всех работает.
Имеется в виду аппаратное декодирование.
А у тебя играется на процессоре. И оно будет играться на одноядерном дюроне 2005го года, только со скоростью 1кадр/сек.
Аппаратной поддержки в видеоплатах встроенных в хасвелы нет и не будет никогда, ибо процессоры появились раньше самого кодека.
Не зря ведь придумали расширение для браузеров h264ify, которое запрещает ютюбчику выдавать не поддерживаемый аппаратно кодек, выдавая вместо этого поддерживаемый повсеместно h264.
А то выдал выхлоп плеера с ютюба и радуется, смешной какой... Смотри что пишет vainfo..
А еще лучше топи на https://wiki.archlinux.org/index.php/Hardware_video_accelera... там черным по белому написано какой проц чего поддерживает и через какую библиотеку.

Ответить | Правка | К родителю #17 | Наверх | Cообщить модератору

42. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +/
Сообщение от Аноним (42), 17-Июн-20, 17:52 
> на одноядерном дюроне 2005го

если 2005, то семпроне

Ответить | Правка | Наверх | Cообщить модератору

18. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +/
Сообщение от Чел (?), 16-Июн-20, 16:16 
если AviSynth будет работать, это ооооочень круто)
Ответить | Правка | Наверх | Cообщить модератору

27. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +2 +/
Сообщение от Аноним (48), 16-Июн-20, 18:21 
AviSynth работает (и старый AvXSynth, если соберешь, и новый AviSynth+), но мало плагинов портировано
https://aur.archlinux.org/packages/?O=0&K=avisynth
https://aur.archlinux.org/packages/?O=0&K=avxsynth
Сначала определись зачем тебе AviSynth. Многое можно сделать через ffmpeg. То, что нельзя, например, QTGMC деинтерлейс, SRestore, качественное FPS конвертирование (SVP, mvtools), лучше сделать в VapourSynth. Но он использует питона, а AviSynth на нормальном C. Насчет IVTC не знаю (в Handbrake есть, а он ffmpeg based), mencoder точно умеет (в том числе следовать pulldown флагам, для VapourSynth нужно собирать D2VWitch и d2vsource). Лучше бы в ffmpeg сделали поддержку прямого импорта VapourSynth скриптов, без vspipe. Или она есть, но надо собирать самому?

Это на винде мода для простейшего конвертирования дергать AviSynth. А после всех этих *synth'ов теряются нелинейные таймкоды контейнера и переменная FPS. Так что лучше их не использовать без особой необходимости. Виндузятники об этом не знают, хотя я им говорил. Нахваливают свою XviD4PSP 5.

Ответить | Правка | Наверх | Cообщить модератору

31. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +/
Сообщение от Аноним (16), 16-Июн-20, 19:41 
Так либы там вполне себе сишные, если ты за производительность переживаешь. Лишь бы не на одном ядре работало (т.е. не как на нормальном си).
Ответить | Правка | Наверх | Cообщить модератору

57. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +/
Сообщение от Аноним (56), 21-Июн-20, 22:19 
Да вот только у меня двухъядерный проц. Виндовый AviSynth (QTGMC preset Faster) загружает его при дефолтных настройках на 70%, но кодирует на 25-33% быстрее, чем линусковый VaspourSynth, который загружает на 100%. При том, что на винде, выставив минимальный приоритет, еще можно чем-то заниматься, а на линуксе, несмотря на приоритеты, отзывчивость падает сильнее.

Знаю, питон только парсит скрипты, аналог которых (точнее устаревшие порты, как и в случае с плагинами) это avs и avsi. Только вот avs* не тянет в систему питонятину, а только маленький avisynth.dll.

Ответить | Правка | Наверх | Cообщить модератору

20. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +/
Сообщение от Аноним (20), 16-Июн-20, 16:37 
Годнота!
Ответить | Правка | Наверх | Cообщить модератору

21. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  –1 +/
Сообщение от Аноним (17), 16-Июн-20, 16:40 
> Как насчёт 4к?

Video ID / sCPN
0FYjApop7Mk / Q1Q4 3KVJ TT0P
Viewport / Frames
1209x680 / 0 dropped of 761
Current / Optimal Res
3840x2160@24 / 3840x2160@24
Volume / Normalized
81% / 49% (content loudness 4.4dB)
Codecs
vp09.00.51.08.01.01.01.01.00 (313) / opus (251)
Color
bt709 / bt709
Connection Speed
С подзагрузками.)

Ответить | Правка | Наверх | Cообщить модератору

22. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +2 +/
Сообщение от Аноним (22), 16-Июн-20, 17:32 
> В Linux осуществлён переход с фрэймсервера для нелинейного редактирования видеопотоков (виртуального видеокодека) AvxSynth, который уже 5 лет находится в заброшенном состоянии, на актуальный форк AviSynth+;

Эхх... а ведь ему недавно 20 лет стукнуло. Это же целое поколение почти и до сих пор незаменим =)


Ответить | Правка | Наверх | Cообщить модератору

28. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +/
Сообщение от Аноним (48), 16-Июн-20, 18:32 
Каких синтовских плагинов тебе не хватает в линуксе? А ведь Синт может подгружать и VirtualDub'овские плагины (которые работают в RGB32). Я как-то использовал их, чтобы убрать полосы с записи ТВ трансляции.

AvXSynth это порт AviSynth версии 2.5, которую уже давно забросили плагинописатели. Работают разве что старые плагины (а на линукс их еще портировать надо). На винде сейчас модно плагины собирать в VS 2019, соответственно редистры 2015-2019 во все поля, фу. Хотя, на линуксе питонятина зато.

Ответить | Правка | Наверх | Cообщить модератору

30. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  –6 +/
Сообщение от Аноним (29), 16-Июн-20, 18:42 
Ктож на линуксе видео редактирует.
Ответить | Правка | Наверх | Cообщить модератору

40. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +2 +/
Сообщение от Аноним (40), 17-Июн-20, 12:06 
Я
Ответить | Правка | Наверх | Cообщить модератору

38. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +/
Сообщение от Аноним (17), 17-Июн-20, 05:01 
> Имеется в виду аппаратное декодирование.

Конкретнее надо было изъясняться, я не сильно в теме, но у меня Хасвел и в целом работает.)

Ответить | Правка | Наверх | Cообщить модератору

39. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +1 +/
Сообщение от Валик (?), 17-Июн-20, 06:25 
>> Имеется в виду аппаратное декодирование.
> Конкретнее надо было изъясняться, я не сильно в теме, но у меня
> Хасвел и в целом работает.)

Смотри какое дело, как это обычно работает вообще:
предположим, что какая-то контора выпускает кодек и этот кодек начинают применять во всяких гуголах (ютюбах), мозилах и т.п. гигантами в индустриях..
но как применять? кодек - это всего лишь какое-то описание способа кодирования потока, просто математический алгоритм, так сказать...  потому, все эти мозиллы, гуглы и прочие ffmpeg-и, пишут ЭТАЛОННЫЕ РЕАЛИЗАЦИИ данного кодека, соревнуясь за одно у кого быстрей получится...
и вот эти все ЭТАЛОННЫЕ и не очень реализации кодеков, они, как правило, пишутся на обычных сях и  работают на центральном процессоре, что не очень эффективно само по себе, зато работает везде.
ВОТ ЭТО И ЕСТЬ ТВОЙ СЛУЧАЙ. И ВООБЩЕ ЭТО ОБЩИЙ СЛУЧАЙ КАК ПРАВИЛО.
а дальше поспевают новые видеокарточки.. в которых уже производитель железа добавляет аппаратную поддержку того или иного кодека.. или не добавляет.. или добавляет, но криво.. - тут еще как повезет.
и этот случай, очевидно, наиболее энергоэффективен. был бы, если бы не требовалась аппаратная поддержка еще и софтом - тем самым софтом, с самого верха этого ликбеза, который и без того работает на процессорах практически любых.
вот этот, последний случай, как раз и описывается в новости, например - добавили поддержку аппаратную vp9 через intel QSV, аппаратная поддержка vp9 в котором есть только для процев от Version 5 (Skylake). то есть, очевидно что АППАРТНО VP9 на HASWELL не заработает НИКОГДА.

Ответить | Правка | Наверх | Cообщить модератору

47. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +/
Сообщение от Аноним (16), 19-Июн-20, 05:46 
Как-то мутно написано, вон с vdpau всё понятно, есть фьюча сеты и определённые параметры кодека поддерживаются только определёнными поколениями карточек (и более поздними). Это декодирование. С кодированием посложнее, там постоянная эволюция качества картинки в каждом новом поколении карточек, но тоже есть разделение. Когда добавили фич в аппаратный кодек, которые посзволили реализовать более качественное кодирование. У интела что-то мутное совсем, непонятно.
Ответить | Правка | Наверх | Cообщить модератору

43. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +/
Сообщение от Аноним (43), 17-Июн-20, 21:56 
Стоит отметить, что почти не сломали api. И это не может не радовать.
Ответить | Правка | Наверх | Cообщить модератору

44. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +/
Сообщение от Аноним (24), 18-Июн-20, 04:49 
Да, между 4.2 и 4.3 номера либ не менялись и это хорошо.
Ответить | Правка | Наверх | Cообщить модератору

49. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +/
Сообщение от Аноним (49), 21-Июн-20, 01:03 
AVI MPEG4 по прежнему на квадратики рассыпаются? Этот формат уже устарел, а эти до сих пор его нормально кодировать не научились.
Ответить | Правка | Наверх | Cообщить модератору

50. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +1 +/
Сообщение от Аноним (48), 21-Июн-20, 06:00 
Используй libxvid (вместо mpeg4) вот с такими настройками:
-c:v libxvid -b:v 2000k -bf 2 -g 250
Следи чтобы битрейта хватало. У ffmpeg дурацкие дефолты при кодировании в AVI XVID. Во первых, нативный mpeg4 не поддерживает детектор сцен, во вторых GOP всего 12 кадров (это приводит к лишнему расходу битрейта на I кадры = качество ухудшается = квадратики), в третьих B кадры по умолчанию отключены. Команда выше избавлена от этих недостатков. Еще можно включить MPEG матрицу вместо H.263, но она требует больше битрейта -mpeg_quant 1
Есть продвинутые настройки https://ffmpeg.org/ffmpeg-codecs.html#libxvid
А команду -mpeg_quant я нашел здесь https://gist.github.com/tayvano/6e2d456a9897f55025e25035478a... (поиск по странице h.263) по выдаче startpage.com
И вот еще https://trac.ffmpeg.org/wiki/Encode/MPEG-4
Ответить | Правка | Наверх | Cообщить модератору

52. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +1 +/
Сообщение от Аноним (48), 21-Июн-20, 06:28 
Еще наблюдение. Команда -vtag xvid не играет никакой роли. При кодировании в mkv кодек всегда помечается MPEG4, при кодировании в avi всегда xvid. По крайней мере, по данным MediaInfo. Еще MediaInfo не может извлечь информацию о B кадрах и матрице кодирования из AVI, закодированных в ffmpeg. Поэтому кодировать ffmpeg libxvid лучше в MKV.
Ответить | Правка | Наверх | Cообщить модератору

58. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +/
Сообщение от Аноним (58), 23-Июн-20, 00:28 
Попробую ваши предложения, но есть сильное ощущение, что это всё я делал, но так и не получил даже близко той картинки что выкладывает scarabey на торрентах (естественно используя те же исходники видео). У скарабея в бложике есть статья как они кодируют, и там используется закрытый виндовый кодек.  Так вот там уверенно получается довольно пристойная картинка, с минимум вмешательства в настройки. Есть такое подозрение, что в реализации кодека у ффмпег для этого формата присутствует ошибка.
Ответить | Правка | К родителю #50 | Наверх | Cообщить модератору

59. "Выпуск мультимедиа-пакета FFmpeg 4.3 c поддержкой графическо..."  +/
Сообщение от Аноним (59), 23-Июн-20, 15:21 
Закрытое он врядли использует. Тот же xvid, может чья-то сборка. xvid как раз очень тюнингуют, чтобы получить что-то пристойное. В частности используют нестандартную матрицу. Если посмотреть в mediainfo, то будет видно, что Matrix: Custom. Скорее всего он также применяет предфильтрацию: шумоподавление, дебандинг. Хотя, на шумных исходниках меньше блочности появляется. Я бы так сказал, что съедобно кодировать в xvid, это искусство, которое я не осилил.
Насчет ошибки, ходили слухи, что в xvid до 65 что-ли версии был какой-то баг. Может быть с закрытым (старым) Divx что-то путное получится? Как ни странно, я встречал очень неплохие рипы с ним, но в основном с шумного исходника (чтобы не было бандинга и квадратов) с минимальным колебанием битрейта. Явно ручное исключение делается только для сложных сцен, типа воды, где битрейт увеличивают. На рутрекере есть кодек 2008 года, можно запустить в wine + virtualdubmod.
Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру