The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги | ]

09.01.2017 23:42  Проект Mesa перешёл на новую схему нумерации выпусков

Разработчики проекта Mesa приняли изменения, отражающие переход к новой схеме нумерации выпусков, включающий сведения о дате выпуска. Находящаяся в разработке ветка Mesa 13.1.0 переименована в Mesa 17.0.0, где первая цифра указывает на год выпуска, вторая цифра является порядковым номером значительного выпуска за указанный год, а третья цифра отражает корректирующие выпуски. Выпуск Mesa 17.0.0 намечен на 3 февраля.

Причиной введения новой схемы является потеря актуальности прошлой нумерации, первая цифра в которой увеличивалась при обеспечении поддержки очередной версии стандарта OpenGL. В настоящее время в Mesa процесс поддержки OpenGL актуализирован и в Mesa 13.0 была обеспечена поддержка самого последнего стандарта OpenGL 4.5.

  1. Главная ссылка к новости (https://lists.freedesktop.org/...)
  2. OpenNews: Релиз Mesa 13.0.0 с поддержкой OpenGL 4.5
  3. OpenNews: Релиз Mesa 12.0.0 с поддержкой OpenGL 4.3
  4. OpenNews: В Mesa включена поддержка OpenGL 4.3 для Nouveau NVC0, RadeonSI и Intel i965
  5. OpenNews: Рассматривается переход СУБД PostgreSQL на новую нумерацию выпусков
  6. OpenNews: Проект LLVM переходит на новую схему нумерации выпусков
Лицензия: CC-BY
Тип: К сведению
Ключевые слова: mesa
При перепечатке указание ссылки на opennet.ru обязательно
Обсуждение Ajax/Линейный | Раскрыть все сообщения | RSS
 
  • 1.1, Аноним (-), 23:59, 09/01/2017 [ответить] [показать ветку] [···]    [к модератору]
  • –1 +/
    За браузерами погнались.
     
     
  • 2.2, neon1ks (ok), 00:07, 10/01/2017 [^] [ответить]    [к модератору]
  • +8 +/
    Ничего страшного нету в привязке нумераций версий к году.
     
     
  • 3.25, Аноним (-), 12:19, 10/01/2017 [^] [ответить]    [к модератору]
  • +/
    Нету. Другой вопрос - была бы в этом реальная необходимость. "Шоб круче смотрелось" - не она, и видно уже что занялись рюшечками.
     
  • 3.36, rshadow (ok), 15:31, 10/01/2017 [^] [ответить]    [к модератору]
  • +1 +/
    Гы гы, достижения оборонки наконец то пошли в мирную жизнь?
     
  • 2.9, NNN (??), 03:26, 10/01/2017 [^] [ответить]    [к модератору]
  • +2 +/
    Первая цифра указывает год  выпуска.
     
     
  • 3.12, Аноним (-), 06:31, 10/01/2017 [^] [ответить]    [к модератору]  
  • +4 +/
    +2000
     
  • 3.19, 1 (??), 10:18, 10/01/2017 [^] [ответить]    [к модератору]  
  • –4 +/
    Т.е. (раз первая цифра, а это 1) выпуск был в 1 AD ?
     
  • 1.3, A.Stahl (ok), 00:11, 10/01/2017 [ответить] [показать ветку] [···]    [к модератору]  
  • +11 +/
    А как они будут решать проблему 3000 года? Версия обнулится, иксы попадают, пароходы взорвутся и пиво прокиснет!
     
     
  • 2.4, Shichael Migorin (?), 00:22, 10/01/2017 [^] [ответить]    [к модератору]  
  • +/
    А что они будут делать, когда обеспечат поддержку финальной версии opengl? Версия обнулится, иксы попадают, пароходы взорвутся и пиво прокиснет!

     
     
  • 3.5, A.Stahl (ok), 00:27, 10/01/2017 [^] [ответить]    [к модератору]  
  • –1 +/
    А почему версия должна обнулится? Просто мажорная часть перестанет изменяться. И через 5 лет получим версию 13.2.476
    Или можно привязать версию к версии Вулкана+13.
    До 3к рукой подать!
     
     
  • 4.6, Аноним84701 (ok), 01:12, 10/01/2017 [^] [ответить]     [к модератору]  
  • –1 +/
    Будет как в емаксе ... весь текст скрыт [показать]
     
  • 3.23, Аноним (-), 12:12, 10/01/2017 [^] [ответить]    [к модератору]  
  • –4 +/
    Миша, что у тебя с ником? Ты сменил пол?
     
  • 3.43, Аноним (-), 19:46, 10/01/2017 [^] [ответить]    [к модератору]  
  • +/
    > А что они будут делать, когда обеспечат поддержку финальной версии opengl?

    Так в том то и дело что они ее уже обеспечили. MESA умеет OpenGL 4.5.

     
  • 2.7, freehck (ok), 01:16, 10/01/2017 [^] [ответить]    [к модератору]  
  • +7 +/
    > А как они будут решать проблему 3000 года?

    Выпустят версию 1000.0.0

     
  • 2.18, Аноним (-), 10:08, 10/01/2017 [^] [ответить]    [к модератору]  
  • +/
    Счетчик зашкалит
     
  • 2.20, КО (?), 10:38, 10/01/2017 [^] [ответить]    [к модератору]  
  • +/
    Выпустят версию 3000.
     
  • 2.31, Michael Shigorin (ok), 13:52, 10/01/2017 [^] [ответить]    [к модератору]  
  • +2 +/
    > А как они будут решать проблему 3000 года?

    2100

     
     
  • 3.37, rshadow (ok), 15:33, 10/01/2017 [^] [ответить]    [к модератору]  
  • +/
    Вот тоже подумал что проблема будет раньше в 100-м году, либо уже будет решена =)
     
  • 2.32, axredneck (?), 14:10, 10/01/2017 [^] [ответить]    [к модератору]  
  • +/
    100.0.0
     
     
  • 3.33, axredneck (?), 14:12, 10/01/2017 [^] [ответить]    [к модератору]  
  • +/
    извиняюсь, опечатался. 1000.0.0
     
  • 2.45, Аноним (-), 22:50, 10/01/2017 [^] [ответить]    [к модератору]  
  • +/
    > А как они будут решать проблему 3000 года?

    это что за проблема?

     
  • 2.47, Аноним (-), 02:13, 11/01/2017 [^] [ответить]    [к модератору]  
  • +/
    и в который раз алкоголики о своем!
    как без этого им прожить, как?
     
  • 1.8, vitalikp (?), 01:56, 10/01/2017 [ответить] [показать ветку] [···]    [к модератору]  
  • +8 +/
    Вообще плохая затея, "на ходу" схему версий менять.
    А уж привязываться к году разработки тем более.
    Мажорная версия должна отражать суть изменений,
    а тут получается мелкий багфикс, новый год и получите новую версию.
    От того, что первая цифра не мотает километраж ничего плохого нету.
    Но последнее время новая мода пошла, менять схему версий.
     
     
  • 2.10, NNN (??), 03:29, 10/01/2017 [^] [ответить]     [к модератору]  
  • +1 +/
    В новости ведь написано, что мажорная версия больше не отражает сути изменений ... весь текст скрыт [показать]
     
     
  • 3.11, Mihail Zenkov (ok), 04:28, 10/01/2017 [^] [ответить]    [к модератору]  
  • +3 +/
    Можно было оставить нумерацию прежней и менять первую цифру при изменении API - новая версия vulkan, opencl или все того же opengl (если будет).
     
     
  • 4.27, Crazy Alex (??), 12:31, 10/01/2017 [^] [ответить]    [к модератору]  
  • +1 +/
    У них же API только в минорных не растёт, и то не уверен.
     
  • 3.14, 1111 (??), 07:23, 10/01/2017 [^] [ответить]    [к модератору]  
  • –1 +/
    Проекту TeX это не мешает.
     
  • 2.38, rshadow (ok), 15:34, 10/01/2017 [^] [ответить]    [к модератору]  
  • +1 +/
    > должна

    Кому должна?

     
     
  • 3.48, Аноним (-), 02:15, 11/01/2017 [^] [ответить]    [к модератору]  
  • +/
    каминтатарам с опеннета
    в их картину мира это вписывается и им разработчики что-то должны
    Сама Очевидность
     
  • 1.13, Аноним (-), 07:13, 10/01/2017 [ответить] [показать ветку] [···]    [к модератору]  
  • +4 +/
    Изменение мажорной версии должно вообще указывать на изменения ABI, а не так вздумалось поменяли.
     
     
  • 2.26, J.L. (?), 12:26, 10/01/2017 [^] [ответить]     [к модератору]  
  • +/
    очень правильное замечание а дата версии должна самой последней идти, перед ней ... весь текст скрыт [показать]
     
  • 2.28, Crazy Alex (??), 12:31, 10/01/2017 [^] [ответить]    [к модератору]  
  • +3 +/
    > Изменение мажорной версии должно вообще указывать на изменения ABI, а не так
    > вздумалось поменяли.

    API, а не ABI

     
     
  • 3.46, Аноним (-), 00:11, 11/01/2017 [^] [ответить]    [к модератору]  
  • –1 +/
    Нет, ABI - major, API - minor, для фиксов - patch.
    MAJOR.MINOR.PATCH
     
  • 2.34, axredneck (?), 14:15, 10/01/2017 [^] [ответить]    [к модератору]  
  • –1 +/
    а у месы АБИ будет ли меняться?
     
  • 1.17, iZEN (ok), 09:32, 10/01/2017 [ответить] [показать ветку] [···]    [к модератору]  
  • –3 +/
    Наконец-то! Стало легко и просто разбираться в версиях прикладного программного обеспечения для GNU/Linux.
     
     
  • 2.35, Клыкастый (ok), 15:20, 10/01/2017 [^] [ответить]    [к модератору]  
  • –1 +/
    строго говоря под BSD ровно то же прикладное программное обеспечение.
     
     
  • 3.44, iZEN (ok), 22:31, 10/01/2017 [^] [ответить]     [к модератору]  
  • –1 +/
    Но BSDшники его только адаптируют для своей системы - их больше не подпускают к ... весь текст скрыт [показать]
     
     
  • 4.50, Клыкастый (ok), 11:24, 11/01/2017 [^] [ответить]     [к модератору]  
  • +/
    Извини, у меня ни разу не спрашивали операционко-расовую принадлежность при пр... весь текст скрыт [показать]
     
     
  • 5.52, Michael Shigorin (ok), 12:15, 11/01/2017 [^] [ответить]    [к модератору]  
  • +/
    > Извини, у меня ни разу не спрашивали "операционко-расовую принадлежность"
    > при приёме патчей. И в патчах для FBSD тоже не отказывали. Не понимаю,
    > что означает "не подпускают к разработке".

    Фу, как можно быть таким практиком и не знать теорию!11

     
  • 4.58, Аноним (-), 07:43, 13/01/2017 [^] [ответить]     [к модератору]  
  • +/
    Их что, скотчем к стулу примотали И вообще, в процессе дебатов один из перцев р... весь текст скрыт [показать]
     
     
  • 5.59, iZEN (ok), 19:03, 13/01/2017 [^] [ответить]    [к модератору]  
  • +/
    >> Но BSDшники его только адаптируют для своей системы - их больше не
    >> подпускают к разработке.
    > Их что, скотчем к стулу примотали? И вообще, в процессе дебатов один
    > из перцев рассказал как в бздах код принимают. И почему его
    > никто поддерживать не хочет. Было убедительно.

    Ну было и было, хотя никто ссылок не видел. А тебе-то что, User294, что решил в канун празднования Старого Нового года возмутиться несправедливости? Заботит?

     
  • 1.22, Аноним (-), 11:02, 10/01/2017 [ответить] [показать ветку] [···]    [к модератору]  
  • +/
    Так скоро у всех программ будет одна версия. Скукотища... После знакомых в *nix 0.1.456.789.02.1
     
  • 1.24, Аноним (-), 12:18, 10/01/2017 [ответить] [показать ветку] [···]    [к модератору]  
  • +4 +/
    "Эффективные маркетологи" пришли.
     
  • 1.30, Аноним (-), 13:38, 10/01/2017 [ответить] [показать ветку] [···]     [к модератору]  
  • –2 +/
    Лет 15 назад, когда айтишники ставили знакомым софт на винду, те никогда не пони... весь текст скрыт [показать]
     
     
  • 2.41, Илья (??), 18:51, 10/01/2017 [^] [ответить]    [к модератору]  
  • +/
    Какая вам разница, насколько быстро прирастает версия, если это происходит не в обратную сторону и как правило со списками изменений?
     
     
  • 3.42, Аноним (-), 19:16, 10/01/2017 [^] [ответить]     [к модератору]  
  • +1 +/
    Чтобы отличать стабильные ветки от нестабильных, чтобы понимать, какое обновлени... весь текст скрыт [показать]
     
  • 3.51, Клыкастый (ok), 11:54, 11/01/2017 [^] [ответить]    [к модератору]  
  • +1 +/
    > Какая вам разница, насколько быстро прирастает версия

    Скорее есть разница в том, что вариантов нумераций уже прилично и это уже никак не похоже не только на стандартизацию, но и на общие принципы. Ситуация "кто в лес, кто по дрова" никак не радует

     
  • 3.54, Аноним (-), 14:19, 11/01/2017 [^] [ответить]     [к модератору]  
  • +1 +/
    И ты хочешь сказать что знаешь влияние каждого изменения на каждую софтину и каж... весь текст скрыт [показать]
     
  • 2.49, Аноним (-), 02:20, 11/01/2017 [^] [ответить]     [к модератору]  
  • +/
    теперь каждая техничка себя будет называть айтишником 8212 пфф компьютерщик... весь текст скрыт [показать]
     
  • 1.39, нонайм (?), 16:33, 10/01/2017 [ответить] [показать ветку] [···]    [к модератору]  
  • –1 +/
    давно пора. ато неясно свежая меса у тебя или нет.
     
  • 1.40, линт (?), 17:30, 10/01/2017 [ответить] [показать ветку] [···]    [к модератору]  
  • –1 +/
    Объясните, вот в стиме установлен metro 2033, ему нужен OpenGl 4 минимум, неужто он на Intel Skylake-GT (HD 530) запустится? Или они OpenGL ES 4 сделали?
     
     
  • 2.57, Аноним (-), 22:36, 11/01/2017 [^] [ответить]    [к модератору]  
  • +/
    У меня отродясь не было OpenGL 4, но Metro 2033 работал. Это точно такое требование есть?
     
  • 1.53, Аноним (-), 14:06, 11/01/2017 [ответить] [показать ветку] [···]    [к модератору]  
  • +/
    Ну, переход на новую нумерацию версий это _второй_ шаг.
    Первый был когда забили на смысл чисел в номере версии.
     
     
  • 2.55, Аноним (-), 14:22, 11/01/2017 [^] [ответить]    [к модератору]  
  • +/
    А следующий шаг - каждая софтина со своим набором библиотек, так как кто знает совместимы ли версии 16.28.10:30 и 17.04.15:00.
     
     
  • 3.56, Michael Shigorin (ok), 15:20, 11/01/2017 [^] [ответить]    [к модератору]  
  • –1 +/
    > А следующий шаг - каждая софтина со своим набором библиотек,
    > так как кто знает совместимы ли версии 16.28.10:30 и 17.04.15:00.

    Вообще-то это вопрос к soname, а не к версии (которые всё равно обычно субъективно лучше "говорящие" семантические, чем временнЫе или последовательные).  А у самых хитрых на случай прощёлканного апстримом изменения soname есть ещё set versions для сравнения отпечатков ABI.

     

     Добавить комментарий
    Имя:
    E-Mail:
    Заголовок:
    Текст:


      Закладки на сайте
      Проследить за страницей
    Created 1996-2018 by Maxim Chirkov  
    ДобавитьПоддержатьВебмастеруГИД  
    Hosting by Ihor