Интерактивная система просмотра системных руководств (man-ов)
authmd5h (7)
>> authmd5h (7) ( Solaris man: Макропакеты и соглашения )
NAME
authmd5h - HMAC-MD5 Authentication Algorithm Module for
IPsec
SYNOPSIS
strmod/authmd5h
DESCRIPTION
This module implements the HMAC-MD5 authentication algorithm
using the MD5 message-digest algorithm and the HMAC tech-
nique documented in RFC2104. The authmd5h module has the
following properties:
key size
128 bits
digest size
96 bits (truncated from 128)
authmd5h is used by both AH and ESP.
ATTRIBUTES
See attributes(5) for descriptions of the following attri-
butes:
____________________________________________________________
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
|_____________________________|_____________________________|
| Availability | SUNWcsr (32-bit) |
|_____________________________|_____________________________|
| | SUNWcsrx (64-bit) |
|_____________________________|_____________________________|
| Interface Stability | Evolving |
|_____________________________|_____________________________|
SEE ALSO
ipseckey(1M),attributes(5),pf_key(7P),ipsec(7P),ipsecah(7P),ipsecesp(7P)
Krawczyk, H., Ballare, M., and Canetti, R., RFC2104, HMAC:
Keyed-HashingforMessageAuthentication, The Internet
Society, 1997
Madsen, C. and Glenn, R., RFC2403, TheUseofHMAC-MD5-96withinESPandAH, The Internet Society, 1998.
Rivest, R., RFC1321, TheMD5Message-DigestAlgorithm, The
Internet Society, 1992.