The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"Jabberd+Postgres+NetBSD"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы OpenNET: Виртуальная конференция (Public)
Изначальное сообщение [Проследить за развитием треда]

"Jabberd+Postgres+NetBSD"  
Сообщение от triam email(ok) on 18-Май-06, 19:52 
У меня система NetBSD 3.0 + postgresql 8.0.4 + jabberd 2.0s10

В чём проблема при запуске сервера в отладочном режиме ( Jabber -D ) , сервак умерает с сообщением о том, что c2s.xml не нашёл модуль pgsql.

Можно ли как-то без пересборки\переустановки jabberd указать поддержку Postgresql?
Ну и вообще как-то побороть это без пересборки jabber'a?

Postgresql и Jabberd2 ставил из пакетов.

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

 Оглавление

Сообщения по теме [Сортировка по времени, UBB]


1. "Jabberd+Postgres+NetBSD"  
Сообщение от triam email(ok) on 19-Май-06, 08:32 
Сам разобрался=)

Просто установка из пакетов подразумевала ТОЛЬКО работу с MySQL =(
Пришлось собрать из исходиков:

./configure --exec-prefix=/usr/pkg --enable-pgsql=yes -enable-mysql=no --enable-debug --enable-idn=yes --with-extra-include-path=/usr/pkg/include --with-extra-library-path=/usr/pkg/lib

Кстати на счёт --enable-debug я погорячился =( Теперь выдаёт кучу инфы в которой тяжело разобраться, но без этой опции в логах пишет очень неинформативные сообщения, даже при максимальной детализации.

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру