The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"ФриБСД 7.0 не видит сетевого адаптера Realtek RTL 8111C "
Вариант для распечатки  
Пред. тема | След. тема 
Форумы OpenNET: Виртуальная конференция (Public)
Изначальное сообщение [ Отслеживать ]

"ФриБСД 7.0 не видит сетевого адаптера Realtek RTL 8111C "  
Сообщение от jant email(ok) on 19-Июл-08, 16:26 
ФриБСД 7.0 не видит сетевого адаптера на системной плате ga-945gcm-s2l
#ifconfig - ничего не показывет, кроме lo0 (всё, кроме сетевой отключено в биосе)
биос сетевую видит (Realtek RTL 8111C (10/100/1000 Mbit), а фря - нет, подскажите, пожалуйста, как поставить драйвер?
Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "ФриБСД 7.0 не видит сетевого адаптера Realtek RTL 8111C "  
Сообщение от parad (??) on 19-Июл-08, 16:40 
покажи вывод dmesg
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "ФриБСД 7.0 не видит сетевого адаптера Realtek RTL 8111C "  
Сообщение от jant email(ok) on 19-Июл-08, 16:50 
>покажи вывод dmesg

rl0 - это pci-адаптер

FreeBSD 7.0-RELEASE #0: Sun Feb 24 19:59:52 UTC 2008
    root@logan.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Intel(R) Pentium(R) Dual  CPU  E2200  @ 2.20GHz (2200.02-MHz 686-class CPU)
  Origin = "GenuineIntel"  Id = 0x6fd  Stepping = 13
  Features=0xbfebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>
  Features2=0xe39d<SSE3,RSVD2,MON,DS_CPL,EST,TM2,SSSE3,CX16,xTPR,PDCM>
  AMD Features=0x20100000<NX,LM>
  AMD Features2=0x1<LAHF>
  Cores per package: 2
real memory  = 1065287680 (1015 MB)
avail memory = 1028857856 (981 MB)
ACPI APIC Table: <GBT    GBTUACPI>
FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
cpu0 (BSP): APIC ID:  0
cpu1 (AP): APIC ID:  1
ioapic0: Changing APIC ID to 2
ioapic0 <Version 2.0> irqs 0-23 on motherboard
kbd1 at kbdmux0
ath_hal: 0.9.20.3 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
hptrr: HPT RocketRAID controller driver v1.1 (Feb 24 2008 19:59:27)
acpi0: <GBT GBTUACPI> on motherboard
acpi0: [ITHREAD]
acpi0: Power Button (fixed)
acpi0: reservation of 0, a0000 (3) failed
acpi0: reservation of 100000, 3f6f0000 (3) failed
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x408-0x40b on acpi0
acpi_hpet0: <High Precision Event Timer> iomem 0xfed00000-0xfed003ff on acpi0
Timecounter "HPET" frequency 14318180 Hz quality 900
cpu0: <ACPI CPU> on acpi0
acpi_perf0: <ACPI CPU Frequency Control> on cpu0
p4tcc0: <CPU Frequency Thermal Control> on cpu0
cpu1: <ACPI CPU> on acpi0
est1: <Enhanced SpeedStep Frequency Control> on cpu1
est: CPU supports Enhanced Speedstep, but is not recognized.
est: cpu_vendor GenuineIntel, msr b240b2406000b24
device_attach: est1 attach returned 6
p4tcc1: <CPU Frequency Thermal Control> on cpu1
acpi_button0: <Power Button> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
vgapci0: <VGA-compatible display> port 0xd000-0xd007 mem 0xd1200000-0xd127ffff,0xc0000000-0xcfffffff,0xd1280000-0xd12bffff irq 16 at device 2.0 on pci0
agp0: <Intel 82945G (945G GMCH) SVGA controller> on vgapci0
agp0: detected 7932k stolen memory
agp0: aperture size is 256M
pcib1: <ACPI PCI-PCI bridge> irq 16 at device 28.0 on pci0
pci1: <ACPI PCI bus> on pcib1
pcib2: <ACPI PCI-PCI bridge> irq 17 at device 28.1 on pci0
pci2: <ACPI PCI bus> on pcib2
pci2: <network, ethernet> at device 0.0 (no driver attached)
pcib3: <ACPI PCI-PCI bridge> at device 30.0 on pci0
pci3: <ACPI PCI bus> on pcib3
rl0: <RealTek 8139 10/100BaseTX> port 0xb000-0xb0ff mem 0xd1100000-0xd11000ff irq 20 at device 0.0 on pci3
miibus0: <MII bus> on rl0
rlphy0: <RealTek internal media interface> PHY 0 on miibus0
rlphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
rl0: Ethernet address: 00:02:44:8f:e3:2e
rl0: [ITHREAD]
isab0: <PCI-ISA bridge> at device 31.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <Intel ICH7 UDMA100 controller> port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xf000-0xf00f at device 31.1 on pci0
ata0: <ATA channel 0> on atapci0
ata0: [ITHREAD]
ata1: <ATA channel 1> on atapci0
ata1: [ITHREAD]
pci0: <serial bus, SMBus> at device 31.3 (no driver attached)
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
atkbd0: [ITHREAD]
pmtimer0 on isa0
orm0: <ISA Option ROMs> at iomem 0xc0000-0xca7ff,0xcc000-0xccfff pnpid ORM0000 on isa0
ppc0: parallel port not found.
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio0: configured irq 4 not in bitmap of probed irqs 0
sio0: port may not be enabled
sio0: configured irq 4 not in bitmap of probed irqs 0
sio0: port may not be enabled
sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
sio0: type 8250 or not responding
sio0: [FILTER]
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
Timecounters tick every 1.000 msec
hptrr: no controller detected.
ad0: 38203MB <SAMSUNG SP0411N TW100-11> at ata0-master UDMA100
SMP: AP CPU #1 Launched!
Trying to mount root from ufs:/dev/ad0s1a
rl0: link state changed to DOWN
rl0: link state changed to UP


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "ФриБСД 7.0 не видит сетевого адаптера Realtek RTL 8111C "  
Сообщение от Аноним (??) on 19-Июл-08, 18:06 
A pciconf -lv?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "ФриБСД 7.0 не видит сетевого адаптера Realtek RTL 8111C "  
Сообщение от ant (??) on 19-Июл-08, 20:05 
>A pciconf -lv?

потерял связь с компом - теперь только в понедельник доступлюсь ( - всё закрыто) :(
извините, спасибо - ещё в понедельник спрошу с вашего разрешения

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "ФриБСД 7.0 не видит сетевого адаптера Realtek RTL 8111C "  
Сообщение от ant (??) on 21-Июл-08, 15:44 
# pciconf -lv

hostb0@pci0:0:0:0:    class=0x060000 card=0x50001458 chip=0x27708086 rev=0x02 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '82945G/GZ/P/PL Host Bridge/DRAM Controller'
    class      = bridge
    subclass   = HOST-PCI
vgapci0@pci0:0:2:0:    class=0x030000 card=0xd0001458 chip=0x27728086 rev=0x02 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '82945G Integrated Graphics Controller'
    class      = display
    subclass   = VGA
pcib1@pci0:0:28:0:    class=0x060400 card=0x00001458 chip=0x27d08086 rev=0x01 hdr=0x01
    vendor     = 'Intel Corporation'
    device     = '82801G (ICH7 Family) PCIe Root Port'
    class      = bridge
    subclass   = PCI-PCI
pcib2@pci0:0:28:1:    class=0x060400 card=0x00001458 chip=0x27d28086 rev=0x01 hdr=0x01
    vendor     = 'Intel Corporation'
    device     = '82801G (ICH7 Family) PCIe Root Port'
    class      = bridge
    subclass   = PCI-PCI
pcib3@pci0:0:30:0:    class=0x060401 card=0x50001458 chip=0x244e8086 rev=0xe1 hdr=0x01
    vendor     = 'Intel Corporation'
    device     = '82801 Family (ICH2/3/4/4/5/5/6/7/8/9,63xxESB) Hub Interface to PCI Bridge'
    class      = bridge
    subclass   = PCI-PCI
isab0@pci0:0:31:0:    class=0x060100 card=0x50011458 chip=0x27b88086 rev=0x01 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '945GL Intel 82801GB/GR (ICH7 Family) LPC Interface Controller - 27B8'
    class      = bridge
    subclass   = PCI-ISA
atapci0@pci0:0:31:1:    class=0x01018a card=0xb0011458 chip=0x27df8086 rev=0x01 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '82801G (ICH7 Family) Ultra ATA Storage Controller'
    class      = mass storage
    subclass   = ATA
none0@pci0:0:31:3:    class=0x0c0500 card=0x50011458 chip=0x27da8086 rev=0x01 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '82801G (ICH7 Family) SMBus Controller'
    class      = serial bus
    subclass   = SMBus
none1@pci0:2:0:0:    class=0x020000 card=0xe0001458 chip=0x816810ec rev=0x02 hdr=0x00
    vendor     = 'Realtek Semiconductor'
    device     = 'RTL8168/8111 PCI-E Gigabit Ethernet NIC'
    class      = network
    subclass   = ethernet
rl0@pci0:3:0:0:    class=0x020000 card=0x032010bd chip=0x813910ec rev=0x10 hdr=0x00
    vendor     = 'Realtek Semiconductor'
    device     = 'RT8139 (A/B/C/810x/813x/C+) Fast Ethernet Adapter'
    class      = network
    subclass   = ethernet

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "ФриБСД 7.0 не видит сетевого адаптера Realtek RTL 8111C "  
Сообщение от ant (??) on 21-Июл-08, 19:33 
>ФриБСД 7.0 не видит сетевого адаптера на системной плате ga-945gcm-s2l
>#ifconfig - ничего не показывет, кроме lo0 (всё, кроме сетевой отключено в
>биосе)
>биос сетевую видит (Realtek RTL 8111C (10/100/1000 Mbit), а фря - нет,
>подскажите, пожалуйста, как поставить драйвер

пробую ставить по инструкции с Реалтека :
Realtek 8139C/8139C+/8169S/8169SB/8169SC/8168B/8101E Driver for FreeBSD v4.x/5.x/6.0                     =

Вот инструкция:
The main steps you have to do:(FreeBSDSrcDir means the directory of FreeBSD source code
    and it may be "/usr/src/sys")

        1. keep the orginal driver source code:
            # cd /usr/src/sys/pci
            # cp if_rl.c if_rl.c.org
            # cp if_rlreg.h if_rlreg.h.org
            
            # cd /usr/src/sys/modules
            # cp Makefile Makefile.org
            
            # cd /usr/src/sys/modules/rl
            # cp Makefile Makefile.org
            
            # cd /usr/src/sys/i386/conf/
            # cp GENERIC GENERIC.org
            
        2. recompile your kernel    (you must install your FreeBSD source code first !!)
            # vim /usr/src/sys/i386/conf/GENERIC and delete rl and re
            # vim /usr/src/sys/modules/Makefile and delete rl and re
            # cd /usr/src/sys/i386/conf
            # /usr/sbin/config GENERIC
            
            (for FreeBSD 5.x/6.x)
            # cd ../compile/GENERIC
            (for FreeBSD 4.x)
            # cd ../../compile/GENERIC

            # make depend
            # make
            # make install
            # reboot
        
        3. update the driver source code:
            Copy the dirver source code( if_rl.c and if_rlreg.h) into /usr/src/sys/pci
            Copy the Makefile into /usr/src/sys/modules/rl
            
        4. build the driver:
            # cd /usr/src/sys/modules/rl
            # make clean
            # make
        
        5. install the driver
            # cd /usr/src/sys/modules/rl
            # kldload ./if_rl.ko
            
        6. configurate the static IP address
            # ifconfig rl0 xxx.xxx.xxx.xxx
            
        7. configurate the IP address by DHCP
            # /sbin/dhclient rl0


на шаге № 4 после make clean
просто make - не выполняется - ошибка:
917 subscripted value is neither array not pointer

ну и всё - сетевых интерфейсов нет вообще (у меня 2-й был тоже реалтек)
:(

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "ФриБСД 7.0 не видит сетевого адаптера Realtek RTL 8111C "  
Сообщение от zow on 22-Июл-08, 10:44 
>>ФриБСД 7.0 не видит сетевого адаптера на системной плате ga-945gcm-s2l
>>#ifconfig - ничего не показывет, кроме lo0 (всё, кроме сетевой отключено в
>>биосе)
>>биос сетевую видит (Realtek RTL 8111C (10/100/1000 Mbit), а фря - нет,
>>подскажите, пожалуйста, как поставить драйвер

попробуй просто kldload if_re.ko .....

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "ФриБСД 7.0 не видит сетевого адаптера Realtek RTL 8111C "  
Сообщение от ant (??) on 22-Июл-08, 15:43 
>>>ФриБСД 7.0 не видит сетевого адаптера на системной плате ga-945gcm-s2l
>>>#ifconfig - ничего не показывет, кроме lo0 (всё, кроме сетевой отключено в
>>>биосе)
>>>биос сетевую видит (Realtek RTL 8111C (10/100/1000 Mbit), а фря - нет,
>>>подскажите, пожалуйста, как поставить драйвер
>
>попробуй просто kldload if_re.ko .....

не могу найти файл : if_re.ko
поставщики на него тоже ссылаются а в поставке драйвера его нет

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "ФриБСД 7.0 не видит сетевого адаптера Realtek RTL 8111C "  
Сообщение от zow on 23-Июл-08, 11:00 
>>>>ФриБСД 7.0 не видит сетевого адаптера на системной плате ga-945gcm-s2l
>>>>#ifconfig - ничего не показывет, кроме lo0 (всё, кроме сетевой отключено в
>>>>биосе)
>>>>биос сетевую видит (Realtek RTL 8111C (10/100/1000 Mbit), а фря - нет,
>>>>подскажите, пожалуйста, как поставить драйвер
>>
>>попробуй просто kldload if_re.ko .....
>
>не могу найти файл : if_re.ko
>поставщики на него тоже ссылаются а в поставке драйвера его нет

Та не в поставке драйвера, а в ядреных модулях... есть и работает...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

10. "ФриБСД 7.0 не видит сетевого адаптера Realtek RTL 8111C "  
Сообщение от Demokrite on 28-Авг-08, 15:41 
>[оверквотинг удален]
>>>>>биос сетевую видит (Realtek RTL 8111C (10/100/1000 Mbit), а фря - нет,
>>>>>подскажите, пожалуйста, как поставить драйвер
>>>
>>>попробуй просто kldload if_re.ko .....
>>
>>не могу найти файл : if_re.ko
>>поставщики на него тоже ссылаются а в поставке драйвера его нет
>
>Та не в поставке драйвера, а в ядреных модулях... есть и работает...
>

собственно, а чем все закончилось?

у меня таже проблема, даже после kldload if_re.ko Фря не видит сетевуху.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

11. "ФриБСД 7.0 не видит сетевого адаптера Realtek RTL 8111C "  
Сообщение от jant email(??) on 19-Сен-08, 22:20 
Пока был в отпуске предыдущую системную плату использовали под винду,
теперь купил Интел - BLKDP43TF и столкнулся с такой же проблемой - установил 7-ку, а сетевой - нет :(:(:(
что же это за политика ?!
как поднять интегрированную сеть? прошу помощи!

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

12. "ФриБСД 7.0 не видит сетевого адаптера Realtek RTL 8111C "  
Сообщение от AlexnderBU on 15-Окт-08, 12:28 
>Пока был в отпуске предыдущую системную плату использовали под винду,
>теперь купил Интел - BLKDP43TF и столкнулся с такой же проблемой -
>установил 7-ку, а сетевой - нет :(:(:(
>что же это за политика ?!
>как поднять интегрированную сеть? прошу помощи!

Мать GA-G31M-S2L
После обновления мира до
stat /home/aмм/>uname -a
FreeBSD stat.silur 7.1-PRERELEASE FreeBSD 7.1-PRERELEASE #0: Fri Oct  3 22:58:40 EEST 2008     baa@stat.firma:/usr/obj/usr/src/sys/GENERIC  i386

всё заработало
stat /home/aмм/>pciconf -lv
re0@pci0:2:0:0: class=0x020000 card=0xe0001458 chip=0x816810ec rev=0x02 hdr=0x00
    vendor     = 'Realtek Semiconductor'
    device     = 'RTL8168/8111 PCI-E Gigabit Ethernet NIC'
    class      = network
    subclass   = ethernet

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

13. "ФриБСД 7.0 не видит сетевого адаптера Realtek RTL 8111C "  
Сообщение от MASiK on 22-Окт-08, 20:48 
>>Пока был в отпуске предыдущую системную плату использовали под винду,
>>теперь купил Интел - BLKDP43TF и столкнулся с такой же проблемой -
>>установил 7-ку, а сетевой - нет :(:(:(
>>что же это за политика ?!
>>как поднять интегрированную сеть? прошу помощи!

кароче файлик в комплекте даёться с дровами if_rl.ko его пихаем в /boot/modules и /boot/kernels (Делаем бек апы если там такие уже есть)

Потом идём в /boot/defoult/loader.conf и там врубаем поддержку if_rl_load="YES" (Поискать предёться)

Ребутаемся, радуемся жизни

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

14. "ФриБСД 7.0 не видит сетевого адаптера Realtek RTL 8111C "  
Сообщение от Anton (??) on 28-Апр-09, 07:24 
>[оверквотинг удален]
>>>установил 7-ку, а сетевой - нет :(:(:(
>>>что же это за политика ?!
>>>как поднять интегрированную сеть? прошу помощи!
>
>кароче файлик в комплекте даёться с дровами if_rl.ko его пихаем в /boot/modules
>и /boot/kernels (Делаем бек апы если там такие уже есть)
>
>Потом идём в /boot/defoult/loader.conf и там врубаем поддержку if_rl_load="YES" (Поискать предёться)
>
>Ребутаемся, радуемся жизни

А как быть в том случае, если сетевая карта нормально поднимается только в том случае, если вручную подгрузишь if_rl.ko?
В /boot/loader.conf прописал if_rl_load="YES", но все равно при загрущке пишет, что к устройству нет драйвера, хотя модуль загружен. (т.к. kldload if_rl.ko выдает, что файл if_rl.ko уже существует).

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру