The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Обновление библиотеки glibc и glibc-common"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы OpenNET: Виртуальная конференция (Public)
Изначальное сообщение [ Отслеживать ]

"Обновление библиотеки glibc и glibc-common"  
Сообщение от Евгений email(??) on 12-Янв-09, 16:29 
Стояла старая библиотека:
Код:

[root@flash-at-xe barinov]# rpm -q glibc
glibc-2.3.4-2.41


Удалить старую неполучается: пишу

Код:

# rpm -e glibc-2.3.4-2.41

выдает кучу всего: (вот часть)

Код:

glibc >= 2.3.3-28 is needed by (installed) sed-4.1.2-7.el4.i386
        glibc > 2.3.4-2.39 is needed by (installed) pam-0.77-66.25.i386
        glibc >= 2.3.4-2.40 is needed by (installed) authconfig-4.6.10-7.el4.i386
        glibc >= 2.2.4-18 is needed by (installed) prelink-0.3.3-0.EL4.i386
        glibc >= 2.2.4 is needed by (installed) bluez-hcidump-1.11-1.i386
        glibc >= 2.2.4 is needed by (installed) bluez-bluefw-1.0-6.i386
        glibc >= 2.0.6 is needed by (installed) ppp-2.4.2-6.4.RHEL4.i386
        glibc = 2.3.4-2.41 is needed by (installed) glibc-headers-2.3.4-2.41.i386
        glibc = 2.3.4-2.41 is needed by (installed) glibc-devel-2.3.4-2.41.i386
        glibc >= 2.3.2 is needed by (installed) oracle-xe-univ-10.2.0.1-1.0.i386
        /etc/ld.so.conf.d is needed by (installed) qt-3.3.3-13.RHEL4.i386
        /sbin/ldconfig is needed by (installed) beecrypt-3.1.0-6.i386
        /sbin/ldconfig is needed by (installed) bzip2-libs-1.0.2-13.EL4.3.i386
        /sbin/ldconfig is needed by (installed) e2fsprogs-1.35-12.17.el4.i386
        /sbin/ldconfig is needed by (installed) elfutils-libelf-0.97.1-5.i386
        /sbin/ldconfig is needed by (installed) expat-1.95.7-4.i386
        /sbin/ldconfig is needed by (installed) gdbm-1.8.0-24.i386
        /sbin/ldconfig is needed by (installed) glib2-2.4.7-1.i386
        /sbin/ldconfig is needed by (installed) libattr-2.4.16-3.1.el4.i386
        /sbin/ldconfig is needed by (installed) libacl-2.2.23-5.4.el4.i386
        /sbin/ldconfig is needed by (installed) libcap-1.10-20.i386
        /sbin/ldconfig is needed by (installed) libselinux-1.19.1-7.4.i386
        /sbin/ldconfig is needed by (installed) device-mapper-1.02.25-2.el4.i386
        /sbin/ldconfig is needed by (installed) libsepol-1.1.1-2.i386


Пытаюсь поставить новую (скачал пакет glibc-2.7-2.i386.rpm)

Устанавливаю:


Код:

[root@flash-at-xe barinov]# rpm -ivh glibc-2.7-2.i386.rpm
warning: glibc-2.7-2.i386.rpm: V3 DSA signature: NOKEY, key ID 4f2a6fd2
error: Failed dependencies:
        glibc-common = 2.7-2 is needed by glibc-2.7-2.i386
        glibc > 2.3.4 conflicts with glibc-common-2.3.4-2.41.i386
[root@flash-at-xe barinov]#


Нахожу ему пакет (glibc-common-2.7-2.i386.rpm)

Устанавливаю:

Код:

[root@flash-at-xe barinov]# rpm -ivh glibc-common-2.7-2.i386.rpm
warning: glibc-common-2.7-2.i386.rpm: V3 DSA signature: NOKEY, key ID 4f2a6fd2
error: Failed dependencies:
        glibc < 2.7 conflicts with glibc-common-2.7-2.i386
[root@flash-at-xe barinov]#


То есть по ходу один не может установиться без другого и наоборот.

Пакеты брал тут:
http://rpm.pbone.net/index.php3?stat...2.7-2.i386.rpm

Тут их тьма и то ли там одинаковых половина .. то ли еще что.

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Обновление библиотеки glibc и glibc-common"  
Сообщение от Andrey Mitrofanov on 12-Янв-09, 17:13 
"Не надо [не исповедавшись] "поднимать версию" libc6."(c)я
Хотя, может быть, и известны отдельные случаи такого "безобразия". но.....

>[root@flash-at-xe barinov]# rpm -q glibc
>glibc-2.3.4-2.41
>Пытаюсь поставить новую (скачал пакет glibc-2.7-2.i386.rpm)
>[root@flash-at-xe barinov]# rpm -ivh glibc-2.7-2.i386.rpm
>warning: glibc-2.7-2.i386.rpm: V3 DSA signature: NOKEY, key ID 4f2a6fd2
>error: Failed dependencies:
>        glibc-common = 2.7-2 is
>Нахожу ему пакет (glibc-common-2.7-2.i386.rpm)
>[root@flash-at-xe barinov]# rpm -ivh glibc-common-2.7-2.i386.rpm
>То есть по ходу один не может установиться без другого и наоборот.

А ССЗБ могу ещё попробовать --
rpm -ivh glibc-2.7-2.i386.rpm glibc-common-2.7-2.i386.rpm

Будьте готовы к тому, что система "неожиданно" сломается, не загружится, задымится и т.п.

>Пакеты брал тут:
>Тут их тьма и то ли там одинаковых половина .. то ли еще что.

Не надо трогать glibc aka linc6. Она настолько глубоко связана со всем "внутри" дистрибутива, что её обновление (не считая секюрити фиксов - без изменения версии фактически) обычно производится _только_ при апгрейде дистрибутива с дополнительными предостережениями / предосторожностями и никак не "в лоб" через rpm -i...

Если у Вас "возникла необходимость" установить "новую" glibc, значит, Вы что-то делаете не так: ставите пакеты не из той версии дистрибутива или вообще из другого дистрибутива, обновляете систему "не через то место" или что-то подобное.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Слёрм
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру