The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Обновление портов не происходит"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Открытые системы на сервере (BSD привязка / FreeBSD)
Изначальное сообщение [ Отслеживать ]

"Обновление портов не происходит"  +/
Сообщение от onlite (ok) on 04-Апр-14, 07:36 
Доброе время суток.
FreeBSD 9.1.
Раньше обновлялись порты нормально этой командой , теперь который раз пытаюсь обновить, выдает


root@PROXY:/ # /usr/local/sbin/portupgrade -anrR
---> Session started at: Thu, 03 Apr 2014 10:42:37 +0400
[Reading data from pkg(8) ... - 1 packages found - done]
[Updating the portsdb <format:bdb_btree> in /usr/ports ... - 24478 port entries
found .........1000.........2000.........3000.........4000.........5000.........
6000.........7000.........8000.........9000.........10000.........11000.........
12000.........13000.........14000.........15000.........16000.........17000.....
....18000.........19000.........20000.........21000.........22000.........23000.
........24000.... ..... done]
---> Upgrade of ports-mgmt/pkg started at: Thu, 03 Apr 2014 10:43:03 +0400
---> Upgrading 'pkg-1.2.6' to 'pkg-1.2.7_1' (ports-mgmt/pkg)
OK? [no]
---> Upgrade of ports-mgmt/pkg ended at: Thu, 03 Apr 2014 10:43:03 +0400 (consu
med 00:00:00)
---> ** Upgrade tasks 1: 1 done, 0 ignored, 0 skipped and 0 failed
---> Listing the results (+:done / -:ignored / *:skipped / !:failed)
+ ports-mgmt/pkg (pkg-1.2.6 -> pkg-1.2.7_1)
---> Packages processed: 1 done, 0 ignored, 0 skipped and 0 failed
---> Session ended at: Thu, 03 Apr 2014 10:43:03 +0400 (consumed 00:00:26)
root@PROXY:/ #

обновляем допустим phpMyAdmin

root@PROXY:/usr/ports/databases/phpmyadmin # pkg_version -v | grep "phpM"
phpMyAdmin-4.1.8 < needs updating (port has 4.1.12)

portupgrade phpMyAdmin-4.1.8

что то обновляется, качает phpMyAdmin-4.1.12, а в итоге та же самая версия phpMyAdmin-4.1.8

хотя когда заходишь на страницу phpmyadmin

Информация о версии: 4.1.12

конфликт какой то, можно ли как то исправить?

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Обновление портов не происходит"  +/
Сообщение от Дядя_Федор on 04-Апр-14, 08:08 
> конфликт какой то, можно ли как то исправить?

Какой-то конфликт наверняка можно как-то исправить. Я в этом уверен.


Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Обновление портов не происходит"  +/
Сообщение от onlite (ok) on 04-Апр-14, 08:44 
>> конфликт какой то, можно ли как то исправить?
>  Какой-то конфликт наверняка можно как-то исправить. Я в этом уверен.

В какую сторону смотреть?

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "Обновление портов не происходит"  +/
Сообщение от ash (??) on 04-Апр-14, 09:51 
>>> конфликт какой то, можно ли как то исправить?
>>  Какой-то конфликт наверняка можно как-то исправить. Я в этом уверен.
> В какую сторону смотреть?

portmaster вам в помощь.

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "Обновление портов не происходит"  +/
Сообщение от Дядя_Федор on 04-Апр-14, 11:21 
> В какую сторону смотреть?

Помимо указанного ниже - в сторону описания возникших проблем. Потому что информации в вашем сообщении - ноль.


Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

5. "Обновление портов не происходит"  +/
Сообщение от onlite (ok) on 04-Апр-14, 11:39 
>> В какую сторону смотреть?
>  Помимо указанного ниже - в сторону описания возникших проблем. Потому что
> информации в вашем сообщении - ноль.

Попробую еще раз.
Давно обновлялись порты командой

>#portsnap fetch update
>#portsnap extract

потом смотрел

>#pkg_version -v | grep need

если было мало портов, я обновлял

>#portupgrade [имя порта]

если много портов делал

>#portupgrade -anrR

и все обновлялось, проверял командой

>#pkg_version -v | grep need

теперь не работает это все в какой то момент :( и как это исправить, не могу найти.
сказано было portmaster тебе в помощь, постмастером обновляет, по одному пакету, больше не пробывал. Сейчас обновляет apache22, посмотрим.


Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

6. "Обновление портов не происходит"  +/
Сообщение от onlite (ok) on 04-Апр-14, 12:23 
Спасибо, portmaster помог.
а вот portupgrade не захотел работать :(

tevent-0.9.18                       <   needs updating (port has 0.9.21)
root@PROXY:/ # portupgrade tevent-0.9.18
[Reading data from pkg(8) ... - 182 packages found - done]
--->  Upgrading 'tevent-0.9.18' to 'tevent-0.9.21' (devel/tevent)
--->  Building '/usr/ports/devel/tevent'
===>  Cleaning for tevent-0.9.21
===>  License LGPL3 accepted by the user
===>  Found saved configuration for tevent-0.9.18
===> Fetching all distfiles required by tevent-0.9.21 for building
===>  Extracting for tevent-0.9.21
=> SHA256 Checksum OK for tevent-0.9.21.tar.gz.
===>  Patching for tevent-0.9.21
===>  Applying FreeBSD patches for tevent-0.9.21
===>   tevent-0.9.21 depends on file: /usr/local/bin/python2.7 - found
===>   tevent-0.9.21 depends on executable: python2 - found
===>   tevent-0.9.21 depends on executable: pkgconf - found
===>   tevent-0.9.21 depends on package: talloc>=2.1.0 - not found
===>   Found talloc-2.0.8, but you need to upgrade to talloc>=2.1.0.
*** [build-depends] Error code 1

Stop in /usr/ports/devel/tevent.
** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portupgrade20140404-22
381-12dlmvb env UPGRADE_TOOL=portupgrade UPGRADE_PORT=tevent-0.9.18 UPGRADE_PORT
_VER=0.9.18 make
** Fix the problem and try again.
** Listing the failed packages (-:ignored / *:skipped / !:failed)
        ! devel/tevent (tevent-0.9.18)  (unknown build error)
root@PROXY:/ #

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

7. "Обновление портов не происходит"  +/
Сообщение от Филимон Покушал on 04-Апр-14, 18:03 
> а вот portupgrade не захотел работать :(
> Found talloc-2.0.8, but you need to upgrade to talloc>=2.1.0.

в man portupgrade почитайте про ключи -R и -r

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

8. "Обновление портов не происходит"  +/
Сообщение от Филимон Покушал on 04-Апр-14, 18:08 
алсо

> #portupgrade -anrR
> и все обновлялось, проверял командой

Странно. n это no execute  Do not actually install, upgrade or fetch any             packages; just show what would be done. Т.е. не устанавливать ничего, а просто показать, что будет сделано

>#portsnap extract только в первый раз. Потом толкьо portsnap fetch update

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

9. "Обновление портов не происходит"  +/
Сообщение от onlite (ok) on 04-Апр-14, 21:08 
> алсо
>> #portupgrade -anrR
>> и все обновлялось, проверял командой
> Странно. n это no execute  Do not actually install, upgrade or
> fetch any          
>    packages; just show what would be done. Т.е.
> не устанавливать ничего, а просто показать, что будет сделано
>>#portsnap extract только в первый раз. Потом толкьо portsnap fetch update

Спасибо. Теперь другая ошибка, при обновлении большинства портов

** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portupgrade20140404-63
097-13hrn29 env UPGRADE_TOOL=portupgrade UPGRADE_PORT=php55-5.5.9 UPGRADE_PORT_V
ER=5.5.9 make
** Fix the problem and try again.

а при некоторых портах, нормально.

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

10. "Обновление портов не происходит"  +/
Сообщение от Sabakwaka (ok) on 04-Апр-14, 22:47 
>> алсо
>>> #portupgrade -anrR

pkg??? какой??? версии??? :)

PKG обновился до PKGNG.
Предупреждение о капецтотальном прекращении поддержки PKG опубликовано.
И теперь базу пакетов (все, что в /var/db/pkg) нужно перестроить в PKGNG формат.

В /ect/make.conf добавить строку WITH_PKGNG=yes

Все pkg_*/pkg_tools - make deinstall.

Вместо них: /usr/ports/ports-mgmt/pkg

Все остальные (и pkg в их числе, и portupgrade, естественно!) установленные из /usr/ports/ports-mgmt/ инструменты — make deinstall && make reinstall

Запустить /usr/local/sbin/pkg2ng

Всё заработает.

---
http://www.freebsd.org/doc/ru/books/handbook/pkgng-intro.html
http://skyline-nismo.ya.ru/replies.xml?item_no=148

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

11. "Обновление портов не происходит"  +/
Сообщение от onlite (ok) on 05-Апр-14, 11:38 
>>> алсо
>>>> #portupgrade -anrR
> pkg??? какой??? версии??? :)

pkg-1.2.7_1                        <
pkgconf-0.9.5                      =

> В /ect/make.conf добавить строку WITH_PKGNG=yes

Это есть.

> Все pkg_*/pkg_tools - make deinstall.
> Вместо них: /usr/ports/ports-mgmt/pkg
> Все остальные (и pkg в их числе, и portupgrade, естественно!) установленные из
> /usr/ports/ports-mgmt/ инструменты — make deinstall && make reinstall

короче грохнулось все, вчера работало, сегодня ни почта, ни postgrey, ни web server. squid + ad работает только. :(

Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

12. "Обновление портов не происходит"  +/
Сообщение от onlite (ok) on 05-Апр-14, 12:06 
> Запустить /usr/local/sbin/pkg2ng
> Всё заработает.

проделал все, не хочет.
pkg2ng: Command not found.


Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

13. "Обновление портов не происходит"  +/
Сообщение от onlite (ok) on 05-Апр-14, 12:53 
>> Запустить /usr/local/sbin/pkg2ng
>> Всё заработает.
> проделал все, не хочет.
> pkg2ng: Command not found.

в общем запустил, но не хочет apache22 запускаться, из за того что нужен пакет perl5.16 или выше. Сейчас у меня perl5.14 и много чего на нем завязано, другой perl не ставится из за конфликта версий, вроде бы как уже есть.
Снести все и установить заново? но сильно много завязано на сервере.
ладно, принцип понял, найду время снести все пакеты perl5.14 и заново поставить perl5.16

Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

14. "Обновление портов не происходит"  +/
Сообщение от onlite (ok) on 05-Апр-14, 14:34 
Разобрался с портами, с приложениями.

Обновил перл
>portupgrade -o lang/perl5.16 -f perl5.14\*

затем обновил весь софт связанный с зависимостями перл

>portupgrade -fr perl5

ну и потихоньку устанавливал проблемные приложения типа apache22, postgrey и т.д.

Научился управлять pkgng

Спасибо всем кто помогал. Вопрос закрыт.

Ответить | Правка | ^ к родителю #13 | Наверх | Cообщить модератору

15. "Обновление портов не происходит"  +/
Сообщение от DeadLoco (ok) on 11-Апр-14, 20:58 
> затем обновил весь софт связанный с зависимостями перл

По хорошему вам надо бы пересобрать все и тотально. Ибо хз, где какие недообработанные зависимости зависли.

# portsnap fetch update
# portmaster --check-depends
# portmaster --check-port-dbdir
# portmaster -aftd
# portmaster -y --clean-distfiles
Но курить придется долго.
Ответить | Правка | ^ к родителю #14 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Партнёры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2024 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру