The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]



"Выпуск Apache Flex 4.14, продолжающий развитие технологии Ad..."
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Выпуск Apache Flex 4.14, продолжающий развитие технологии Ad..."  +/
Сообщение от opennews (ok), 03-Фев-15, 19:49 
Состоялся (https://blogs.apache.org/flex/entry/apache_flex_4_14_released) релиз Apache Flex 4.14 (http://flex.apache.org/), кроссплатформенного открытого фреймворка для создания интерактивных (Rich Internet Applications) web-приложений, идентично выполняемых как в web-браузере, так и в виде отдельных настольных программ или мобильных приложений. В Apache Flex 4.14 добавлена (http://apache-mirror.rbc.ru/pub/apache/flex/4.14.0/RELEASE_N... поддержка свежих версий Flash Player 16.0 и AIR 16.0, реализованы темы оформления для iOS 7+ и Android 4.x+, в  spark добавлен компонент RichTextEditor, в TLF (Text Layout Framework) обеспечена встроенная поддержка таблиц.

Apache Flex базируется на коде Adobe Flex, который был передан (https://www.opennet.ru/opennews/art.shtml?num=32324) в 2011 году компанией Adobe фонду Apache. Apache Flex 4.13 полностью совместим с продуктом Adobe Flex SDK (http://www.adobe.com/devnet/flex/flex-sdk-download.html), и содержит всю доступную в нём функциональность, в том числе средства создания мобильных и web-приложений с использованием для разработки интерфейсов разметки MXML (http://ru.wikipedia.org/wiki/MXML) и языка ActionScript 3. Основанная на Eclipse интегрированная среда для разработки Flash Builder (http://www.adobe.com/products/flash-builder.html) остаётся проектом, подконтрольным Adobe.  

Среди сильных сторон Flex, актуальных при разработке приложений для корпоративного сектора, отмечается обеспечение целостной и полнофункциональной поддержки работы на различных платформах, эффективность компонентов Flex и модели программирования при создании сложных интерфейсов пользователя, зрелость ActionScript как языка программирования для разработки больших приложений, наличие большого числа вспомогательных инструментов для редактирования кода, отладки и профилирования.

URL: https://blogs.apache.org/flex/entry/apache_flex_4_14_released
Новость: https://www.opennet.ru/opennews/art.shtml?num=41600

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения [Сортировка по времени | RSS]


1. "Выпуск Apache Flex 4.14, продолжающий развитие технологии Ad..."  –1 +/
Сообщение от Verbum (ok), 03-Фев-15, 19:49 
Вопрос.
Кто-нибудь использовал сие вместо Adobe Flex SDK
при работе во FlashDevelop?
Ответить | Правка | Наверх | Cообщить модератору

2. "Выпуск Apache Flex 4.14, продолжающий развитие технологии Ad..."  +1 +/
Сообщение от тоже Анонимemail (ok), 03-Фев-15, 20:01 
Имхо, не тот ресурс.
Здесь слишком хорошо помнят эпичный официальный клиент ICQ под Линукс, основанный на технологиях Adobe, и обходят их стороной.
Ответить | Правка | Наверх | Cообщить модератору

5. "Выпуск Apache Flex 4.14, продолжающий развитие технологии Ad..."  +/
Сообщение от Alex (??), 03-Фев-15, 22:54 
А можете написать что такого с этой аськой случилось? помню была эта версия а потом не стало.
Ответить | Правка | Наверх | Cообщить модератору

7. "Выпуск Apache Flex 4.14, продолжающий развитие технологии Ad..."  +/
Сообщение от Не пользовался осуждаю (?), 03-Фев-15, 23:14 
Вроде, она как не в себя ела ресурсы.
Примерно, как типичная игра :)
Ответить | Правка | Наверх | Cообщить модератору

8. "Выпуск Apache Flex 4.14, продолжающий развитие технологии Ad..."  +2 +/
Сообщение от тоже Анонимemail (ok), 04-Фев-15, 09:36 
На самом деле, было два фактора, предрекшие судьбу этого приложения:
1. Заявленные системные требования действительно больше были похожи на игру, чем на IM. Начиная с гигабайта памяти минимум (!) и далее по списку.
2. Собственно, именно под Линукс именно официальный клиент вообще мало кому впился, когда есть вполне справляющиеся с "аськой" Pidgin, Kopete etc. Рекламу через него, может, и удобнее показывать, но это удобство - не для пользователей.
А уж с таким багажом - вовсе вышел анекдот. Эпический. В назидание потомкам.
Ответить | Правка | Наверх | Cообщить модератору

10. "Выпуск Apache Flex 4.14, продолжающий развитие технологии Ad..."  –1 +/
Сообщение от Zenitur (ok), 04-Фев-15, 10:02 
Со вторым соглашусь, но справедливости ради скажу что если бы аська устанавливалась без проблем у неё было бы много пользователей. С первым не соглашусь: ест 60 Мб памяти - и почему-то 20% одного ядра процессора. Гигабайт памяти указан потому что ребята не представляют чтобы Linux работал на компьютере слабее (не видели ничего кроме Ubuntu?)
Ответить | Правка | Наверх | Cообщить модератору

12. "Выпуск Apache Flex 4.14, продолжающий развитие технологии Ad..."  +/
Сообщение от тоже Анонимemail (ok), 04-Фев-15, 11:29 
Фишка в том, что пользователи "аськи" и пользователи официального клиента - это два очень разных по размеру множества. Многие и под виндой-то пользуются Мирандой, например. А уж под Убунтой при наличии Pidgin из коробки именно официальный клиент оказывается альтернативным, а плюсов-то у него, по факту, нет. Скорее наоборот.
Ответить | Правка | Наверх | Cообщить модератору

9. "Выпуск Apache Flex 4.14, продолжающий развитие технологии Ad..."  –1 +/
Сообщение от Zenitur (ok), 04-Фев-15, 10:00 
Она и сейчас есть, спокойно себе работает. Только Adobe AIR перестал выпускаться для Linux, в связи с чем появилось два бага: 1). В GNOME3 не работает из-за хранения паролей в gnome-keyring (только в GNOME2 и KDE3/4). 2). При установке программы она прекрасно пропишется в системную базу пакетов RPM/DEB, но сама установка не удастся, если дата не 2011/2012 год. После установки можно вернуть дату как было. Если Mail.ru пересоберут бинарник ICQ для Linux с сертификатом хотя бы на 2015-2020 годы, и откажутся от хранения паролей системными средствами KDE и GNOME, то аська для Linux перестанет ассоциироваться с костылями. Скачать старый релиз можно здесь: http://www.icq.com/download/linux/en

Сам Adobe AIR хоть и не обновляется, но работает в Ubuntu 14.10, SteamOS, Fedora 21 и Opensuse 13.2. Вот что LSB животворящий делает! В линуксе нужен играм Canabalt, Botanicula, Defender's Quest, Indie Game: The Movie, Anodyne, Offspring Fling и McPixel. Устанавливать из пакетов: http://airdownload.adobe.com/air/lin/download/2.6/adobeair.deb http://airdownload.adobe.com/air/lin/download/2.6/adobeair.i... А вот API для добавления игр на Adobe AIR в Steam для разработчиков игр: https://github.com/Ventero/FRESteamWorks

Ответить | Правка | К родителю #5 | Наверх | Cообщить модератору

13. "Выпуск Apache Flex 4.14, продолжающий развитие технологии Ad..."  +/
Сообщение от Аноним (-), 04-Фев-15, 11:55 
> В GNOME3 не работает из-за хранения паролей в gnome-keyring (только в GNOME2 и KDE3/4).

В MATE работает?

Ответить | Правка | Наверх | Cообщить модератору

4. "Выпуск Apache Flex 4.14, продолжающий развитие технологии Ad..."  +/
Сообщение от jdeveloper (?), 03-Фев-15, 21:42 
Пользуюсь. Разницы, в сравнении со старым от адоби, никакой.
Ответить | Правка | К родителю #1 | Наверх | Cообщить модератору

6. "Выпуск Apache Flex 4.14, продолжающий развитие технологии Ad..."  +/
Сообщение от Grammar_Nazi (?), 03-Фев-15, 22:58 
от Адоба
Ответить | Правка | Наверх | Cообщить модератору

11. "Выпуск Apache Flex 4.14, продолжающий развитие технологии Ad..."  +2 +/
Сообщение от irinat (ok), 04-Фев-15, 11:21 
> от Адоба

Adobe [əˈdoʊbiː]

Ответить | Правка | Наверх | Cообщить модератору

15. "Выпуск Apache Flex 4.14, продолжающий развитие технологии Ad..."  +/
Сообщение от George (??), 05-Фев-15, 13:34 
http://www.multitran.ru/c/m.exe?CL=1&s=adobe&l1=1  тяжёлая элювиальная глина
Это не тот адоб
Ответить | Правка | Наверх | Cообщить модератору

16. "Выпуск Apache Flex 4.14, продолжающий развитие технологии Ad..."  +2 +/
Сообщение от irinat (ok), 05-Фев-15, 13:51 
https://web.archive.org/web/20090326033602/http://www.adobe....

"Source of Name. Named after Adobe Creek which ran behind Warnock’s home in Los Altos, California".

Послушай, как произносится "Adobe Creek" в https://www.youtube.com/watch?v=9pq2MLFZjwo

Кстати, ещё: Apache произносится как "апачи", а не "апач".

Ответить | Правка | Наверх | Cообщить модератору

14. "Выпуск Apache Flex 4.14, продолжающий развитие технологии Ad..."  +/
Сообщение от Аноним (-), 04-Фев-15, 12:56 
Юзаем, разницы нет.
Ответить | Правка | К родителю #1 | Наверх | Cообщить модератору

17. "портирование программ "  +/
Сообщение от Артурemail (??), 25-Фев-15, 18:34 
Заплачу хорошую цену за портирование программы whatsapp на платформу Bada 2.0.
условия о сделке строгие ,но разумные.
За быстро и качественно выполненную работу полагается дополнительная плата.
дополнительная информация по адресу http://vk.com/secretintelligenceservice
Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру