The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]



"Уязвимость в Samba, позволяющая выполнить код на сервере"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Уязвимость в Samba, позволяющая выполнить код на сервере"  +/
Сообщение от opennews on 24-Май-17, 14:11 
Опубликованы (https://lists.samba.org/archive/samba-announce/2017/000406.html) корректирующие обновления Samba 4.6.4, 4.5.10 и 4.4.14, в которых устранена критическая уязвимость (https://www.samba.org/samba/security/CVE-2017-7494.html) (CVE-2017-7494 (https://security-tracker.debian.org/tracker/CVE-2017-7494)), позволяющая организовать выполнение кода на сервере при наличии доступа на запись в предоставляемое сервером хранилище. Уязвимость позволяет клиенту загрузить разделяемую библиотеку на SMB-хранилище и инициировать её загрузку сервером. Проблема вызвана ошибкой в реализации IPC для именованных каналов для клиентов Windows NT.


Уязвимости подвержены все версии Samba, начиная с 3.5.0, поэтому дополнительно подготовлены патчи (http://samba.org/samba/patches/) для старых версий. В качестве обходного пути защиты можно добавить в параметр "nt pipe support = no" в секцию "[global]" smb.conf и перезапустить smbd. Обновления пакетов уже сформированы для FreeBSD (http://www.vuxml.org/freebsd/), Debian (https://security-tracker.debian.org/tracker/CVE-2017-7494), Fedora (https://bugzilla.redhat.com/show_bug.cgi?id=1455050) и RHEL (https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-7494).

Проследить за выпуском обновлений пакетов в других дистрибутивах можно на данных страницах: Ubuntu (https://www.ubuntu.com/usn/), openSUSE (https://lists.opensuse.org/opensuse-security-announce/2017-05/), SUSE (https://bugzilla.novell.com/show_bug.cgi?id=CVE-2017-7494), CentOS (https://lists.centos.org/pipermail/centos-announce/2017-May/...).

URL: https://lists.samba.org/archive/samba-announce/2017/000406.html
Новость: https://www.opennet.ru/opennews/art.shtml?num=46591

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Уязвимость в Samba, позволяющая выполнить код на сервере"  +5 +/
Сообщение от . on 24-Май-17, 14:11 
"никогда не было, и вот... опять"

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

22. "Уязвимость в Samba, позволяющая выполнить код на сервере"  +/
Сообщение от Аноним (??) on 25-Май-17, 12:36 
не так, Самба- это хорошо, выполнить код удаленно- это плохо, сервер- это хорошо, итого получается хорошо.
Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

2. "Уязвимость в Samba, позволяющая выполнить код на сервере"  +28 +/
Сообщение от Аноним (??) on 24-Май-17, 14:24 
Это не уязвимость, а код для совместимости с WannaDecryptor
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

10. "Уязвимость в Samba, позволяющая выполнить код на сервере"  +1 +/
Сообщение от пох on 24-Май-17, 16:23 
> Это не уязвимость, а код для совместимости с WannaDecryptor

тот еще в марте выпилили. Для совместимости.
Но, поскольку ЦРУ не поделилось готовыми скриптами для самбы, мир вряд ли в ближайшее время узнает, сколько у нас линукс-мусорок без обновлений и с сасамбой во внешний мир :-(

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

20. "Уязвимость в Samba, позволяющая выполнить код на сервере"  +9 +/
Сообщение от Аноним (??) on 24-Май-17, 20:52 
WannaDecryptor уже получил статус Platinum на сайте WineHQ.
Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

3. "Уязвимость в Samba, позволяющая выполнить код на сервере"  –1 +/
Сообщение от ЫКУ on 24-Май-17, 14:55 
Для 3.6.25 нет патчей
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

6. "Уязвимость в Samba, позволяющая выполнить код на сервере"  –1 +/
Сообщение от iZEN email(ok) on 24-Май-17, 15:21 
Чем вам NFSv3 не протокол?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

7. "Уязвимость в Samba, позволяющая выполнить код на сервере"  +4 +/
Сообщение от Аноним (??) on 24-Май-17, 15:41 
Отсутствием авторизации и шифрования
Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

9. "Уязвимость в Samba, позволяющая выполнить код на сервере"  +/
Сообщение от smbman on 24-Май-17, 16:19 
Так оберни его в Kerberos, будет и то и другое.
Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

16. "Уязвимость в Samba, позволяющая выполнить код на сервере"  +1 +/
Сообщение от Аноним (??) on 24-Май-17, 19:08 
Что обернуть, NFSv3? Ты циферку хорошо разглядел?
Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

8. "Уязвимость в Samba, позволяющая выполнить код на сервере"  +/
Сообщение от Аноним (??) on 24-Май-17, 15:55 
Попробовал бы заюзать, не задавал бы таких вопросов
Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

11. "Уязвимость в Samba, позволяющая выполнить код на сервере"  +/
Сообщение от пох on 24-Май-17, 16:25 
> Попробовал бы заюзать, не задавал бы таких вопросов

админы локалхостов не поймут-с - у них "все работает", поскольку на самом деле ничего им и не нужно.


Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

13. "Уязвимость в Samba, позволяющая выполнить код на сервере"  –1 +/
Сообщение от Аноним (??) on 24-Май-17, 16:46 
Нет поддержки в телефоне
Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

14. "Уязвимость в Samba, позволяющая выполнить код на сервере"  +4 +/
Сообщение от P.Galloway (ok) on 24-Май-17, 17:06 
> Нет поддержки в телефоне

И обратной совместимости с декадношаговыми АТС

Ответить | Правка | ^ к родителю #13 | Наверх | Cообщить модератору

15. "Уязвимость в Samba, позволяющая выполнить код на сервере"  –1 +/
Сообщение от Michael Shigorin email(ok) on 24-Май-17, 17:37 
А, на это ж сегодня эмбарго снято?
В общем, у нас в курсе.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

18. "Уязвимость в Samba, позволяющая выполнить код на сервере"  +4 +/
Сообщение от Аноним (??) on 24-Май-17, 19:27 
Для АЛЬТА не актуально же, ведь да?
Ответить | Правка | ^ к родителю #15 | Наверх | Cообщить модератору

19. "Уязвимость в Samba, позволяющая выполнить код на сервере"  +2 +/
Сообщение от пох on 24-Май-17, 20:20 
кстати, внезапно - неактуально для редхата и клонов.
selinux target для самбы благополучно блокирует попытку загрузки подсунутого .so, если только специально этого не ломать.

Михаил, и как у нас с selinux ?

Ответить | Правка | ^ к родителю #18 | Наверх | Cообщить модератору

27. "Уязвимость в Samba, позволяющая выполнить код на сервере"  –2 +/
Сообщение от Michael Shigorin email(ok) on 25-Май-17, 16:00 
> Михаил, и как у нас с selinux ?

Гляньте при желании пакет selinux-policy-alt.

Ответить | Правка | ^ к родителю #19 | Наверх | Cообщить модератору

28. "Уязвимость в Samba, позволяющая выполнить код на сервере"  –1 +/
Сообщение от пох on 25-Май-17, 17:21 
> Гляньте при желании пакет selinux-policy-alt.

ключевой вопрос - включается ли оно при установке _по_умолчанию_?
Если нет - то смотреть особенно и не на что - даже у редгада, у которого включается, хотя и в permissive mode, куча вполне очевидных, десять лет известных мест, которые не работают без ручных пинков ни в какой вообразимой разумом конфигурации.

Вот, типичная юзерская центось v6, что было под рукой (в "настоящем" редхате все то же):
allow shutdown_t var_log_t:file { write open };
то есть банально - они даже не сообразили, что shutdown на каждой перезагрузке пишет в wtmp.
Этому лет - я уж не знаю сколько, наверное, вот сколько вообще шестым версиям. Как и то, каким местом они эти политики разрабатывают, если даже никогда не заглядывают потом в audit log.

Ответить | Правка | ^ к родителю #27 | Наверх | Cообщить модератору

26. "Уязвимость в Samba, позволяющая выполнить код на сервере"  –2 +/
Сообщение от Michael Shigorin email(ok) on 25-Май-17, 15:59 
> Для АЛЬТА не актуально же, ведь да?

* Wed May 24 2017 Evgeny Sinelnikov <sin@altlinux> 4.6.4-alt1.S1
- Update to second spring security release
- Fix longtime initialization bug in ldb proxy
- Security fixes:
  + CVE-2017-7494 Remote code execution from a writable share

Ответить | Правка | ^ к родителю #18 | Наверх | Cообщить модератору

23. "Уязвимость в Samba, позволяющая выполнить код на сервере"  +/
Сообщение от Аноним (??) on 25-Май-17, 12:39 
> А, на это ж сегодня эмбарго снято?
> В общем, у нас в курсе.

к великому сожалению это очень актуально для РеактОС.

Ответить | Правка | ^ к родителю #15 | Наверх | Cообщить модератору

17. "Уязвимость в Samba, позволяющая выполнить код на сервере"  +1 +/
Сообщение от dq0s4y71 (ok) on 24-Май-17, 19:17 
Опять можно пользовать KaHT2?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

24. "Уязвимость в Samba, позволяющая выполнить код на сервере"  +/
Сообщение от Аноним (??) on 25-Май-17, 12:57 
вам можно, кстати, а вы заплатили налоги, заняли очередь, проголосовали, анархист?
Ответить | Правка | ^ к родителю #17 | Наверх | Cообщить модератору

25. "Уязвимость в Samba, позволяющая выполнить код на сервере"  +/
Сообщение от anonymous (??) on 25-Май-17, 14:05 
Когда ждать порта под AFS?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру