The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]



"Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +/
Сообщение от opennews (??), 07-Янв-20, 10:36 
Подготовлен  выпуск проекта Nuitka 0.6.6, в рамках которого развивается компилятор, позволяющий транслировать скрипт на языке Python в представление на C++, которое затем можно скомпилировать в исполняемый файл, использующий libpython для обеспечения максимальной совместимости с CPython (используются штатные средства CPython для управления объектами). Обеспечена полная совместимость с актуальными выпусками Python 2.x и 3.x. По сравнению с CPython скомпилированные скрипты демонстрируют в тестах pystone повышение производительности на 312%. Код проекта распространяется под лицензией Apache...

Подробнее: https://www.opennet.ru/opennews/art.shtml?num=52145

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения [Сортировка по времени | RSS]


1. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +18 +/
Сообщение от Аноним (1), 07-Янв-20, 10:36 
Никак питонисты не могут преодолеть до конца эту "великую схизму" версий
Ответить | Правка | Наверх | Cообщить модератору

3. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +7 +/
Сообщение от Аноним (3), 07-Янв-20, 10:56 
Гвидо осознал что это навсегда - поэтому с горя и отстранился от раработки
Ответить | Правка | Наверх | Cообщить модератору

56. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  –1 +/
Сообщение от Аноним (-), 08-Янв-20, 08:44 
Что поделать, хипстерам не объясняли что можно задолбаться быть даже BDFL'ом :)
Ответить | Правка | Наверх | Cообщить модератору

30. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +/
Сообщение от Аноним (30), 07-Янв-20, 16:45 
Питонисты-то давно преодолели, и я бы сказал что несовместимая 3-я версия это лучшее что случилось с питоном, а другим языкам тянущим гнилую легаси десятилетиями следовало бы поучиться. Не осилил только кто даже не пытался.
Ответить | Правка | К родителю #1 | Наверх | Cообщить модератору

34. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +5 +/
Сообщение от Аноним (34), 07-Янв-20, 18:00 
> другим языкам тянущим гнилую легаси десятилетиями следовало бы поучиться

У других языков изначально все более-менее гладко, развитие происходит путем добавления новых фич, максимально используя уже существующие выразительные средства.

В пихоне же автор выдумывает что-то пРиКоЛьНое))), потом оно ему уже не кажется таким уж пРиКоЛьНым))), и он выдумывает что-то альтернативно-пРиКоЛьНое))). И далее по кругу, как левый мизинец правой ноги пожелает.

Вот выдумал гвидончик для вывода в стдоут юзать... кейворд, а не функцию:

   print 'Hello World!'

Потом гвиндочик вырос, понял, что нужно было изначально делать print функцией, а не кейвордом. В других языках это понимали с самого начала, а гвидончик не понял ни с первого (python 1), ни со второго (python 2) раза.

В итоге из-за того, что гвидончику обобщения даются нелегко, и из-за того, что каждую новую задачу он решает новой пРиКоЛьНой))) синтаксической конструкцией, имеем кучу несовместимостей. Да что уж там, даже однострочный хелловорлд нужно писать по-особому, чтобы он заработал везде.

Ответить | Правка | Наверх | Cообщить модератору

37. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +2 +/
Сообщение от myhand (ok), 07-Янв-20, 18:35 
> У других языков изначально все более-менее гладко

Это что-ж такие за языки такие валшебные такие?  (Высунув язык конспектирует)

Ответить | Правка | Наверх | Cообщить модератору

44. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +1 +/
Сообщение от Аноним (44), 07-Янв-20, 21:24 
"print на самом деле не является настоящей функцией (это конструкция языка), поэтому заключать аргументы в скобки необязательно. "
Ответить | Правка | Наверх | Cообщить модератору

48. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  –3 +/
Сообщение от Аноним (48), 08-Янв-20, 00:47 
Вы уж простите за грубость, но кто использует "print" в коде? Школьники?
Если Вы работаете более менее плотно с Python, то используете logging или более оптимальную замену, а если Вы про концепт, так "Мало ли в Бразилии педров" в смысле полным полно полудохлых концепций и идей в языках сегодня. А если про стандартным библиотекам пройтись? Полным полно не реентерабельных, потокоопасных и т.д. и т.п.
Ответить | Правка | Наверх | Cообщить модератору

51. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +1 +/
Сообщение от Аноним (-), 08-Янв-20, 01:23 
>Вы уж простите за грубость, но кто использует "print" в коде? Школьники?

Это настолько детский лепет, что даже вызывает удивление. Сплошь и рядом print() используется и в консольных программах, и при отладке. А вот как раз logging используется только при сложной отладке, и в вебе.

Ответить | Правка | Наверх | Cообщить модератору

47. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +1 +/
Сообщение от Илья (??), 07-Янв-20, 23:46 
Это что-ж такие за языки такие валшебные такие?
с#,
java,
Ответить | Правка | К родителю #37 | Наверх | Cообщить модератору

39. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +1 +/
Сообщение от Аноним (39), 07-Янв-20, 19:16 
Ну, кстати, тут стоит вспомнить php-шный echo, который киворд (и при этом print - функция, насколько я помню)
Ответить | Правка | К родителю #34 | Наверх | Cообщить модератору

43. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +/
Сообщение от Аноним (44), 07-Янв-20, 21:24 
в php echo и print тоже оператор, а не функция.
Ответить | Правка | К родителю #34 | Наверх | Cообщить модератору

46. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +1 +/
Сообщение от Аноним (39), 07-Янв-20, 22:46 
print в php все же функция, ключевым словом только echo является
Ответить | Правка | Наверх | Cообщить модератору

59. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +2 +/
Сообщение от Аноним Анонимович Анонимов (?), 08-Янв-20, 14:07 
В официальной документации документации сказано обратное. Вот printf действительно функция.
Ответить | Правка | Наверх | Cообщить модератору

61. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +1 +/
Сообщение от Аноним (39), 08-Янв-20, 16:47 
Да, и правда... А многие пишут, что принт - функция
Ответить | Правка | Наверх | Cообщить модератору

55. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  –1 +/
Сообщение от Андрей (??), 08-Янв-20, 05:43 
> Вот выдумал гвидончик для вывода в стдоут юзать... кейворд, а не функцию

Ну, это ещё самое малое зло. А вот использование выравнивания для определения блоков так и не убрали. Ну, может, в 4-ом питоне...

Ответить | Правка | К родителю #34 | Наверх | Cообщить модератору

62. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +3 +/
Сообщение от Аноним (62), 08-Янв-20, 22:23 
Разве это не преимущество питона? Все говорят, что это как раз нехилый плюс
Ответить | Правка | Наверх | Cообщить модератору

72. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +/
Сообщение от Андрей (??), 10-Янв-20, 00:40 
Часто бывает нужно попробовать заменить тот или иной кусок кода, закомментировав старый, а из-за выравнивания эта тривиальная операция превращается в боль.
Ответить | Правка | Наверх | Cообщить модератору

73. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +1 +/
Сообщение от Аноним (-), 10-Янв-20, 02:07 
Это от редактора зависит. Например, в Emacs -е все это делается выделением куска кода, а затем командой "comment-region" или "uncomment-region". Будет весь кусок закомментирован или раскомментирован. А если эти команды повесить на клавиши, то и еще проще.
Ответить | Правка | Наверх | Cообщить модератору

71. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +/
Сообщение от Аноним (71), 09-Янв-20, 16:55 
> У других языков изначально все более-менее гладко, развитие происходит путем добавления новых фич, максимально используя уже существующие выразительные средства.

Ага, скажите это C++.

Ответить | Правка | К родителю #34 | Наверх | Cообщить модератору

76. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +/
Сообщение от Аноним (76), 13-Янв-20, 19:31 
> У других языков изначально все более-менее гладко, развитие происходит путем добавления новых фич, максимально используя уже существующие выразительные средства.

Особенно это заметно на примере C++.

Ответить | Правка | К родителю #34 | Наверх | Cообщить модератору

2. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  –9 +/
Сообщение от Аноним (3), 07-Янв-20, 10:55 
рад что питон 2.7 жив и будет жить
Ответить | Правка | Наверх | Cообщить модератору

4. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +6 +/
Сообщение от iPony129412 (?), 07-Янв-20, 10:57 
Python2 и Flash — кто кого...
Ответить | Правка | Наверх | Cообщить модератору

40. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +2 +/
Сообщение от Оно Ним (?), 07-Янв-20, 19:26 
Питон2. Ибо прост и доступен. В пику кастовости и нишевости.
Ответить | Правка | Наверх | Cообщить модератору

49. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  –1 +/
Сообщение от Аноним (48), 08-Янв-20, 00:49 
А Python 3 сложен и не доступен?

Просто какие-то товарищи все еще используют чей-то легаси, который отлично работает и платить за апгрейд не собираться вот для них начинает расти стоимость технического долга и рано или поздно она будет равна стоимости обслуживания ситсемы и тогда они скорее всего задумаються об обновлении.

Ответить | Правка | Наверх | Cообщить модератору

5. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  –1 +/
Сообщение от iPony129412 (?), 07-Янв-20, 11:03 
Есть что полезного?

http://bugs.debian.org/cgi-bin/pkgreport.cgi?tag=py2removal;...

Ответить | Правка | Наверх | Cообщить модератору

54. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +/
Сообщение от Андрей (??), 08-Янв-20, 05:17 
Ни много ни мало: mercurial. Получается, что популярность упала настолько, что такой вопрос вообще возник. Тогда разработчики в срочном порядке объявили, что вот-вот мы заявим, что следующий релиз будет "стабильным" на третьем питоне.

А tortoise-hg уже выкинули.

При попытке открывать большие файлы на diff в Meld, можно убедиться, что там дефект в дизайне. Открываешь в diffuse - и никаких проблем. diffuse выкинули.

Ответить | Правка | Наверх | Cообщить модератору

6. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +/
Сообщение от iPony129412 (?), 07-Янв-20, 11:27 
> 21 Dec 2019: fonts-noto-color-emoji (0~20180810-1.1) unstable; urgency=medium

  * Change build-dependencies from python-nototools to python3-nototools
    (Closes: 943022)
  * Apply upstream patches for python 3 support.

Во, попёрло 👍

Ответить | Правка | Наверх | Cообщить модератору

7. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +1 +/
Сообщение от Аноним (7), 07-Янв-20, 11:50 
а как у него производительность/жор ресурсов, в сравнении с нативным питонячьим кодом? (Ну, т.е - запустить рядом скомпилированный нуиткой бинарь и helloworld.py, из которого этот бинарь был сделан)
Ответить | Правка | Наверх | Cообщить модератору

24. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +2 +/
Сообщение от Главный Ананим (ok), 07-Янв-20, 14:31 
Работает реально быстрее пока нет активной работы с юникодовыми строками, там получается адское падение скорости в 5-10 раз, по крайней мере один год назад так было, из чего отказался использовать. Нуитка не умеет работать с питон2 оболочкой gtkglext почему то.
Ответить | Правка | Наверх | Cообщить модератору

8. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  –7 +/
Сообщение от Аноним (8), 07-Янв-20, 12:02 
>развивается компилятор, позволяющий транслировать скрипт на языке Python в представление на C++

Пишут на пистоне, чтобы потом транслировать в C++?! Не проще сразу на C++ и не парить моск созданием костылей?

Ответить | Правка | Наверх | Cообщить модератору

10. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +1 +/
Сообщение от Аноним (10), 07-Янв-20, 12:29 
А кто сказал, что вчерашние пистонописатели после курса "кресты за 21 день" напишут сразу на с++ код лучше, чем нуитка оттранслирует? На крестах по-человечески писать за один вечер не получится, думать надо, а это время. В каких-нибудь саенсах может быть реальной проблемой найти людей, пишущих более-менее приличный код и не на питоне, что теперь, благотворительно учить глухих слепыми?
Ответить | Правка | Наверх | Cообщить модератору

11. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +6 +/
Сообщение от Дмитрий Литвиновemail (?), 07-Янв-20, 12:46 
Как вам сказать, на питоне писать раз в 6 быстрее и проще. А ещё там ногу себе прострелить сложно.
Ответить | Правка | К родителю #8 | Наверх | Cообщить модератору

14. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +1 +/
Сообщение от Аноним (14), 07-Янв-20, 13:17 
> Как вам сказать, на питоне писать раз в 6 быстрее и проще.

А думать и проектировать во сколько раз быстрее?

> А ещё там ногу себе прострелить сложно.

Помню, исправлял в плагине Kodi опечатку в имени переменной.

Ответить | Правка | Наверх | Cообщить модератору

18. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +/
Сообщение от Аноним (3), 07-Янв-20, 13:35 
для этих случаев придумали Rpython

https://rpython.readthedocs.io/en/latest/rpython.html

который совместим с python 2.7 конечно

Ответить | Правка | Наверх | Cообщить модератору

20. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +1 +/
Сообщение от Аноним84701 (ok), 07-Янв-20, 14:03 
> для этих случаев придумали Rpython
> https://rpython.readthedocs.io/en/latest/rpython.html
> который совместим с python 2.7 конечно

RPython придумка ученых (ну т.е. для конкретной реализации пинали ассистентов и студентов, все как обычно) исследоваших "динамические языки программирования".

Поэтому RPython -- фреймворк для написания интерпретаторов дин. ЯП. (в первую очередеь PyPy) с кучей плюшек и автомагии, но не с (первоочередной) целью решения каких-то конкретных "реальных" задач.

И уж конечно, он не совместим с python2.7 - там строго типизованное подмножество.

https://rpython.readthedocs.io/en/latest/faq.html#what-is-rp...
> What is RPython?
> RPython is a framework for implementing interpreters and virtual machines for programming languages, especially dynamic languages.

.
> Can RPython compile normal Python programs to C?
> No, RPython is not a Python compiler.
> In Python, it is mostly impossible to prove anything about the types that a program will manipulate by doing a static analysis. It should be clear if you are familiar with Python, but if in doubt see [BRETT].

.
> Do I have to rewrite my programs in RPython?
> No, and you shouldn’t try. First and foremost, RPython is a language designed for writing interpreters. It is a restricted subset of Python. If your program is not an interpreter but tries to do “real things”, like use any part of the standard Python library or any 3rd-party library, then it is not RPython to start with. You should only look at RPython if you try to write your own interpreter.

Ответить | Правка | Наверх | Cообщить модератору

28. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +/
Сообщение от Аноним (3), 07-Янв-20, 14:46 
- совместимость в запуске на python 2.7

- ну и что что пишут что это про создание интерпретаторов - можно смело использовать для своих нужд

Ответить | Правка | Наверх | Cообщить модератору

58. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +/
Сообщение от Урри (?), 08-Янв-20, 12:34 
А не подскажет ли уважаемая публика - чем такой хелп как у сабжа генерят?
Не первый раз этот шаблон вижу. Это что-то похожее на dixygen?
Ответить | Правка | К родителю #18 | Наверх | Cообщить модератору

74. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +/
Сообщение от andrew (??), 10-Янв-20, 14:39 
sphinx-doc.org

Там в самом низу страницы мелким написано.

Ответить | Правка | Наверх | Cообщить модератору

16. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +1 +/
Сообщение от Аноним (3), 07-Янв-20, 13:30 
единственная плющка - в том чтобы можно было создавать бинари без зависимостей

скорости на самом деле не много прибавится т к используются те же механизмы для совместимости и libpython

Ответить | Правка | К родителю #8 | Наверх | Cообщить модератору

25. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +10 +/
Сообщение от Аноним84701 (ok), 07-Янв-20, 14:31 
> Пишут на пистоне, чтобы потом транслировать в C++?! Не проще сразу на C++ и не парить моск созданием костылей?

Писать на С++, чтобы потом транслировать в асм и машкод? 😕
Не проще сразу вбивать опкоды и не парить моск созданием костылей и лишних абстракций?

Ответить | Правка | К родителю #8 | Наверх | Cообщить модератору

50. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +1 +/
Сообщение от kai3341 (ok), 08-Янв-20, 01:01 
> Пишут на пистоне, чтобы потом транслировать в C++?! Не проще сразу на C++ и не парить моск созданием костылей?

Пишут на С++ чтобы транслировать в машинные коды?! Не проще ли сразу на машинных кодах и не парить моск созданием костылей?

Ответить | Правка | К родителю #8 | Наверх | Cообщить модератору

12. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +2 +/
Сообщение от Аноним (12), 07-Янв-20, 13:05 
Прощальные гастроли затянулись.
Ответить | Правка | Наверх | Cообщить модератору

13. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +/
Сообщение от iPony129412 (?), 07-Янв-20, 13:08 
Модераторы скрыли комментарий с ссылкой о состоянии в Debian пакетов, зависящих от Python 2.
Видать кто-то боится конкуренции альт линуксу 😮
Ну и ладно. А так в Ubuntu 20.04 посмотрел — из коробки 📦 уже не стоит.
Так что вперёд в будущее 👉
Ответить | Правка | Наверх | Cообщить модератору

15. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +/
Сообщение от Аноним (14), 07-Янв-20, 13:18 
Видать кое-кто так и не научился тыкать мышкой в ссылочки.

СКРЫТО Отмодерировано: ASKBOT, Форсирование: Наличие жалоб

Ответить | Правка | Наверх | Cообщить модератору

17. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +2 +/
Сообщение от iPony129412 (?), 07-Янв-20, 13:31 
Ну я понимаю, что багтрекер дебиана – это очень страшная вещь, но всё же странная реакция...
Ответить | Правка | Наверх | Cообщить модератору

19. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +/
Сообщение от Аноним (14), 07-Янв-20, 13:50 
Да вполне обычная реакция - набросил на модеров, оказался не прав и теперь старательно забалтывает исходный посыл.
Ответить | Правка | Наверх | Cообщить модератору

22. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +/
Сообщение от iPony129412 (?), 07-Янв-20, 14:23 
Ничего не понял, ну ладно...


Ответить | Правка | Наверх | Cообщить модератору

23. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +2 +/
Сообщение от Аноним (23), 07-Янв-20, 14:25 
Этош ипоня чего ты от него хотел?
Ответить | Правка | К родителю #19 | Наверх | Cообщить модератору

29. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +2 +/
Сообщение от Аноним (14), 07-Янв-20, 14:51 
Ну да... труд создал из обезьяны человека, а из лошади транспорт.
Ответить | Правка | Наверх | Cообщить модератору

63. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +/
Сообщение от Browndoor (?), 08-Янв-20, 22:53 
Вы забыли в самом конце добавить эможи: 👌
Ответить | Правка | К родителю #13 | Наверх | Cообщить модератору

21. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +1 +/
Сообщение от Аноним (23), 07-Янв-20, 14:22 
На сколько я недавно узнал сабж не поддерживает PySide 2 по каким то своим внутренним идеологическим причинам. Ну и пошел он гулять заюзал pyinstaller как и всегда, для создания стендэлон аппликейшена.
Ответить | Правка | Наверх | Cообщить модератору

26. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +1 +/
Сообщение от Главный Ананим (ok), 07-Янв-20, 14:32 
Это лучшее что есть в этом направлении, если вы не используете юникод строки. По крайней мере для питон2.
Ответить | Правка | Наверх | Cообщить модератору

27. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +/
Сообщение от user90 (?), 07-Янв-20, 14:39 
Петон - это костыль для мозга)) Именно потому .. <можно подставить все, что угодно>. А уж сколько хромых ныне в кодинге не мне вам говорить.
Ответить | Правка | Наверх | Cообщить модератору

32. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +/
Сообщение от Anonymoustus (ok), 07-Янв-20, 17:39 
Пихтон прекрасный ЯП, если используется только для пресловутого прототипирования. Но поскольку незрелые умы используют его для написания «боевого» ПО — да, это таки рак.
Ответить | Правка | Наверх | Cообщить модератору

33. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +/
Сообщение от user90 (?), 07-Янв-20, 17:57 
Слова-то какие, г-спади! Но я пожалуй тупо выпью, ну не кодить же?
* Как можно считать нормальным йазык с    этими    отступами, аа?
Ответить | Правка | Наверх | Cообщить модератору

35. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +/
Сообщение от Anonymoustus (ok), 07-Янв-20, 18:06 
> * Как можно считать нормальным йазык с    этими  
>   отступами, аа?

Когда-то все языки (все 3,5) были с отступами. Отступы — наше всё!

Ответить | Правка | Наверх | Cообщить модератору

36. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +/
Сообщение от user90 (?), 07-Янв-20, 18:29 
А кому-то - скобки нопример!
Ответить | Правка | Наверх | Cообщить модератору

41. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  –1 +/
Сообщение от Оно Ним (?), 07-Янв-20, 19:32 
> * Как можно считать нормальным йазык с    этими    отступами, аа?

Чисто читаемый. Сравнивая со "скобочными".

Трудности с самодисциплиной?? А тогда не надо нам путанного и неряшливого кода от таких.

Ответить | Правка | К родителю #33 | Наверх | Cообщить модератору

42. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +/
Сообщение от user90 (?), 07-Янв-20, 19:53 
А это зависит уже от редактора кода, амиго. Ты надеюсь не про блокнот (бумажный или вендовый)?

> Трудности с самодисциплиной??

Просто_неприятно.

Ответить | Правка | Наверх | Cообщить модератору

57. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +/
Сообщение от Аноним (8), 08-Янв-20, 12:17 
>Пихтон прекрасный ЯП, если используется только для пресловутого прототипирования

Ну, в его "нишу" еще можно приписать небольшие скрипты для автоматизации сисадминов или использование как "язык-клей", когда легкая оболочка "дергает" высокопроизводительные либы.

Ответить | Правка | К родителю #32 | Наверх | Cообщить модератору

77. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +/
Сообщение от Аноним (76), 13-Янв-20, 19:43 
Вебня на питоне отлично пишется в разумные сроки.
Ответить | Правка | Наверх | Cообщить модератору

52. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  –5 +/
Сообщение от Аноним ещё один (?), 08-Янв-20, 04:53 
Ты даже в русском языке хромой, молчал бы лучше.
Ответить | Правка | К родителю #27 | Наверх | Cообщить модератору

31. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +/
Сообщение от Anonymoustus (ok), 07-Янв-20, 17:34 
> Прекращение поддержки Python 2.7 перенесено на апрель

Чото ржу. :) А с каким пафосом били себя в грудь!

Ответить | Правка | Наверх | Cообщить модератору

45. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +1 +/
Сообщение от Аноним (-), 07-Янв-20, 22:26 
А смысл отказываться? 3.8, почти наверняка, никуда внедряться не будет. И дальнейшее развитие питона как языка, тоже под большим вопросом.
Ответить | Правка | Наверх | Cообщить модератору

53. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  –10 +/
Сообщение от Аноним ещё один (?), 08-Янв-20, 04:54 
Под большим вопросом состояние твоей психики.
Ответить | Правка | Наверх | Cообщить модератору

60. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +/
Сообщение от Аноним (60), 08-Янв-20, 14:31 
Проекты типа Octoprint плотно сидят на 2.7. И, скорее, перейдут на Go, чем на питон 3.
Ответить | Правка | К родителю #31 | Наверх | Cообщить модератору

64. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +/
Сообщение от Аноним (64), 08-Янв-20, 22:58 
А что это такое? Сколько у него пользователей? Где посмотреть исходники?
Ответить | Правка | Наверх | Cообщить модератору

65. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +/
Сообщение от пофигу (?), 09-Янв-20, 01:10 
Для тех, кого в гугле забанили -

1. https://octoprint.org/ : The snappy web interface for your 3D printer.
2. }{3
3. https://github.com/foosel/OctoPrint

Ответить | Правка | Наверх | Cообщить модератору

66. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +/
Сообщение от Аноним (66), 09-Янв-20, 03:49 
а их багтрекер говорит об ином
https://github.com/foosel/OctoPrint/issues/2722#issuecomment...
Ответить | Правка | К родителю #60 | Наверх | Cообщить модератору

67. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +/
Сообщение от Аноним (-), 09-Янв-20, 08:22 
У них прикол в том, что идея сделать управление 3d принтером на питоне работала, пока принтеры были медленными. Сейчас же, для того, чтобы оно хоть как-то работало, они требуют самые свежие платы RaspberryPi, при том, что реально вычислительная нагрузка почти никакая. Проклятье питона в действии.....
Ответить | Правка | Наверх | Cообщить модератору

68. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +/
Сообщение от Аноним (14), 09-Янв-20, 08:34 
Это что, если случайно запустить что-то (например, распаковку архива) параллельно, может поплыть печать?
Ответить | Правка | Наверх | Cообщить модератору

69. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +1 +/
Сообщение от Аноним (69), 09-Янв-20, 11:26 
Оно выдаёт команды принтеру в реальном времени. Команды там типа типа сделать столько-то шагов по оси такой-то, выдавив филамент на столько-то шагов (управление везде шаговыми двигателями). При этом надо понимать, что филамент после выдавливания должен охлажаться. На него дует поток с вентиляторов. Соответственно, можем получить неоднородности в скорости охлаждения и склейки слоёв, если команда на перемещение не была выдана вовремя. Ну и, чистая потеря времени. Принтер может печатать быстрее, чем octaprint выдавать команды.

Бинарные, но, к сожалению, закрытые программы управления типа https://www.astroprint.com/download-3d-printer-software работают на куда более слабом железе.

Ответить | Правка | Наверх | Cообщить модератору

70. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +/
Сообщение от Аноним (14), 09-Янв-20, 11:44 
Спасибо за разъяснения. Смысл проблемы понятен, не мог представить, что кто-то допускает такое.
Ответить | Правка | Наверх | Cообщить модератору

38. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +3 +/
Сообщение от Аноним (38), 07-Янв-20, 18:40 
> обеспечена совместимость с библиотеками и приложениями sklearn, osgeo, gdal, dill, scikit-image, skimage, weasyprint, dask, pendulum, pytz и pytzdata

Ну, pytzdata

Ответить | Правка | Наверх | Cообщить модератору

75. "Выпуск компилятора Nuitka 0.6.6. Прекращение поддержки Pytho..."  +/
Сообщение от Ан оНим (?), 11-Янв-20, 12:59 
Вот уж почти смешно. Убило вот такое отношение, прилетело нынче в обновлениях:

"Чувак, мне пофек, я заменил в своей либе язык и не меняю ни название ни версию либы, совместимость у тебя теперь сломана и потеряна, а ты поменяешь свои скрипты, не развалишся."


apt-listchanges: News
---------------------

libplist (2.0.1~git20190921.6a53de9-1) unstable; urgency=medium

  This package version drops the python-plist package with Python 2 bindings
  and replace it with python3-plist package with Python 3 bindings.
  .
  If you use plist in Python 2 scripts you will have to port those scripts to
  Python 3.

-- Yves-Alexis Perez <corsac@debian.org>  Tue, 24 Sep 2019 08:43:45 +0200


Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру