The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"OpenNews: Близится прекращение поддержки FreeBSD 4.11, 5.3, ..."
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Разговоры, обсуждение новостей (Public)
Изначальное сообщение [Проследить за развитием треда]

"OpenNews: Близится прекращение поддержки FreeBSD 4.11, 5.3, ..."  
Сообщение от opennews on 13-Окт-06, 08:57 
В ближайшем будущем состоится (http://lists.freebsd.org/pipermail/freebsd-security/2006-October/004045.html) окончание жизненного цикла 4.11, 5.3, 5.4, 6.0 релизов FreeBSD.


В первую очередь это ударит по системам с эксплуатируемой в большом количестве по всему миру ветвью RELENG_4/RELENG_4_11, снискавшей популярность как производительное решение, и традиционно используемой в телекоммуникационной среде в качестве серверов DNS, роутеров, межсетевых экранов и т.д.


Скорое прекращение официальной поддержки 4й ветви связано в т.ч. как со всё возрастающим количеством несовместимых, "сломанных" (BROKEN) портов, большей сложностью бекпортирования кода, так и с ослаблением интереса со стороны разработчиков и концентрацией на активном развитии текущей ветви.


В ответ за возникший протест коммьюнити оставить хотя бы ограниченную поддержку в форме обновлений безопасности, последней было предложено сопровождать RELENG_4 после EoL своими силами.


Поддержка RELENG_4  и RELENG_4_11 прекражается 31 января 2007 года, RELENG_6_1, RELENG_5  и RELENG_5_5 - 31 мая 2008 года, RELENG_5_3 и RELENG_5_4 - 31 октября 2006 г.


URL: http://lists.freebsd.org/pipermail/freebsd-security/2006-October/004045.html
Новость: https://www.opennet.ru/opennews/art.shtml?num=8521

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени, UBB]


4. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от medik on 13-Окт-06, 09:44 
А 4.11 всё равно жалко...
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

16. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от Квагга on 13-Окт-06, 12:22 
>А 4.11 всё равно жалко...
Не жалко ни капельки. Поставьте 6.1 и почувствуйте разницу.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от gvf on 13-Окт-06, 10:06 
4.5 было жалко, а 4.11 совсем нет.
Какой смысл поддерживать 5.х если есть 6.х ??? 5-ка совсем сырая была...
Любителям 4.х: ну и оставайтесь на 4-ке, кто вам мешает? В случае нормально
настроенной системы секурность вполне обеспечена. Проблемы в самой системе (не требующие локального юзера) я уже не помню когда находили.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от McLaud on 13-Окт-06, 10:37 
Согласен
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

32. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от Аноним on 13-Окт-06, 19:45 
Чем же 4.5 была так хороша?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

10. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от Lakon (??) on 13-Окт-06, 10:41 
точно. 4.11 жалко
очень нравится. как танк работает.
в общем на 6-ую постепенно мигрирую.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

11. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от prox email on 13-Окт-06, 10:46 
Господа, поделитесь плиз инфой, у меня есть пара статеек о том как перелазить со старой ветки на новую на машинке с критичным сервисом, я бы хотел опубликовать...
куда засылать её, на какой адрес?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

18. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от дринк on 13-Окт-06, 14:34 
на wiki.bsdportal.ru публикуй
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

19. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от Maxim Chirkov email(ok) on 13-Окт-06, 14:50 
>Господа, поделитесь плиз инфой, у меня есть пара статеек о том как
>перелазить со старой ветки на новую на машинке с критичным сервисом,
>я бы хотел опубликовать...
>куда засылать её, на какой адрес?

Внизу каждой страницы сайта есть ссылка "Добавить", далее нужно выбрать "Опубликовать статью" (https://www.opennet.ru/announce_art.shtml).
Другие варианты: прислать мне на email или опубликовать в http://wiki.opennet.ru

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

12. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от rolano (??) on 13-Окт-06, 10:54 
Давайте еще порассуждаем как плохо прекращать работы над ядрами Линуха 2.0.х. Или над Постфиксом 1.х. Прогресс не стоит на месте, выходят новые релизы. Кто не хочет, тот может вообще сидеть себе на DOS - маленькая система, где можно все ошибки выявить.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

17. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от KonstantinK email(??) on 13-Окт-06, 13:56 
Давайте.
Первый коммерческий RedHat (RHEL2.1) до сих пор поддерживается.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

21. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от kruk on 13-Окт-06, 14:54 
Обратите внимание на ключевое слово "коммерческий". RH поддержку продаёт, пока её покупают. FBSD team в общем-то делает ОС, а не поддержку.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

22. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от nuclight email on 13-Окт-06, 14:59 
Это сторонняя контора. Которая осуществляет КОММЕРЧЕСКУЮ поддержку. А основные разработчики ядро 2.2 давно не поддерживают. Чуете аналогию? Здесь коммунити тоже было предложено поддерживать самостоятельно, т.е. в принципе любая коммерческая контора может это сделать, ежели заплатят.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

13. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от pr0r0k_d email(??) on 13-Окт-06, 11:08 
а 6-тую ветку зачем прекращать, то?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

14. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от cvsup on 13-Окт-06, 11:14 
Согласно политике release cycle, срок поддержки - 2 года с момента последнего релиза. Что соответственно и отражено как для RELENG_6_1 так и других ветвей.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

20. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от Осторожный on 13-Окт-06, 14:52 
Один сервак стоит под FreeBSD 4.11
Как выйдет FreeBSD 6.2 - так поставлю и проблема отпадет.

А то что есть проблемы с портами на 4.11 - это факт !

Насчет супер-стабильности 6.1 - не верю, стоит почитать что пофиксили в 6.2.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

24. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от Sergey (??) on 13-Окт-06, 15:20 
Ну и переходи на 6.2 тогда. Правда когда выйдет. А 6.1 еще поддерживается и sa для нее выходят. Зачем паниковать?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

42. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от Осторожный on 14-Окт-06, 14:19 
До 6.2 осталось меньше месяца.
А пока все крутится на FreeBSD 5.5
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

67. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от Валентин. on 17-Окт-06, 13:01 
>Насчет супер-стабильности 6.1 - не верю, стоит почитать что пофиксили в 6.2.

http://milw0rm.com/exploits/2542
http://milw0rm.com/exploits/2541


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

25. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от Валентин. on 13-Окт-06, 16:28 
4.11 - супер.
Тоже очень нравится. как танк работает.
Что делать не знаю.
5-ка мура.
6- ?

Всё время начинал пробовать с Х.3 а в работу где-то с Х.5(хотя-бы, а то и 7).
И ни разу не мучаясь, и не в ущерб работе.
И с 2.Х так уходил и с 3.Х . А с 4-ки :(

Придётся слушать пайонеров :)
И становится бесплатным тестером:)

А как всё хорошо шло - одним рюшечки , другим - работа и все били довольны.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

27. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от dawnshade email on 13-Окт-06, 17:28 
>
>Придётся слушать пайонеров :)
>И становится бесплатным тестером:)

никто не держит - либо уходите на тот же рхел с такой позицией, либо создайте/наймите профессиональную фирму которая занимается тестированием и которой вы готовы оплатить такую услугу.
а так чтоб на чужом х;ю въехать в рай (другие оттестят, а я буду ставить в продакшн) не получится.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

26. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от necotyan email(??) on 13-Окт-06, 17:08 
Это у только у меня deco в 6.1 собранная работает в 6.1, а на 6.2-пре падает в корку?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

28. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от gvf on 13-Окт-06, 18:13 
ага.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

29. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от developer (??) on 13-Окт-06, 18:27 
лажа 6.X
5.4 из всех 5 самая нормальная - остальные глючные
4 просто уже свое отжила
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

35. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от creativ (??) on 13-Окт-06, 21:52 
>лажа 6.X
>5.4 из всех 5 самая нормальная - остальные глючные
>4 просто уже свое отжила

Все бред кроме "4 просто уже свое отжила". Почему это 6.х лажа?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

30. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от Аноним on 13-Окт-06, 18:43 
4.11 не жалко. Сколько времени уходит чтобы свои порты под нее подогнать. Хотя то, что она еще широко используется - факт, к сожалению.
5.x ветка вообще недоразумение, в выпуске 5.5 не было ни какого смысла. Так что long live 6.x, и быстрой смерти когда выйдет 7.x
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

31. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от mikle email(??) on 13-Окт-06, 19:13 
Жалко 4.11. У меня 4.3 ставил предыдущий админ еще в 2002-м. До сих пор пашет (обновленная до 4.11). На ней столько уже наворочено, что переходить на 6.2 - все равно, что всемирную революцию устравивать :-)
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

34. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от Квагга on 13-Окт-06, 21:43 
> всемирную революцию устравивать???

buildworld, что-ли???

Накатывается на пятерку, а с пятерки на 6.1 сама, как астролябия О.Бендера! Было бы что накатывать, как говорится!

Ровно тот же процесс, что с 4.8 на 4.11.

Тем более, что порты порушены безвозвратно изменением в base системе.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

41. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от Осторожный on 14-Окт-06, 14:17 
При переходе с 5-ки на 6-ку ВСЕ ПОРТЫ нужно пересобирать !

Так что если хочеть обновить с 4.11 до 6.2 - то IMHO лучше clean install

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

43. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от dawnshade email on 14-Окт-06, 15:34 
>При переходе с 5-ки на 6-ку ВСЕ ПОРТЫ нужно пересобирать !

сказки не рассказывайте. не умеете пользоваться misc/compat5x не рассуждайте.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

48. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от Осторожный on 15-Окт-06, 11:08 
>>При переходе с 5-ки на 6-ку ВСЕ ПОРТЫ нужно пересобирать !
>
>сказки не рассказывайте. не умеете пользоваться misc/compat5x не рассуждайте.

Почитай /usr/src/UPDATING ...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

50. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от dawnshade email on 15-Окт-06, 12:03 
>>>При переходе с 5-ки на 6-ку ВСЕ ПОРТЫ нужно пересобирать !
>>
>>сказки не рассказывайте. не умеете пользоваться misc/compat5x не рассуждайте.
>
>Почитай /usr/src/UPDATING ...


И?


        [8] In order to have a kernel that can run the 5.x binaries
        needed to do an installworld, you must include the COMPAT_FREEBSD5
        option in your kernel.  Failure to do so may leave you with a system
        that is hard to boot to recover. A similar kernel option COMPAT_FREEBSD5
        is required to run the 5.x binaries on more recent kernels.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

56. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от mar email(??) on 16-Окт-06, 00:29 
>> всемирную революцию устравивать???
>
>buildworld, что-ли???
>
>Накатывается на пятерку, а с пятерки на 6.1 сама, как астролябия О.Бендера!
>Было бы что накатывать, как говорится!
>
>Ровно тот же процесс, что с 4.8 на 4.11.
>
>Тем более, что порты порушены безвозвратно изменением в base системе.
если мне не изменяет память, с 4 на 5 просто так не накатить, проще переставить. С 5 на 6, да там принципиальные вещи не менялись

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

74. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от Sem (??) on 18-Окт-06, 15:30 
>>> всемирную революцию устравивать???
>>
>>buildworld, что-ли???
>>
>>Накатывается на пятерку, а с пятерки на 6.1 сама, как астролябия О.Бендера!
>>Было бы что накатывать, как говорится!
>>
>>Ровно тот же процесс, что с 4.8 на 4.11.
>>
>>Тем более, что порты порушены безвозвратно изменением в base системе.
>если мне не изменяет память, с 4 на 5 просто так не
>накатить, проще переставить. С 5 на 6, да там принципиальные вещи
>не менялись


Не просто, но есть инструкция. Следуя ей все достаточно гладко проходит.
http://www.freebsd.org/releases/5.3R/migration-guide.html

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

60. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от oops on 16-Окт-06, 09:05 
>Накатывается на пятерку, а с пятерки на 6.1 сама, как астролябия О.Бендера!
>Было бы что накатывать, как говорится!
>Ровно тот же процесс, что с 4.8 на 4.11.

Насколько я помню официально переход 4.Х -> 5.Х не поддерживается. т.к. было много чего порушено

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

71. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от Rakshas on 18-Окт-06, 11:44 
>>Накатывается на пятерку, а с пятерки на 6.1 сама, как астролябия О.Бендера!
>>Было бы что накатывать, как говорится!
>>Ровно тот же процесс, что с 4.8 на 4.11.
>
>Насколько я помню официально переход 4.Х -> 5.Х не поддерживается. т.к. было много чего порушено


Нет было. на freebsd.org даже документ был. По крайней мере я переводил. Перевелось нормально. Были заморочки но все решаемо....

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

72. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от Rakshas on 18-Окт-06, 11:57 
>>Накатывается на пятерку, а с пятерки на 6.1 сама, как астролябия О.Бендера!
>>Было бы что накатывать, как говорится!
>>Ровно тот же процесс, что с 4.8 на 4.11.
>
>Насколько я помню официально переход 4.Х -> 5.Х не поддерживается. т.к. было много чего поруше

Дополнение
http://www.freebsd.org/releases/5.3R/migration-guide.html


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

40. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от Осторожный on 14-Окт-06, 14:15 
Full backup
Чистая установка 6.2
Потом аккуратно водружается все обратно

Если критично время простоя сервера и нет опыта работы на 6.x
- сначала лучше поставить на тестовом компе 6.2
попробовать, поработать с системой - изучить
а потом уже обновлять с 4.x на 6.2

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

33. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от pavlinux email(??) on 13-Окт-06, 20:49 
Ну вы и так знаете, что я скажу...
Близится день страшного суда, для BSD как что-то напоминающее OS
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

47. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от L.Torvalds on 15-Окт-06, 04:48 
>Ну вы и так знаете, что я скажу...
>Близится день страшного суда, для BSD как что-то напоминающее OS
>

Ну на то и тролли чтоб вонять :)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

36. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от RomanN on 13-Окт-06, 22:24 
4-ка была хороша
Но....
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

37. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от Andrew Kolchoogin on 13-Окт-06, 22:34 
На настоящий момент у RELENG_4 есть _ровно одно_ преимущество перед RELENG_6: производительность на UP-системах.
Что уж тут поделать, такова нелёгкая судьба IT'шника: старое оборудование нужно выкидывать. А на новом оборудовании "провал" производительности RELENG_6 уже незаметен.
А что касается стабильности, то 6.1-p10 работает у меня на "живых" серверах без нареканий на стабильность. От пяти до восьми jail'ов на каждой, 700-800 мегабайт физического ОЗУ в Active (под полтыщщи процессов на каждой), сервисов до матери, всё нормально, ничего никуда не падает.
RELENG_4 -- это, конечно, образец OS'остроения, никогда у FreeBSD не было столько релизов из одного бранча, стабильность дай боже, и с поддержкой оборудования всё великолепно, но, скажу честно, без nss_ldap мне уже операционные системы неинтересны. IPSec NAT Traversal бэкпортить под RELENG_4 мне тоже не хочется.
Так что придётся RELENG_4 списать ввиду морального устаревания. :)
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

38. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от Skif (??) on 14-Окт-06, 02:22 
>Так что придётся RELENG_4 списать ввиду морального устаревания
Слова не мальчика, но мужа.
4-ку жаль, но зависать на ней только потому что жаль - глупо.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

39. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от ТинПу on 14-Окт-06, 12:06 
Amen! (Т.е. - Аминь!)
Вcе - так. 4-ка была хороша, сказка как хороша! Но жизнь - это движение. Мне _мрачно_ не нравилась 5-ка. Но _пришлось_ перегнать N машин на 5.4 ... работает но нет того чу_Й_ства изящности и непробиваемости как с 4-кой.
Начиная с 6.1 - снова поверил - все будет Ок! На линуксы пока ушли только официальные Oracle10gR2 боксы, подожду 6.2 и если udp в ней починят, останусь с FreeBSD! Томкаты снова на фряхе, а вот оракал :) похоже надолго будет под RHEL...
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

44. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от Аноним on 14-Окт-06, 20:18 
Друзья !

Подскажите пожалуйста статью где описываются особенности перехода с 4_ки на 6_ку
и возможные подводные камни. Есть 5 серверов физически расположенных за сотни км друг от друга и от меня. Сколько не тяну с переходом, а переходить придется.
Так, что пожалуйста выручайте!

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

49. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от Осторожный on 15-Окт-06, 11:16 
>Друзья !
>
>Подскажите пожалуйста статью где описываются особенности перехода с 4_ки на 6_ку
>и возможные подводные камни. Есть 5 серверов физически расположенных за сотни км
>друг от друга и от меня. Сколько не тяну с переходом,
>а переходить придется.
>Так, что пожалуйста выручайте!

А чем сервера-то занимаются ?

Вообщем если ты делал buildworld то не должно быть страшно
Если не делал - изучи !
Сначала обновление 4.11 -> 5.5
Потом обновление 5.5 -> 6.2 ( как выйдет разумеется )
Порты скорее всего придется пересобрать или установить новые пакеты

Подводные камни - ВНИМАТЕЛЬНО прочитать /usr/src/UPDATING, /usr/ports/UPDATING

Если страшно, то сначала потренируйся на сервере с 4.11 который под боком
Предварительно сделав full backup разумеется
Есле сервера под боком нету, то сначала сначала поставь себе 4.11 и потренируйся

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

76. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от zyxman on 22-Окт-06, 00:16 
я использую на работе FreeBSD еще с появления 2.1 (1996 год) и скажу что качество веток постоянно падает :(

я переходил с 4.6 на 5.4 а потом на RELENG_5 - потому что 5.4 еще была сыровата.
- RELENG_5 (брал с CVS прямо перед заморозкой 5.5pre) отличается от 5.4 почти как 5.4 от 4.6.
Да, у меня не enterprise, но на _единственном_ сервере крутится все - и роутер с почтой и биллинг и девелоперские проги (апач 1.3 и 2.0.55, несколько СУБД) и нестандартное (для сервака) железо - usb-bluetooth и BT848 (соответственно захват видео и т.п).
- переходить реально пришлось из-за того что в ветке 4 не было поддержки bluetooth, плюс хотелось попробовать netgraph.
реально в лице 5.4R получил сервак падающий несколько раз в день и только с RELENG_5 получил стабильность как 4.6 (но с нюансами от ng, требующими иногда перезагружать ядро), плюс приятные вкусности ipfw2 (самому понравилось, как организовал запуск зарубежного траффика в отдельный канал, то есть можно _очень_просто_ организовать source/service based routing, и очень здорово и _правильно_ работает ng_ipacct для подсчета траффика).
netgraph толком попользовать не удалось, потому что в 5 ветке есть косяк из-за которого невозможно сделать ipfw divert того что обрабатывает ng и ничего взамен и нет приличных примеров программинга ng.

в 6 ветке много чего поправили, даже добавили пару полезных вещей, но опять масса недоделок, например все еще нет нормального управления ограничением памяти и CPU для jail.

сказать что прийдется пересобрать все порты - ничего не сказать!
- я сделал "последнее прощай" _всем_ своим патчам, а с учетом что без "обработки напильником" под фрей много чего не собирается, я очень сомневаюсь в дальнейших перспективах FreeBSD, если решение о закрытии ветки 5 не будет изменено :(

Единственное, что действительно порадовало - система портов действительно работает весьма стабильно и неожиданности практически только положительные - типа когда порту нужен gcc 3.4 - оно для себя его ставит а остальное работает с общесистемным, но масса времени уходит на обновление дерева портов с CVS и кроме матерых apache/mysql на установку остального времени ушло как в первый раз :(

я наконец-то дождался нормального бесплатного эмулятора - QEMU и прикупил добавочной памяти, и это позволит мне какое-то время выжидать развития событий, поднимая какие-то сервисы в linux под QEMU, а если политика возобладает над здравым смыслом - буду полностью уходить с FreeBSD и уводить друзей :(

>>Друзья !
>>
>>Подскажите пожалуйста статью где описываются особенности перехода с 4_ки на 6_ку
>>и возможные подводные камни. Есть 5 серверов физически расположенных за сотни км
>>друг от друга и от меня. Сколько не тяну с переходом,
>>а переходить придется.
>>Так, что пожалуйста выручайте!
>
>А чем сервера-то занимаются ?
>
>Вообщем если ты делал buildworld то не должно быть страшно
>Если не делал - изучи !
>Сначала обновление 4.11 -> 5.5
>Потом обновление 5.5 -> 6.2 ( как выйдет разумеется )
>Порты скорее всего придется пересобрать или установить новые пакеты
>
>Подводные камни - ВНИМАТЕЛЬНО прочитать /usr/src/UPDATING, /usr/ports/UPDATING
>
>Если страшно, то сначала потренируйся на сервере с 4.11 который под боком
>
>Предварительно сделав full backup разумеется
>Есле сервера под боком нету, то сначала сначала поставь себе 4.11 и
>потренируйся


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

45. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от Аноним on 14-Окт-06, 20:52 
да что не говори а 4,11 - очень жаль остальные - так себе - сыроваты(идеи на бумаги которые ждут своего  часа),,,,,,, 4, - ветка это легенда а легенды не умирают,,,,,,,
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

46. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от gvf on 15-Окт-06, 00:50 
И 3-ка была легендой, а уж 2.2.8 какой была легендой.....
Даааа, было время.... :)
Ребят, не заморачивайтесь.
temporas mutambur,........
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

69. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от RedRat (??) on 17-Окт-06, 13:37 
>И 3-ка была легендой, а уж 2.2.8 какой была легендой.....

Не была 3-ка никакой легендой. Была она "недоразумением", как и 5-ка. Поэтому я с 2.2.8 сразу на 4.0 переходил.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

51. "OpenNews: Близится прекращение поддержки FreeBSD 4.11, 5.3, ..."  
Сообщение от cryptoson on 15-Окт-06, 13:04 
Жаль, кажется пришел конец фришке на моих серверах. Надоело уже buildkernel, buldworld, конфиги мержить. Все-таки apt-get distupgrade или yum upgrade на дштгч-сервере процедур куда менее трудоемкая и опасная (после тестов полюбому).
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

52. "OpenNews: Близится прекращение поддержки FreeBSD 4.11, 5.3, ..."  
Сообщение от Аноним on 15-Окт-06, 19:25 
>Жаль, кажется пришел конец фришке на моих серверах. Надоело уже buildkernel, buldworld,
>конфиги мержить. Все-таки apt-get distupgrade или yum upgrade на дштгч-сервере процедур
>куда менее трудоемкая и опасная (после тестов полюбому).

Скатертью дорога. Криворукие юзают винду, там все за вас сделают, да и конфигов-то собственно нету :)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

53. "OpenNews: Близится прекращение поддержки FreeBSD 4.11, 5.3, ..."  
Сообщение от pan_john on 15-Окт-06, 20:25 
У меня на шлюзе до сих пор 4.8 стоит. Ставилась в 2002 году летом. машинка очень очень старая. Тем не менее никакизх нареканий нет. Работает просто отлично.
После 5.3 я особо никакого отличия в 6.1 не заметил, так что 5.х можно свободно вычеркивать, а 4.х действительно жалко...


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

54. "OpenNews: Близится прекращение поддержки FreeBSD 4.11, 5.3, ..."  
Сообщение от uF0 on 15-Окт-06, 21:41 
> а 4.х действительно жалко...

Блин, ну что такое, кому жалко 4.x, те пожалуйста помогите проекту FreeBSD, помогите с поддержкой 4.x.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

55. "OpenNews: Близится прекращение поддержки FreeBSD 4.11, 5.3, ..."  
Сообщение от cryptoson on 16-Окт-06, 00:22 
>>
>Скатертью дорога. Криворукие юзают винду, там все за вас сделают, да и
>конфигов-то собственно нету :)
Апгрейд даже 5-ти серверов с FreeBSD пересборкой мира занимает довольно большое время. Куда быстрее проапгрейдить линух-сервера с локального зеркала и спать спокойно. В виндой последнее условие не соблюдается.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

57. "OpenNews: Близится прекращение поддержки FreeBSD 4.11, 5.3, ..."  
Сообщение от RedStalker_Mike (??) on 16-Окт-06, 00:52 
>>>
>>Скатертью дорога. Криворукие юзают винду, там все за вас сделают, да и
>>конфигов-то собственно нету :)
>Апгрейд даже 5-ти серверов с FreeBSD пересборкой мира занимает довольно большое время.
>Куда быстрее проапгрейдить линух-сервера с локального зеркала и спать спокойно. В
>виндой последнее условие не соблюдается.

Тут я не могу не согласиться. Даже те 5 серверов, которые мне рано или поздно придётся переводить на 6.Х, отнимут огромное количество времени, но никуда не деться.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

58. "OpenNews: Близится прекращение поддержки FreeBSD 4.11, 5.3, ..."  
Сообщение от wildcat (??) on 16-Окт-06, 03:34 

>Тут я не могу не согласиться. Даже те 5 серверов, которые мне
>рано или поздно придётся переводить на 6.Х, отнимут огромное количество времени,
>но никуда не деться.

У Вас или у Вашего сервера? :)
В моем случае cvsup-сервер локальный - значит все сервера (8шт.) обновились бы локально. Набрать команду на пересборку мира не намного дольше, чем в линексе ;) Правда, это все абстракно, т.к. все мои на 6.1. И не падают ;) Видимо, что-то не так делаю ;)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

59. "OpenNews: Близится прекращение поддержки FreeBSD 4.11, 5.3, ..."  
Сообщение от cryptoson on 16-Окт-06, 04:03 
Сама компиляции при апгрейде не нагружает. Вот mergemaster муторная процедура, да еще и чреватая сбоями после ребута системы при малейшей невнимательности, особенно если прыгать на другую ветку. Потом даже внимательно чтение UPDATING не всегда спасает. Был удивлен после апгрейда с 4-ки на 5-ку тем что перестал fwd работать в ipfw. Пока въехал в тему маршрутизатор уже на линухе заработал.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

61. "OpenNews: Близится прекращение поддержки FreeBSD 4.11, 5.3, ..."  
Сообщение от Осторожный on 16-Окт-06, 09:26 
>>Скатертью дорога. Криворукие юзают винду, там все за вас сделают, да и
>>конфигов-то собственно нету :)
>Апгрейд даже 5-ти серверов с FreeBSD пересборкой мира занимает довольно большое время.
>Куда быстрее проапгрейдить линух-сервера с локального зеркала и спать спокойно. В
>виндой последнее условие не соблюдается.

buildworld на Celeron 600 занимает полдня. Собственно запустить можно на всех 5 одновременно.
installworld и mergemaster - не больше часа на сервер.
Можно сделать buildworld на одном быстром компе, потом через NFS раздать /usr/src & /usr/obj. Потом останется только сделать installworld & mergemaster.

Все сильно зависит от того какой Linux и насколько старая там система. В свое время делал distupgrade AltLinux 2.2 -> 2.4 - не понравилось - остальные компы тупо проставил 2.4 c нуля.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

62. "OpenNews: Близится прекращение поддержки FreeBSD 4.11, 5.3, ..."  
Сообщение от cryptosonbian (??) on 16-Окт-06, 13:41 
Так в Альте же apt-rpm, до родного дебовского ему как до луны пешком. Но все равно даже так лучше чем во фришке.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

63. "OpenNews: Близится прекращение поддержки FreeBSD 4.11, 5.3, ..."  
Сообщение от uF0 on 16-Окт-06, 13:50 
> Но все равно даже так лучше чем во фришке.

Я не пойму чего лучше, вообще если перелизать с 4.x, то да, будет работы достаточно.
Но если делать во FreeBSD просто апдейт на новый релиз скажем из шестой ветки то можно а) поставить бинарный апдейт б) собрать всё на своих машинах при помощи distcc, и потом по nfs раздать, это получиться довольно быстро если скажем 5 одинаковых сервеов с одинаковым релизом и тд и тп...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

64. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от Аноним on 16-Окт-06, 14:59 
жаль, похоронили хороший проект
6.1 компилирует сильно кастрированное ядро на cel 1,13 512Mb чуть меньше 3х часов... тормоз =(
четвёрка на той же машине - около 10 минут
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

68. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от CrazyF email on 17-Окт-06, 13:19 
>жаль, похоронили хороший проект
>6.1 компилирует сильно кастрированное ядро на cel 1,13 512Mb чуть меньше 3х
>часов... тормоз =(
>четвёрка на той же машине - около 10 минут
ЛОЖЬ! 5-8 минут и никаких гвоздей :)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

75. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от Sergey (??) on 20-Окт-06, 17:13 
Сдается что время 5-8 или 10 минут возникает за счет того что, не стерты уже откомпилированные сорцы с момента последнего компилирования ядра. Сотрите конфигурацию и пересоздайте ее заново и удалите /usr/obj. Время полной компиляции заметно увеличивается.
Для примера: полная компиляция 6.1 на Athlon64 3200 занимает минут 10-15 уже не помню точно:( Зато если если конфигурацию не стирать, а просто обновить сорцы ядра через cvsup и перекомпилить ядро, то на эту операцию уйдет времени не более 5 минут.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

79. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от CrazyF email on 07-Ноя-06, 14:17 
>Сдается что время 5-8 или 10 минут возникает за счет того что,
>не стерты уже откомпилированные сорцы с момента последнего компилирования ядра. Сотрите
>конфигурацию и пересоздайте ее заново и удалите /usr/obj. Время полной компиляции
>заметно увеличивается.
>Для примера: полная компиляция 6.1 на Athlon64 3200 занимает минут 10-15 уже
>не помню точно:( Зато если если конфигурацию не стирать, а просто
>обновить сорцы ядра через cvsup и перекомпилить ядро, то на эту
>операцию уйдет времени не более 5 минут.
Абсолютно монопесуально

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

65. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от soko1 email(??) on 16-Окт-06, 15:46 
да уж, ну и новость. у нас тут почти все на 4-ке работает=((((((
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

66. "Близится прекращение поддержки FreeBSD 4.11, 5.3, 5.4, 6.0"  
Сообщение от uF0 on 16-Окт-06, 17:19 
Все те которые так мило продолжают плакать о 4-ке, ответьте на два вопроса:
Что вы сделали для проекта FreeBSD?
И как вы собираетесь поддержать проект FreeBSD для того чтобы суппорт четвёртой версии всё ещё был?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

73. "FreeBSD 4.x EoL"  
Сообщение от cvsup email on 18-Окт-06, 15:30 
http://lists.freebsd.org/pipermail/freebsd-security/2006-October/004111.html
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

80. "OpenNews: Близится прекращение поддержки FreeBSD 4.11, 5.3, ..."  
Сообщение от qwe (??) on 14-Дек-06, 20:14 
мдя...народ посоветуйте плз,
С FreeBSD дело никогда раньше не имел но недавно поднял firewall на 6.1 сейчас перечитываю кучу доков по security.
Но после прочтения данной статейки задумался...может лучше на Debian ili ALT перейти?
З.Ы.
Только очень прошу не надо высказываний типа "ламо оставайся на винде..." все вы когда-то начинали;)
Спасибо.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру