The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"OpenNews: В состав 2.6.28 Linux ядра принята подсистема GEM ..."
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Разговоры, обсуждение новостей (Public)
Изначальное сообщение [ Отслеживать ]

"OpenNews: В состав 2.6.28 Linux ядра принята подсистема GEM ..."  
Сообщение от opennews on 17-Окт-08, 09:55 
"GEM Patches Submitted For Linux 2.6.28-rc1 (http://www.phoronix.com/scan.php?page=news_item&px=Njc4OQ)" - в состав 2.6.28 Linux ядра принята подсистема GEM (Graphics Execution Manager), разработанная компанией Intel и предназначенная для низкоуровневого взаимодействия с GPU (DRM модуль для управления памятью, переключению видеорежимов). GEM также позволяет организовать совместный одновременный доступ нескольких приложений к видеокарте (представлено специальное GEM API).


При использовании GEM с видеокартами Intel i915 было отмечено увеличение производительность игры OpenArena примерно на 50%, скорость выполнения glxgears тестов выросла на 60%.

URL: http://www.phoronix.com/scan.php?page=news_item&px=Njc4OQ
Новость: https://www.opennet.ru/opennews/art.shtml?num=18459

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


2. "Релиз драйвера ATI Catalyst 8.10. GEM одобрен для включения ..."  
Сообщение от VecH email(??) on 17-Окт-08, 10:40 
В заголовке между
> 10.

и
>  GEM

вставьте "а также"
я чуть не родил, думал капец, дрова каталиста в ядро запихали :)))

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "Релиз драйвера ATI Catalyst 8.10. GEM одобрен для включения ..."  
Сообщение от Аноним (??) on 17-Окт-08, 11:23 
В Arch до сих пор не обновили xorg до 7.4 (лежит уже несколько недель в testing). Они ведь ни этих дров ждали?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

12. "GEM одобрен для включения в Linux ядро 2.6.28. Релиз драйвер..."  
Сообщение от avb (??) on 17-Окт-08, 12:44 
>В новой версии реализована возможность работы с X.Org 7.4 /X Server 1.5

Поправка. 8.10 поддерживает X Server 1.5 только для пользователей Убунту, поставивших его из репозиториев Убунту же. Остальные ждут 8.11

Оригинал с фороникса
To all of the e-mails and forum posts we've come across in the past day, no, this public driver doesn't support X Server 1.5. Non-Ubuntu users will either need to wait for Catalyst 8.11 next month or install Catalyst 8.10 but then extract the fglrx 8.54.3 Ubuntu package and copy over the binary driver components.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

13. "GEM одобрен для включения в Linux ядро 2.6.28. Релиз драйвер..."  
Сообщение от Аноним (??) on 17-Окт-08, 12:57 
ОФИЦИАЛЬНО драйвера НЕ поддерживают 1.5. Не пишите ерунду.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

14. "GEM одобрен для включения в Linux ядро 2.6.28. Релиз драйвер..."  
Сообщение от User294 (ok) on 17-Окт-08, 13:54 
> #  Крах X-сервера после нескольких логаутах пользовтеля;

Автор!За новость спасибо.Но вот что вам хочется сказать по поводу выделенного предложения: в русском языке в отличие от английского есть еще такая штука - падежи.Их при построении фразы хорошо бы согласовывать.А то получается что-то типа "моя твоя не понимать" :).И грамматика хромает (пользовАтеля).Уделить пару минуток до постинга статьи ее проверке все-таки не зазорно, а?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

15. "GEM одобрен для включения в Linux ядро 2.6.28. Релиз драйвер..."  
Сообщение от Аноним (??) on 17-Окт-08, 14:27 
Я составлял пару-тройку новостей для opennet. Могу сказать, что это не так уж и просто (хотя со стороны кажется, что работы на пару минут). У меня уходило где-то 20-30 минут на одну новость (перевод + уточнение некоторых терминов в словаре или википедии + переписывание на русском + проверка своего творчества). И всё равно, некоторых ляпов избежать не удавалось. Так что, к авторам новостей нужно относится более благосклонно.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

26. "GEM одобрен для включения в Linux ядро 2.6.28. Релиз драйвер..."  
Сообщение от User294 (ok) on 21-Окт-08, 21:22 
>Я составлял пару-тройку новостей для opennet. Могу сказать, что это не так
>уж и просто (хотя со стороны кажется, что работы на пару
>минут).

А вы иногда обращайте внимание на то кто автор новостей до того как рассказывать что и как, ага?Тогда узнаете для себя немало нового.Например, что я тоже умею постить новости ;).

>Так что, к авторам новостей нужно относится более благосклонно.

Ну да, дождешься, как же.Покритиковать всегда найдут за что.Порой даже будут правы :).
И все-таки я считаю что перечитать новость до нажатия кнопочки отсылки новости чтобы отловить режущие глаз ляпы - не зазорно.Качественно написаные новости - один из признаков серьезного хорошего ресурса.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

17. "GEM одобрен для включения в Linux ядро 2.6.28. Релиз драйвер..."  
Сообщение от pavlinux (ok) on 17-Окт-08, 17:03 
А вы видели патч 2.6.27.1
За это морду бить надо -

config DYNAMIC_FTRACE
- bool "enable/disable ftrace tracepoints dynamically"
+ bool "enable/disable ftrace tracepoints dynamically (BROKEN)"
+ depends on BROKEN
depends on FTRACE
depends on HAVE_DYNAMIC_FTRACE
default y


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

21. "GEM одобрен для включения в Linux ядро 2.6.28. Релиз драйвер..."  
Сообщение от Аноним (??) on 17-Окт-08, 21:32 
Лишь повод дай...
А что не предложил своего решения? Интеловцы бились бились над решением. так и не нашли его. Вместо этого сказали что одна из новых фич сломана...
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

22. "GEM одобрен для включения в Linux ядро 2.6.28. Релиз драйвер..."  
Сообщение от Аноним (??) on 17-Окт-08, 21:38 
>Лишь повод дай...
>А что не предложил своего решения? Интеловцы бились бились над решением. так
>и не нашли его. Вместо этого сказали что одна из новых
>фич сломана...

сказано ведь:
disable CONFIG_DYNAMIC_FTRACE due to possible memory corruption on module unload

при выгрузке модуля повреждается память при включённом фтрасе, значит виноват фтрасе а не интел.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

23. "OpenNews: В состав 2.6.28 Linux ядра принята подсистема GEM ..."  
Сообщение от wanderlust on 19-Окт-08, 13:49 
Eagle:/usr/src/modules/fglrx# make
make -C /lib/modules/2.6.27-rc9-dv5-1004nr/build SUBDIRS=/usr/src/modules/fglrx modules
make[1]: Вхожу у каталог "/usr/src/dv5temp/linux-2.6.27-rc9"
  CC [M]  /usr/src/modules/fglrx/firegl_public.o
/usr/src/modules/fglrx/firegl_public.c: In function ‘__ke_vm_phys_addr_str’:
/usr/src/modules/fglrx/firegl_public.c:3522: warning: return makes pointer from integer without a cast
/usr/src/modules/fglrx/firegl_public.c:3523: warning: return makes pointer from integer without a cast
/usr/src/modules/fglrx/firegl_public.c:3524: warning: return makes pointer from integer without a cast
/usr/src/modules/fglrx/firegl_public.c:3526: warning: return makes pointer from integer without a cast
/usr/src/modules/fglrx/firegl_public.c: In function ‘KCL_enable_pat’:
/usr/src/modules/fglrx/firegl_public.c:4063: error: too many arguments to function ‘smp_call_function’
/usr/src/modules/fglrx/firegl_public.c: In function ‘KCL_disable_pat’:
/usr/src/modules/fglrx/firegl_public.c:4082: error: too many arguments to function ‘smp_call_function’
/usr/src/modules/fglrx/firegl_public.c: At top level:
/usr/src/modules/fglrx/firegl_public.c:5774: warning: initialization from incompatible pointer type
/usr/src/modules/fglrx/firegl_public.c:5800: warning: initialization from incompatible pointer type
make[2]: *** [/usr/src/modules/fglrx/firegl_public.o] Помилка 1
make[1]: *** [_module_/usr/src/modules/fglrx] Помилка 2
make[1]: Залишаю каталог "/usr/src/dv5temp/linux-2.6.27-rc9"
make: *** [kmod_build] Помилка 2


Одним словом поддержки 2.6.27 нету :) Поправьте пожалуйста :)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

25. "OpenNews: В состав 2.6.28 Linux ядра принята подсистема GEM ..."  
Сообщение от steepf (ok) on 21-Окт-08, 21:09 
>Одним словом поддержки 2.6.27 нету :) Поправьте пожалуйста :)

Открываешь файл /usr/src/modules/fglrx/firegl_public.c идешь на строчку 4063
там будет функция ‘smp_call_function’
третий параметр удаляешь! точно также поступаешь и со вторым ЕГОРОМ.
пробуешь компилить опять.ети две ошиьки пропадут
PS;для интересующихся. кернел выпустили а разработчики софта не успевают за ними.
если посмотреть обе функции (в ядре 2.6.26 и в 2.6.27) то в последнем отсутствует третий параметр- разработчики его чета выкинули. или так сказать упустили. у меня щас самое новое ядро 2.6.27.2 и самые новые дрова ATI Catalyst™ 8.10 все поет

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

24. "GEM одобрен для включения в Linux ядро 2.6.28. Релиз драйвер"  
Сообщение от Spiker on 19-Окт-08, 22:17 
Спасибо за новость.Првда предложения странно построены ,можно и необрощать внимания , новость того стоит ).
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру