The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Вышел релиз языка программирования Ruby 1.8.7 и фреймворка R..."
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Разговоры, обсуждение новостей (Public)
Изначальное сообщение [ Отслеживать ]

"Вышел релиз языка программирования Ruby 1.8.7 и фреймворка R..."  
Сообщение от opennews on 27-Ноя-08, 14:33 
Через шесть месяцев после выхода фреймворка для создания web-приложений Ruby on Rails 2.0 вышла (http://weblog.rubyonrails.org/2008/6/1/rails-2-1-time-zones-...) новая версия -  Ruby on Rails 2.1 (http://rubyonrails.org). Из нововведений стоит отметить:


-  поддержку часовых поясов;
-  «грязные» объекты;
-  зависимости от gem-ов;
-  именованные рамки;
-  миграции, датированные по UTC;
-  улучшенное кеширование.


Почти одновременно  был выпущен (http://www.ruby-lang.org/en/news/2008/05/31/ruby-1-8-7-has-b.../) релиз языка программирования Ruby 1.8.7 (http://www.ruby-lang.org), в котором кроме исправления ошибок, проведена работа нацеленная на увеличение производительности. Кроме того, в новую версию были портированы некоторые улучшения (http://svn.ruby-lang.org/repos/ruby/tags/v1_8_7/NEWS) из экспериментальной ветки Ruby 1.9.


URL: http://weblog.rubyonrails.org/2008/6/1/rails-2-1-time-zones-...
Новость: https://www.opennet.ru/opennews/art.shtml?num=16231

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Ubuntu 8.10 даунгрейд ruby 1.8.7 до 1.8.6"  
Сообщение от Mikhailov Anatoly email on 27-Ноя-08, 14:33 
http://railsgeek.com/2008/11/27/ubuntu-8-10-downgrade-ruby-1...
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "несовместимость сигналов"  
Сообщение от Andrey Mitrofanov on 27-Ноя-08, 15:43 
>railsgeek.com/2008/11/27/ubuntu-8-10-downgrade-ruby-1-8-7-to-1-8-6

Для сведения: эта новость, про выход rails 2.1 была --
01.06.2008 20:23

...меня смутило только то, что на днях уже была --
24.11.2008 12:59  Опубликован релиз web-фреймворка Ruby on Rails 2.2

Но, да 2.2: видимо, ещё нет в репозитариях, 1.8.7 уже кое-где может и быть...
Вот в Debian lenny -- 2.1.0 и 1.8.7.72.

В каком 1.8.7.NN починили и починили ли эту проблему, если знаете?

----
И вообще - сейчас по ссылке из ссылки написано
"We recommend Ruby 1.8.7 for use with Rails. Ruby 1.8.6, 1.8.5, 1.8.4 and 1.8.2 are still usable too, but version 1.8.3 is not.",
а по ссылке непосредственно -
"We recommend Ruby 1.8.6 for use with Rails. Ruby 1.8.7, 1.8.5, 1.8.4 and 1.8.2 are still usable too, but version 1.8.3 is not. Ruby 1.8.7 still has some bugs to straighten out.".

Хотелось бы восстановить %) целостную картину мира. Кто кого обманывает, где чего починили, кто кого сломал, пытается сломать и пр.?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "объясните им кто-н.,о чём они говорят,а то нам не понятно!"  
Сообщение от Andrey Mitrofanov on 27-Ноя-08, 16:26 
"As you may know Ruby 1.8.7 don't compatable with Rails" <--> "Ruby 1.8.7 breaks backward compatibility and is only compatible with Rails 2.1 and later,"

Увлекательно - не то слово. :)

Видимо, всё-таки имеется в виду установка "старого" ruby со "старым" rails -- вместо "штатных" новых в составе _новой_ ubuntu -- для _приложений_ ещё не мигрировавших (ещё не или не совместимых) на rails 2.1 или выше.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "объясните им кто-н.,о чём они говорят,а то нам не понятно!"  
Сообщение от Mikhailov Anatoly email on 27-Ноя-08, 18:44 
Буквально за 2 часа разработчики Rails изменили свое решение по поводу совместимости версии Ruby для своего фреймворка. Что ж будем ждать, когда Radiant и прочее будут нормально работать с Ruby 1.8.7

>"As you may know Ruby 1.8.7 don't compatable with Rails" <--> "Ruby 1.8.7 breaks backward compatibility and is only compatible with Rails 2.1 and later,"
>
>Увлекательно - не то слово. :)
>
>Видимо, всё-таки имеется в виду установка "старого" ruby со "старым" rails --
>вместо "штатных" новых в составе _новой_ ubuntu -- для _приложений_ ещё
>не мигрировавших (ещё не или не совместимых) на rails 2.1 или
>выше.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру