The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"OpenNews: Критическая уязвимость в phpMyAdmin"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Разговоры, обсуждение новостей (Public)
Изначальное сообщение [ Отслеживать ]

"OpenNews: Критическая уязвимость в phpMyAdmin"  
Сообщение от opennews (??) on 17-Сен-08, 23:23 
В популярном web-интерфейсе для управления СУБД MySQL - phpMyAdmin (http://www.phpmyadmin.net), используемом на многих хостингах, обнаружена (http://www.securityfocus.com/bid/31188) критическая уязвимость, позволяющая удаленному злоумышленнику выполнить PHP-код на сервере, включая вызов внешних команд через PHP-функцию exec(). Проблема устранена в  phpMyAdmin версиях 2.11.9.1 (http://www.phpmyadmin.net/home_page/downloads.php?relnotes=1) и <a href="http://www.phpmyadmin.net/home_page/downloads.php#3.0.0-rc2&... rel="external">3.0.0-rc2</a>.


Пример, запроса выполняющего команду "cp":

http://www.example.com/server_databases.php?pos=0&dbstats=0&...) OR exec('cp $(pwd)"/config.inc.php" config.txt'); //&sort_order=desc&token=[valid token]

URL: http://www.securityfocus.com/bid/31188
Новость: https://www.opennet.ru/opennews/art.shtml?num=17946

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по ответам | RSS]

1. "Критическая уязвимость в phpMyAdmin"  
Сообщение от alex (??) on 17-Сен-08, 23:23 
Простите за выражение, конечно, но задрали. Бублик, блин.
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "Критическая уязвимость в phpMyAdmin"  
Сообщение от аноним on 17-Сен-08, 23:50 
чтото не работает
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "Критическая уязвимость в phpMyAdmin"  
Сообщение от Аноним (??) on 18-Сен-08, 04:50 
У меня на phpMyAdmin-2.11.9+FreeBSD 7.1 не срабатывает.
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

5. "Критическая уязвимость в phpMyAdmin"  
Сообщение от Аноним (??) on 18-Сен-08, 06:57 
Package: phpmyadmin
State: installed
Automatically installed: yes
Version: 4:2.11.3-1ubuntu1.1

не срабатывает

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

8. "Критическая уязвимость в phpMyAdmin"  
Сообщение от Алексей email(??) on 18-Сен-08, 10:02 
phpMyAdmin 2.10.3, FreeBsd 6.2 - уязвимость срабатывает.
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

9. "Критическая уязвимость в phpMyAdmin"  
Сообщение от RKA KriK on 18-Сен-08, 11:23 
phpMyAdmin - 2.11.8.1
Уязвимость не срабатывает.
Apache/2.2.8 (Ubuntu) PHP/5.2.4-2ubuntu5.3 with Suhosin-Patch Server at localhost Port 80
phpMyAdmin 2.11.3deb1ubuntu1
Тут тоже уязвимость не срабатывает))
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

10. "Критическая уязвимость в phpMyAdmin"  
Сообщение от Аноним (??) on 18-Сен-08, 11:56 
>phpMyAdmin - 2.11.8.1
>Уязвимость не срабатывает.
>Apache/2.2.8 (Ubuntu) PHP/5.2.4-2ubuntu5.3 with Suhosin-Patch Server at localhost Port 80
>phpMyAdmin 2.11.3deb1ubuntu1
>Тут тоже уязвимость не срабатывает))

Блин нада бы проверить, но что такое "Valid token" ? в смысле что там писать))

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

13. "Критическая уязвимость в phpMyAdmin"  
Сообщение от zuborg email on 18-Сен-08, 14:45 
ну дырка, ну и что
все равно чтоб ею воспользоваться надо знать логин/пасс на базу
а у тех у кого есть такая информация обычно и так шелл доступ на сервер имеют
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

15. "Критическая уязвимость в phpMyAdmin"  
Сообщение от Аноним (??) on 19-Сен-08, 10:47 
>Блин нада бы проверить, но что такое "Valid token" ? в смысле
>что там писать))

пример адреса в phpmyadmine
http://localhost/phpmyadmin/server_databases.php?token=79f5b...

79f5bb3bf38a77ae9669aa7861429d68 - вот это и есть этот токен

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

16. "Критическая уязвимость в phpMyAdmin"  
Сообщение от FreeBolik email on 19-Сен-08, 15:57 
>>Блин нада бы проверить, но что такое "Valid token" ? в смысле
>>что там писать))
>
>пример адреса в phpmyadmine
>http://localhost/phpmyadmin/server_databases.php?token=79f5b...
>
>79f5bb3bf38a77ae9669aa7861429d68 - вот это и есть этот токен

ток не стоит забывать, что нормально описанный пхп: отрубленые глобалы, вызов екзеков( и ещё несколько), права нободи, вообщем, весь набор того что нужно сделать чтоб хостинг можно было бы назвать НЕ дырявым(а не только сайты). Отсуда у кого-то работает, а у кого-то хрен(а мож просто кривые руки). Отсуда и слово КРИТИЧЕСКАЯ весьма относительно, в данном случае самое критическое в етой уязвимости - ето руки админа.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

17. "Критическая уязвимость в phpMyAdmin"  
Сообщение от NoName on 19-Сен-08, 21:56 
И это есть истина
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору


Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру