The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"Ip routing problem Cisco 2801"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"Ip routing problem Cisco 2801"  
Сообщение от dem email(ok) on 19-Июл-07, 08:17 
Доброго времени суток всем.
Имеется Cisco 2801 требуется настроить маршрутизацию между подсетями 192.168.0.0 и 192.168.2.0 почитал маны вроде все просто, только вот что не работает, подскажите что делаю не так.
Вот конфиг :
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
no logging buffered
enable secret 5 $1$MOTF$DrnNgPEVj4JpomfqVZek11
enable password qwe
!
no aaa new-model
!
resource policy
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
ip cef
!
!
!
!
ip name-server 192.168.0.221
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
description $ETH-LAN$
ip address 192.168.0.3 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
description $ETH-LAN$
ip address 192.168.2.3 255.255.255.0
speed auto
full-duplex
no mop enabled
!
interface FastEthernet0/3/0
shutdown
!
interface FastEthernet0/3/1
shutdown
!
interface FastEthernet0/3/2
shutdown
!
interface FastEthernet0/3/3
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.0.221
ip route 192.168.0.0 255.255.255.0 FastEthernet0/0
ip route 192.168.2.0 255.255.255.0 FastEthernet0/1
!
ip http server
no ip http secure-server
!
snmp-server community public RO
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
password q
login
!
end


Заранее спасибо.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени, UBB]


1. "Ip routing problem Cisco 2801"  
Сообщение от GolDi (??) on 19-Июл-07, 09:30 
>Доброго времени суток всем.
>Имеется Cisco 2801 требуется настроить маршрутизацию между подсетями 192.168.0.0 и 192.168.2.0 почитал
>маны вроде все просто, только вот что не работает, подскажите что
>делаю не так.
>Вот конфиг :
>!
>version 12.4
>service timestamps debug datetime msec
>service timestamps log datetime msec
>no service password-encryption
>!
>hostname Router
>!
>boot-start-marker
>boot-end-marker
>!
>no logging buffered
>enable secret 5 $1$MOTF$DrnNgPEVj4JpomfqVZek11
>enable password qwe
>!
>no aaa new-model
>!
>resource policy
>!
>mmi polling-interval 60
>no mmi auto-configure
>no mmi pvc
>mmi snmp-timeout 180
>ip subnet-zero
>ip cef
>!
>!
>!
>!
>ip name-server 192.168.0.221
>!
>!
>!
>!
>!
>!
>!
>!
>!
>interface FastEthernet0/0
> description $ETH-LAN$
> ip address 192.168.0.3 255.255.255.0
> duplex auto
> speed auto
>!
>interface FastEthernet0/1
> description $ETH-LAN$
> ip address 192.168.2.3 255.255.255.0
> speed auto
> full-duplex
> no mop enabled
>!
>interface FastEthernet0/3/0
> shutdown
>!
>interface FastEthernet0/3/1
> shutdown
>!
>interface FastEthernet0/3/2
> shutdown
>!
>interface FastEthernet0/3/3
> shutdown
>!
>interface Vlan1
> no ip address
> shutdown
>!
>ip classless
>ip route 0.0.0.0 0.0.0.0 192.168.0.221


>ip route 192.168.0.0 255.255.255.0 FastEthernet0/0      
>ip route 192.168.2.0 255.255.255.0 FastEthernet0/1

Вот эти ^^^^^^^^ 2 строки убери и без них должно работать.            

>!
>ip http server
>no ip http secure-server
>!
>snmp-server community public RO
>!
>!
>control-plane
>!
>!
>line con 0
>line aux 0
>line vty 0 4
> password q
> login
>!
>end
>
>
>Заранее спасибо.
>


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Ip routing problem Cisco 2801"  
Сообщение от fantom email(ok) on 19-Июл-07, 09:35 
>>Доброго времени суток всем.
>>Имеется Cisco 2801 требуется настроить маршрутизацию между подсетями 192.168.0.0 и 192.168.2.0 почитал
>>маны вроде все просто, только вот что не работает, подскажите что
>>делаю не так.
>>Вот конфиг :
>>!
>>version 12.4
>>service timestamps debug datetime msec
>>service timestamps log datetime msec
>>no service password-encryption
>>!
>>hostname Router
>>!
>>boot-start-marker
>>boot-end-marker
>>!
>>no logging buffered
>>enable secret 5 $1$MOTF$DrnNgPEVj4JpomfqVZek11
>>enable password qwe
>>!
>>no aaa new-model
>>!
>>resource policy
>>!
>>mmi polling-interval 60
>>no mmi auto-configure
>>no mmi pvc
>>mmi snmp-timeout 180
>>ip subnet-zero
>>ip cef
>>!
>>!
>>!
>>!
>>ip name-server 192.168.0.221
>>!
>>!
>>!
>>!
>>!
>>!
>>!
>>!
>>!
>>interface FastEthernet0/0
>> description $ETH-LAN$
>> ip address 192.168.0.3 255.255.255.0
>> duplex auto
>> speed auto
>>!
>>interface FastEthernet0/1
>> description $ETH-LAN$
>> ip address 192.168.2.3 255.255.255.0
>> speed auto
>> full-duplex
>> no mop enabled
>>!
>>interface FastEthernet0/3/0
>> shutdown
>>!
>>interface FastEthernet0/3/1
>> shutdown
>>!
>>interface FastEthernet0/3/2
>> shutdown
>>!
>>interface FastEthernet0/3/3
>> shutdown
>>!
>>interface Vlan1
>> no ip address
>> shutdown
>>!
>>ip classless
>>ip route 0.0.0.0 0.0.0.0 192.168.0.221
>
>
>>ip route 192.168.0.0 255.255.255.0 FastEthernet0/0      
>>ip route 192.168.2.0 255.255.255.0 FastEthernet0/1
>
> Вот эти ^^^^^^^^ 2 строки убери и без них должно работать.
>
>
>>!
>>ip http server
>>no ip http secure-server
>>!
>>snmp-server community public RO
>>!
>>!
>>control-plane
>>!
>>!
>>line con 0
>>line aux 0
>>line vty 0 4
>> password q
>> login
>>!
>>end
>>
>>
>>Заранее спасибо.
>>

и добавь
ip routing

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Ip routing problem Cisco 2801"  
Сообщение от dem email(ok) on 19-Июл-07, 09:53 
>>>ip route 192.168.0.0 255.255.255.0 FastEthernet0/0      
>>>ip route 192.168.2.0 255.255.255.0 FastEthernet0/1
>>
>> Вот эти ^^^^^^^^ 2 строки убери и без них должно работать.

без них тоже самое

>
>и добавь
>ip routing

захожу в сонфигуре, пишу ip routing принемает команду, выхожу из сонфигуре, но в running-config этой строчки нету и маршрутизация не работает.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Ip routing problem Cisco 2801"  
Сообщение от XPurple email(ok) on 19-Июл-07, 10:49 
>>>>ip route 192.168.0.0 255.255.255.0 FastEthernet0/0      
>>>>ip route 192.168.2.0 255.255.255.0 FastEthernet0/1
>>>
>>> Вот эти ^^^^^^^^ 2 строки убери и без них должно работать.
>
>без них тоже самое
>
>>
>>и добавь
>>ip routing
>
>захожу в сонфигуре, пишу ip routing принемает команду, выхожу из сонфигуре, но
>в running-config этой строчки нету и маршрутизация не работает.
С рабочих станций или между интерфейсами Cisco не пересылается ?
Если первое, то возможно на рабочих станциях не сконфигурированы default-gateway (как вариант)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Ip routing problem Cisco 2801"  
Сообщение от dem email(ok) on 19-Июл-07, 10:56 
>>>>>ip route 192.168.0.0 255.255.255.0 FastEthernet0/0      
>>>>>ip route 192.168.2.0 255.255.255.0 FastEthernet0/1
>>>>
>>>> Вот эти ^^^^^^^^ 2 строки убери и без них должно работать.
>>
>>без них тоже самое
>>
>>>
>>>и добавь
>>>ip routing
>>
>>захожу в сонфигуре, пишу ip routing принемает команду, выхожу из сонфигуре, но
>>в running-config этой строчки нету и маршрутизация не работает.
>С рабочих станций или между интерфейсами Cisco не пересылается ?
>Если первое, то возможно на рабочих станциях не сконфигурированы default-gateway (как вариант)
>

С рабочих станций. С машины из подсети 2.0 192.168.0.3 пингуется нормально а дальше ничего.  

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "Ip routing problem Cisco 2801"  
Сообщение от GolDi (??) on 19-Июл-07, 11:16 
>>>>>>ip route 192.168.0.0 255.255.255.0 FastEthernet0/0      
>>>>>>ip route 192.168.2.0 255.255.255.0 FastEthernet0/1
>>>>>
>>>>> Вот эти ^^^^^^^^ 2 строки убери и без них должно работать.
>>>
>>>без них тоже самое
>>>
>>>>
>>>>и добавь
>>>>ip routing
>>>
>>>захожу в сонфигуре, пишу ip routing принемает команду, выхожу из сонфигуре, но
>>>в running-config этой строчки нету и маршрутизация не работает.
>>С рабочих станций или между интерфейсами Cisco не пересылается ?
>>Если первое, то возможно на рабочих станциях не сконфигурированы default-gateway (как вариант)
>>
>
>С рабочих станций. С машины из подсети 2.0 192.168.0.3 пингуется нормально а
>дальше ничего.

        Это говорит о том, что маршрутизация работает.
        А что-там у тебя дальше - нам не ведомо.
  

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "Ip routing problem Cisco 2801"  
Сообщение от dem email(ok) on 19-Июл-07, 11:44 
>>>>>>>ip route 192.168.0.0 255.255.255.0 FastEthernet0/0      
>>>>>>>ip route 192.168.2.0 255.255.255.0 FastEthernet0/1
>>>>>>
>>>>>> Вот эти ^^^^^^^^ 2 строки убери и без них должно работать.
>>>>
>>>>без них тоже самое
>>>>
>>>>>
>>>>>и добавь
>>>>>ip routing
>>>>
>>>>захожу в сонфигуре, пишу ip routing принемает команду, выхожу из сонфигуре, но
>>>>в running-config этой строчки нету и маршрутизация не работает.
>>>С рабочих станций или между интерфейсами Cisco не пересылается ?
>>>Если первое, то возможно на рабочих станциях не сконфигурированы default-gateway (как вариант)
>>>
>>
>>С рабочих станций. С машины из подсети 2.0 192.168.0.3 пингуется нормально а
>>дальше ничего.
>
>        Это говорит о том,
>что маршрутизация работает.
>        А что-там у тебя
>дальше - нам не ведомо.
>
тогда почему из консоли пингуется любая машина из нулевой подсети? а с машины из подсети 2.0 только интерфейсы циски?

P.S. tracert останавливается на 192.168.2.3

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "Ip routing problem Cisco 2801"  
Сообщение от fantom email(ok) on 19-Июл-07, 11:51 

>тогда почему из консоли пингуется любая машина из нулевой подсети? а с
>машины из подсети 2.0 только интерфейсы циски?
>
>P.S. tracert останавливается на 192.168.2.3

Хороший вопрос был насчет шлюза по умолчанию на машинах - он там точно прописан?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "Ip routing problem Cisco 2801"  
Сообщение от dem email(ok) on 19-Июл-07, 12:15 
>
>>тогда почему из консоли пингуется любая машина из нулевой подсети? а с
>>машины из подсети 2.0 только интерфейсы циски?
>>
>>P.S. tracert останавливается на 192.168.2.3
>
>Хороший вопрос был насчет шлюза по умолчанию на машинах - он там
>точно прописан?
естественно

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

10. "Ip routing problem Cisco 2801"  
Сообщение от XPurple email(ok) on 19-Июл-07, 12:44 
>>
>>>тогда почему из консоли пингуется любая машина из нулевой подсети? а с
>>>машины из подсети 2.0 только интерфейсы циски?
>>>
>>>P.S. tracert останавливается на 192.168.2.3
>>
>>Хороший вопрос был насчет шлюза по умолчанию на машинах - он там
>>точно прописан?
>естественно
access-list-ы точно пропускают icmp?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

11. "Ip routing problem Cisco 2801"  
Сообщение от dem email(ok) on 19-Июл-07, 12:48 
>>>
>>>>тогда почему из консоли пингуется любая машина из нулевой подсети? а с
>>>>машины из подсети 2.0 только интерфейсы циски?
>>>>
>>>>P.S. tracert останавливается на 192.168.2.3
>>>
>>>Хороший вопрос был насчет шлюза по умолчанию на машинах - он там
>>>точно прописан?
>>естественно
>access-list-ы точно пропускают icmp?

Смотри 1 сообщение там полный конфиг.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

12. "Ip routing problem Cisco 2801"  
Сообщение от dem email(??) on 20-Июл-07, 10:59 
Проблема решена всем спасибо!
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

13. "Ip routing problem Cisco 2801"  
Сообщение от fantom email(ok) on 20-Июл-07, 11:08 
>Проблема решена всем спасибо!

И какова же была причина?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

14. "Ip routing problem Cisco 2801"  
Сообщение от Onn on 23-Июл-07, 18:47 
>>Проблема решена всем спасибо!
>
>И какова же была причина?

я думаю что все таки в дефолтах на клиенских машинах ну или в /dev/hands

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

15. "Ip routing problem Cisco 2801"  
Сообщение от ValeDenis (??) on 24-Июл-07, 07:52 
>>Проблема решена всем спасибо!
>
>И какова же была причина?

тоже интересует... потому как такая же беда!

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

16. "Ip routing problem Cisco 2801"  
Сообщение от fantom email(ok) on 24-Июл-07, 10:12 
>>>Проблема решена всем спасибо!
>>
>>И какова же была причина?
>
>тоже интересует... потому как такая же беда!

Дык написалиже - толи дефолты на рабочих станциях, толи /dev/hands

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

17. "Ip routing problem Cisco 2801"  
Сообщение от ValeDenis (??) on 24-Июл-07, 12:55 
>>>>Проблема решена всем спасибо!
>>>
>>>И какова же была причина?
>>
>>тоже интересует... потому как такая же беда!
>
>Дык написалиже - толи дефолты на рабочих станциях, толи /dev/hands

автор не отписал, это всего лишь предположение...

У меня тоже проблема.... абсоллютно такая же...
Я понимаю что все это CIDR, и роутить должно без проблем... туда и обратно любой траффик! но почему то только icmp хотят.. ACL никаких не висит..  вот конфиг

Building configuration...

Current configuration : 1214 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot system flash
boot-end-marker
!
!
no aaa new-model
ip cef
!
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet3/0
no ip address
duplex full
!
interface FastEthernet3/0.1
encapsulation dot1Q 410
ip address 192.168.160.200 255.255.255.0
!
interface FastEthernet3/0.2
encapsulation dot1Q 1 native
ip address 192.168.0.200 255.255.255.0
!
interface FastEthernet3/0.3
encapsulation dot1Q 11
ip address 192.168.1.200 255.255.255.0
!
router ospf 1
log-adjacency-changes
network 192.168.0.0 0.0.0.255 area 0
network 192.168.1.0 0.0.0.255 area 0
network 192.168.160.0 0.0.0.255 area 0
!
no ip http server
no ip http secure-server
!
!
!
logging alarm informational
access-list 1 permit any
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
privilege level 15
password ciscorouter
login
!
!
end

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

18. "Ip routing problem Cisco 2801"  
Сообщение от Изгой (??) on 24-Июл-07, 16:04 
>[оверквотинг удален]
> stopbits 1
>line aux 0
> stopbits 1
>line vty 0 4
> privilege level 15
> password ciscorouter
> login
>!
>!
>end

ip subnet zero

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

19. "Ip routing problem Cisco 2801"  
Сообщение от fenix2 email(??) on 25-Июл-07, 01:38 
>[оверквотинг удален]
>>>>>машины из подсети 2.0 только интерфейсы циски?
>>>>>
>>>>>P.S. tracert останавливается на 192.168.2.3
>>>>
>>>>Хороший вопрос был насчет шлюза по умолчанию на машинах - он там
>>>>точно прописан?
>>>естественно
>>access-list-ы точно пропускают icmp?
>
>Смотри 1 сообщение там полный конфиг.

sh ip route плз

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

20. "Ip routing problem Cisco 2801"  
Сообщение от ps email(??) on 22-Авг-07, 15:15 
>[оверквотинг удален]
>>>>>>P.S. tracert останавливается на 192.168.2.3
>>>>>
>>>>>Хороший вопрос был насчет шлюза по умолчанию на машинах - он там
>>>>>точно прописан?
>>>>естественно
>>>access-list-ы точно пропускают icmp?
>>
>>Смотри 1 сообщение там полный конфиг.
>
>sh ip route плз

Ребята добавте командочку
gateway

для разрешения прохождения между интерфейсами и все бедет работать

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

21. "Ip routing problem Cisco 2801"  
Сообщение от oleg_matroskin (ok) on 22-Авг-07, 16:29 
>[оверквотинг удален]
>>>>access-list-ы точно пропускают icmp?
>>>
>>>Смотри 1 сообщение там полный конфиг.
>>
>>sh ip route плз
>
>Ребята добавте командочку
>gateway
>
>для разрешения прохождения между интерфейсами и все бедет работать

для прохождения между интерфейсами и так все должно работать!

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

22. "Ip routing problem Cisco 2801"  
Сообщение от LOMONOSOV email(ok) on 23-Авг-07, 22:23 
>[оверквотинг удален]
>>>>Смотри 1 сообщение там полный конфиг.
>>>
>>>sh ip route плз
>>
>>Ребята добавте командочку
>>gateway
>>
>>для разрешения прохождения между интерфейсами и все бедет работать
>
>для прохождения между интерфейсами и так все должно работать!

ip routing  

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

23. "Ip routing problem Cisco 2801"  
Сообщение от LOMONOSOV (ok) on 27-Авг-07, 18:04 
>[оверквотинг удален]
>>>>sh ip route плз
>>>
>>>Ребята добавте командочку
>>>gateway
>>>
>>>для разрешения прохождения между интерфейсами и все бедет работать
>>
>>для прохождения между интерфейсами и так все должно работать!
>
>ip routing

ip routing
Включает IP маршрутизацию на киске
ipx routing сами понимаете.
Удачи

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру