The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"G.711 проблема с этим кодеком"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"G.711 проблема с этим кодеком"  
Сообщение от smartkz email(ok) on 26-Ноя-08, 17:45 
Здравствуйте.

Есть следующая схема:

мини АТС - isdn pri - Cisco 2811 - ethernet - различные VoIP клиенты (AddPac и AudioCodes).

так вот звонки со стороны АТС на клиентов проходят в кодеке G.711, а вот с клиентов на АТС только g.729. Как организовать прохождение голоса с кодеком g.711 от клиентов на АТС?

p/s - самое странное что от клиентов даже сигнализация не проходит сразу идет отлуп(если физически указать шлюзу отправлять только g.711)

Ниже привожу данные:


Cisco IOS Software, 2800 Software (C2800NM-ADVENTERPRISEK9_IVS-M), Version 12.4(11)T, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2006 by Cisco Systems, Inc.
Compiled Sat 18-Nov-06 17:16 by prod_rel_team

ROM: System Bootstrap, Version 12.4(13r)T, RELEASE SOFTWARE (fc1)

Cisco 2811 (revision 53.51) with 247808K/14336K bytes of memory.
Processor board ID FHK1126F1EQ
2 FastEthernet interfaces
31 Serial interfaces
1 Channelized E1/PRI port
1 Virtual Private Network (VPN) Module
DRAM configuration is 64 bits wide with parity enabled.
239K bytes of non-volatile configuration memory.
62720K bytes of ATA CompactFlash (Read/Write)

#sh diag
Slot 0:
        C2811 Motherboard with 2FE and integrated VPN Port adapter, 2 ports
        Port adapter is analyzed
        Port adapter insertion time unknown
        Onboard VPN             : v2.3.3
        EEPROM contents at hardware discovery:
        PCB Serial Number        : FOC11246B8Q
        Hardware Revision        : 1.0
        Top Assy. Part Number    : 800-26920-03
        Board Revision           : A0
        Deviation Number         : 0
        Fab Version              : 03
        RMA Test History         : 00
        RMA Number               : 0-0-0-0
        RMA History              : 00
        Processor type           : 87
        Hardware date code       : 20070622
        Chassis Serial Number    : FHK1126F1EQ
        Chassis MAC Address      : 001c.5868.9ee0
        MAC Address block size   : 24
        CLEI Code                : COM7C00ARA
        Product (FRU) Number     : CISCO2811      
        Part Number              : 73-10258-04
        Version Identifier       : V04
        EEPROM format version 4
        EEPROM contents (hex):
          0x00: 04 FF C1 8B 46 4F 43 31 31 32 34 36 42 38 51 40
          0x10: 03 E7 41 01 00 C0 46 03 20 00 69 28 03 42 41 30
          0x20: 88 00 00 00 00 02 03 03 00 81 00 00 00 00 04 00
          0x30: 09 87 83 01 32 40 DE C2 8B 46 48 4B 31 31 32 36
          0x40: 46 31 45 51 C3 06 00 1C 58 68 9E E0 43 00 18 C6
          0x50: 8A 43 4F 4D 37 43 30 30 41 52 41 CB 8F 43 49 53
          0x60: 43 4F 32 38 31 31 20 20 20 20 20 20 82 49 28 12
          0x70: 04 89 56 30 34 20 D9 02 40 C1 FF FF FF FF FF FF

        PVDM Slot 0:
        64-channel (G.711) Voice/Fax PVDMII DSP SIMM PVDM daughter card
        Hardware Revision        : 4.0
        Part Number              : 73-8541-05
        Board Revision           : B0
        Deviation Number         : 0
        Fab Version              : 04
        PCB Serial Number        : FOC11232D9Z
        RMA Test History         : 00
        RMA Number               : 0-0-0-0
        RMA History              : 00
        Processor type           : 00
        Product (FRU) Number     : PVDM2-64
        Version Identifier       : V01
        EEPROM format version 4
        EEPROM contents (hex):
          0x00: 04 FF 40 03 EC 41 04 00 82 49 21 5D 05 42 42 30
          0x10: 88 00 00 00 00 02 04 C1 8B 46 4F 43 31 31 32 33
          0x20: 32 44 39 5A 03 00 81 00 00 00 00 04 00 09 00 CB
          0x30: 88 50 56 44 4D 32 2D 36 34 89 56 30 31 20 D9 02
          0x40: 40 C1 FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x50: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x60: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x70: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

        PVDM Slot 1:
        48-channel (G.711) Voice/Fax PVDMII DSP SIMM PVDM daughter card
        Hardware Revision        : 3.2
        Part Number              : 73-8540-04
        Board Revision           : A0
        Deviation Number         : 0
        Fab Version              : 03
        PCB Serial Number        : FOC10103GV0
        RMA Test History         : 00
        RMA Number               : 0-0-0-0
        RMA History              : 00
        Processor type           : 00
        Product (FRU) Number     : PVDM2-48
        Version Identifier       : NA  
        EEPROM format version 4
        EEPROM contents (hex):
          0x00: 04 FF 40 03 ED 41 03 02 82 49 21 5C 04 42 41 30
          0x10: 88 00 00 00 00 02 03 C1 8B 46 4F 43 31 30 31 30
          0x20: 33 47 56 30 03 00 81 00 00 00 00 04 00 09 00 CB
          0x30: 88 50 56 44 4D 32 2D 34 38 89 4E 41 20 20 D9 02
          0x40: 40 C1 FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x50: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x60: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x70: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

        WIC Slot 0:
        VWIC2-1MFT-T1/E1 - 1-Port RJ-48 Multiflex Trunk - T1/E1
        Hardware Revision        : 0.0
        Top Assy. Part Number    : 800-22628-05
        Board Revision           : B0
        Deviation Number         : 0
        Fab Version              : 04
        PCB Serial Number        : FOC11250GU5
        RMA Test History         : 00
        RMA Number               : 0-0-0-0
        RMA History              : 00
        Product (FRU) Number     : VWIC2-1MFT-T1/E1
        Version Identifier       : V01
        EEPROM format version 4
        EEPROM contents (hex):
          0x00: 04 FF 40 03 FD 41 00 00 C0 46 03 20 00 58 64 05
          0x10: 42 42 30 88 00 00 00 00 02 04 C1 8B 46 4F 43 31
          0x20: 31 32 35 30 47 55 35 03 00 81 00 00 00 00 04 00
          0x30: CB 90 56 57 49 43 32 2D 31 4D 46 54 2D 54 31 2F
          0x40: 45 31 89 56 30 31 20 D9 02 40 C1 FF FF FF FF FF
          0x50: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x60: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x70: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

!
card type e1 0 0

!


network-clock-participate wic 0

!

!
isdn switch-type primary-qsig
!
voice-card 0
codec complexity medium
no dspfarm
!
!
!
voice service voip
fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback cisco
!
!
voice class codec 1
codec preference 1 g711alaw
codec preference 2 g711ulaw
codec preference 3 g729r8
codec preference 4 g729br8

!
!
controller E1 0/0/0
framing NO-CRC4
pri-group timeslots 1-31
!
class-map match-any SDM-Transactional-1
match  dscp af21
match  dscp af22
match  dscp af23
class-map match-any SDM-Signaling-1
match  dscp cs3
match  dscp af31
class-map match-any SDM-Scavenger-1
match  dscp cs1
class-map match-any SDM-Routing-1
match  dscp cs6
class-map match-any SDM-Voice-1
match  dscp ef
match  dscp 47
match  dscp cs7
match protocol h323
match protocol rtp audio
class-map match-any SDM-Streaming-Video-1
match  dscp cs4
class-map match-any SDM-Management-1
match  dscp cs2
class-map match-any SDM-Interactive-Video-1
match  dscp af41
class-map match-any SDM-BulkData-1
match  dscp af11
match  dscp af12
match  dscp af13
!
!
policy-map SDM-QoS-Policy-1
class SDM-Voice-1
  priority percent 50
  set dscp cs7
class SDM-Signaling-1
  bandwidth percent 5
class SDM-Routing-1
  bandwidth percent 5
class SDM-Management-1
  bandwidth percent 5
class SDM-Transactional-1
  bandwidth percent 5
class class-default
  fair-queue
  random-detect
!

interface FastEthernet0/1
description Wan
ip address  255.255.255.248
no ip redirects
no ip unreachables
no ip proxy-arp
ip nbar protocol-discovery
duplex auto
speed auto
no cdp enable
h323-gateway voip interface
h323-gateway voip id GK ipaddr 1719
h323-gateway voip h323-id gk
service-policy output SDM-QoS-Policy-1
hold-queue 100 out
!
interface Serial0/0/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-qsig
isdn overlap-receiving
isdn incoming-voice voice
no cdp enable
!

!

!
!
!
!
!
!
control-plane
!
!
!
voice-port 0/0/0:15
!
!
!
!
!
dial-peer voice 1 pots
destination-pattern 1...
direct-inward-dial
port 0/0/0:15
forward-digits all


dial-peer voice 38 voip
destination-pattern 38...
voice-class codec 1
session target ras
dtmf-relay h245-signal h245-alphanumeric
fax rate 9600
fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback cisco
ip qos dscp cs1 media
no vad

gateway
timer receive-rtp 1200
!
!
!
gatekeeper
shutdown
!
!


Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "G.711 проблема с этим кодеком"  
Сообщение от LEXX (??) on 26-Ноя-08, 18:53 
ну раз прописано

codec preference 1 g711alaw
и в диалпире

voice-class codec 1

то неудивительно, что исходящий уходит в G.711

Может, в диалпире просто прописать вместо codec g729 ?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "G.711 проблема с этим кодеком"  
Сообщение от smartkz email(ok) on 26-Ноя-08, 19:08 
>ну раз прописано
>
>codec preference 1 g711alaw
> и в диалпире
>
>voice-class codec 1
>
>то неудивительно, что исходящий уходит в G.711
>
>Может, в диалпире просто прописать вместо codec g729 ?

Мне нужно чтоб от клиентов приходил кодек g.711 и соответственно работал...

на клиентов (т.е с циски) уходят любые кодеки и приэтом прекрасно работают...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "G.711 проблема с этим кодеком"  
Сообщение от ru_irk_LEXX (ok) on 26-Ноя-08, 19:12 
>
>Мне нужно чтоб от клиентов приходил кодек g.711 и соответственно работал...
>
>на клиентов (т.е с циски) уходят любые кодеки и приэтом прекрасно работают...
>

Может, я что-то недопонимаю, но войповый диалпир описывает ИСХОДЯЩИЙ звонок, а не ВХОДЯЩИЙ. Чтобы гейтвей работал на приём с кодеком G.711 вам не_надо_ его явно прописывать в диалпире. Тем более что звонок call (входящий) вообще не проверяется на соответствия какие-либо.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "G.711 проблема с этим кодеком"  
Сообщение от smartkz email(ok) on 26-Ноя-08, 19:17 
>>
>>Мне нужно чтоб от клиентов приходил кодек g.711 и соответственно работал...
>>
>>на клиентов (т.е с циски) уходят любые кодеки и приэтом прекрасно работают...
>>
>
>Может, я что-то недопонимаю, но войповый диалпир описывает ИСХОДЯЩИЙ звонок, а не
>ВХОДЯЩИЙ. Чтобы гейтвей работал на приём с кодеком G.711 вам не_надо_
>его явно прописывать в диалпире. Тем более что звонок call (входящий)
>вообще не проверяется на соответствия какие-либо.

Я привел конфиг cisco что бы Вы посмотрели почему Cisco не принимает G.711... ?

C циски звонки уходят как мне нужно.

Повторяю вопрос: Циска от клиентов НЕ принимает звонки с кодеком g.711 ПОЧЕМУ ЦИСКА НЕ ПРИНИМАЕТ ???

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "G.711 проблема с этим кодеком"  
Сообщение от ru_irk_LEXX (ok) on 26-Ноя-08, 19:32 
а звонок попадает в sh call history voice last 1?
Или отбивается до установки соединения?


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "G.711 проблема с этим кодеком"  
Сообщение от smartkz email(ok) on 26-Ноя-08, 19:37 
>а звонок попадает в sh call history voice last 1?
>Или отбивается до установки соединения?

звонок падает....
сейчас протестировал с софтового телефона т.е. с компьютера (openphone) - установил програмно кодек g.711 - и звонок прошол на этом кодеке..... (ни чего не понимаю) а с аудиокодека когда прописываеш отправлять g.711 то не проходит... (хотя аудиокодек принммает g.711 от циски)возвращает аудиокодеку g.729 все работает... Вот такая не понятная задача....


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "G.711 проблема с этим кодеком"  
Сообщение от ru_irk_LEXX (ok) on 26-Ноя-08, 19:45 
>>а звонок попадает в sh call history voice last 1?
>>Или отбивается до установки соединения?
>
>звонок падает....
>сейчас протестировал с софтового телефона т.е. с компьютера (openphone) - установил програмно
>кодек g.711 - и звонок прошол на этом кодеке..... (ни чего
>не понимаю) а с аудиокодека когда прописываеш отправлять g.711 то не
>проходит... (хотя аудиокодек принммает g.711 от циски)возвращает аудиокодеку g.729 все работает...
>Вот такая не понятная задача....

что-то я запутался в вашей терминологии. аудиокодек = какой-то девайс/софт?
недопонимаю конструкцию типа "а с аудиокодека когда прописываеш отправлять g.711". G.711 - это и так аудиокодек.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "G.711 проблема с этим кодеком"  
Сообщение от smartkz email(ok) on 26-Ноя-08, 19:50 
>[оверквотинг удален]
>>звонок падает....
>>сейчас протестировал с софтового телефона т.е. с компьютера (openphone) - установил програмно
>>кодек g.711 - и звонок прошол на этом кодеке..... (ни чего
>>не понимаю) а с аудиокодека когда прописываеш отправлять g.711 то не
>>проходит... (хотя аудиокодек принммает g.711 от циски)возвращает аудиокодеку g.729 все работает...
>>Вот такая не понятная задача....
>
>что-то я запутался в вашей терминологии. аудиокодек = какой-то девайс/софт?
>недопонимаю конструкцию типа "а с аудиокодека когда прописываеш отправлять g.711". G.711 -
>это и так аудиокодек.

AudioCodes (это бренд) MP-114 FXS  - это голосовой шлюз в него воткнуты 4 телефонных аппарата.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "G.711 проблема с этим кодеком"  
Сообщение от Myxa email(??) on 27-Ноя-08, 09:02 
>[оверквотинг удален]
>>>не понимаю) а с аудиокодека когда прописываеш отправлять g.711 то не
>>>проходит... (хотя аудиокодек принммает g.711 от циски)возвращает аудиокодеку g.729 все работает...
>>>Вот такая не понятная задача....
>>
>>что-то я запутался в вашей терминологии. аудиокодек = какой-то девайс/софт?
>>недопонимаю конструкцию типа "а с аудиокодека когда прописываеш отправлять g.711". G.711 -
>>это и так аудиокодек.
>
>AudioCodes (это бренд) MP-114 FXS  - это голосовой шлюз в него
>воткнуты 4 телефонных аппарата.

ulaw alaw играть не пробовали?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

10. "G.711 проблема с этим кодеком"  
Сообщение от smartkz email(ok) on 27-Ноя-08, 10:18 
>[оверквотинг удален]
>>>>Вот такая не понятная задача....
>>>
>>>что-то я запутался в вашей терминологии. аудиокодек = какой-то девайс/софт?
>>>недопонимаю конструкцию типа "а с аудиокодека когда прописываеш отправлять g.711". G.711 -
>>>это и так аудиокодек.
>>
>>AudioCodes (это бренд) MP-114 FXS  - это голосовой шлюз в него
>>воткнуты 4 телефонных аппарата.
>
>ulaw alaw играть не пробовали?

в каком месте на циске нужно пробывать играть с этими кодеками ?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

11. "G.711 проблема с этим кодеком"  
Сообщение от APach on 27-Ноя-08, 10:25 
Попробуйте просто прописать clear-channel вместо 711
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

12. "G.711 проблема с этим кодеком"  
Сообщение от smartkz email(ok) on 27-Ноя-08, 10:31 
>Попробуйте просто прописать clear-channel вместо 711

Где это нужно прописать, в какой секции?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

13. "G.711 проблема с этим кодеком"  
Сообщение от APach on 27-Ноя-08, 10:54 
voice class codec 1
codec preference 1 clear-channel
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

14. "G.711 проблема с этим кодеком"  
Сообщение от smartkz email(ok) on 27-Ноя-08, 12:29 
>voice class codec 1
>codec preference 1 clear-channel

voice class codec 1 - отвечает за исходящие звонки от циски на клиента.... тут проблем нет
мне нужно входящий звонок от клиента на циску ....

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

15. "G.711 проблема с этим кодеком"  
Сообщение от blank (ok) on 27-Ноя-08, 13:11 
>>voice class codec 1
>>codec preference 1 clear-channel
>
>voice class codec 1 - отвечает за исходящие звонки от циски на
>клиента.... тут проблем нет
>мне нужно входящий звонок от клиента на циску ....

циско шлюз ждет от AudioCodes MP-114 любой кодек и на каком они сговорятся на таком и идет передача, видимо все таки нужно настраивать AudioCodes MP-114 что-бы он отдавал 711 кодеком.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

16. "G.711 проблема с этим кодеком"  
Сообщение от smartkz email(ok) on 27-Ноя-08, 13:13 
>>>voice class codec 1
>>>codec preference 1 clear-channel
>>
>>voice class codec 1 - отвечает за исходящие звонки от циски на
>>клиента.... тут проблем нет
>>мне нужно входящий звонок от клиента на циску ....
>
>циско шлюз ждет от AudioCodes MP-114 любой кодек и на каком они
>сговорятся на таком и идет передача, видимо все таки нужно настраивать
>AudioCodes MP-114 что-бы он отдавал 711 кодеком.

полностью согласен.... я пробывал на разных оборудованиях AddPac, другая циска... и еще разное китайское барахло... результат один и тот же


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Партнёры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2024 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру