The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Режим transparent firewall в cisco pix"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Диагностика и решение проблем)
Изначальное сообщение [ Отслеживать ]

"Режим transparent firewall в cisco pix"  +/
Сообщение от InsiderMK email(ok) on 08-Июн-09, 09:49 
Пытаюсь настроить cisco pix в режиме firewall transparent, но что-то никак не получается. С пикса пингуются и шлюз и внутренняя сетка за пиксом, я могу подключится по SSH или ASDM, но из сети наружу ничего не проходит. Шлюз не пингуется. Вот конфиг. По режиму transparent очень мало информации. Подскажите в чем может быть дело или где почитать?

PIX Version 8.0(4)
!
firewall transparent
!
hostname FW-GW
names
!
interface Ethernet0
nameif outside
security-level 0
!
interface Ethernet1
nameif inside
security-level 100
!

mtu outside 1500
mtu inside 1500

boot system flash:/pix804.bin
asdm image flash:/asdm-613.bin
no asdm history enable
ftp mode passive

access-list inside_access_in extended permit ip any any
access-group inside_access_in in interface inside

access-list outside_access_in extended permit icmp any any echo
access-list outside_access_in extended permit icmp any any echo-reply
access-list outside_access_in extended permit icmp any any source-quench
access-list outside_access_in extended permit icmp any any unreachable
access-list outside_access_in extended permit icmp any any time-exceeded
access-group outside_access_in in interface outside

ip address 85.233.xxx.yy 255.255.255.240

http server enable
http 85.233.xxx.zz 255.255.255.255 inside
ssh 85.233.xxx.zz 255.255.255.255 inside

pager lines 24
logging enable
logging asdm informational
icmp unreachable rate-limit 1 burst-size 1
arp timeout 14400
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet timeout 5
ssh timeout 5
console timeout 0
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect sip  
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
: end

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Режим transparent firewall в cisco pix"  +/
Сообщение от mario email(ok) on 08-Июн-09, 10:23 
>[оверквотинг удален]
>  inspect skinny
>  inspect sunrpc
>  inspect xdmcp
>  inspect sip
>  inspect netbios
>  inspect tftp
>!
>service-policy global_policy global
>prompt hostname context
>: end

правила настройте на аутсайд.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Режим transparent firewall в cisco pix"  +/
Сообщение от InsiderMK email(ok) on 08-Июн-09, 11:23 
>
>правила настройте на аутсайд.
>

Вот так настраивал, все равно ничего не работает. Или нужно что-то еще настроить? В режиме no firewall transparent с такими правилами все работает.

access-list inside_access_in extended permit ip any any
access-list inside_access_in extended permit icmp any any
access-group inside_access_in in interface inside

access-list outside_access_in extended permit ip any any
access-list outside_access_in extended permit icmp any any
access-group outside_access_in in interface outside


Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "Режим transparent firewall в cisco pix"  +/
Сообщение от mario email(ok) on 08-Июн-09, 16:34 
>[оверквотинг удален]
>настроить? В режиме no firewall transparent с такими правилами все работает.
>
>
>access-list inside_access_in extended permit ip any any
>access-list inside_access_in extended permit icmp any any
>access-group inside_access_in in interface inside
>
>access-list outside_access_in extended permit ip any any
>access-list outside_access_in extended permit icmp any any
>access-group outside_access_in in interface outside

извините, но у меня не было необходимости в 2 стороны делать, меня устроило в одну все разрешить,  так как это технологически не нужно.
кстатии расскажите зачем вам такой результат нужен ?
Если не ошибаюсь я RDP пробросил на секурность
Кстатии секурность по 50 не пробовали ставить ?

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "Режим transparent firewall в cisco pix"  +/
Сообщение от InsiderMK email(ok) on 08-Июн-09, 21:08 
>кстатии расскажите зачем вам такой результат нужен ?
>Если не ошибаюсь я RDP пробросил на секурность
>Кстатии секурность по 50 не пробовали ставить ?

Да мне не нужен именно такой результат. Просто привел для примера, что даже так не работает. Мне нужен доступ изнутри наружу. Изначально были вот такие правила:

access-list inside_access_in extended permit ip any any
access-group inside_access_in in interface inside

access-list outside_access_in extended permit icmp any any echo
access-list outside_access_in extended permit icmp any any echo-reply
access-list outside_access_in extended permit icmp any any source-quench
access-list outside_access_in extended permit icmp any any unreachable
access-list outside_access_in extended permit icmp any any time-exceeded
access-group outside_access_in in interface outside


Тут похоже дело не в правилах. Не могу понять в чем.

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "Режим transparent firewall в cisco pix"  +/
Сообщение от mario email(ok) on 09-Июн-09, 18:02 
>[оверквотинг удален]
>
>access-list outside_access_in extended permit icmp any any echo
>access-list outside_access_in extended permit icmp any any echo-reply
>access-list outside_access_in extended permit icmp any any source-quench
>access-list outside_access_in extended permit icmp any any unreachable
>access-list outside_access_in extended permit icmp any any time-exceeded
>access-group outside_access_in in interface outside
>
>
>Тут похоже дело не в правилах. Не могу понять в чем.

вам нужно что бы кто сидит за фаером пользовался сетью, а из сети не могли к ним достучаться ?
тогда воообще не заморачивайтесь с АЦЛ

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

6. "Режим transparent firewall в cisco pix"  +/
Сообщение от mario email(ok) on 09-Июн-09, 18:04 
>[оверквотинг удален]
>>access-list outside_access_in extended permit icmp any any unreachable
>>access-list outside_access_in extended permit icmp any any time-exceeded
>>access-group outside_access_in in interface outside
>>
>>
>>Тут похоже дело не в правилах. Не могу понять в чем.
>
>вам нужно что бы кто сидит за фаером пользовался сетью, а из
>сети не могли к ним достучаться ?
>тогда воообще не заморачивайтесь с АЦЛ

в общем опишите задачу а не то что у вас получилось

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

7. "Режим transparent firewall в cisco pix"  +/
Сообщение от InsiderMK email(ok) on 09-Июн-09, 18:35 
>вам нужно что бы кто сидит за фаером пользовался сетью, а из
>сети не могли к ним достучаться ?
>тогда воообще не заморачивайтесь с АЦЛ

Я тут максимально упрощаю задачу. Мне нужно, чтобы внутренняя сеть имела доступ в нитернет. Все. В access-list именно это я постарался прописать + еще правила чтобы работал ping. Еще раз повторю, дело не в правилах. А в чем понять не могу до сих пор.

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

8. "Режим transparent firewall в cisco pix"  +/
Сообщение от Myxa email(??) on 11-Июн-09, 13:49 
>>вам нужно что бы кто сидит за фаером пользовался сетью, а из
>>сети не могли к ним достучаться ?
>>тогда воообще не заморачивайтесь с АЦЛ
>
>Я тут максимально упрощаю задачу. Мне нужно, чтобы внутренняя сеть имела доступ
>в нитернет. Все. В access-list именно это я постарался прописать +
>еще правила чтобы работал ping. Еще раз повторю, дело не в
>правилах. А в чем понять не могу до сих пор.

А собственно роутинг где?

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

9. "Режим transparent firewall в cisco pix"  +/
Сообщение от mario email(ok) on 11-Июн-09, 14:03 
>>>вам нужно что бы кто сидит за фаером пользовался сетью, а из
>>>сети не могли к ним достучаться ?
>>>тогда воообще не заморачивайтесь с АЦЛ
>>
>>Я тут максимально упрощаю задачу. Мне нужно, чтобы внутренняя сеть имела доступ
>>в нитернет. Все. В access-list именно это я постарался прописать +
>>еще правила чтобы работал ping. Еще раз повторю, дело не в
>>правилах. А в чем понять не могу до сих пор.
>
>А собственно роутинг где?

+1 не обратил внимание :)

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

10. "Режим transparent firewall в cisco pix"  +/
Сообщение от InsiderMK (ok) on 16-Июн-09, 19:07 
>>
>>А собственно роутинг где?
>
>+1 не обратил внимание :)

Это режим transparent, там нет роутинга. Так и не разобрался с этим. Пока работает в routed mode.

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

11. "Режим transparent firewall в cisco pix"  +/
Сообщение от ilya (ok) on 17-Июн-09, 08:52 
А что говорит товарисч лог, например logg mon 7 ?
Внутренние хосты видят арп шлюза и наоборот, шлюз видит арп внутренних хостов?
Подключение шлюза выполненое непосредственно в пикс (т.е. ассиметрии трафика нет случайно)?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

12. "Режим transparent firewall в cisco pix"  +/
Сообщение от InsiderMK (ok) on 17-Июн-09, 21:21 
>А что говорит товарисч лог, например logg mon 7 ?
>Внутренние хосты видят арп шлюза и наоборот, шлюз видит арп внутренних хостов?
>
>Подключение шлюза выполненое непосредственно в пикс (т.е. ассиметрии трафика нет случайно)?

В логе ничего интересного нет. Т.е. никаких deny или ошибок. MAC адреса определяются. Пробовал очищать ARP таблицы и делать ping. После этого в ARP таблице появляются правильные значения MAC адресов. debug icmp trace 255 показывает, что ICMP echo принимается внутренним интерфейсом (пингую изнутри) и на этом все. Судя по косвенным признакам, пакет дропается на внутреннем интерфейсе и с внешнего не ретранслируется. Причина мне непонятна. В правилах доступа ставил разрешить все куда угодно.

Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

13. "Режим transparent firewall в cisco pix"  +/
Сообщение от ilya (ok) on 18-Июн-09, 17:33 
>[оверквотинг удален]
>>
>>Подключение шлюза выполненое непосредственно в пикс (т.е. ассиметрии трафика нет случайно)?
>
>В логе ничего интересного нет. Т.е. никаких deny или ошибок. MAC адреса
>определяются. Пробовал очищать ARP таблицы и делать ping. После этого в
>ARP таблице появляются правильные значения MAC адресов. debug icmp trace 255
>показывает, что ICMP echo принимается внутренним интерфейсом (пингую изнутри) и на
>этом все. Судя по косвенным признакам, пакет дропается на внутреннем интерфейсе
>и с внешнего не ретранслируется. Причина мне непонятна. В правилах доступа
>ставил разрешить все куда угодно.

7ю версию не пробовали накатить?

Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

14. "Режим transparent firewall в cisco pix"  +/
Сообщение от InsiderMK (ok) on 18-Июн-09, 20:31 
>7ю версию не пробовали накатить?

Нет. С 6.4 перешел сразу на 8, и вот решил попробовать режим transparent. Прихожу к выводу, что надо сбросить весь конфиг на factory default, а потом все прописать с нуля. Больше идей нет.

Ответить | Правка | ^ к родителю #13 | Наверх | Cообщить модератору

15. "Режим transparent firewall в cisco pix"  +/
Сообщение от alexeirus email(ok) on 07-Фев-12, 09:04 
>>7ю версию не пробовали накатить?
> Нет. С 6.4 перешел сразу на 8, и вот решил попробовать режим
> transparent. Прихожу к выводу, что надо сбросить весь конфиг на factory
> default, а потом все прописать с нуля. Больше идей нет.

Прошу Вас уточнить, о вашей проблеме с transparent mode????

Ответить | Правка | ^ к родителю #14 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру