The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"GRE Тулень между Несколькими 'точками'"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Cisco маршрутизаторы)
Изначальное сообщение [ Отслеживать ]

"GRE Тулень между Несколькими 'точками'"  +/
Сообщение от cubespace email(ok) on 29-Окт-10, 12:30 
Здравствуйте!

У меня проблема при создании GRE тунеля!
В нете много информации о создании тунеля между "точка-точка"
А мне нужно создать GRE - тунель между 12 "точками"

Дело в том, что у нас по области, стоит пока 12 "точек", єто (оборудование с GPRS модемами)
И каждые сутки программа с сервера заходит на эти "точки" и снимает свою информацию!

Со стороны связи компания GSМ-связи предоставила нам точку доступа типа (connect.kompania.net)
и диапазон ІР-адресов  
Типа
10.20.30.1 - 10.20.30.254
И ІР их шлюза типа : ХХ.ХХ.ХХ.ХХ

Конфиг циски


version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname router
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
enable secret 5
!
no aaa new-model
dot11 syslog
ip cef
!
!
!
!
ip domain name mydomain
ip name-server YY.YY.YY.YY


interface FastEthernet0/0
description Connectet to DataGroup ADSL
ip address AA.AA.AA.AA 255.255.255.252
ip nat outside
ip virtual-reassembly
ip tcp adjust-mss 1452
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.5.10 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface Dialer0
no ip address
shutdown
no cdp enable
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 JJ.JJ.JJ.JJ
ip route 10.20.30.0 255.255.255.0 YY.YY.YY.YY
ip route 192.168.1.0 255.255.255.0 192.168.5.3

ip http server
ip http access-class 1
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip http path flash:
ip nat inside source list 1 interface FastEthernet0/0 overload
ip nat inside source static tcp 192.168.5.1 3389 AA.AA.AA.AA 3389 extendable
!
access-list 1 permit 192.168.5.0 0.0.0.255
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 23 permit 192.168.1.0 0.0.0.255
access-list 23 permit PP.PP.PP.0 0.0.0.255
access-list 101 permit udp any any eq domain
access-list 101 permit udp any eq domain any
no cdp run

!
line con 0
password 7
logging synchronous
login
line aux 0
line vty 0 4
access-class 23 in
privilege level 15
login local
transport input telnet ssh
line vty 5 15
access-class 23 in
privilege level 15
login local
transport input telnet ssh
!
scheduler allocate 20000 1000
end

В нас это работало без проблем на ФРЕШКЕ, но теперь нужно на циске это сделать!

На фришке было так:

rc.conf
gre_enable="YES"
/usr/local/etc/rc.d/gre.sh
ifconfig gre0 create
ifconfig gre0 inet 192.168.1.11 ХХ.ХХ.ХХ.ХХ netmask 0xffffffff
ifconfig gre0 tunnel АА.АА.АА.АА  ХХ.ХХ.ХХ.ХХ
route add 10.20.30.0/24 ХХ.ХХ.ХХ.ХХ


АА.АА.АА.АА - обозначил наш белый ІР
ХХ.ХХ.ХХ.ХХ - ІР шлюз компания GSМ-связи

И всё работало!

А как теперь настроить для 12 соединений ?
Можно ли это одним туннелем и как это реализовать ?

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "GRE Тулень между Несколькими 'точками'"  +/
Сообщение от uasash2 email on 29-Окт-10, 15:18 
у меня так 40 gre
interface Tunnel8
ip address 192.168.254.29 255.255.255.252
tunnel source 1.1.1.1
tunnel destination 2.2.2.2
tunnel key 11111
tunnel protection ipsec profile VTI
!
interface Tunnel9
ip address 192.168.254.33 255.255.255.252
tunnel source 1.1.1.1
tunnel destination 3.3.3.3
tunnel key 33333333
tunnel protection ipsec profile VTI

tunnel protection ipsec profile VTI это можно убрать это шифрование если просто gre то не надо.
и еще tunnel source можно указать в твоем случае tunnel source  FastEthernet0/0

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

4. "GRE Тулень между Несколькими 'точками'"  +/
Сообщение от kolyaniust email(ok) on 29-Окт-10, 20:55 
>[оверквотинг удален]
> interface Tunnel9
>  ip address 192.168.254.33 255.255.255.252
>  tunnel source 1.1.1.1
>  tunnel destination 3.3.3.3
>  tunnel key 33333333
>  tunnel protection ipsec profile VTI
>  tunnel protection ipsec profile VTI это можно убрать это шифрование если
> просто gre то не надо.
> и еще tunnel source можно указать в твоем случае tunnel source
> FastEthernet0/0

У меня так же :

interface Tunnel1
ip address 192.168.14.106 255.255.255.252
ip mtu 1476
tunnel source 91.204.X.X
tunnel destination 178.133.Y.Y

и так 20 туннелей, с GPRS модемами.
Правда маршрутизация на все 20 пока прописана вручную.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "GRE Тулень между Несколькими 'точками'"  +/
Сообщение от _RAW_ email(ok) on 29-Окт-10, 15:39 
> Здравствуйте!
> У меня проблема при создании GRE тунеля!
> В нете много информации о создании тунеля между "точка-точка"
> А мне нужно создать GRE - тунель между 12 "точками"

Так подымите 12 точка-точка туннелей с одним центром. Чем вам не нравится такой вариант?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "GRE Тулень между Несколькими 'точками'"  +/
Сообщение от BJ (ok) on 29-Окт-10, 19:41 
Центр:
interface Tunnel77
ip address 10.33.33.1 255.255.255.0
ip nhrp map 10.33.0.2 2.2.2.2
ip nhrp map 10.33.0.3 3.3.3.3
...
ip nhrp map 10.33.0.13 13.13.13.13
ip nhrp network-id 77
tunnel source 1.1.1.1
tunnel mode gre multipoint

1-я точка:
interface Tunnel77
ip address 10.33.33.2 255.255.255.0
no ip redirects
no ip proxy-arp
ip nhrp map 10.33.0.1 1.1.1.1
ip nhrp network-id 77
tunnel source 2.2.2.2
tunnel mode gre multipoint

и тд

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру