The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Cisco и полоса пропускания на  CBWFQ"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]

"Cisco и полоса пропускания на  CBWFQ"  +/
Сообщение от baronzzz email(??) on 11-Май-12, 22:16 
Добрый день !

Сложилась ситуация, которая мне не нравится, прошу совета как уйти от проблемы загрузки CPU Cisco 2921.

Стандартный конфиг на нарезку клиенат:

class-map match-all vl781-out
match access-group name vl781-out
class-map match-all vl781-in
match access-group name vl781-in


policy-map CBWFQ-OUT
class vl781-out
  shape average    4096000 768000 1536000
  bandwidth 8
  random-detect dscp-based
policy-map CBWFQ-IN
class vl781-in
  shape average 4096000 768000 1536000
  bandwidth 8
  random-detect dscp-based

ip access-list extended vl781-in
remark ##########              vl780            ###############
permit ip 188.XXX.XX.8 0.0.0.3 any
ip access-list extended vl781-out
remark ##########             vl780            ###############
permit ip any 188.XX.XX.8 0.0.0.3    

На физических интерфейсах имеется:

interface GigabitEthernet0/1
description #########Clients##########
no ip address
ip route-cache policy
load-interval 30
duplex auto
speed auto
media-type rj45
no cdp enable
service-policy output CBWFQ-OUT
end


!
interface GigabitEthernet0/0
description 2UpLinker
no ip address
ip route-cache policy
load-interval 30
duplex auto
speed auto
no mop enabled
service-policy output CBWFQ-IN
end


Что есть: 2 BGP Full View, 50+30 трафика во внеху, около 50 клиентов с тарифным планом в среденм 2 мегобита\с. Каждый клиент в отдельном Vlan.

НАТА НЕТ.

Суть проблемы
При существование строчек на физических интерфейсах кошки типа service-policy output CBWFQ-ХХ

Загрузка проца возрастает в пиках до 80%, хотя потребляемый трафик сумарно 40-60 мегобит.

При снятие строчек типа service-policy output CBWFQ-ХХ, загрузка вообще шикарная 7-8 и до 20% в пике.

ВОПРОС.

Есть ли варианты, сниить нагрузку на CPU но при этом не лишиться гарантированных скоростей для клиентов ? Быть может что то я сделал не так ?

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Cisco и полоса пропускания на  CBWFQ"  +/
Сообщение от Merridius (ok) on 11-Май-12, 23:06 
>[оверквотинг удален]
> Суть проблемы
> При существование строчек на физических интерфейсах кошки типа service-policy output CBWFQ-ХХ
> Загрузка проца возрастает в пиках до 80%, хотя потребляемый трафик сумарно 40-60
> мегобит.
> При снятие строчек типа service-policy output CBWFQ-ХХ, загрузка вообще шикарная 7-8 и
> до 20% в пике.
> ВОПРОС.
> Есть ли варианты, сниить нагрузку на CPU но при этом не лишиться
> гарантированных скоростей для клиентов ? Быть может что то я сделал
> не так ?

Перейти на полисинг

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Cisco и полоса пропускания на  CBWFQ"  +/
Сообщение от baronzzz email(??) on 12-Май-12, 07:33 
>[оверквотинг удален]
>> При существование строчек на физических интерфейсах кошки типа service-policy output CBWFQ-ХХ
>> Загрузка проца возрастает в пиках до 80%, хотя потребляемый трафик сумарно 40-60
>> мегобит.
>> При снятие строчек типа service-policy output CBWFQ-ХХ, загрузка вообще шикарная 7-8 и
>> до 20% в пике.
>> ВОПРОС.
>> Есть ли варианты, сниить нагрузку на CPU но при этом не лишиться
>> гарантированных скоростей для клиентов ? Быть может что то я сделал
>> не так ?
> Перейти на полисинг

Почему то не уверен.

Есть мысль, возможно ли:

Сделать шаблоны по 1,2,4,6,8, 10, 16 и 20 Мегобит\с
И по шаблону раздавать т.е. конфиг не раздуеться нагрузка будет меньше...
ЕСть еще варианты ???

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "Cisco и полоса пропускания на  CBWFQ"  +/
Сообщение от baronzzz email(??) on 12-Май-12, 07:36 
>[оверквотинг удален]
>>> ВОПРОС.
>>> Есть ли варианты, сниить нагрузку на CPU но при этом не лишиться
>>> гарантированных скоростей для клиентов ? Быть может что то я сделал
>>> не так ?
>> Перейти на полисинг
> Почему то не уверен.
> Есть мысль, возможно ли:
> Сделать шаблоны по 1,2,4,6,8, 10, 16 и 20 Мегобит\с
> И по шаблону раздавать т.е. конфиг не раздуеться нагрузка будет меньше...
> ЕСть еще варианты ???

П.С. Если шаблонами то как ?


Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "Cisco и полоса пропускания на  CBWFQ"  +/
Сообщение от Merridius (ok) on 12-Май-12, 09:59 
>[оверквотинг удален]
>>>> Есть ли варианты, сниить нагрузку на CPU но при этом не лишиться
>>>> гарантированных скоростей для клиентов ? Быть может что то я сделал
>>>> не так ?
>>> Перейти на полисинг
>> Почему то не уверен.
>> Есть мысль, возможно ли:
>> Сделать шаблоны по 1,2,4,6,8, 10, 16 и 20 Мегобит\с
>> И по шаблону раздавать т.е. конфиг не раздуеться нагрузка будет меньше...
>> ЕСть еще варианты ???
> П.С. Если шаблонами то как ?

1.От размера конфиги, производительность не зависит.
2.А почему нет. пример:

class-map POLICE
match any

policy-map 1M
class POLICE
  police cir 1M

policy-map 2M
class POLICE
  police cir 2M

policy-map 4M
class POLICE
  police cir 4M

и так далее

Если у Вас один абонент = один VLAN, можно и rate-limit исползовать.

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "Cisco и полоса пропускания на  CBWFQ"  +/
Сообщение от baronzzz email(??) on 12-Май-12, 10:16 
>[оверквотинг удален]
>  class POLICE
>   police cir 1M
> policy-map 2M
>  class POLICE
>   police cir 2M
> policy-map 4M
>  class POLICE
>   police cir 4M
> и так далее
> Если у Вас один абонент = один VLAN, можно и rate-limit исползовать.

Да вариант, я только с другой стороны заходил и это было не правильно, то как деалла я уперлось бы в 265. Далее клиентов бы не смог добавлять.

С п.1 согласен я и не к этому.
С п.2 буду пробовать смысл понял.

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

6. "Cisco и полоса пропускания на  CBWFQ"  +/
Сообщение от baronzzz email(??) on 12-Май-12, 10:18 
>[оверквотинг удален]
>> policy-map 4M
>>  class POLICE
>>   police cir 4M
>> и так далее
>> Если у Вас один абонент = один VLAN, можно и rate-limit исползовать.
> Да вариант, я только с другой стороны заходил и это было не
> правильно, то как деалла я уперлось бы в 265. Далее клиентов
> бы не смог добавлять.
> С п.1 согласен я и не к этому.
> С п.2 буду пробовать смысл понял.

Стоп, а разве при таком условии теклиенты котороые подвязаны к
>>  class POLICE
>>   police cir 1M

не будут делить полосу пропускания на всех тах кто в полиси находиться ?

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

7. "Cisco и полоса пропускания на  CBWFQ"  +/
Сообщение от Merridius (ok) on 12-Май-12, 10:43 
>[оверквотинг удален]
>> Да вариант, я только с другой стороны заходил и это было не
>> правильно, то как деалла я уперлось бы в 265. Далее клиентов
>> бы не смог добавлять.
>> С п.1 согласен я и не к этому.
>> С п.2 буду пробовать смысл понял.
> Стоп, а разве при таком условии теклиенты котороые подвязаны к
>>>  class POLICE
>>>   police cir 1M
> не будут делить полосу пропускания на всех тах кто в полиси находиться
> ?

Во-первых у вас один абонент = один влан, соответственно он привязан к своему интерфейсу.
Если нет, то придется описывать каждого класс-мапами, и в одну полиси-мап засовывать.

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

8. "Cisco и полоса пропускания на  CBWFQ"  +/
Сообщение от baronzzz email(??) on 12-Май-12, 11:05 
>[оверквотинг удален]
>>> С п.1 согласен я и не к этому.
>>> С п.2 буду пробовать смысл понял.
>> Стоп, а разве при таком условии теклиенты котороые подвязаны к
>>>>  class POLICE
>>>>   police cir 1M
>> не будут делить полосу пропускания на всех тах кто в полиси находиться
>> ?
> Во-первых у вас один абонент = один влан, соответственно он привязан к
> своему интерфейсу.
> Если нет, то придется описывать каждого класс-мапами, и в одну полиси-мап засовывать.

В указанной Вами схеме, как систему научить различить клиента ? Т.е. какой методикой ? ACL ?

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

9. "Cisco и полоса пропускания на  CBWFQ"  +/
Сообщение от Merridius (ok) on 12-Май-12, 11:10 
>[оверквотинг удален]
>>> Стоп, а разве при таком условии теклиенты котороые подвязаны к
>>>>>  class POLICE
>>>>>   police cir 1M
>>> не будут делить полосу пропускания на всех тах кто в полиси находиться
>>> ?
>> Во-первых у вас один абонент = один влан, соответственно он привязан к
>> своему интерфейсу.
>> Если нет, то придется описывать каждого класс-мапами, и в одну полиси-мап засовывать.
> В указанной Вами схеме, как систему научить различить клиента ? Т.е. какой
> методикой ? ACL ?

Можно и аклами.

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

10. "Cisco и полоса пропускания на  CBWFQ"  +/
Сообщение от baronzzz email(??) on 14-Май-12, 07:03 
>[оверквотинг удален]
>>>>>>  class POLICE
>>>>>>   police cir 1M
>>>> не будут делить полосу пропускания на всех тах кто в полиси находиться
>>>> ?
>>> Во-первых у вас один абонент = один влан, соответственно он привязан к
>>> своему интерфейсу.
>>> Если нет, то придется описывать каждого класс-мапами, и в одну полиси-мап засовывать.
>> В указанной Вами схеме, как систему научить различить клиента ? Т.е. какой
>> методикой ? ACL ?
> Можно и аклами.

Все таки как сделать шаблонами ? Разжуйте пжлст.

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

11. "Cisco и полоса пропускания на  CBWFQ"  +/
Сообщение от Merridius (ok) on 14-Май-12, 09:51 
>[оверквотинг удален]
>>>>>>>   police cir 1M
>>>>> не будут делить полосу пропускания на всех тах кто в полиси находиться
>>>>> ?
>>>> Во-первых у вас один абонент = один влан, соответственно он привязан к
>>>> своему интерфейсу.
>>>> Если нет, то придется описывать каждого класс-мапами, и в одну полиси-мап засовывать.
>>> В указанной Вами схеме, как систему научить различить клиента ? Т.е. какой
>>> методикой ? ACL ?
>> Можно и аклами.
> Все таки как сделать шаблонами ? Разжуйте пжлст.

Может мне еще подъехать и самому все настроить? А вы деньги получите.

Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

12. "Cisco и полоса пропускания на  CBWFQ"  +/
Сообщение от baronzzz email(??) on 14-Май-12, 10:52 
>[оверквотинг удален]
>>>>>> не будут делить полосу пропускания на всех тах кто в полиси находиться
>>>>>> ?
>>>>> Во-первых у вас один абонент = один влан, соответственно он привязан к
>>>>> своему интерфейсу.
>>>>> Если нет, то придется описывать каждого класс-мапами, и в одну полиси-мап засовывать.
>>>> В указанной Вами схеме, как систему научить различить клиента ? Т.е. какой
>>>> методикой ? ACL ?
>>> Можно и аклами.
>> Все таки как сделать шаблонами ? Разжуйте пжлст.
> Может мне еще подъехать и самому все настроить? А вы деньги получите.

Этого не надо, просто принцип.

Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

13. "Cisco и полоса пропускания на  CBWFQ"  +/
Сообщение от root0 (ok) on 14-Май-12, 11:05 
Вообще правильно с бордера снять все эти приблуды и переместить на коммутаторы доступа и резать непосредственно на портах скорость или в крайнем случ через полисинг на L3 коммутаторе

P.S. Без этой всей фигни эта железка может прожевать 600-800М трафика с 2-мя Full View.
А так больше ничего у вас не получится сделать, чем больше сервисов тем меньше скорость и тем больше загрузка CPU

•Provides interactive media services and service virtualization
•Ideal for mid-range deployments needing business agility and collaboration
•Circuit-speed WAN performance up to 75 Mbps , plus variety of services
•1-2 RU modular form factor

Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

14. "Cisco и полоса пропускания на  CBWFQ"  +/
Сообщение от baronzzz email(??) on 14-Май-12, 13:46 
>[оверквотинг удален]
> доступа и резать непосредственно на портах скорость или в крайнем случ
> через полисинг на L3 коммутаторе
> P.S. Без этой всей фигни эта железка может прожевать 600-800М трафика с
> 2-мя Full View.
> А так больше ничего у вас не получится сделать, чем больше сервисов
> тем меньше скорость и тем больше загрузка CPU
> •Provides interactive media services and service virtualization
> •Ideal for mid-range deployments needing business agility and collaboration
> •Circuit-speed WAN performance up to 75 Mbps , plus variety of services
> •1-2 RU modular form factor

ТОго же мнение, посему начал переброс на L3 коммутатор

Ответить | Правка | ^ к родителю #13 | Наверх | Cообщить модератору

15. "Cisco и полоса пропускания на  CBWFQ"  +/
Сообщение от baronzzz email(??) on 19-Май-12, 23:09 
>[оверквотинг удален]
> доступа и резать непосредственно на портах скорость или в крайнем случ
> через полисинг на L3 коммутаторе
> P.S. Без этой всей фигни эта железка может прожевать 600-800М трафика с
> 2-мя Full View.
> А так больше ничего у вас не получится сделать, чем больше сервисов
> тем меньше скорость и тем больше загрузка CPU
> •Provides interactive media services and service virtualization
> •Ideal for mid-range deployments needing business agility and collaboration
> •Circuit-speed WAN performance up to 75 Mbps , plus variety of services
> •1-2 RU modular form factor

Появился вопрос.
Стоит машрутизатор - коммутатор L3 3550, на него и хочу перенести.


Вопрос, Service service-policy вешается только на 1 интерфейс, который смотрит на кошку.
1. Ни как не могу понять куда вешить service-policy второй..
2. ПРи одном service-policy, счетчики на acl не изменяются.


Собственно, если service-policy вешать на кошку, щетчики меняются, но ничего не происходит.

Собственного ни как не могу разобраться...

Может подкинит кто идею ?

Ответить | Правка | ^ к родителю #13 | Наверх | Cообщить модератору

16. "Cisco и полоса пропускания на  CBWFQ"  +/
Сообщение от eek email on 21-Май-12, 07:55 
> Появился вопрос.
> Стоит машрутизатор - коммутатор L3 3550, на него и хочу перенести.
> Вопрос, Service service-policy вешается только на 1 интерфейс,
> который смотрит на кошку.
> 1. Ни как не могу понять куда вешить service-policy второй..

Для того чтобы это понять нужно открыть документацию по железке и увидеть там особенности этой платформы и способы настройки нужных вам функций. Полисит умеет в обе стороны ingress/egress.

> 2. ПРи одном service-policy, счетчики на acl не изменяются.

Если говорим о 3550, то в этих счетчиках вы ничего не увидите, платформа позволяет заказать статистику поинтерфейсно и смотреть её отдельной командой.

> Собственного ни как не могу разобраться...
> Может подкинит кто идею ?

Вам сюда:
http://www.cisco.com/en/US/docs/switches/lan/catalyst3550/so...

Ответить | Правка | ^ к родителю #15 | Наверх | Cообщить модератору

17. "Cisco и полоса пропускания на  CBWFQ"  +/
Сообщение от Галеев Руслан Муллагалиевич email on 21-Май-12, 11:34 
interface GigabitEthernet0/1
rate-limit output 2097152 65536 131072 conform-action transmit exceed-action drop
rate-limit input 2097152 65536 131072 conform-action transmit exceed-action drop
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру