The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

[Solaris] Ultra 10 videomode (solaris video-mode)


<< Предыдущая ИНДЕКС Поиск в статьях src Установить закладку Перейти на закладку Следующая >>
Ключевые слова: solaris, video-mode,  (найти похожие документы)
_ RU.UNIX.SOLARIS (2:5077/15.22) _____________________________ RU.UNIX.SOLARIS _ From : Denis Golubev 2:5020/400 12 Nov 99 21:40:20 Subj : [Solaris] Ultra 10 videomode ________________________________________________________________________________ From: Denis Golubev <dlg@jet.msk.su> >>>>> "Alexey" == Alexey Kuz'michev <alekz@redcenter.ru> writes: Alexey> On Thu, 11 Nov 1999, Serguei Revtov wrote: SR> SR>> SR>> HО, желаемого 1152x900x85x24 (или чего-либо подобного) SR> не SR>> оказалось :((( SR> SR> Am> А это как это? Где не оказалось? В списке, который выдается SR> по words ;-) Если просто нахально написать setenv output-device SR> screen:r1152x900x85x24, то выставляется какой-то режим - даже не SR> тот, который при screen:, а с более низким рефрешем и разрешением. SR> Добрый день. Alexey> А если setenv fcode-debug? true setenv diag-switch? true Alexey> В версия BootPROMa? У нас 3.19. Может в этом дело... Версия OBP ни при чем. Hедавно поднял OBP на Ultra 10 с 3.11.12 до 3.19.4 - Onboard PGX как и раньше в режиме консоли поддерживает только 1152x900x66 и соответственно setenv output-device screen:rXXXXXXXX не работает. Дело в версии PGX/PGX24. ( Ultra 10 самая древняя - 300Mhz/512Kb cache ). У меня есть маленький скриптик :-) : #!/bin/sh PRTCONF='/usr/sbin/prtconf -pv' NAWK=/bin/nawk ${PRTCONF} | grep -v translations | ${NAWK} '/Node/ { i=0; ispr=0; Node=$0; do { getline; qaz[i++]=$0; if ( $0 ~ "device_type:.*display" ) { ispr=1; } } while ( length($0) > 2 ); if ( ispr ) { print Node; for ( j=0; j < i; j++ ) { print qaz[j]; } } }' Что он выдает в полях model, aty,fcode, aty,card#, aty,rom# и pgx_version ? Hа нашей U10 : aty,fcode: 'APL-1.0b36' aty,card#: 'XXX-XXXXX-XX' aty,rom#: '113-37701-106' model: 'ATY,GT-B' name: 'SUNW,m64B' И вот я нашел на U5 поновее : aty,fcode: '1.60' aty,card#: '109-41900-00' aty,rom#: '113-41901-104' model: 'ATY,GT-C' name: 'SUNW,m64B' pgx_version: '@(#)pgx24.fth 1.7 98/11/09 ' Если aty,fcode: '1.60' pgx_version: '@(#)pgx24.fth 1.7 98/11/09 ' имеет смысл поднимать OBP до 3.19.4 - там Fcode 1.7 для PGX24, а APL-1.0b36 ничего не поможет кроме m64config ( но он только для X-сервера ) Alexey> Alekz С уважением, Денис --------------------------------- Denis Golubev, Moscow, Russia Jet Infosystems Technical Staff Phone: (+7 095) 973-48-48 E-mail: dlg@jet.msk.su Fax: (+7 095) 973-48-42 --- ifmail v.2.14dev3 * Origin: Jet Infosystems (2:5020/400)

<< Предыдущая ИНДЕКС Поиск в статьях src Установить закладку Перейти на закладку Следующая >>

 Добавить комментарий
Имя:
E-Mail:
Заголовок:
Текст:




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру