The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  вход/выход  слежка  RSS
"Релиз медиаплеера  Parole 0.9.0, развиваемого прое..."
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Релиз медиаплеера  Parole 0.9.0, развиваемого прое..."  +/
Сообщение от opennews (??) on 12-Фев-17, 09:40 
Проект Xfce представил (https://smdavis.us/2017/02/11/parole-media-player-0-9-0-rele.../) новый выпуск мультимедийного проигрывателя Parole 0.9.0 (http://docs.xfce.org/apps/parole/start), использующего фреймворк GStreamer и библиотеку GTK+. В состав входят плагины для сворачивания в системный лоток, манипуляции метаданными потока, установки своего заголовка окна и блокирования перехода в спящий режим во время просмотра видео.

Особенности новой версии:

-  Добавлен уменьшенный режим, который можно активировать через контекстное меню, вызываемое при клике правой кнопкой мыши;

-  Обеспечен показ больших кнопок начала или возобновления воспроизведения, которые размещены в области отображения содержимого вместо чёрного экрана;

-  Прекращена поддержка устаревших API;

-  При выводе через X11/XV включена двойная буферизация;

-  Текст в заголовке окна теперь включает имя файла, если теги ID3 не найдены;

-  Плагины теперь загружаются по имени (plugin-name.so), а не по полному пути;

-  Обновлены переводы для казахского, русского и украинского языков.

URL: https://smdavis.us/2017/02/11/parole-media-player-0-9-0-rele.../
Новость: https://www.opennet.ru/opennews/art.shtml?num=46032

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +24 +/
Сообщение от Аноним (??) on 12-Фев-17, 09:40 
Фу-х-х-х... Наконец-то количество более или менее аккуратных плееров перевалило за 5 тысяч. А то ведь совершенно не из чего было выбирать!
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  –1 +/
Сообщение от анонимчик on 12-Фев-17, 09:45 
чем он лучше vlc?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

17. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  –6 +/
Сообщение от фвфыв on 12-Фев-17, 11:46 
Ну тот например до сих пор не может субтитры из mkv вытаскивать. По крайней мере под GNU/Linux, под Windows этим всякие там ffdshow занимаются.
Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

50. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +/
Сообщение от Онаним on 12-Фев-17, 19:39 
Всё он умеет. Смотрел в VLC MKV-видос c субтитрами вполне себе.
Ответить | Правка | ^ к родителю #17 | Наверх | Cообщить модератору

65. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +/
Сообщение от Owlet on 12-Фев-17, 20:44 
Ерунда какая-то, vlc даже выбирать из несколько встроенных дорожен субтитров позволяет..
Ответить | Правка | ^ к родителю #17 | Наверх | Cообщить модератору

71. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  –2 +/
Сообщение от Аноним (??) on 12-Фев-17, 21:44 
Зачем минусите? Он писал про Parole, а не VLC.
Ответить | Правка | ^ к родителю #65 | Наверх | Cообщить модератору

83. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +1 +/
Сообщение от Аноним (??) on 13-Фев-17, 12:31 
Мы: Не указывай нам что делать! /s
Ответить | Правка | ^ к родителю #71 | Наверх | Cообщить модератору

3. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +8 +/
Сообщение от Аноним email(??) on 12-Фев-17, 10:30 
опять глючный и убогий GStreamer. Очень трудно самим ffmpeg к плееру самим приделать.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

97. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +/
Сообщение от Аноним (??) on 15-Фев-17, 17:09 
GStreamer-хейтеры и ffmpeg-филы могут последовать туда же, куда и sysvinit-хейтеры и systemd-филы.
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

98. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +/
Сообщение от Michael Shigorin email(ok) on 16-Фев-17, 16:53 
> опять глючный и убогий GStreamer.

Как-то именно parole выручил, когда к конкретному армовому SoC-у видеоакселерация была вендором склёпана только в виде модулей под gst 0.10...

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

4. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +7 +/
Сообщение от Анончик email on 12-Фев-17, 10:43 
Плеер устраивает, но использовал только для проигрывания самого обычного видео, даже звуковую дорожку не выбирал никогда. Интересно следующее: зачем каждому DE свой плеер? Свой блокнот, свой терминал...
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

6. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +3 +/
Сообщение от Аноним (??) on 12-Фев-17, 10:46 
чтобы было в системе меньше зависимостей на другие либы
Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

8. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  –1 +/
Сообщение от Аноним (??) on 12-Фев-17, 10:48 
Потому что ДЕ это _окружение_ рабочего стола, а не голый ВМ. Даже в MATE nemo есть.
Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

39. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +3 +/
Сообщение от Аноним (??) on 12-Фев-17, 16:26 
1. Nemo не плеер.
2. И не из MATE.
3. А вот плеера в MATE как раз нету.
Мимо.
Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

20. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +4 +/
Сообщение от AlexYeCu (ok) on 12-Фев-17, 12:39 
>Интересно следующее: зачем каждому DE свой плеер?

Велосипедисты, сэр.
И кстати, если вы думаете, что «в каждой DE свой плеер» — это очень плохо, то вы отстали от прогресса лет на 10. Сейчас моден подход «в каждой DE свой плеер, который в других DE толком не работает». Привет kde-разрабам.

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

92. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  –1 +/
Сообщение от PnDx (ok) on 14-Фев-17, 11:47 
Если Вы про Kaffeine, оно и в KDE толком не работает. Увы.
До последнего времени минимум вопросов вызывал mpv (на мой вкус, плеер должен просто работать). Однако, с пято-кедами (sddm?) у mpv нетрадиционный секс, приводящий к краху DE. Пока не копал, но похоже он как-то некорректно (с точки зрения DE) отбирает канву в режиме "на весь экран".
Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

95. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  –1 +/
Сообщение от AlexYeCu (ok) on 14-Фев-17, 21:04 
А что с пятокедами не приводит к нетрадиционному сексу? После чехарды с несколькими X-серверами уже и удивляться-то лень…
Ответить | Правка | ^ к родителю #92 | Наверх | Cообщить модератору

40. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +/
Сообщение от Аноним (??) on 12-Фев-17, 16:28 
> Плеер устраивает, но использовал только для проигрывания самого обычного видео, даже звуковую
> дорожку не выбирал никогда. Интересно следующее: зачем каждому DE свой плеер?
> Свой блокнот, свой терминал...

Именно в этом и заключается любое DE. Что не так?

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

42. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +/
Сообщение от Аноним (??) on 12-Фев-17, 17:06 
Чтобы выглядело целостно, блеат. Это называется look-and-feel. И когда что-то выглядит вырвиглазно или явно выделяется из канонов системы / DE, то это всегда неприятно.
Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

47. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +1 +/
Сообщение от Аноним (??) on 12-Фев-17, 18:13 
> Чтобы выглядело целостно, блеат. Это называется look-and-feel. И когда что-то выглядит
> вырвиглазно или явно выделяется из канонов системы / DE, то это
> всегда неприятно.

А создать подходящий скин не позволяют религиозные убеждения, ведь NIH? И что там с браузером, IDE и прочим, cкоро заменят?

Да станет известно латентным маководам и прочим гнумерастам, что главная фишка ДЕ во взаимодействии основного набора приложений между собой, простоты конфигурации и возможности "работы из коробки" сразу после установки, а никак не только и исключительно в цветовых палетах по-феншую.
Ведь очевидно, что даже жирного ДЕ едва хватает на сидение в фейспукотентакликах да смотрение мультиков про поней и поэтому наивно предполагать, что набора приложений из ДЕ, да еще и самосборных велосипедов с квадратными колесами (но феншуйной покраской!), хватит всем и каждому.

Ответить | Правка | ^ к родителю #42 | Наверх | Cообщить модератору

51. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +1 +/
Сообщение от Аноним (??) on 12-Фев-17, 19:57 
> А создать подходящий скин не позволяют религиозные убеждения

Так не про скины речь. А про то, что, скажем, хоткеи одинаковы, контекстные меню одинаковы, меню везде по одной схеме и т.д.

> И что там с браузером

В GNOME Epiphany вполне заменяет.

> IDE

На самом деле GNOME Builder и KDevelop тоже существуют. Но вообще тут да.

> Да станет известно латентным маководам и прочим гнумерастам, что главная фишка ДЕ
> во взаимодействии основного набора приложений между собой, простоты конфигурации и возможности
> "работы из коробки" сразу после установки, а никак не только и
> исключительно в цветовых палетах по-феншую.

Правильно. А каким образом левые сторонние приложения будут взаимодействовать?
А простота заключается в основном в однородности. Если все приложения конфигурируются где попало и как попало, то это не DE.

> Ведь очевидно, что даже жирного ДЕ едва хватает на сидение в фейспукотентакликах
> да смотрение мультиков про поней

Вам виднее. Только проецировать не надо.

Ответить | Правка | ^ к родителю #47 | Наверх | Cообщить модератору

70. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +1 +/
Сообщение от Аноним (??) on 12-Фев-17, 21:29 
> Так не про скины речь. А про то, что, скажем, хоткеи одинаковы, контекстные меню динаковы, меню везде по одной схеме и т.д.

Это и называется взаимодействием.
Ваш КО.

Однако, подпилить менюшки и тем более хоткеи обычно сильно проще, чем создать с нуля хорошее ПО, будь то хоть аудиоплеер, хоть даже навороченный редактор текста.

> В GNOME Epiphany вполне заменяет.

Я не только в курсе, что в KDE Konqueror с khtml/webkit (мидоря в элементари и т.д.), но и про то, что все эти
epiphany, surf, uzbl, xombrero, и т.д. просто обертка вокруг webkitgtk.
И что с плагинами там все довольно печально, а последние пару лет печально становится и с вебом. Падения «на ровном месте», типа страницы битбакета, зависания при поиске на некоторых страницах, не говоря уж о неравильном отображении контента. Погуглить^W searx-ить еще пойдет, но именно как замена gecko/blink gtkшный webkit уже не тянет, про кхтмл и упоминать не стоит.

>> IDE
> На самом деле GNOME Builder и KDevelop тоже существуют.

На самом деле я кдевелопом сам пользуюсь, хоть лет десять уже как не кедовец, но тут не о том. В кедах и разработчиков поболе будет и пилили его лет 15. И так с любым софтом_ чуть сложнее текстового редактора - необходима минимальная пользовательская база и определенный срок существования ПО для доводки и допилки. Не зря вы тут то кеды, то на гном киваете. Куча "уникального" софта в ДЕ - ни то ни се. Хоть leafpad/mousepad, хоть noise https://launchpad.net/noise (плеер пантеона), хоть просмотрщик картинок в каком нибудь LXQT. Про почтовых клиентов или браузеры лучше не упоминать. Сложно представить себе пользователя, меняющего браузер или почтовый клиент с привычного на "ДЕшный". Так же c IDEшками. Или переходящего с более удобной джини на какой-нибудь leafpad только из-за однородности последнего с ДЕ. А еще есть куча мелкого софта, которого вообще нет в ДЕ.

> Правильно. А каким образом левые сторонние приложения будут взаимодействовать?

Мифическим. На самом деле какая-то интеграция идет на уровне тулкита, какая-то на уровне xdg и прочих.
А какие-то особо навороченные сценарии "интеграции" есть только в тяжелом ДЕ типа кед. Да и то, больше на бумаге^W^W в радостных описаниях "как оно может работать, если представить себе вакуумную сферу в коне".

>> Ведь очевидно, что даже жирного ДЕ едва хватает на сидение в фейспукотентакликах
>> да смотрение мультиков про поней
> Вам виднее. Только проецировать не надо.

Что, аргументиков нет и нужно обязательно перейти на личности? Как мило )


Ответить | Правка | ^ к родителю #51 | Наверх | Cообщить модератору

75. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +/
Сообщение от Аноним (??) on 12-Фев-17, 23:00 
> Однако, подпилить менюшки и тем более хоткеи обычно сильно проще, чем создать
> с нуля хорошее ПО, будь то хоть аудиоплеер, хоть даже навороченный
> редактор текста.

Не всегда. Как минимум если оно на другом тулките, то уже нет.

> Я не только в курсе, что в KDE Konqueror с khtml/webkit (мидоря
> в элементари и т.д.), но и про то, что все эти
> epiphany, surf, uzbl, xombrero, и т.д. просто обертка вокруг webkitgtk.

Ну и правильно. А движок-то зачем велосипедить?

> И что с плагинами там все довольно печально, а последние пару лет
> печально становится и с вебом. Падения «на ровном месте», типа страницы
> битбакета, зависания при поиске на некоторых страницах, не говоря уж о
> неравильном отображении контента. Погуглить^W searx-ить еще пойдет, но именно как замена
> gecko/blink gtkшный webkit уже не тянет, про кхтмл и упоминать не
> стоит.

Есть такое, хоть пока и редко. Но тут еще не факт, что именно DE-шные браузеры виноваты. Мака нет, проверить в Safari не могу.
По-хорошему, им бы на Blink переползти, как Qt...

> На самом деле я кдевелопом сам пользуюсь, хоть лет десять уже как
> не кедовец, но тут не о том. В кедах и разработчиков
> поболе будет и пилили его лет 15. И так с любым
> софтом_ чуть сложнее текстового редактора - необходима минимальная пользовательская база
> и определенный срок существования ПО для доводки и допилки. Не зря
> вы тут то кеды, то на гном киваете. Куча "уникального" софта
> в ДЕ - ни то ни се. Хоть leafpad/mousepad, хоть noise
> https://launchpad.net/noise (плеер пантеона), хоть просмотрщик картинок в каком нибудь
> LXQT. Про почтовых клиентов или браузеры лучше не упоминать. Сложно представить
> себе пользователя, меняющего браузер или почтовый клиент с привычного на "ДЕшный".

А вот теперь представьте.
Mozilla/5.0 (X11; Fedora; Linux x86_64) AppleWebKit/603.1 (KHTML, like Gecko) Version/10.0 Safari/603.1 Epiphany/3.22.6
(правда, с X11 наврали, на самом деле тут Wayland)
А вот почтовик таки да. Юзаю Thunderbird, потому что Evolution неюзабелен, а новый клиент в гноме все еще в планах.

> Так же c IDEшками. Или переходящего с более удобной джини на
> какой-нибудь leafpad только из-за однородности последнего с ДЕ. А еще есть
> куча мелкого софта, которого вообще нет в ДЕ.

А до Epiphany/Thunderbird я пользовался SeaMonkey. (потому что до гнома я юзал MATE, и там SeaMonkey был относительно однороден). Решил оставить тормоза только почтовику.
От пары вещей пришлось отвыкнуть, зато браузер летает.
А из IDE я только Android Studio юзаю, ей замены, к сожалению, нет. А под десктоп хватает Gedit-а.

> Мифическим. На самом деле какая-то интеграция идет на уровне тулкита, какая-то на
> уровне xdg и прочих.

Согласен. Но:
1. Только если DE не использует свои надстройки/обертки. Посмотреть на тот же KDE, или, там, elementary — берем любое другое приложение на Qt/GTK3, оно не будет однородным с ними.
2. Если взять UI, то только если тулкит предоставляет только один способ делать интерфейсы.
А то вон взять какое-нибудь новое гномовское приложение (да тот же Epiphany), и взять Evolution, или даже gnome-terminal. Никакой однородности и близко нет.

> А какие-то особо навороченные сценарии "интеграции" есть только в тяжелом ДЕ типа
> кед. Да и то, больше на бумаге^W^W в радостных описаниях "как
> оно может работать, если представить себе вакуумную сферу в коне".

Согласен.

> Что, аргументиков нет и нужно обязательно перейти на личности? Как мило )

Извиняюсь, на автомате вышло.

Ну и да: это все относится именно к "жирным" DE. А приложения типа Parole (на мой взгляд) как раз ближе к DE-независимым.

Ответить | Правка | ^ к родителю #70 | Наверх | Cообщить модератору

76. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  –1 +/
Сообщение от Аноним (??) on 12-Фев-17, 23:57 
Даёшь форк имакса под каждый ДЕ!
Ответить | Правка | ^ к родителю #42 | Наверх | Cообщить модератору

79. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +/
Сообщение от Аноним (??) on 13-Фев-17, 06:27 
> Даёшь форк имакса под каждый ДЕ!

Он и так почти DE.

Ответить | Правка | ^ к родителю #76 | Наверх | Cообщить модератору

86. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +/
Сообщение от Аноним (??) on 13-Фев-17, 14:48 
> Даёшь форк имакса под каждый ДЕ!

выше бери.
http://www.informatimago.com/linux/emacs-on-user-mode-linux.... (Emacs as PID1)


Ответить | Правка | ^ к родителю #76 | Наверх | Cообщить модератору

94. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +/
Сообщение от Аноним (??) on 14-Фев-17, 19:45 
>> Даёшь форк имакса под каждый ДЕ!
> выше бери.
> http://www.informatimago.com/linux/emacs-on-user-mode-linux.... (Emacs
> as PID1)

systemd против emacs!?
Эпическая битва

Ответить | Правка | ^ к родителю #86 | Наверх | Cообщить модератору

5. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  –1 +/
Сообщение от Sluggard (ok) on 12-Фев-17, 10:46 
> Текст в заголовке окна теперь включает имя файла, если теги ID3 не найдены

А в каких плеерах можно выбрать, что отображать — теги или имя файла?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

11. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +/
Сообщение от Sluggard (ok) on 12-Фев-17, 10:55 
А, всё, нашёл опцию show_tag_in_window_title в smplayer.ini
Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

7. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +7 +/
Сообщение от Омномноммномном on 12-Фев-17, 10:48 
MPV наше всё..
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

14. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  –8 +/
Сообщение от anonimbl on 12-Фев-17, 11:37 
SMPlayer получше будет.
Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

15. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +8 +/
Сообщение от Sluggard (ok) on 12-Фев-17, 11:39 
SMPlayer — это фронтенд, который работает с MPlayer или MPV в качестве бэкендов. GUI для консольных плееров, грубо говоря.
Откуда вы такие берётесь в каждой новости о плеерах, а?
Ответить | Правка | ^ к родителю #14 | Наверх | Cообщить модератору

22. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  –6 +/
Сообщение от anonimbl on 12-Фев-17, 12:59 
> SMPlayer — это фронтенд, который работает с MPlayer или MPV в качестве
> бэкендов. GUI для консольных плееров, грубо говоря.
> Откуда вы такие берётесь в каждой новости о плеерах, а?

Откуда ВЫ такие беретесь, которые думают, что кто-то, мать его, не знает, что такое smplayer.

Ответить | Правка | ^ к родителю #15 | Наверх | Cообщить модератору

23. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +4 +/
Сообщение от Sluggard (ok) on 12-Фев-17, 13:01 
> Откуда ВЫ такие беретесь, которые думают, что кто-то, мать его, не знает,
> что такое smplayer.

А, то есть ты просто собезьянничал. Ну извини. )

Ответить | Правка | ^ к родителю #22 | Наверх | Cообщить модератору

35. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +4 +/
Сообщение от Аноним (??) on 12-Фев-17, 14:54 
> Откуда ВЫ такие беретесь, которые думают, что кто-то, мать его, не знает,
> что такое smplayer.

Оттуда же, откуда вы - не знающие что такое smplayer и теперь усиленно делающие вид, что "это такой щютка был, да". Не бойтесь, вам на уроке биологии все расскажут!

Ответить | Правка | ^ к родителю #22 | Наверх | Cообщить модератору

16. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  –1 +/
Сообщение от Аноним (??) on 12-Фев-17, 11:42 
Чем?
Ответить | Правка | ^ к родителю #14 | Наверх | Cообщить модератору

19. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +1 +/
Сообщение от анонимус (??) on 12-Фев-17, 12:13 
Чем mpv
Ответить | Правка | ^ к родителю #16 | Наверх | Cообщить модератору

9. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +/
Сообщение от Аноним (??) on 12-Фев-17, 10:49 
В поддержку ass-сабов все еще не может нормально?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

13. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +4 +/
Сообщение от Аноним (??) on 12-Фев-17, 11:34 
А кто такие ass-сабы ? Это что-то связанное с BDSM ?
Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

25. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +/
Сообщение от Аноним (??) on 12-Фев-17, 13:09 
У кого что болит.
Ответить | Правка | ^ к родителю #13 | Наверх | Cообщить модератору

12. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +/
Сообщение от Аноним (??) on 12-Фев-17, 11:28 
Чего за оформление окон у xfce на скриншотах?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

18. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +/
Сообщение от Аноним (??) on 12-Фев-17, 12:00 
Greybird-accessibility
Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

36. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +2 +/
Сообщение от Аноним (??) on 12-Фев-17, 15:03 
> Чего за оформление окон у xfce на скриншотах?

OMGME (oh my god, my eyes!) или же "сломай свои глаза, читая серое на сером, в плоском".


Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

21. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +2 +/
Сообщение от Аноним (??) on 12-Фев-17, 12:41 
Один горе-дизайнер много лет назад решил, что регулятор громкости должен быть разворачивающийся (из соображений экономии экранного пространства на спичках, не иначе), и теперь все как мартышки повторяют эту глупость.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

24. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +1 +/
Сообщение от Sluggard (ok) on 12-Фев-17, 13:08 
Кто, все? В SMPlayer ползунок, в Kaffeine тоже, в VLC полноценный регулятор.
Да и вообще, пофигу, если на значке регулятора работает скролл колесом.
Ответить | Правка | ^ к родителю #21 | Наверх | Cообщить модератору

27. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +/
Сообщение от Аноним (??) on 12-Фев-17, 13:33 
Все - это фигура речи такая, понимаете? Очень многие, подразумевается, особенно в вебе.
Да и не пофигу, уровень громкости всегда должен быть явно виден.
Ответить | Правка | ^ к родителю #24 | Наверх | Cообщить модератору

28. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +/
Сообщение от Sluggard (ok) on 12-Фев-17, 13:37 
> Да и не пофигу, уровень громкости всегда должен быть явно виден.

Тогда и во всех DE, по-твоему, нужно значок в трее заменить ползунком?
Зачем видеть уровень громкости _всегда_? На мой взгляд, достаточно отображения в момент изменения.

Ответить | Правка | ^ к родителю #27 | Наверх | Cообщить модератору

31. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +2 +/
Сообщение от Аноним (??) on 12-Фев-17, 14:02 
> Зачем видеть уровень громкости _всегда_?

Это, наверное, пишет один из тех чудаков, у которых conky кажут версию ядра, аптайм и прочую сверхважную информацию.

Ответить | Правка | ^ к родителю #28 | Наверх | Cообщить модератору

32. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +1 +/
Сообщение от Sluggard (ok) on 12-Фев-17, 14:15 
> Это, наверное, пишет один из тех чудаков, у которых conky кажут версию
> ядра, аптайм и прочую сверхважную информацию.

Коньки же обычно на рабочем столе, и перекрываются окнами, так что всё равно видны далеко не всегда, да и места полно на рабстоле — пихай что хочешь.

Ответить | Правка | ^ к родителю #31 | Наверх | Cообщить модератору

26. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +/
Сообщение от алекс (??) on 12-Фев-17, 13:15 
Он vdpau умеет? У меня пока smplayer в xfce.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

29. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +/
Сообщение от LinuxID (ok) on 12-Фев-17, 13:54 
SMPlayer наше все.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

30. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  –1 +/
Сообщение от анонимус (??) on 12-Фев-17, 13:57 
Пользуясь случаем, спрошу у знатоков - какой плеер, кроме vls, поддерживает удалённое управление?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

81. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +/
Сообщение от Anonn on 13-Фев-17, 10:53 
Kodi
Ответить | Правка | ^ к родителю #30 | Наверх | Cообщить модератору

82. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  –1 +/
Сообщение от анонимус (??) on 13-Фев-17, 11:17 
Спасибо тебе, добрый человек.
Ответить | Правка | ^ к родителю #81 | Наверх | Cообщить модератору

38. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +2 +/
Сообщение от all_glory_to_the_hypnotoad (ok) on 12-Фев-17, 15:58 
Поставил я это чудо чтобы палочкой потыкать, попробовал открыть какой-то видос и результат меня сильно удивил. Parole заявил что у меня нет нужных кодеков (это нормально) и предложил их установить - ну что это за мастдайный пц?! От разработчкиов xfce такого дeбилизма как-то не ожидаешь. Доустановка, кстати, всё равно не работает.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

41. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +/
Сообщение от Аноним (??) on 12-Фев-17, 16:33 
> Поставил я это чудо чтобы палочкой потыкать, попробовал открыть какой-то видос и
> результат меня сильно удивил. Parole заявил что у меня нет нужных
> кодеков (это нормально) и предложил их установить - ну что это
> за мaстдайный пц?! От разработчкиов xfce такого дeбилизма как-то не ожидаешь.

Где тут дeбилизм? Что должно было произойти?

> Доустановка, кстати, всё равно не работает.

Так отправьте баг, что не работает.

Ответить | Правка | ^ к родителю #38 | Наверх | Cообщить модератору

43. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +/
Сообщение от all_glory_to_the_hypnotoad (ok) on 12-Фев-17, 17:20 
> Где тут дeбилизм? Что должно было произойти?

Это же очевидно - то же самое, что и происходит во всех остальных плеерах, т.е. нужно ненавязчиво предупредить об отсутствии кодека и продолжить работу "как получается".

> Так отправьте баг, что не работает.

Ты идиoт? Мне то эта фича не нужна и хорошо что она не работает - мало ли до какого пц догадаются трaхнутые на голову мастдайники если возьмутся за её допилку. Посыл тут очень простой, хочешь сделать странное и не знаешь как - не делай никак.

Кстати, как ты, упoрoтый мастдайник, предлагаешь допиливать эту фичу для произвольного linux-дистрибутива?

Ответить | Правка | ^ к родителю #41 | Наверх | Cообщить модератору

52. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +/
Сообщение от Аноним (??) on 12-Фев-17, 20:04 
> Это же очевидно - то же самое, что и происходит во всех
> остальных плеерах

Во всех? Totem себя так же ведет, скажем.

> т.е. нужно ненавязчиво предупредить об отсутствии кодека и продолжить работу "как получается".

Что значит продолжить работу? Что он будет показывать, если кодека нет?

>> Так отправьте баг, что не работает.
> Ты идиoт?

О, переход на личности. Значит, хорошо, качественно подгорело.

> Мне то эта фича не нужна

А кто-то под дулом пистолета заставляет ставить ненавистный Parole, искать файлы в хз каких форматах и пытаться проигрывать их, принципиально не ставя кодеков? Это такой особый вид мазохизма, я так понимаю? :)

> хочешь сделать странное и не знаешь как - не делай никак.

Странное? Да нет, совершенно очевидная вещь.
Не знаешь как? Ну вы не знаете, а разработчики тут причем?
Так что мимо.

> предлагаешь допиливать эту фичу для произвольного linux-дистрибутива?

Очевидно, через PackageKit

Ответить | Правка | ^ к родителю #43 | Наверх | Cообщить модератору

77. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +/
Сообщение от freehck email(ok) on 13-Фев-17, 00:35 
>> т.е. нужно ненавязчиво предупредить об отсутствии кодека и продолжить работу "как получается".
> Что значит продолжить работу? Что он будет показывать, если кодека нет?

Ну, если нет декомпрессора для видеопотока, но есть для аудиопотока, то можно запустить только звуковую дорожку.

Ответить | Правка | ^ к родителю #52 | Наверх | Cообщить модератору

78. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  –3 +/
Сообщение от Аноним (??) on 13-Фев-17, 06:25 
> Ну, если нет декомпрессора для видеопотока, но есть для аудиопотока, то можно
> запустить только звуковую дорожку.

Да, можно.
Но тут те же вопросы:
1. А если аудиофайл?
2. Зачем? Мне кажется, это не настолько много кому нужно, чтобы ради этого реализовывать дополнительную логику (Хотя я не знаю, насколько просто/сложно это делается через GStreamer). Тем более, если как минимум часть тех, кому такое нужно, если вообще придут в багтрекер, то придут с криками и матами.

Ответить | Правка | ^ к родителю #77 | Наверх | Cообщить модератору

85. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +/
Сообщение от freehck email(ok) on 13-Фев-17, 14:42 
> 1. А если аудиофайл?

Ну, если никак не получается, то никак и не воспроизводить.

> 2. Зачем?

Ну вот например. Есть контейнер mkv, в нём один видео-поток, и несколько аудио-потоков.
Первый аудиопоток кодирован mp3, остальные flac. Кодеков mp3 в системе не стоит.

В случае сабжа будет выведено предложение перед просмотром поставить
кодеки mp3. Желательное поведение: включить вторую аудио-дорожку, и
начать показ с ней.

Если пользователь захочет попереключаться между дорожками, он
обнаружит, что первая дорожка не открывается, прочитает сообщение об
ошибке, и примет решение о доустановке кодеков из репозитория.

Весь разговор этот о том, что каким пакетам в системе стоять, а каким
нет, должен решать администратор данной системы, и как бы не
проигрывателя это дело, в управление пакетами лезть.

> Мне кажется, это не настолько много кому нужно, чтобы ради этого
> реализовывать дополнительную логику (Хотя я не знаю, насколько
> просто/сложно это делается через GStreamer).

Думаю, это не очень сложно. Во всяком случае не сложнее логики, при
которой нужные кодеки предлагается доустановить непосредственно из
проигрывателя.

> Тем более, если как минимум часть тех, кому такое нужно, если вообще
> придут в багтрекер, то придут с криками и матами.

Согласен. Те, кому такое нужно, до багтрекера вряд ли дойдут.

Ответить | Правка | ^ к родителю #78 | Наверх | Cообщить модератору

89. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +/
Сообщение от Аноним (??) on 13-Фев-17, 21:13 
> Ну вот например

Хороший пример, соглашусь. Тогда имеет смысл поговорить с разработчиками Parole.

Ну а насчет "не проигрывателя это дело" — логика разработчиков такая: если пользователь решил воспроизвести видео, то он хочет его именно воспроизвести. Если кодеков нет, то надо об этом предупредить. Если есть возможность поставить (через PackageKit), то это дополнительное удобство.
В GNOME еще похожим образом предлагаются для установки шрифты при открытии текстовых файлов, содержащих иероглифы/деванагари/еще что.

В любом случае — переубедили, спасибо. :) Тогда компромиссный вариант — "Установить? Да/Нет (некоторые функции могут не работать)"

Ответить | Правка | ^ к родителю #85 | Наверх | Cообщить модератору

90. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +/
Сообщение от freehck email(ok) on 14-Фев-17, 05:23 
> Ну а насчет "не проигрывателя это дело" — логика разработчиков такая: если
> пользователь решил воспроизвести видео, то он хочет его именно воспроизвести. Если
> кодеков нет, то надо об этом предупредить. Если есть возможность поставить
> (через PackageKit), то это дополнительное удобство.

Меня всё-таки смущает, что в этом случае для каждого возможного дистрибутива и кодека должна быть запись в программе, какой пакет ставить. Кто-то же её должен будет вести.

А по поводу дополнительного удобства и...

> В GNOME еще похожим образом предлагаются для установки шрифты при открытии текстовых
> файлов, содержащих иероглифы/деванагари/еще что.

Знаете, я просто гляжу вперёд, и (зная гномопилов) подозреваю, куда всё катится с этим их удобством: "Установить кодеки такие-то? Да/Нет" - "Да" - "Поздравляем, Вы поставили кодеки"! А какие конкретно пакеты поставились - хрен его разберёт.

Я же думаю, не надо на дурака ориентироваться. Чего пользователю стоит переключиться если не в терминал, то хоть бы в тот же Synaptic, и поставить пакеты как полагается? Да, это несколько действий, вместо одного "на кнопочку ок кликнуть", но зато всё наверняка.

> Тогда компромиссный вариант — "Установить? Да/Нет (некоторые функции могут не работать)"

В виду вышесказаноого - без разницы.

Да Вы и сами видите, что весь тред возник от того, что человека (и я его весьма понимаю), очень напряг интерфейс "с ориентацией на дурака". Есть такое чувство неправильной вещи во всём этом.

> В любом случае — переубедили, спасибо. :)

Да всегда пожалуйста.

Ответить | Правка | ^ к родителю #89 | Наверх | Cообщить модератору

93. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  –1 +/
Сообщение от Аноним (??) on 14-Фев-17, 14:10 
> Меня всё-таки смущает, что в этом случае для каждого возможного дистрибутива и
> кодека должна быть запись в программе, какой пакет ставить. Кто-то же
> её должен будет вести.

В идеале — мейнтейнеры дистрибутива при сборке. Скажем, называется пакет по умолчанию gstreamer-plugins-bad, у вас называется по-другому, ну укажите это при сборке.
Как оно реализовано по факту, если честно, не знаю. Может, для этого какая-нибудь логика в PackageKit есть.

> А по поводу дополнительного удобства и...
> Знаете, я просто гляжу вперёд, и (зная гномопилов) подозреваю, куда всё катится
> с этим их удобством: "Установить кодеки такие-то? Да/Нет" - "Да" -
> "Поздравляем, Вы поставили кодеки"! А какие конкретно пакеты поставились - хрен
> его разберёт.

А так оно и есть. Вообще, знать такие вещи действительно бы полезно, чтобы потом можно было эти пакеты удалить, но тут хватит просто истории транзакций в менеджере пакетов, как в DNF. Там можно либо выборочно делать undo/redo отдельных транзакций (если при этом не возникнет проблем с зависимостями), либо полностью откатиться до такого-то состояния.

> Я же думаю, не надо на дурака ориентироваться. Чего пользователю стоит переключиться
> если не в терминал, то хоть бы в тот же Synaptic,
> и поставить пакеты как полагается? Да, это несколько действий, вместо одного
> "на кнопочку ок кликнуть", но зато всё наверняка.

А что в этом такого? Если вы хотите сами поставить кодеки руками, поставьте. :) Никто же не отнимает такую возможность. А вот если вдруг забыли поставить, то плеер напомнит и предложит поставить. Ну и тут же цель, чтобы меньше допиливать после установки. Если есть возможность делать то же с меньшими телодвижениями, то почему бы и нет? Главное, чтоб это не было обязательно, на тот случай, который вы упомянули. И галочка "больше не показывать" не помешает.
Просто можно ту же логику продолжить: зачем нужна автонастройка экранов, чего стоит руками выставить разрешение и частоту? И т.д.

> Да Вы и сами видите, что весь тред возник от того, что
> человека (и я его весьма понимаю), очень напряг интерфейс "с ориентацией
> на дурака". Есть такое чувство неправильной вещи во всём этом.

См. выше. Если хочется все ставить руками, то такая возможность есть.
А брызгать слюнями из-за того, что какой-то плеер, которым человек в любом случае не собирался пользоваться (он же тыкал палочкой, как было сказано), добавил диалог автоустановки кодеков — это даже не перебор, а даже не знаю. Да даже если бы и было это обязательно, то чего-чего, а видеоплееров полно. Тот же mplayer.

Ну т.е. мое мнение: это просто обычная автоматизация действий. Хорошо же, если система может выполнять их автоматически, а не руками. Главное, чтоб ее не навязывали безальтернативно. т.к. все-таки бывают случаи, когда она мешает.

Ответить | Правка | ^ к родителю #90 | Наверх | Cообщить модератору

96. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +/
Сообщение от freehck email(ok) on 15-Фев-17, 14:38 
> В идеале — мейнтейнеры дистрибутива при сборке. Скажем, называется пакет по умолчанию
> gstreamer-plugins-bad, у вас называется по-другому, ну укажите это при сборке.
> Как оно реализовано по факту, если честно, не знаю. Может, для этого
> какая-нибудь логика в PackageKit есть.

Не всегда мейнтейнеры ответственно подходят к своей работе. Вполне может статься, что оно "собралось" -- и мейнтейнеру достаточно. А дистрибутивы не все такие большие, как Debian. В каких-то дистрах неработоспособность этого функционала может всплыть лишь после релиза дистрибутива, что будет весьма обидно.

Далее, пользователь может подключать сторонние репозитории.  debian-backports, debian-multimedia, а в убунточке так и вовсе ppa есть. Вот укажет мейнтейнер пакет, а он подтянется не из того репозитория, или его зависимости неправильно разрезолвятся. А юзеру потом разбираться, что не так пошло, и почему после "успешной установки кодеков" ничего не работает.

Пользователь может выставить отрицательные пины каким-то пакетам, чтобы запретить им ставиться. Это может помешать резолвингу зависимостей. В общем, результат работы этих "простых кнопочек" сильно зависит от множества факторов, которые нельзя предусмотреть заранее.

Сама по себе возможность так поставить доп.пакеты - это не плохо.  Плохо то, что в случае возникновения проблем -- тяжко будет разобраться, что пошло не так. Отсюда возникает устойчивое чувство неправильной вещи.

> Просто можно ту же логику продолжить: зачем нужна автонастройка экранов, чего стоит
> руками выставить разрешение и частоту? И т.д.

Автонастройка экранов? А у меня это... Всё ещё скриптики с xrandr. Работает, не трогаю. :)

> Если хочется все ставить руками, то такая возможность есть.

И я ещё раз повторюсь, что проблема с разгребанием последствий при возникновении ошибок. Вот в том же примере с отрицательными пинами. Как оно поведёт себя в этом случае? А вдруг оно попробует, наподобие аптитуды, выбрать какое-нибудь, по её мнению подходящее, решение проблемы и хоть как-то да поставиться? И при этом она ведь может к тому же попробовать снести полсистемы. Да ну нафиг.

Управление пакетами - это серьёзная задача. Её надо решать инструментами, в которых ты абсолютно уверен.

> Ну т.е. мое мнение: это просто обычная автоматизация действий. Хорошо же, если
> система может выполнять их автоматически, а не руками. Главное, чтоб ее
> не навязывали безальтернативно. т.к. все-таки бывают случаи, когда она мешает.

Моё мнение: оно, конечно, будет, но я этим пользоваться поберегусь. :)

Ответить | Правка | ^ к родителю #93 | Наверх | Cообщить модератору

44. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +/
Сообщение от vi (ok) on 12-Фев-17, 17:35 
>> Поставил я это чудо чтобы палочкой потыкать, попробовал открыть какой-то видос и
>> результат меня сильно удивил. Parole заявил что у меня нет нужных
>> кодеков (это нормально) и предложил их установить - ну что это
>> за мaстдайный пц?! От разработчкиов xfce такого дeбилизма как-то не ожидаешь.
> Где тут дeбилизм? Что должно было произойти?

Должно было произойти следующее: в то же момент должен был появится маркетолух из _подставите_в_этом_месте_название_фирмы_ в наряде снегурочки, и рассказать Вам, что необходимо установить новую версию (чего?, всего, начиная с обновления железа ;)

Ответить | Правка | ^ к родителю #41 | Наверх | Cообщить модератору

46. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  –1 +/
Сообщение от Принц on 12-Фев-17, 18:06 
Шёл 2017 год, кто-то писал софт с использованием GTK+...
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

54. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  –1 +/
Сообщение от Гость (??) on 12-Фев-17, 20:07 
Остальные плееры запрещены?
Ответить | Правка | ^ к родителю #46 | Наверх | Cообщить модератору

72. "Релиз медиаплеера  Parole 0.9.0, развиваемого прое..."  +/
Сообщение от алекс (??) on 12-Фев-17, 22:00 
Сейчас пока промежуточный релиз планируют - 4.14,а дальнейший функционал будет развиваться в 4.16. Надо писать в багтрекер с запросом функционала и попробовать подискутировать с ними.
Ответить | Правка | ^ к родителю #46 | Наверх | Cообщить модератору

67. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  +/
Сообщение от trubulizator (ok) on 12-Фев-17, 20:59 
Так-то ничего, но MPV быстрее всех запускается и быстрее всех перематывает
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

69. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  –1 +/
Сообщение от iZEN (ok) on 12-Фев-17, 21:25 
Xfmedia был поинтереснее.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

84. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  –2 +/
Сообщение от Аноним (??) on 13-Фев-17, 14:28 
Я за смену Лого Linux. Сам Linux с этим пингвином как детская игрушка выглядит.

А детишек - молодых разработчиков разработка ядра уже давно не привлекает.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

91. "Релиз медиаплеера  Parole 0.9.0, развиваемого проектом Xfce"  –1 +/
Сообщение от алекс (??) on 14-Фев-17, 10:26 
Никто окна не трогает, и пингвин тоже не надо трогать, это уже История!
Ответить | Правка | ^ к родителю #84 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру