The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]



"В Rust будет прекращена поддержка старых Linux-систем"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от opennews (??), 01-Авг-22, 21:49 
Разработчики проекта Rust предупредили пользователей о скором повышении требований к окружению Linux в компиляторе, пакетном менеджере  Cargo и стандартной библиотеке libstd. Начиная с версии  Rust 1.64, намеченной на 22 сентября 2022 года, минимальные требования к Glibc будут подняты с версии 2.11 до 2.17, а ядра Linux c 2.6.32 до 3.2. Ограничения также распространяются на исполняемые файлы Rust-приложений, собранных с libstd...

Подробнее: https://www.opennet.ru/opennews/art.shtml?num=57582

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения [Сортировка по времени | RSS]


1. "В Rust будет прекращена поддержка старых Linux-систем"  +24 +/
Сообщение от Аноним (1), 01-Авг-22, 21:49 
Вот для этого его и придумали
Ответить | Правка | Наверх | Cообщить модератору

7. "В Rust будет прекращена поддержка старых Linux-систем"  –9 +/
Сообщение от Аноним (7), 01-Авг-22, 22:09 
Для чего?
Чтобы нельзя было компилять под centos 6 и ubuntu 10.04? Компилять в 23-24 годах (когда на все основные дистры именно эта версия попадет)?
Тебе голову солнышко напекло, деточка?)
Ответить | Правка | Наверх | Cообщить модератору

32. "В Rust будет прекращена поддержка старых Linux-систем"  +4 +/
Сообщение от Бывалый смузихлёб (?), 02-Авг-22, 05:23 
> В C++ будет прекращена поддержка старых Linux-систем

:)

Ответить | Правка | Наверх | Cообщить модератору

212. "В Rust будет прекращена поддержка старых Linux-систем"  +4 +/
Сообщение от анон_тот самый (?), 03-Авг-22, 01:43 
верно подметил. дерьмовый язык если в нем изменения должны касаться версии операционных систем. и правильно подмечено, что си и с++ такого даже представить не могут. там только ограничения на версии компиляторов.
Ответить | Правка | Наверх | Cообщить модератору

328. "В Rust будет прекращена поддержка старых Linux-систем"  +1 +/
Сообщение от Аноним (328), 08-Авг-22, 17:04 
Последняя версия glibc (которая в свою очередь является зависимостью к libstdc++) требует ядро Linux 3.2 или новее.
Пруф: https://sourceware.org/git/?p=glibc.git;a=blob_plain;f=READM...

Так что да, представь себе, современные компиляторы C++ (и их библиотеки) тоже не поддерживают старые ядра.

Ответить | Правка | К родителю #32 | Наверх | Cообщить модератору

213. "В Rust будет прекращена поддержка старых Linux-систем"  +4 +/
Сообщение от Аноним (213), 03-Авг-22, 05:57 
>Для чего?

Чтобы нельзя было компилять под centos 6 и ubuntu 10.04? Компилять в 23-24 годах (когда на все основные дистры именно эта версия попадет)?
Тебе голову солнышко напекло, деточка?)

"Это современный язык программирования, Раст это безопасность" - говорили они. А что сейчас? "Братан, мы решили , что эта версия ядра тебе ненужна". Где сейчас все те умники, которые говорили, что Раст в ядре это хорошо, безопасно и никак не повлияет на его развитие, что это не проприетарный блоб для захвата контроля ядра?! Если это не оно, то что?

Ответить | Правка | К родителю #7 | Наверх | Cообщить модератору

235. "В Rust будет прекращена поддержка старых Linux-систем"  +1 +/
Сообщение от Аноним (-), 04-Авг-22, 15:12 
> Тебе голову солнышко напекло, деточка?)

Прикинь, а на сях можно компилять еще и не под такое. Вебмакаки опять облажались с претензией на системный яп, деточка. Кому надо "системный" яп где софт каждые 2 года превращается в труху как питонятина?

Ответить | Правка | К родителю #7 | Наверх | Cообщить модератору

8. "В Rust будет прекращена поддержка старых Linux-систем"  +11 +/
Сообщение от Аноним (7), 01-Авг-22, 22:10 
Решение принято для упрощения разработки Rust-а, не более. Хороший это подход или нет я не буду судить. Просто не надо очевидное подменять теориями заговоров
Ответить | Правка | К родителю #1 | Наверх | Cообщить модератору

11. "В Rust будет прекращена поддержка старых Linux-систем"  +9 +/
Сообщение от Аноним (11), 01-Авг-22, 22:24 
> для упрощения разработки Rust

а остальное гори синем пламенем

Ответить | Правка | Наверх | Cообщить модератору

17. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Самый Лучший Гусь (?), 01-Авг-22, 23:01 
Слышал когда нибудь о слове - "выбор предпочтительных приоритетов"?
Ответить | Правка | Наверх | Cообщить модератору

22. "В Rust будет прекращена поддержка старых Linux-систем"  +3 +/
Сообщение от Аноним (22), 02-Авг-22, 00:02 
Что «остальное»? Убунты десятилетней давности в следовых количествах встречаются, и там, где их использование оправдано, никакой rust не нужен.
Ответить | Правка | К родителю #11 | Наверх | Cообщить модератору

25. "В Rust будет прекращена поддержка старых Linux-систем"  +2 +/
Сообщение от Аноним (25), 02-Авг-22, 01:01 
Как будто старые версии Раст вычистят из Интернета...
Ответить | Правка | К родителю #11 | Наверх | Cообщить модератору

44. "В Rust будет прекращена поддержка старых Linux-систем"  +1 +/
Сообщение от Аноним (44), 02-Авг-22, 09:12 
Нет, софт, который можно компилировать старыми версиями раста, уже вычищен из интернета. Нужно ещё 32-бита дропнуть. Тоже в целях упрощение сопровождения.
Ответить | Правка | Наверх | Cообщить модератору

157. "В Rust будет прекращена поддержка старых Linux-систем"  +1 +/
Сообщение от ИмяХ (?), 02-Авг-22, 14:25 
>> Нужно ещё 32-бита дропнуть.

Многие дистрибутвы уже давно 32бита дропнули в отличие от маздая

Ответить | Правка | Наверх | Cообщить модератору

268. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (268), 05-Авг-22, 00:53 
> Многие дистрибутвы уже давно 32бита дропнули в отличие от маздая

Дебиан до сих пор 32-бита поддерживает даже на х86, но кроме этого и на архитектурах где маздая не было никогда. Так что пафос не понятен. У винды системные требвоания сейчас сильно выше чем у линукса, если не брать в расчет тухляк типа XP для которой софт не найдешь уже.

Ответить | Правка | Наверх | Cообщить модератору

236. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (-), 04-Авг-22, 15:14 
> Решение принято для упрощения разработки Rust-а, не более.

Очень говорящее об апстриме действо. Что еще они для упрощения своей жизни сделают? Дропнут все кроме ночнушек хруста? Вот еще всякое стабильное майнтайнить, делать устоявшиеся стандарты и проч. А кто не хочет переписывать свой код каждый год ... облажался с выбором ЯП?

Ответить | Правка | К родителю #8 | Наверх | Cообщить модератору

2. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (2), 01-Авг-22, 21:49 
>предложено обновить свои системы, оставаться на старых выпусках компилятора или самостоятельно поддерживать своё ответвление libstd с прослойками для сохранения совместимости.

Обновляйся, оставайся, оболдевайся

Ответить | Правка | Наверх | Cообщить модератору

6. "В Rust будет прекращена поддержка старых Linux-систем"  +6 +/
Сообщение от Аноним (6), 01-Авг-22, 22:03 
Попробуйте язык D, у него есть аж три разных полноценных компилятора, если одна реализация скажет "мы прекратили поддержку ваших старых систем" - ее можно будет выкинуть. Так сказать, наши старые системы прекратили поддержку ваших компиляторов.
Ответить | Правка | Наверх | Cообщить модератору

23. "В Rust будет прекращена поддержка старых Linux-систем"  +2 +/
Сообщение от burjui (ok), 02-Авг-22, 00:41 
Полноценными они будут, когда перестануть падать их стабильные версии, и когда поправят нелепые баги 14-летней давности во фронтенде, который у них общий. А пока можно выкинуть все три компилятора вместе с Ubuntu 12.04, которая нужна только анонам с Опеннета.
Ответить | Правка | Наверх | Cообщить модератору

50. "В Rust будет прекращена поддержка старых Linux-систем"  –1 +/
Сообщение от Аноним (50), 02-Авг-22, 09:49 
А ты продолжай кодить на своём php столетней давности.
Ответить | Правка | Наверх | Cообщить модератору

73. "В Rust будет прекращена поддержка старых Linux-систем"  –1 +/
Сообщение от burjui (ok), 02-Авг-22, 11:29 
Что ты несёшь? За всю жизнь строк сто написал - и то, не по работе.
Ответить | Правка | Наверх | Cообщить модератору

60. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (60), 02-Авг-22, 10:31 
У тебя не срослось с D, что так болезненно реагируешь?
Ответить | Правка | К родителю #23 | Наверх | Cообщить модератору

75. "В Rust будет прекращена поддержка старых Linux-систем"  –3 +/
Сообщение от burjui (ok), 02-Авг-22, 11:35 
Во-первых, не срослось у тысяч. Во-вторых, я не хотел бы, чтобы и другие потратили впустую годы на эту недоделанную фигню, даже если это опеннетчики, которые потом будут гадить в комментарии и разводить демагогию.
Ответить | Правка | Наверх | Cообщить модератору

105. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (105), 02-Авг-22, 12:59 
>  Во-вторых, я не хотел бы, чтобы и другие потратили впустую годы на эту недоделанную фигню

И хотель бы что бы они потратили годы на rust.

Хитро.

Если с D годы тратить не получиться, то rust'ом без проблем.

Ответить | Правка | Наверх | Cообщить модератору

133. "В Rust будет прекращена поддержка старых Linux-систем"  +1 +/
Сообщение от Vindex (?), 02-Авг-22, 13:40 
Я потратил уже 7 лет, пока останавливаться не планирую
Ответить | Правка | К родителю #75 | Наверх | Cообщить модератору

150. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от burjui (ok), 02-Авг-22, 14:11 
Искренне рад, что у тебя всё работает.
Ответить | Правка | Наверх | Cообщить модератору

237. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (-), 04-Авг-22, 15:15 
> Полноценными они будут, когда перестануть падать их стабильные версии, и когда поправят
> нелепые баги 14-летней давности во фронтенде, который у них общий. А
> пока можно выкинуть все три компилятора вместе с Ubuntu 12.04, которая
> нужна только анонам с Опеннета.

Знаешь что, умник, твои ерничания не выглядят убедительно когда тима озвучила свою линию. Этак они много чего еще "для упрощения разработки сделают". Перевалив все свои проблемы на неудачников которые в это вляпались.

Ответить | Правка | К родителю #23 | Наверх | Cообщить модератору

249. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от burjui (ok), 04-Авг-22, 15:55 
Вот интересно, почему от этой новости горит жопа у тех, кто даже не пишет на Rust?
Ответить | Правка | Наверх | Cообщить модератору

269. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (-), 05-Авг-22, 01:10 
Сабжевая новость - хороший хинт на тему почему сабжем лучше, наверное, не пользоваться. Черт его там знает что еще для упрощения жизни они захотят. Скажут, мол, качайте безопасТные curl | sh ночнушки - а остальное unsupported.

Хотя для проектов toy programming language - сойдет, конечно. Там кодер на проект положит до того как вон то станет проблемой. Потому что кодить 1 прогу за всю жизнь - не очень круто, а когда всех надо постоянно подпатчивать там и тут, т.к. там и тут всякие няши-питоняши себе в очередной раз жизнь упростить решили - свободное время почему-то сливается на страдание фигней с борьбой с искусственными проблемами. И потом эти тела еще что-то вещают про high productive blah-doh-something, insert buzzword here.

Ответить | Правка | Наверх | Cообщить модератору

74. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (74), 02-Авг-22, 11:34 
D на порядки тормознее Раста
Ответить | Правка | К родителю #6 | Наверх | Cообщить модератору

138. "В Rust будет прекращена поддержка старых Linux-систем"  –2 +/
Сообщение от Аноним (138), 02-Авг-22, 13:57 
Зачем учить язык для которого нет работы?
Ответить | Правка | К родителю #6 | Наверх | Cообщить модератору

9. "В Rust будет прекращена поддержка старых Linux-систем"  +5 +/
Сообщение от Аноним (9), 01-Авг-22, 22:12 
У кого-то из вас 2.6.32? :)
Ответить | Правка | Наверх | Cообщить модератору

18. "В Rust будет прекращена поддержка старых Linux-систем"  +2 +/
Сообщение от Аноним (-), 01-Авг-22, 23:07 
> У кого-то из вас 2.6.32? :)

Это опеннет. Т.е. у особо негодующих скорее всего 10.0.19044.1865 :)

https://www.opennet.ru/opennews/art.shtml?num=44919
> Релиз системной библиотеки Glibc 2.24
> 05.08.2016 08:46
> Подняты требования к минимальной версии ядра Linux. Для работы Glibc на архитектурах, отличных от x86 и x86_64 теперь требуется ядро Linux 3.2 или более новый выпуск. Для систем x86 и x86_64 возможна работа с ядром 2.6.32. Для сборки на любых архитектурах требуются заголовочные файлы от ядра 3.2 или новее;

Ответить | Правка | Наверх | Cообщить модератору

21. "В Rust будет прекращена поддержка старых Linux-систем"  +3 +/
Сообщение от hefenud (ok), 01-Авг-22, 23:39 
Linux XXXX 2.6.32-042stab145.3 #1 SMP Thu Jun 11 14:05:04 MSK 2020 x86_64 x86_64 x86_64 GNU/Linux

У меня такая беда :-D

Но тут ничего сделать я сам не могу. Это OpenVZ-таз и вопрос к хостеру(когда последний раз писал хостеру тот разводил руками и говорил, что обновлять хосты этих тазов планов нет)

В целом жить это не мешает, стоит Ubuntu 16.04, подключен ESM и обновления безопасности приходят. Не думаю, что меня как-то заденет тот факт, что свежий раст не будет со мной дружить

Ответить | Правка | К родителю #9 | Наверх | Cообщить модератору

26. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (9), 02-Авг-22, 01:35 
А што за хостер? Просто официальных фиксов для 2.6.32 больше нет :D
Ответить | Правка | Наверх | Cообщить модератору

185. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от hefenud (ok), 02-Авг-22, 16:12 
Ну вот есть такой. У них дешевые storage VPS, 1Tb места за 60 евро в год, но вот такая вот беда, что ядро 2.6.32 и соответственно нельзя поставить в таз ничего свежей Ubuntu 16.04 или соответствующего CentOS
Ответить | Правка | Наверх | Cообщить модератору

200. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (200), 02-Авг-22, 17:49 
1Tb за 60€ в год — это безумно дорого.
Ответить | Правка | Наверх | Cообщить модератору

210. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от hefenud (ok), 02-Авг-22, 22:40 
Нет, учитывая, что при этом у тебя тазик с 2 гигами рама на котором ты крутишь еще то что тебе нужно, от LEMP до shadowsocks
Ответить | Правка | Наверх | Cообщить модератору

271. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (-), 05-Авг-22, 01:27 
Одноплатник с терабайтником будет не хуже по всем параметрам да еще сможет wireguard'а. А 60 евро на электричестве он навверное за всю мою жизнь не сожрет.
Ответить | Правка | Наверх | Cообщить модератору

322. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от hefenud (ok), 06-Авг-22, 19:08 
Мне нужно хранилище в цивилизованной стране и при этом стране отличной от моего местонахождения. Я нашел достаточно дешевого хостера в стране в которую не планирую ближайшие годы
Увы, но коло было бы дороже, а так я бы с радостью поставил малинку с хардом тера на 4 в той же стране
Ответить | Правка | Наверх | Cообщить модератору

239. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (-), 04-Авг-22, 15:24 
> А што за хостер? Просто официальных фиксов для 2.6.32 больше нет :D

Openvz как бы проблемный по части новых ядер. Они не поспевали патчи портировать на майнлайн, на чем и сдулись.

Ответить | Правка | К родителю #26 | Наверх | Cообщить модератору

29. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от ДаНуНафиг (?), 02-Авг-22, 04:07 
Даже если у кого-то это еще есть, вряд ли под это развернется разработка хоть чего-то в ближайшее время. Да и в прошлые пару лет вряд ли кто-то что-то написал, чтобы сейчас реально было больно от прекращения сопровождения.
Ответить | Правка | К родителю #21 | Наверх | Cообщить модератору

188. "В Rust будет прекращена поддержка старых Linux-систем"  +1 +/
Сообщение от hefenud (ok), 02-Авг-22, 16:13 
> Даже если у кого-то это еще есть, вряд ли под это развернется
> разработка хоть чего-то в ближайшее время. Да и в прошлые пару
> лет вряд ли кто-то что-то написал, чтобы сейчас реально было больно
> от прекращения сопровождения.

Дык и я о том же. Вот я с 2.6.32 и меня явно не заденет эта новость. Правильно делают, что выкидывают легаси, что бы не тратить время на сопровождение

Ответить | Правка | Наверх | Cообщить модератору

37. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (37), 02-Авг-22, 09:01 
> У кого-то из вас 2.6.32?

На половине роутеров и прочих embedded.

Ответить | Правка | К родителю #9 | Наверх | Cообщить модератору

41. "В Rust будет прекращена поддержка старых Linux-систем"  +3 +/
Сообщение от Аноним (41), 02-Авг-22, 09:08 
>На половине роутеров и прочих embedded

На которых просто не обойтись без рабочего Rust-тулчейна :D

Ответить | Правка | Наверх | Cообщить модератору

80. "В Rust будет прекращена поддержка старых Linux-систем"  +1 +/
Сообщение от Аноним (37), 02-Авг-22, 11:53 
Почему бы тогда и везде не обойтись без него?
Ответить | Правка | Наверх | Cообщить модератору

140. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (138), 02-Авг-22, 13:59 
Везде и обходятся, разве что на стек оверфлоу очень любят
Ответить | Правка | Наверх | Cообщить модератору

240. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (-), 04-Авг-22, 15:25 
> На которых просто не обойтись без рабочего Rust-тулчейна :D

Вообще от системного яп ожидается универсальность, а не полисовка куда и как ходить.

Ответить | Правка | К родителю #41 | Наверх | Cообщить модератору

62. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (60), 02-Авг-22, 10:48 
В OpenWRT уж 5.4 как.
Ответить | Правка | К родителю #37 | Наверх | Cообщить модератору

64. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (64), 02-Авг-22, 10:58 
Ты же в курсе что в 2.6.32 есть RCE в сетевом стеке, которые уже никто никогда не закроет, потому что поддержку дропнули?
Ответить | Правка | К родителю #37 | Наверх | Cообщить модератору

241. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (-), 04-Авг-22, 15:27 
> Ты же в курсе что в 2.6.32 есть RCE в сетевом стеке,
> которые уже никто никогда не закроет, потому что поддержку дропнули?

Может вон те штуки вообще в сеть не высовываются? Или это пропатчено/неэксплуатируемо на конкретной платформе. Это уж точно не той команде смузихлебов решать, много на себя берут.

Ответить | Правка | Наверх | Cообщить модератору

263. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Ананимус (?), 04-Авг-22, 18:58 
>> Ты же в курсе что в 2.6.32 есть RCE в сетевом стеке,
>> которые уже никто никогда не закроет, потому что поддержку дропнули?
> Может вон те штуки вообще в сеть не высовываются? Или это пропатчено/неэксплуатируемо
> на конкретной платформе. Это уж точно не той команде смузихлебов решать,
> много на себя берут.

А разработчики glibc? Они тоже смузихлебы?

Ответить | Правка | Наверх | Cообщить модератору

272. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (-), 05-Авг-22, 01:28 
На вон тех glibc особо никто и не пользуется. Сабж что, к glibc прибит на гвозди?
Ответить | Правка | Наверх | Cообщить модератору

287. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Ананимус (?), 05-Авг-22, 07:19 
Нет, ты можешь использовать другие libc.
Ответить | Правка | Наверх | Cообщить модератору

288. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Ананимус (?), 05-Авг-22, 07:21 
Но речь не об этом. Рестрикшон на ядро идёт от glibc, почему опеннетчики не истерят по этому поводу и не называют разработчиков glibc смузихлебами? :D
Ответить | Правка | К родителю #272 | Наверх | Cообщить модератору

292. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (-), 05-Авг-22, 10:02 
> Но речь не об этом. Рестрикшон на ядро идёт от glibc, почему
> опеннетчики не истерят по этому поводу и не называют разработчиков glibc
> смузихлебами? :D

Потому что "Вынепонимаете! Этодругое!"™©®

Ответить | Правка | Наверх | Cообщить модератору

305. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (-), 05-Авг-22, 21:13 
> Но речь не об этом. Рестрикшон на ядро идёт от glibc, почему
> опеннетчики не истерят по этому поводу и не называют разработчиков glibc
> смузихлебами? :D

Так вон то хрустики анонсировали. Им что, другой libc будет не комильфо?

Ответить | Правка | К родителю #288 | Наверх | Cообщить модератору

43. "В Rust будет прекращена поддержка старых Linux-систем"  +5 +/
Сообщение от Igor (??), 02-Авг-22, 09:10 
Ну у меня на работе на одном объекте 2.0.36 ядро на 10 компах. И никто их обновлять не собирается - это АСУТП. Еще на нескольких объектах - ядро 2.6.37 (это Слакварь 13.37).
Я рад, что ржавчина не будет больше работать на таких системах!
Ответить | Правка | К родителю #9 | Наверх | Cообщить модератору

94. "В Rust будет прекращена поддержка старых Linux-систем"  –1 +/
Сообщение от burjui (ok), 02-Авг-22, 12:37 
Зря радуешься - Perl всё ещё работает, и там закорючек в синтаксисе ещё больше, а мы все знаем по комментариям местных хейтерков вроде тебя, что это главный недостаток в языке.
Ответить | Правка | Наверх | Cообщить модератору

111. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (105), 02-Авг-22, 13:04 
> Зря радуешься - Perl

Не зря.

Главный недостаток это карго и остутствие поддержки старых версий.

Ответить | Правка | Наверх | Cообщить модератору

152. "В Rust будет прекращена поддержка старых Linux-систем"  –1 +/
Сообщение от burjui (ok), 02-Авг-22, 14:14 
Cargo никто не заставляет пользоваться: хочешь - вызывай rustc вручную, а зависимости копируй в проект. Да и компилятор с поддержкой старых версий никто не мешает поставить.
Ответить | Правка | Наверх | Cообщить модератору

163. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (105), 02-Авг-22, 14:38 
> Cargo никто не заставляет пользоваться: хочешь - вызывай rustc вручную, а зависимости копируй в проект. Да и компилятор с поддержкой старых версий никто не мешает поставить.

Вот только большинство сторонних наработок используют карго. А без них гол как сокол.

А компиляторы старых версий патчить от дыр не хотят.

Ответить | Правка | Наверх | Cообщить модератору

169. "В Rust будет прекращена поддержка старых Linux-систем"  –1 +/
Сообщение от burjui (ok), 02-Авг-22, 14:59 
> Вот только большинство сторонних наработок используют карго. А без них гол как
> сокол.

А большинство проектов на C используют make и всякие autoconf, но при этом ещё есть cmake, meson, ninja и т.д. И ничего, пользуются как-то этим зоопарком. А тут всего одна система сборки, это же намного удобнее. Так а в чём заключаются недостатки Cargo конкретно для тебя?

> А компиляторы старых версий патчить от дыр не хотят.

Язык быстро развивается, новые версии выходят часто, потому старые версии и не поддерживают - их слишком много. Вот когда язык устаканится и обрастёт жиром, как C++, тогда и будут всякие LTS-версии. А сейчас это делать не стоит - только хуже будет.

Ответить | Правка | Наверх | Cообщить модератору

217. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (105), 03-Авг-22, 14:13 
> Так а в чём заключаются недостатки Cargo конкретно для тебя?

В том что для сборки сторонних модулей, которые вроде бы можно использовать, он скачивает все зависимости, вместо использования тех, что установлены в системе.

Такое верифицировать невозможно. Особенно когда начинают параллельно несколько версий одного и того же работать.

Ответить | Правка | Наверх | Cообщить модератору

224. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Ф1 (?), 04-Авг-22, 08:20 
>В том что для сборки сторонних модулей, которые вроде бы можно использовать, он скачивает все зависимости,

Он может без проблем работать с локальным репозиторием.
Так же есть cargo vendor который скачивает все зависимости и дальше можно работать полностью офлайн.

Ответить | Правка | Наверх | Cообщить модератору

228. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (105), 04-Авг-22, 13:39 
Вот только это не то, что нужно. Нужно не работать со скачанным. А работать с установленным в систему.

И это должно быть мейнстримом.

А что бы такое стало мейнстримом надо дропнуть карго. И в каргно добавть необходимую функциональность а скачивание дропнуть.

Но тут есть проблема. У языка слабо развиты возможности работать с разными версиями одной библиотеки, если API менялось.

Поэтому и идет заточка на скачивание использованного в проекте.

Ответить | Правка | Наверх | Cообщить модератору

264. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Ананимус (?), 04-Авг-22, 19:05 
> Вот только это не то, что нужно. Нужно не работать со скачанным.
> А работать с установленным в систему.
> И это должно быть мейнстримом.
> А что бы такое стало мейнстримом надо дропнуть карго. И в каргно
> добавть необходимую функциональность а скачивание дропнуть.
> Но тут есть проблема. У языка слабо развиты возможности работать с разными
> версиями одной библиотеки, если API менялось.
> Поэтому и идет заточка на скачивание использованного в проекте.

Не, заточка идет не поэтому. Заточка идет потому что за последние двадцать лет всех изрядно достала ситуация, когда клоуны из редхата или дебиана фиксируют версию библиотеки (одну на всю систему, да) и пуская слюни рассказывают что она такой останется двадцать лет. А пользователи ходят и ноют что новых версий нет памагите и репортят баги для старого и уже давно неподдерживаемого релиза. В итоге все современные языки (включая плюсы, да) так или иначе ориентируются на подтягивание зависимостей.

Ответить | Правка | Наверх | Cообщить модератору

297. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (105), 05-Авг-22, 13:28 
> В итоге все современные языки (включая плюсы, да) так или иначе ориентируются на подтягивание зависимостей.

Какой проект идущий в дистрибутивах подтягивает зависимости?

Все что я вижу. Ито подтягивание зависимостей для воспроизведения тестов на начально этапе разработки.

Дальше идет работа по адаптации ко всем версиям библиотек во всех действующих дистрибутвах.

И тестирования в них.

Вот этот этап напрочь отсутсвует в расте. Именно из-за проблем с организацией этого.

Ответить | Правка | Наверх | Cообщить модератору

299. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Ананимус (?), 05-Авг-22, 15:22 
> Вот этот этап напрочь отсутсвует в расте. Именно из-за проблем с организацией этого.

И в Go. И в Python с недавних пор. Firefox, Chrome, LibreOffice за собой тоже таскают либы. ВНЕЗАПНО авторам софта не очень хочется возиться с сотнями дистрибутивов и их зависимостями.

Ответить | Правка | Наверх | Cообщить модератору

300. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (105), 05-Авг-22, 17:01 
Показать вывод ldd для libreoffice?

То что часть зависимостей таскают - это да. Но лишь часть. И то это дополнительный труд. Поэтому при возможности начинают использовать системные.

Накой чудую работы выполнять?

Ответить | Правка | К родителю #299 | Наверх | Cообщить модератору

302. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Ананимус (?), 05-Авг-22, 17:24 
> То что часть зависимостей таскают - это да. Но лишь часть. И то это дополнительный труд. Поэтому при возможности начинают использовать системные. Накой чудую работы выполнять?

Все очень просто! Прикинь, ты пишешь софт для чтения комиксов про голых баб. Тебе нужна библиотека рендеринга голых баб. Ты её качаешь из пакетного репозитория, собираешь свой софт локально на своей любимой убанте и все ок. После чего ты делаешь релиз.

А потом начинается ад. Потому что к тебе приходят из стабильного дебиана и начинают ныть твой патченый-перепатченный софт у них не работает. Ты лезешь смотреть что происходит и выясняется, что там либа для отрисовки голых баб ппц старой версии и ты с ней даже не проверял. То же самое происходит с кучей других дистров.

Тебе, автору программы для отрисовки голых баб, все это нужно? Нет. Поэтому ты просто берешь Go, делаешь статическую сборку которая у всех одинаковая и тебе хорошо. С Rust'ом та же история.

Ответить | Правка | К родителю #300 | Наверх | Cообщить модератору

331. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (105), 10-Авг-22, 15:49 
> Тебе, автору программы для отрисовки голых баб, все это нужно? Нет. Поэтому ты просто берешь Go, делаешь статическую сборку которая у всех одинаковая и тебе хорошо. С Rust'ом та же история.

А потом тебя достают, что твоя библиотека с дырой и надо бы персобрать.

Что в убунте пофиксили рисование теней, а в твоей библиотеке этого нет.

И еще сотню разных.

Хотя для отрисвоки тут всего меньше. Но вот с обменом через какие-либо протоколы - полный швах.

Ответить | Правка | К родителю #302 | Наверх | Cообщить модератору

332. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Ананимус (?), 10-Авг-22, 21:54 
> А потом тебя достают, что твоя библиотека с дырой и надо бы персобрать.

А это все бот на gtihub'е за тебя делает.

> Что в убунте пофиксили рисование теней, а в твоей библиотеке этого нет.

Скорее будет наоборот :D Но по факту это реально решается ботом на гейхабе, который сам тупо проверяет не сильно либо у тебя отсосный релиз и тупо пересобирает если надо, прогоняя через CI.

Ответить | Правка | К родителю #331 | Наверх | Cообщить модератору

242. Скрыто модератором  +/
Сообщение от Аноним (242), 04-Авг-22, 15:32 
Ответить | Правка | К родителю #169 | Наверх | Cообщить модератору

250. Скрыто модератором  +/
Сообщение от burjui (ok), 04-Авг-22, 16:02 
Ответить | Правка | Наверх | Cообщить модератору

273. Скрыто модератором  –1 +/
Сообщение от Аноним (-), 05-Авг-22, 01:36 
Ответить | Правка | Наверх | Cообщить модератору

293. Скрыто модератором  +/
Сообщение от Аноним (-), 05-Авг-22, 10:23 
Ответить | Правка | Наверх | Cообщить модератору

311. Скрыто модератором  +/
Сообщение от Аноним (-), 05-Авг-22, 22:58 
Ответить | Правка | Наверх | Cообщить модератору

312. Скрыто модератором  +1 +/
Сообщение от Аноним (-), 05-Авг-22, 23:31 
Ответить | Правка | Наверх | Cообщить модератору

306. Скрыто модератором  +/
Сообщение от Аноним (306), 05-Авг-22, 21:24 
Ответить | Правка | К родителю #250 | Наверх | Cообщить модератору

304. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Ананимус (?), 05-Авг-22, 19:15 
> Может, стоило бы уволить вебмакак, и наконец начать сначала проектировать а потом
> кодить? Пока что сделали образцовое месиво с дизайном "а давайте засунем
> сюда все кульные шняги и баззворды". Проблема этого паттерна проектирования в
> том что проект все больше напоминает свалку костылей и, вот, начинает
> скатываться в эксплуатационные проблемы "типа питон".

А теперь читаем мейнтейнеров ядра:

On Tue, Aug 2, 2022 at 4:01 PM Matthew Wilcox <willy@infradead.org> wrote:
>
> No objections to any of this.  I love the idea of being able to write
> filesystems in Rust.

Почему-то мейнейнерам ядра нравится идея писать FS на Rust. Как же так-то, а, вебмакаки же, ну?

Ответить | Правка | К родителю #242 | Наверх | Cообщить модератору

307. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (-), 05-Авг-22, 21:30 
Так это, сама идея может и ничего. Если вебмакачьи замашки выбить. А вон тот кадр, кстати, не так давно был @microsoft.com если что. Поэтому что там у него на уме это сильно отдельный вопрос.
Ответить | Правка | Наверх | Cообщить модератору

55. "В Rust будет прекращена поддержка старых Linux-систем"  –1 +/
Сообщение от Аноним (55), 02-Авг-22, 10:00 
Я даже знаю человека, который люто полирует свой жезл на 2.6.* ядро. Очень любит.
Ответить | Правка | К родителю #9 | Наверх | Cообщить модератору

68. "В Rust будет прекращена поддержка старых Linux-систем"  +1 +/
Сообщение от torvn77 (ok), 02-Авг-22, 11:21 
>У кого-то из вас 2.6.32? :)

Думаю что на серверах такое вполне возможно.

Ответить | Правка | К родителю #9 | Наверх | Cообщить модератору

77. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (64), 02-Авг-22, 11:37 
Серверах чего? Мы тут боремся за каждый иопс, а они 2.6.32 предлагают с Big Kernel Lock.
Ответить | Правка | Наверх | Cообщить модератору

116. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (105), 02-Авг-22, 13:09 
АСУТП. Которая еще лет двадцать проработает.
Ответить | Правка | Наверх | Cообщить модератору

135. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Ананимус (?), 02-Авг-22, 13:51 
Если к ней есть возможность удаленного доступа, то это дыра. Если нету, то на ней не нужно ничего нового, она окуклилась и ей ок. С чего батхерт-то? :)
Ответить | Правка | Наверх | Cообщить модератору

165. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (105), 02-Авг-22, 14:40 
> Если нету, то на ней не нужно ничего нового

В корне неверная информация.

Доработки периодически нужны.

Ответить | Правка | Наверх | Cообщить модератору

175. "В Rust будет прекращена поддержка старых Linux-систем"  +1 +/
Сообщение от Ананимус (?), 02-Авг-22, 15:30 
>> Если нету, то на ней не нужно ничего нового
> В корне неверная информация.
> Доработки периодически нужны.

А чо мешает заодно ядро-то обновить? А то потом выяснится, что нужна новая программа, а она хочет новой glibc. А новый glibc, внезапно, тоже хочет 3.2.

Ответить | Правка | Наверх | Cообщить модератору

198. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Igor (??), 02-Авг-22, 17:24 
Никто не хочет присесть в тюрьму, если АСУТП начнет криво работать и виснуть на новом ядре! Одно дело, новую отчетную форму добавить на АРМе, и совсем другое - поменять ядро на управляющих контроллерах.
Ответить | Правка | Наверх | Cообщить модератору

199. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Ананимус (?), 02-Авг-22, 17:36 
А если чип сдохнет в процессе работы? Тебя тоже посадят?
Ответить | Правка | Наверх | Cообщить модератору

203. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от torvn77 (ok), 02-Авг-22, 19:14 
> А если чип сдохнет в процессе работы? Тебя тоже посадят?

Кто знает?...

Ответить | Правка | Наверх | Cообщить модератору

207. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Ананимус (?), 02-Авг-22, 19:34 
>> А если чип сдохнет в процессе работы? Тебя тоже посадят?
> Кто знает?...

Ну вот это отличный пример как НЕ НАДО проектировать системы. Потому что чипы дохнут налево и направо, память дохнет налево и направо, сторадж дохнет вообще ударными темпами. Если безопасность других  зависит исключительно от того, свалится ли сегодня ядро в панику, то ты баклажан.

Ответить | Правка | Наверх | Cообщить модератору

234. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от torvn77 (ok), 04-Авг-22, 14:45 
>>> А если чип сдохнет в процессе работы? Тебя тоже посадят?
>> Кто знает?...
>
>Если безопасность других  зависит исключительно от
> того, свалится ли сегодня ядро в панику, то ты баклажан.

Так вопрос не в том, что сделают программист и инженер, а что будет в голове у начальника, позиция "я только писал докладные и ничего не трогал, просто вышел срок эксплуатации" может оказаться просто безопаснее, чем ежели единожды вызвал аварию единственной за много лет, причём не своей, ошибкой.

Ответить | Правка | Наверх | Cообщить модератору

244. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (244), 04-Авг-22, 15:45 
Даже с нормальным начальником будет характерный риск: вон то ядро за десятилетия проверено что стабильно. А более новое - если оно раз в год дуреет, вы это сразу не отловите, а потом уже поздняк. Вы же врядли будете пяток лет тестировать апгрейд ядра? Тем более за это время вон те и его легаси объявят как раз. Для упрощения разработки - но не вам.
Ответить | Правка | Наверх | Cообщить модератору

248. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Ананимус (?), 04-Авг-22, 15:54 
>>>> А если чип сдохнет в процессе работы? Тебя тоже посадят?
>>> Кто знает?...
>>
>>Если безопасность других  зависит исключительно от
>> того, свалится ли сегодня ядро в панику, то ты баклажан.
> Так вопрос не в том, что сделают программист и инженер, а что
> будет в голове у начальника, позиция "я только писал докладные и
> ничего не трогал, просто вышел срок эксплуатации" может оказаться просто безопаснее,
> чем ежели единожды вызвал аварию единственной за много лет, причём не
> своей, ошибкой.

Ну... не работай в говноконторе? Кто тебя заставляет-то.

Ответить | Правка | Наверх | Cообщить модератору

258. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от torvn77 (ok), 04-Авг-22, 18:26 

> Ну... не работай в говноконторе? Кто тебя заставляет-то.

А может проще не делать апдейтов там, где эти апдейты не нужны?

Ответить | Правка | К родителю #248 | Наверх | Cообщить модератору

260. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Ананимус (?), 04-Авг-22, 18:42 
>> Ну... не работай в говноконторе? Кто тебя заставляет-то.
> А может проще не делать апдейтов там, где эти апдейты не нужны?

Проще не работать в конторе, где тебя посадят, если линукс зависнет.

Ответить | Правка | К родителю #258 | Наверх | Cообщить модератору

282. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (-), 05-Авг-22, 02:11 
> Проще не работать в конторе, где тебя посадят, если линукс зависнет.

Не все же вебмакакингом заканчивается. Вон тот RT_LINUX явно не для вебмакак делают. А что, вы бы не хотели чтобы ваш код смог пилотировать аж к другой планете, например? А вон Ариадне вроде вштыривает когда код на 2 планетах пашет.

Ответить | Правка | К родителю #260 | Наверх | Cообщить модератору

289. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Ананимус (?), 05-Авг-22, 07:25 
> Не все же вебмакакингом заканчивается. Вон тот RT_LINUX явно не для вебмакак делают. А что, вы бы не хотели чтобы ваш код смог пилотировать аж к другой планете, например? А вон Ариадне вроде вштыривает когда код на 2 планетах пашет.

Не помню чтобы кого-то в НАСА посадили за зависший Линукс. Если у них начинает лажать софт, они тупо ребутают модуль управления, лол.

Ответить | Правка | К родителю #282 | Наверх | Cообщить модератору

308. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (-), 05-Авг-22, 21:35 
> Не помню чтобы кого-то в НАСА посадили за зависший Линукс. Если у
> них начинает лажать софт, они тупо ребутают модуль управления, лол.

В надежных системах комплексно к проблемам подходят. Но это кроме всего прочего делает такие системы сложнее и дороже. У NASA то денег много, а вот автомобиль по цене ракеты вам уже врядли зайдет. Поэтому там уже технологии попроще и подешевле, так что многократного резерва модулей может и не быть. И это не только там. Хотя пойнт что если из-за взвиса линукса что-то сильно плохое случается - валиден, но это не извиняет зависов системы.

Ответить | Правка | К родителю #289 | Наверх | Cообщить модератору

318. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Ананимус (?), 06-Авг-22, 00:15 
> В надежных системах комплексно к проблемам подходят. Но это кроме всего прочего делает такие системы сложнее и дороже. У NASA то денег много, а вот автомобиль по цене ракеты вам уже врядли зайдет. Поэтому там уже технологии попроще и подешевле, так что многократного резерва модулей может и не быть. И это не только там. Хотя пойнт что если из-за взвиса линукса что-то сильно плохое случается - валиден, но это не извиняет зависов системы.

Это резко обесценивает аргументацию нежелающих обновляться. Есть некая разница между "потратили дополнительные две недели на багфикс" и "убили человека", не находишь? И если цена вопроса это плюс пара недель на отладку мелких багов, то возникает напрашивается вывод: если эти люди настолько ленивые, что не готовы потратить немного времени на приведение проекта в актуальное состояние, почему за них это время должны трать авторы Rust, LVM и glibc, которым придется делать слои совместимости и прочее усложнение кода?

Ответить | Правка | К родителю #308 | Наверх | Cообщить модератору

274. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (-), 05-Авг-22, 01:38 
> А может проще не делать апдейтов там, где эти апдейты не нужны?

Вот вы сейчас авионику, космонавтику, automotive и прочее "ненужно" приложили то. Ну да, можно и на конской ж@пе ездить вечно, конечно, без этого вашего линукса. А линукс пусть только всякую пафосную дрянь для вебмкак рисует. Или нет? Воооооон тот движ по части RT_LINUX намекает что надо это все же не вебмакакам, наверное.

Ответить | Правка | К родителю #258 | Наверх | Cообщить модератору

243. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (-), 04-Авг-22, 15:40 
> А если чип сдохнет в процессе работы? Тебя тоже посадят?

Если проектировщик не смог в failsafe в критичной системе, он, очевидно, должен ответить за последствия. Это именно то что называется "criminal negligence", и за это - сажают. Добро пожаловать во взрослый мир, где as is может и не быть вариантом.

Ответить | Правка | К родителю #199 | Наверх | Cообщить модератору

251. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Ананимус (?), 04-Авг-22, 16:03 
>> А если чип сдохнет в процессе работы? Тебя тоже посадят?
> Если проектировщик не смог в failsafe в критичной системе, он, очевидно, должен
> ответить за последствия. Это именно то что называется "criminal negligence", и
> за это - сажают. Добро пожаловать во взрослый мир, где as
> is может и не быть вариантом.

Отлично! Тогда что мешает обновить ядро? :D

Ответить | Правка | Наверх | Cообщить модератору

275. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (-), 05-Авг-22, 01:51 
> Отлично! Тогда что мешает обновить ядро? :D

То что на нормальное тестирование обновления надо дофига ресурсов выделить и даже так лажа может проскочить. Все же код работающий 10 лет без приколов доверия внушает заведомо больше чем свеженаписаный.

Да, есть юнит тесты, есть функциональные тесты, тестирование в диком виде и проч, но - д@рьмо иногда случается. Даже у грандов. Вон Dreamliner немного накосячил в 1 из компьютеров. Минус два Dreamliner'а вместе с пассажирами. Не совсем удачный релиз, да?

А, кстати какой там кернел похрен. Если кто шарится в fly by wire сетках, это уже полный кабздец сам по себе.

Ответить | Правка | Наверх | Cообщить модератору

252. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Ананимус (?), 04-Авг-22, 16:07 
>> А если чип сдохнет в процессе работы? Тебя тоже посадят?
> Если проектировщик не смог в failsafe в критичной системе, он, очевидно, должен
> ответить за последствия. Это именно то что называется "criminal negligence", и
> за это - сажают. Добро пожаловать во взрослый мир, где as
> is может и не быть вариантом.
> Это именно то что называется "criminal negligence", и за это - сажают.

К слову нет, не сажают, потому что когда тойота начала давить людей из-за переполнения в сишной прошивке, то они отделались иском.

Ответить | Правка | К родителю #243 | Наверх | Cообщить модератору

276. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (-), 05-Авг-22, 01:53 
> К слову нет, не сажают, потому что когда тойота начала давить людей
> из-за переполнения в сишной прошивке, то они отделались иском.

А есть какие-то данные об участи кодеров?

NB сабж, кстати, без MMU/MPU точно так же переполнение словит, приколитесь? :)

Ответить | Правка | Наверх | Cообщить модератору

290. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Ананимус (?), 05-Авг-22, 07:37 
> А есть какие-то данные об участи кодеров?

Есть решение суда, там только компенсация ущерба.

> NB сабж, кстати, без MMU/MPU точно так же переполнение словит, приколитесь? :)

Ага, поэтому пускать тормозную систему через фирмварь это на редкость плохая затея.

Ответить | Правка | Наверх | Cообщить модератору

309. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (-), 05-Авг-22, 21:52 
> Есть решение суда, там только компенсация ущерба.

Это они легко отделались, если на этом все закончилось.

> Ага, поэтому пускать тормозную систему через фирмварь это на редкость плохая затея.

Как показала практика, двуногие глючнее любой фирмвари. Если дело приняло скверный оборот - они делают рефлекторную тапку в пол на тормоз. Это не есть эффективный способ тормозить, от чего много двуногих умирает по своей же глупости. Так что фирмвари ABS спасли чертому тучу жизней двуногих. А более современные авто вообще довольно сильно корректируют input от водителя, позволяя быть почти как Шумахер любой клаве, которые без этих подсистем убились бы нахрен, за отсутствием "чувства машины" вообще совсем.

Но вообще-то тойота факапнулась в электронном газе. Педальку процик обрабатывает, он ECU по шине отсылает мнение чего водитель хотел. А когда у процыка сорвало стек, потому что тойтчики лохи и не смогли оценку размера стэка, отлов что он переполнился, и перекрыли с дюжину правил MISRA, оказалось что переросший стэк накрыл область переменных. И вот фирмваре видит - "водитель сделал газ в пол". В переменной так написано. Проблема только в том что водитель не в курсе этого, ведь то что в переменной более не отражает состояние педали, там теперь труха из стека. И вот тут как вы понимаете, решившее поддать газу по своей инициативе авто - довольно неожиданная штука для водителя, может активно помочь помереть в дтп.

Ответить | Правка | К родителю #290 | Наверх | Cообщить модератору

316. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Ананимус (?), 06-Авг-22, 00:10 
> Как показала практика, двуногие глючнее любой фирмвари. Если дело приняло скверный оборот - они делают рефлекторную тапку в пол на тормоз. Это не есть эффективный способ тормозить, от чего много двуногих умирает по своей же глупости. Так что фирмвари ABS спасли чертому тучу жизней двуногих. А более современные авто вообще довольно сильно корректируют input от водителя, позволяя быть почти как Шумахер любой клаве, которые без этих подсистем убились бы нахрен, за отсутствием "чувства машины" вообще совсем.

Это все здорово, тока ABS прекрасно работает без электроники, если чо.

> Но вообще-то тойота факапнулась в электронном газе. Педальку процик обрабатывает, он ECU по шине отсылает мнение чего водитель хотел. А когда у процыка сорвало стек, потому что тойтчики лохи и не смогли оценку размера стэка, отлов что он переполнился, и перекрыли с дюжину правил MISRA, оказалось что переросший стэк накрыл область переменных. И вот фирмваре видит - "водитель сделал газ в пол". В переменной так написано. Проблема только в том что водитель не в курсе этого, ведь то что в переменной более не отражает состояние педали, там теперь труха из стека. И вот тут как вы понимаете, решившее поддать газу по своей инициативе авто - довольно неожиданная штука для водителя, может активно помочь помереть в дтп.

Все довольно просто -- если жизнь человека зависит от того, протек сегодня программист в стек или нет, то такую систему нужно выкидывать на помойку. Потому что сложность кода (особенно на CVE language, коим является C) не позволяет толком провести верификацию корректности реализации. Особенно когда в дело вступает компилятор, который, внезапно, тоже может налажать.

Ответить | Правка | К родителю #309 | Наверх | Cообщить модератору

222. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (105), 03-Авг-22, 18:50 
> А чо мешает заодно ядро-то обновить? А то потом выяснится, что нужна новая программа, а она хочет новой glibc. А новый glibc, внезапно, тоже хочет 3.2.

Сторонние модули, исходников которых нет.

Ответить | Правка | К родителю #175 | Наверх | Cообщить модератору

227. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Ананимус (?), 04-Авг-22, 13:33 
> Сторонние модули, исходников которых нет.

Бгг, классика embedded'а. Ядро 2.6.32 с модулями от сдохшей конторы, и все это преподносится как валидный use-case.

Ответить | Правка | Наверх | Cообщить модератору

229. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (105), 04-Авг-22, 13:41 
Оно работает. В отличии от...
Ответить | Правка | Наверх | Cообщить модератору

233. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Ананимус (?), 04-Авг-22, 13:55 
> Оно работает. В отличии от...

В отличии от чего? От glibc? glibc   тоже работает, тока теперь хочет 3.2 :D

Ответить | Правка | Наверх | Cообщить модератору

254. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (105), 04-Авг-22, 16:20 
В отличии от того, что собирается качая исходники сторонних модулей из инета.

Эти через пару лет собираться перестают.

Ответить | Правка | Наверх | Cообщить модератору

256. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Ананимус (?), 04-Авг-22, 16:40 
> В отличии от того, что собирается качая исходники сторонних модулей из инета.
>
> Эти через пару лет собираться перестают.

Ты же слышал про Cargo.lock, да?

Ответить | Правка | Наверх | Cообщить модератору

261. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (105), 04-Авг-22, 18:48 
И как это спасет от модуля, который тебе в наследство достался?

И там этого Cargo.lock не было?

Ответить | Правка | К родителю #256 | Наверх | Cообщить модератору

262. "В Rust будет прекращена поддержка старых Linux-систем"  +1 +/
Сообщение от Ананимус (?), 04-Авг-22, 18:53 
> И как это спасет от модуля, который тебе в наследство достался?
> И там этого Cargo.lock не было?

Cargo.lock есть во всех бинарных проектах. Он ссылается на версию и hash всех зависимостей, которые ему нужна. Сборка полностью повторяемая, даже если ты руками зависимости доставал, получая сырцы через матричный принтер по факсу. А сырцы продолбаются примерно с той же вероятностью, с которой продолбаются любые другие сырцы в Интернете. Для особо параноидальных есть локальные зеркала и cargo vendor.

Ответить | Правка | К родителю #261 | Наверх | Cообщить модератору

298. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (105), 05-Авг-22, 13:36 
>  А сырцы продолбаются примерно с той же вероятностью, с которой продолбаются любые другие сырцы в Интернете.

В корне неверная информация. Достать все релизы redhat - не проблема. Все исходики доступны всегда.

Ответить | Правка | К родителю #262 | Наверх | Cообщить модератору

303. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Ананимус (?), 05-Авг-22, 18:28 
> В корне неверная информация. Достать все релизы redhat - не проблема. Все исходики доступны всегда.

Ага. Модули руста тоже всегда доступны.

Ответить | Правка | К родителю #298 | Наверх | Cообщить модератору

277. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (-), 05-Авг-22, 01:53 
> В отличии от чего? От glibc? glibc   тоже работает, тока
> теперь хочет 3.2 :D

Кто ж глибсу то в эмбедовке с 2.6.32 использовал...

Ответить | Правка | К родителю #233 | Наверх | Cообщить модератору

291. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Ананимус (?), 05-Авг-22, 07:40 
Отлично, значит все продолжит работать и дальше. Чего истерить-то тогда?
Ответить | Правка | Наверх | Cообщить модератору

79. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Zenitur (ok), 02-Авг-22, 11:41 
У меня SLES 11 SP4, упомянутый в новости. Ядро тут 3.0, но я вручную обновил до 3.16
Ответить | Правка | К родителю #9 | Наверх | Cообщить модератору

155. "В Rust будет прекращена поддержка старых Linux-систем"  –3 +/
Сообщение от Michael Shigorinemail (ok), 02-Авг-22, 14:20 
Есть и 2.6.32, а что?

Некоторые же должны были с младенчества усвоить, что не надо каждую встречную блестяшку в рот тащить.

Некоторые, как видим, так в нём и остались.

Ответить | Правка | К родителю #9 | Наверх | Cообщить модератору

173. "В Rust будет прекращена поддержка старых Linux-систем"  +2 +/
Сообщение от Ананимус (?), 02-Авг-22, 15:26 
> Есть и 2.6.32, а что?

То, что оно не поддерживается апстримом?

> Некоторые же должны были с младенчества усвоить, что не надо каждую встречную
> блестяшку в рот тащить.
> Некоторые, как видим, так в нём и остались.

Я не знаю зачем вы засунули себе в рот 2.6.32 и теперь не хотите вытаскивать.

Ответить | Правка | Наверх | Cообщить модератору

164. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от InuYasha (??), 02-Авг-22, 14:39 
2.6 не трогать! Это святое!
Ответить | Правка | К родителю #9 | Наверх | Cообщить модератору

14. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (-), 01-Авг-22, 22:41 
> If you are targeting an old glibc version, consider targeting musl instead.

Низкоуровневые разработчики, итоги.

Ответить | Правка | Наверх | Cообщить модератору

279. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (-), 05-Авг-22, 02:03 
> Низкоуровневые разработчики, итоги.

Да, на сях есть штуки 4 стандартных либ на разные вкусы. Или даже больше. Даже у плюсов штуки 2-3 есть. А у хруста... эээ... одна либа и расстрел, на выбор? Ну замечательно, когда вон те хрены за кадром решают кого они "расстреливают" сегодня :)

Ответить | Правка | Наверх | Cообщить модератору

15. "В Rust будет прекращена поддержка старых Linux-систем"  +10 +/
Сообщение от Анонимemail (15), 01-Авг-22, 22:52 
Наш ржавый червячок начал постепенно отращивать крылышки и превращаться в в радужную обкуренную бабочку повторяя героический путь Perl 6 -> Raku...
...Сколько их еще таких будет... ))))
Ответить | Правка | Наверх | Cообщить модератору

24. "В Rust будет прекращена поддержка старых Linux-систем"  –7 +/
Сообщение от burjui (ok), 02-Авг-22, 00:52 
"Ржавый червячок", "радужную обкуренную бабочку"... испанский стыд. Очередной ыксперт, которому нечего сказать, но очень хочется передёрнуть на плюсики.
Ответить | Правка | Наверх | Cообщить модератору

51. "В Rust будет прекращена поддержка старых Linux-систем"  +7 +/
Сообщение от Аноним (50), 02-Авг-22, 09:50 
Очередной ыксперт, которому нечего сказать, но очень топит за раст при том что сам даже программировать не умеет.  
Ответить | Правка | Наверх | Cообщить модератору

72. "В Rust будет прекращена поддержка старых Linux-систем"  +2 +/
Сообщение от Аноним (72), 02-Авг-22, 11:27 
burjui один из 2х человек на всем opennet, который смог показать свой код, компилятор для risc-v

Ты же зафлудил всю новость, но ничего не показал

Ответить | Правка | Наверх | Cообщить модератору

76. "В Rust будет прекращена поддержка старых Linux-систем"  +1 +/
Сообщение от burjui (ok), 02-Авг-22, 11:36 
Умею

https://github.com/burjui/rambo

Ответить | Правка | К родителю #51 | Наверх | Cообщить модератору

245. "В Rust будет прекращена поддержка старых Linux-систем"  –2 +/
Сообщение от Аноним (-), 04-Авг-22, 15:51 
> Умею
> https://github.com/burjui/rambo

Ультраценный проект, уровня студенческой домашки. Toy programming language, без доков, без sample'ов. Спасибо, сразу видно кто топит за Rust.

Ответить | Правка | Наверх | Cообщить модератору

253. "В Rust будет прекращена поддержка старых Linux-систем"  +2 +/
Сообщение от burjui (ok), 04-Авг-22, 16:15 
>Ультраценный проект, уровня студенческой домашки

Это хобби-проект, мне плевать, какова его ценность для какого-то анона. И ты такую "домашку" в принципе не напишешь, потому что для этого нужно больше одной извилины.

>без доков, без sample'ов

Можно подумать, есть смысл пилить доки для хобби-проекта.

>Спасибо, сразу видно кто топит за Rust.

Impressive. Very nice. Let's see Paul Allen's code.
Ах да, аноны код не пишут же.

Ответить | Правка | Наверх | Cообщить модератору

278. "В Rust будет прекращена поддержка старых Linux-систем"  +1 +/
Сообщение от Аноним (-), 05-Авг-22, 01:57 
> Это хобби-проект, мне плевать, какова его ценность для какого-то анона. И ты
> такую "домашку" в принципе не напишешь, потому что для этого нужно
> больше одной извилины.

Я так то и получше написал. Просто это тот случай когда one who knows, doesn't speak. One who speaks doesn't knows.

> Можно подумать, есть смысл пилить доки для хобби-проекта.

Ггг наглядно иллюстрирует уровень хрустопроектов.

> Impressive. Very nice. Let's see Paul Allen's code.
> Ах да, аноны код не пишут же.

Да почему не пишут? :) Если б это было правдой - я бы не знал большинство вон тех вещей. Их можно узнать только практикуя. И говоря за себя если мой уровень вон тот я вообще постеснялся бы козырять таким проектом. А смысл? Прослыть эпичным наколенщиком? Ну так себе репутация :)

Ответить | Правка | Наверх | Cообщить модератору

285. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от burjui (ok), 05-Авг-22, 06:25 
> Я так то и получше написал. Просто это тот случай когда one
> who knows, doesn't speak. One who speaks doesn't knows.

"Так-то я и получше писал, но код не покажу. Ай олсо спик Инглишь вери гуд."

> Ггг наглядно иллюстрирует уровень хрустопроектов.

Который, всё же, выше нуля, который демонстрируешь ты.

> Если б это было правдой - я
> бы не знал большинство вон тех вещей. Их можно узнать только
> практикуя. И говоря за себя если мой уровень вон тот я
> вообще постеснялся бы козырять таким проектом. А смысл? Прослыть эпичным наколенщиком?
> Ну так себе репутация :)

Прослыть у кого, местной ылиты? Более жалких отмазок в жизни не слышал.

Короче, бздеть в мою сторону вы тут все мастера, но, увы, это всё, на что вы способны.

Ответить | Правка | Наверх | Cообщить модератору

310. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (310), 05-Авг-22, 22:14 
> "Так-то я и получше писал, но код не покажу.

Под чутка другим углом можно сказать и "у меня хотя-бы хватает ума не позориться тупыми потугами набить себе цену" :)

> Ай олсо спик Инглишь вери гуд."

I do. Эта поговорка, вроде бы, изначально китайская. Но мне впервые попалась в виде back-translate на инглиш. В русском нет хорошего эквивалента, буквальный перевод еще деревяннее, а англичане как я понимаю наполовину специально так говорят. Да и между нами, если ты будешь говорить так, амер спросит из какого ты штата. А если будешь умничать как ты сейчас, вопрос будет вида "MGIMO finished?" :P

> Который, всё же, выше нуля, который демонстрируешь ты.

Ваше мнение очень важно для нас.

> Прослыть у кого, местной ылиты? Более жалких отмазок в жизни не слышал.

Ну а перед кем ты пытался тут п@нтануться то, наверное не перед Торвальдсом же? :)

> Короче, бздеть в мою сторону вы тут все мастера,

Как впрочем и ты.

> но, увы, это всё, на что вы способны.

Ну, не факт. А про таких как ты было метко написано в одной книжке - "он думал что скажет хрю-хрю, но вышло лишь жалко уи-уи". Это хорошо отражает суть вон тех проектов и подобного понта в целом.

Ответить | Правка | Наверх | Cообщить модератору

321. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от n00by (ok), 06-Авг-22, 07:15 
> Эта поговорка, вроде бы, изначально китайская. Но мне впервые попалась
> в виде back-translate на инглиш. В русском нет хорошего эквивалента, буквальный
> перевод еще деревяннее, а англичане как я понимаю наполовину специально так
> говорят.

Неслыханные слова рождаются сами собой.
Ураганный ветер не может дуть с утра до вечера.
Буря с дождем не может продолжаться целыми днями.
Кто же установил это?
Небо и Земля.
Небо и Земля полны величия, однако и они не вечны,
тем более, может ли человек равняться с ними?!
И потому тот, кто в делах следует Дао,
устанавливает с ним связь.
Очищающий свой дух.
вступает в союз с силой Дэ.
Утративший эту связь,
не имеет ничего в своей жизни, кроме потерь.
Для того, кто имеет связь с Дао,
Дао — это то, что дает ему радость.
Для вступившего в союз с силой Дэ,
Дэ — это то, что дает ему радость.
Тот, кто утратил связь с Дао,
всю жизнь довольствуется этим.
Доказывающий не знает,
знающий не доказывает.

Ответить | Правка | Наверх | Cообщить модератору

323. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (323), 08-Авг-22, 03:51 
Бобёр, выдыхай!
Ответить | Правка | Наверх | Cообщить модератору

329. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от n00by (ok), 10-Авг-22, 11:26 
Из количества слов «Дао» и «Дэ» очевидно же, что это Дао-Де цзин, а не Ци-гун.
Ответить | Правка | Наверх | Cообщить модератору

325. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от burjui (ok), 08-Авг-22, 12:17 
> Под чутка другим углом можно сказать и "у меня хотя-бы хватает ума
> не позориться тупыми потугами набить себе цену" :)

Под таким углом и упасть можно.

> если ты будешь говорить так, амер спросит из какого ты штата.

После "doesn't knows" он ничего спрашивать не будет - тем более, когда это будет озвучено акцентом явно не коренного жителя.

> Ну а перед кем ты пытался тут п@нтануться то, наверное не перед
> Торвальдсом же? :)

Не понтовался, а просто оставил ссылку. Понтуетесь тут вы, псевдоэксперты, потому что потоки фекалий от вас (или из вас) не останавливаются (не конструктивной критики, заметь), а вот продемонстрировать свой реальный уровень вы банально ссыте, потому что боитесь, что ваш код здесь на смех поднимут такие же, как вы. Я же отдаю себе отчёт в том, что мой код оставляет желать лучшего, но я хотя бы осилил простой компилятор с оптимизациями в честный машинный код безо всяких LLVM. Всё, что мог и что не лень было, написал сам просто для того, чтобы доказать самому себе, что могу. И мне не стыдно выложить свой хобби-проект, который местные ыксперты, разумеется, будут оценивать с "профессиональной" точки зрения, при этом не показав ни строчки своего для сравнения. Да пусть. Как говорят американцы, talk is cheap :)

> А про таких как ты было метко написано в
> одной книжке - "он думал что скажет хрю-хрю, но вышло лишь
> жалко уи-уи".

Скорее, я тут пытаюсь общаться на человеческом, а в ответ слышу "хрю-хрю" да "уи-уи". Одни кривляния, детский лексикон, "хруст" и "сраст" - вот это ваш уровень. Даже код показать не можете. Код же писать надо, а это уже работа, да? Да не, нафиг надо, лучше бегать по новостям о языке, на котором даже писать не умеете, и петросянить. Так ведь сразу видно, что маститые эксперты, а не шпана, которой заняться нечем :)

Ответить | Правка | К родителю #310 | Наверх | Cообщить модератору

211. "В Rust будет прекращена поддержка старых Linux-систем"  +1 +/
Сообщение от Аноним (72), 03-Авг-22, 00:21 
Зачем вы поделитесь на толстенный тралинг местных дурачков? Нравится им выливать продукты жизнедеятельности на opennet, а администрации видеть это у себя на сайте, пусть
Зачем на это всё отвечать?
Ответить | Правка | К родителю #24 | Наверх | Cообщить модератору

215. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (72), 03-Авг-22, 07:53 
*поддаетесь
Ответить | Правка | Наверх | Cообщить модератору

326. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от burjui (ok), 08-Авг-22, 12:33 
Пока сижу дома со стопой в гипсе, нашёл себе развлечение - тестировать границы интеллекта местных экспертов. Вот просто интересно, насколько долго они могут поддерживать диалог, не прибегая к фактам и логике, на одних школьных понтах. Вдруг кто-то не выдержит и сорвётся? Или, ни дай бог, к дискуссии подключится адекватный оппонент, у которого даже можно чему-то научиться. Не волнуйся, как сниму гипс, у меня сразу появятся дела поинтереснее - работа, море и т.д.
Ответить | Правка | К родителю #211 | Наверх | Cообщить модератору

30. "В Rust будет прекращена поддержка старых Linux-систем"  –2 +/
Сообщение от ДаНуНафиг (?), 02-Авг-22, 04:09 
Может, наоборот будет меньше всяких костылей для поддержки старых никому не нужных систем?
Ответить | Правка | К родителю #15 | Наверх | Cообщить модератору

120. "В Rust будет прекращена поддержка старых Linux-систем"  +2 +/
Сообщение от Аноним (105), 02-Авг-22, 13:12 
> Может, наоборот будет меньше всяких костылей для поддержки старых никому не нужных систем?

Если появляются намеки на никому ненужные системы, то ищи поблизости ынтырпрайз.

Ответить | Правка | Наверх | Cообщить модератору

45. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (41), 02-Авг-22, 09:17 
Каков слог! Поэзия!
Ответить | Правка | К родителю #15 | Наверх | Cообщить модератору

56. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Вы забыли заполнить поле Name (?), 02-Авг-22, 10:10 
Браво! Браво!
Ответить | Правка | Наверх | Cообщить модератору

96. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (96), 02-Авг-22, 12:38 
Кукарезия
Ответить | Правка | К родителю #45 | Наверх | Cообщить модератору

89. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (96), 02-Авг-22, 12:31 
Хейтер перла не любит раст? Не удивительно.
Напомнить, сколько лет вы уже перл хороните? Пхп как хоронили, напомнить? Пыхоплеяда, помнишь были такие словечки лет 10 назад? Еще помямлишь лет пять и пойдешь переучиваться на голанг, где бывшие пхпшники тебя будут унижать на код ревью, потому что ты будешь тянуть чуть лучше джуна, если вообще.
Ответить | Правка | К родителю #15 | Наверх | Cообщить модератору

121. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (105), 02-Авг-22, 13:13 
> Напомнить, сколько лет вы уже перл хороните?

Раньше он шел по умолчанию. Сейчас на новую систему он не ставится - смысла нет. Вся системщина на питоне.

Ответить | Правка | Наверх | Cообщить модератору

170. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (96), 02-Авг-22, 15:07 
Смысла у него нет, спешите видеть. А две несовместимых версии питона есть смысл поставлять? Смыслитель ты наш.
Ответить | Правка | Наверх | Cообщить модератору

218. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (105), 03-Авг-22, 14:15 
Так это вы у разработчиков системщины спросите. Раньше системщина перл тянула, теперь нет. Теперь только питон. Иногда две версии - это да, но уже реже.
Ответить | Правка | Наверх | Cообщить модератору

19. "В Rust будет прекращена поддержка старых Linux-систем"  +2 +/
Сообщение от Аноним (72), 01-Авг-22, 23:07 
Что поделаешь. Миллиона который задонатили в rust foundation надолго не хватит
Ответить | Правка | Наверх | Cообщить модератору

20. "В Rust будет прекращена поддержка старых Linux-систем"  +5 +/
Сообщение от Урри (ok), 01-Авг-22, 23:22 
999 тысяч 999 потратили на смузи, оставшегося доллара не хватило нанять студента следить чтобы никто виртуалку с дженкинсом не выключил.
Ответить | Правка | Наверх | Cообщить модератору

36. "В Rust будет прекращена поддержка старых Linux-систем"  +2 +/
Сообщение от Бывалый смузихлёб (?), 02-Авг-22, 08:37 
Потратили, на самом деле, на сотню-и-один баксов больше - просто студент ещё и сам доплатил за "эту великую честь, приобщиться и помогать развитию Открытого и Свободного проекта"ТМ, но там где серваки часто отключают свет а тот студент не умеет их включать
Ответить | Правка | Наверх | Cообщить модератору

52. "В Rust будет прекращена поддержка старых Linux-систем"  +2 +/
Сообщение от Аноним (50), 02-Авг-22, 09:52 
Да практикант еще и бумагу для принтера сам купил.  
Ответить | Правка | Наверх | Cообщить модератору

142. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (138), 02-Авг-22, 14:04 
А принтер купили с донатов
Ответить | Правка | Наверх | Cообщить модератору

28. "В Rust будет прекращена поддержка старых Linux-систем"  +10 +/
Сообщение от Аноним (28), 02-Авг-22, 02:03 
Раст для луддитов, любители смузи уже две недели как переписывают свои хелоуворды на карбон.
Ответить | Правка | Наверх | Cообщить модератору

35. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (35), 02-Авг-22, 08:36 
Причем тут вообще язык? Язык - это логика. Не поддерживает IDE, компилятор? Если хотят сделать ЭТО в духе Java и C# ... Ну что же - успехов. С вечен. А этих сколько уже перебывало?
Ответить | Правка | Наверх | Cообщить модератору

46. "В Rust будет прекращена поддержка старых Linux-систем"  +1 +/
Сообщение от Аноним (41), 02-Авг-22, 09:21 
Что значит "при чём"? (кстати, твоя дислексия красноречива). Язык определяет мышление. Попробуй записывать химические реакции шахматной нотацией. То-то и оно.
Ответить | Правка | Наверх | Cообщить модератору

139. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (139), 02-Авг-22, 13:57 
> Язык определяет мышление.

Нет. Сегодня консенсус, что гипотеза Сепира-Уорфа (лингвистической относительности) в сильном смысле точно не верна

> Попробуй записывать химические реакции шахматной нотацией

А языки программирования мейнстримные всё Тьюринг-полны, так что алгоритмы можно написать на любом из них

Ответить | Правка | Наверх | Cообщить модератору

187. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (41), 02-Авг-22, 16:12 
Блин, я даже не понял, что ты сказал. Сливаюсь из дискуссии, сорри.
Ответить | Правка | Наверх | Cообщить модератору

284. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (-), 05-Авг-22, 03:58 
> А языки программирования мейнстримные всё Тьюринг-полны, так что алгоритмы можно написать
> на любом из них

В теории они все эквивалентны. На практике есть нюансы.

Ответить | Правка | К родителю #139 | Наверх | Cообщить модератору

42. "В Rust будет прекращена поддержка старых Linux-систем"  –1 +/
Сообщение от Аноним (44), 02-Авг-22, 09:09 
Cabron же.
Ответить | Правка | К родителю #28 | Наверх | Cообщить модератору

98. "В Rust будет прекращена поддержка старых Linux-систем"  –2 +/
Сообщение от burjui (ok), 02-Авг-22, 12:41 
Объясните кто-нибудь, что не так со смузи, и почему они ассоциируются с хипстерами, хотя существуют как минимум с момента выпуска первого советского кухонного комбайна.
Ответить | Правка | К родителю #28 | Наверх | Cообщить модератору

178. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от BorichL (ok), 02-Авг-22, 15:53 
Во времена, когда юзали советский кухонный комбайн, хипстеров называли ламерами.
Ответить | Правка | Наверх | Cообщить модератору

184. "В Rust будет прекращена поддержка старых Linux-систем"  +1 +/
Сообщение от burjui (ok), 02-Авг-22, 16:10 
Нет, дружок, ламерами называли ламеров - например, людей, неспособных и не желающих читать документацию (местные хейтерочки), а хипстеров называли модниками. Для наглядности:
- Хипстер бросится изучать Rust только потому, что это модно.
- Ламер принципиально не будет изучать Rust только потому, что это модно. Или, как вариант, изучит по диагонали главную страницу сайта, прочитает 10 строк кода (опционально) и побежит на Опеннет жаловаться, что его преследуют лживые маркетоиды, при этом приводя в пример исковерканные высказывания с главной страницы.
- Нормальный человек будет изучать Rust, если ему это интересно, и использовать, если полезно.
Ответить | Правка | Наверх | Cообщить модератору

283. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (-), 05-Авг-22, 02:15 
Ламер - это чайник, который думает что круто заварен (c) народная мудрость. Ты и твой код выглядите как вот именно это самое. То-есть убогая хня, показывающая как софтварные проекты делать не надо, если целью было что-то отличное от слива времени в унитаз неизвестно зачем. Зато с пафосом "могу показать код". Ну, круто, только я не понимаю в каком месте это доказывает что ты ниибаца програмер и что софт надо писать именно так.
Ответить | Правка | Наверх | Cообщить модератору

286. "В Rust будет прекращена поддержка старых Linux-систем"  +1 +/
Сообщение от burjui (ok), 05-Авг-22, 06:34 
Короче, код не покажешь, а жалкие попытки оправдаться за мой счёт можно было опустить.
Ответить | Правка | Наверх | Cообщить модератору

202. "В Rust будет прекращена поддержка старых Linux-систем"  +1 +/
Сообщение от Programmer (?), 02-Авг-22, 17:53 
Во времена советского союза это называлось томатный сок
Ответить | Правка | К родителю #98 | Наверх | Cообщить модератору

225. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Ф1 (?), 04-Авг-22, 08:23 
Яблочно-персиковый сок с мякотью :)
Ответить | Правка | Наверх | Cообщить модератору

314. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (-), 06-Авг-22, 00:01 
> Во времена советского союза это называлось томатный сок

Чего только не узнаешь на опеннете. Записать томатный сок в смузи это лихо.

Ответить | Правка | К родителю #202 | Наверх | Cообщить модератору

146. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (138), 02-Авг-22, 14:07 
Карбон - убийца Раста
Ответить | Правка | К родителю #28 | Наверх | Cообщить модератору

33. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от какая разница (?), 02-Авг-22, 05:50 
> ограниченные ресурсы по продолжению сопровождения совместимости со старыми окружениями.

А потом удивляетесь, почему люди используют "винду", которая даже в "десятке" позволяет запускать 16-битные приложения..

Ответить | Правка | Наверх | Cообщить модератору

34. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (34), 02-Авг-22, 06:12 
Просто плебеям пофиг, что линь тоже позволяет. Тока тс-с-с!
Ответить | Правка | Наверх | Cообщить модератору

40. "В Rust будет прекращена поддержка старых Linux-систем"  +2 +/
Сообщение от 1 (??), 02-Авг-22, 09:07 
Запусти мне в 10ке (ну или в 7ке) первую цивилизацию.
Ответить | Правка | К родителю #33 | Наверх | Cообщить модератору

53. "В Rust будет прекращена поддержка старых Linux-систем"  –1 +/
Сообщение от Аноним (50), 02-Авг-22, 09:53 
DosBox поставь не позорься.  
Ответить | Правка | Наверх | Cообщить модератору

59. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от какая разница (?), 02-Авг-22, 10:27 
Встречное предложение - запусти (хотя бы установи) handbrake 0.9x в убунту 20.04..
Ответить | Правка | К родителю #40 | Наверх | Cообщить модератору

67. "В Rust будет прекращена поддержка старых Linux-систем"  +1 +/
Сообщение от Аноним (22), 02-Авг-22, 11:19 
Скачал рип с old-games.ru, распаковал в семёрку и всё прекрасно запустилось (только курсор экран портит, ну тут вопросы к виртуалке, скорее всего).
Ответить | Правка | К родителю #40 | Наверх | Cообщить модератору

70. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (22), 02-Авг-22, 11:25 
Впрочем, win-версия первой цивы 32-битная, это не интересно, а вот и 16 бит: https://i.imgur.com/dRe3dMW.png
Ответить | Правка | Наверх | Cообщить модератору

231. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от 1 (??), 04-Авг-22, 13:45 
> Впрочем, win-версия первой цивы 32-битная, это не интересно, а вот и 16
> бит: https://i.imgur.com/dRe3dMW.png

Это вторая цива. Первая была 2D

Ответить | Правка | Наверх | Cообщить модератору

247. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (-), 04-Авг-22, 15:53 
> Впрочем, win-версия первой цивы 32-битная, это не интересно, а вот и 16
> бит: https://i.imgur.com/dRe3dMW.png

Римский Карта? Тоже вариант.

Ответить | Правка | К родителю #70 | Наверх | Cообщить модератору

95. "В Rust будет прекращена поддержка старых Linux-систем"  –1 +/
Сообщение от Аноним (96), 02-Авг-22, 12:37 
Люди используют винду, потому что ничего другого использовать не могут. Поддержка запуска старых программ в десяточке местами хуже, чем в Wine.
Ответить | Правка | К родителю #33 | Наверх | Cообщить модератору

112. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (112), 02-Авг-22, 13:04 
>потому что ничего другого использовать не могут

А надо?

Ответить | Правка | Наверх | Cообщить модератору

118. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (22), 02-Авг-22, 13:10 
Вот только людям нужно использовать не только старые программы, но и новые.
Ответить | Правка | К родителю #95 | Наверх | Cообщить модератору

180. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Ф1 (?), 02-Авг-22, 16:03 
>А потом удивляетесь, почему люди используют "винду", которая даже в "десятке" позволяет запускать 16-битные приложения..

Уже не позволяет 64 битная.

Ответить | Правка | К родителю #33 | Наверх | Cообщить модератору

320. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (-), 06-Авг-22, 00:37 
> Уже не позволяет 64 битная.

А в 64-битном линухе, так, кстати, можно если за каким-то хреном вдруг нужно. Что самое то интересное.

Ответить | Правка | Наверх | Cообщить модератору

38. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (44), 02-Авг-22, 09:03 
>Среди причин прекращения поддержки старых Linux-систем упоминаются ограниченные ресурсы по продолжению сопровождения совместимости со старыми окружениями.

Ну не любят люди работать. Любят смузи хлебать, а работать - ни-ни. Прискорбно, что значительная часть экосистемы теперь завязана на этих неадекватных бездельников.

Ответить | Правка | Наверх | Cообщить модератору

87. "В Rust будет прекращена поддержка старых Linux-систем"  +1 +/
Сообщение от Остас (?), 02-Авг-22, 12:26 
Так пойди поработай, дружок! Допивай свою смузи, заканчивай с последним комментом, и вперёд портировать контрибьютить!
Ответить | Правка | Наверх | Cообщить модератору

92. "В Rust будет прекращена поддержка старых Linux-систем"  +1 +/
Сообщение от Аноним (96), 02-Авг-22, 12:34 
И не только портировать, но и тестировать! Никто давно не пользуется такими древними версиями, так что баги можно выявить только тестированием!
Ответить | Правка | Наверх | Cообщить модератору

99. "В Rust будет прекращена поддержка старых Linux-систем"  –1 +/
Сообщение от burjui (ok), 02-Авг-22, 12:46 
Местные ыксперты работать умеют только языком. И все так ненавидят Rust, аж кушать не могут, но свой код (хоть на чём) не покажут, потому что или стыдно, или его нет.
Ответить | Правка | К родителю #87 | Наверх | Cообщить модератору

124. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (105), 02-Авг-22, 13:18 
Если кому-то код показывать не стыдно, то или он работает не ынтырпрайзе или он безстыжий.
Ответить | Правка | Наверх | Cообщить модератору

156. "В Rust будет прекращена поддержка старых Linux-систем"  +1 +/
Сообщение от burjui (ok), 02-Авг-22, 14:23 
В моём случае - оба. В данный момент пишу исключительно для себя, а код показывать не стыдно, потому что самое страшное, что может случиться - какой-то аноним расстроится. А если случится чудо, и кто-то выступит с конструктивной критикой кода, тогда я научусь чему-то полезному. Стыдно мне будет, если я не смогу написать рабочий код. А рабочий всегда можно довести до ума, если это действительно кому-то нужно.
Ответить | Правка | Наверх | Cообщить модератору

149. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (138), 02-Авг-22, 14:09 
Раст устарел, за что его любить? Уже есть Карбон
Ответить | Правка | К родителю #99 | Наверх | Cообщить модератору

266. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Вы забыли заполнить поле Name (?), 04-Авг-22, 21:42 
> Местные ыксперты работать умеют только языком

Судя по кол-ву комментариев от тебя - ты один из них.

Ответить | Правка | К родителю #99 | Наверх | Cообщить модератору

39. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (44), 02-Авг-22, 09:06 
>Будет прекращена поддержка

Старых версий Android, а также более новых кастомных поделок, но на старых ядрах, ибо проприетарные блобы с нарушением GPL.

Ответить | Правка | Наверх | Cообщить модератору

48. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от kusb (?), 02-Авг-22, 09:48 
А это проблема? Можно протащить на старое ядро новую Glibc?
Ответить | Правка | Наверх | Cообщить модератору

61. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (60), 02-Авг-22, 10:44 
Это проблема протаскиивающего лично.
Ответить | Правка | Наверх | Cообщить модератору

49. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним12345 (?), 02-Авг-22, 09:48 
Странно, я думал, что в линуксе можно забанить хруст, но не наоборот
Ответить | Правка | Наверх | Cообщить модератору

58. "В Rust будет прекращена поддержка старых Linux-систем"  +1 +/
Сообщение от Аноним (58), 02-Авг-22, 10:25 
Вся суть хипстеров - ломать устоявшееся.
Ответить | Правка | Наверх | Cообщить модератору

63. "В Rust будет прекращена поддержка старых Linux-систем"  +3 +/
Сообщение от fsb4000 (?), 02-Авг-22, 10:56 
В Clang и libc++ уже какое-то время были такие ограничения.

Норм, когда-то старые платформы прекращают поддерживать.

Ответить | Правка | Наверх | Cообщить модератору

66. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от fsb4000 (?), 02-Авг-22, 11:10 
С другой стороны мне кажется если кто-то из Опеннетовских экспертов вызовется поддерживать совместить Rust и старых glibc и находить обходные решения при реализации новых возможностей, то какое-то время поддержка в Rust могла бы сохраниться.

Но понятно, что никто на себя такие обязанности взваливать не будет, так как это сложно...

Ответить | Правка | Наверх | Cообщить модератору

90. "В Rust будет прекращена поддержка старых Linux-систем"  –1 +/
Сообщение от Аноним (96), 02-Авг-22, 12:33 
Ядер 2.6.32 нет в проде уже лет 10, проснитесь. Какой смысл поддерживать то, что никто не использует?
Ответить | Правка | Наверх | Cообщить модератору

214. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Zenitur (ok), 03-Авг-22, 06:34 
Не, ну RHEL 6 будет поддерживаться до 2024 года
Ответить | Правка | Наверх | Cообщить модератору

103. "В Rust будет прекращена поддержка старых Linux-систем"  –1 +/
Сообщение от burjui (ok), 02-Авг-22, 12:57 
Местные эксперты даже на русском-то писать не всегда умеют, а вы тут фантазируете :)
Ответить | Правка | К родителю #66 | Наверх | Cообщить модератору

182. "В Rust будет прекращена поддержка старых Linux-систем"  –1 +/
Сообщение от Аноним (182), 02-Авг-22, 16:07 
Да ты тоже в русском-то особо не преуспел.  
Ответить | Правка | Наверх | Cообщить модератору

128. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (105), 02-Авг-22, 13:22 
> Но понятно, что никто на себя такие обязанности взваливать не будет, так как это сложно...

Это особо сложно в rust. Тут механизмы условной компиляции не позволяют делать того-же, что можно в Си.

Ответить | Правка | К родителю #66 | Наверх | Cообщить модератору

226. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Ф1 (?), 04-Авг-22, 08:28 
>Тут механизмы условной компиляции не позволяют делать того-же, что можно в Си.

Вроде никаких проблем с простой условной компиляций в расте как и в D например (у которого тоже нет препроцессора) нет.

Ответить | Правка | Наверх | Cообщить модератору

232. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (105), 04-Авг-22, 13:48 
Покажи пример где бы одна и та же функция вызывалась с разными параметрами, ну и естественно код этой функции, где бы в одном случае этот параметр использовался а вдругом нет.

Естественно все за счет условной компиляции.

Ответить | Правка | Наверх | Cообщить модератору

257. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Ф1 (?), 04-Авг-22, 17:45 
>Покажи пример где бы одна и та же функция вызывалась с разными параметрами, ну и естественно код этой функции, где бы в одном случае этот параметр использовался а вдругом нет.

Надо бы на си пример и объяснить зачем такое нужно, мне как с++ программисту такое использование макросов кажется очень некрасивым.

Ответить | Правка | Наверх | Cообщить модератору

296. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (105), 05-Авг-22, 13:08 
https://github.com/torvalds/linux/blob/master/arch/arm/vfp/v...

А насчет красивости: Какая разница? Главное - работает и используется.

Ответить | Правка | Наверх | Cообщить модератору

301. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Ф1 (?), 05-Авг-22, 17:21 
> А насчет красивости: Какая разница? Главное - работает и используется.

Некрасиво на макросах и в расте такое просто делается: https://play.rust-lang.org/?version=stable&mode=debug&editio...

Ответить | Правка | Наверх | Cообщить модератору

330. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (105), 10-Авг-22, 14:40 
Где тут разное число аргументов у функции?

Может я чего не понимаю?

Ответить | Правка | Наверх | Cообщить модератору

333. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Ф1 (?), 14-Авг-22, 11:49 
> Где тут разное число аргументов у функции?

Там было у макроса разное число аргументов, для быстрого варианта с твоим лозунгом "главное - работает" вполне нормально, но  соорудить вариант с разным числом параметров у функции в релизе и отладке https://play.rust-lang.org/?version=nightly&mode=debug&editi... тоже несложно, и макросы можно переиспользовать в отличии от сишных для разных функций.


Ответить | Правка | Наверх | Cообщить модератору

195. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (138), 02-Авг-22, 16:51 
> если кто-то из Опеннетовских экспертов вызовется поддерживать совместить Rust и

Опеннетовские эксперты не любят Rust и не вызовутся поддерживать его совместить. Rust любят эксперты so, но они тоже не вызовутся его поддерживать.

Ответить | Правка | К родителю #66 | Наверх | Cообщить модератору

71. "В Rust будет прекращена поддержка старых Linux-систем"  +1 +/
Сообщение от Аноним (71), 02-Авг-22, 11:25 
Я думал что язык своей стандартной библиотекой опирается на вызовы ядра и только. Я ошибаюсь?
Ответить | Правка | Наверх | Cообщить модератору

108. "В Rust будет прекращена поддержка старых Linux-систем"  –1 +/
Сообщение от burjui (ok), 02-Авг-22, 13:00 
Но ведь всем же нужна совместимость с C.
Ответить | Правка | Наверх | Cообщить модератору

78. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Zenitur (ok), 02-Авг-22, 11:39 
Печально. Ubuntu 10.04 и Debian 6 - лучшие системы. Надеюсь, что при пересборке из исходников можно будет получить совместимость хоть с Debian 3.1
Ответить | Правка | Наверх | Cообщить модератору

83. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от забей (?), 02-Авг-22, 12:10 
зачем тебе свежий сабж на 10 бубунте?

последний раз раст обновлял для сборки ff-102, который 10 бубунте и d-6 не светит...
И там нужен 1.5х который будет работать, а не 1.64 который не будет работать а сентябре...

Ответить | Правка | Наверх | Cообщить модератору

85. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Zenitur (ok), 02-Авг-22, 12:24 
Ну как зачем, современный Firefox собирать

> который 10 бубунте и d-6 не светит...

Собрать GCC 11 и GTK 3.10 и норм

Ответить | Правка | Наверх | Cообщить модератору

100. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от забей (?), 02-Авг-22, 12:49 
> Ну как зачем, современный Firefox собирать
>> который 10 бубунте и d-6 не светит...
> Собрать GCC 11 и GTK 3.10 и норм

там чтоб "норм" пол системы надо перебрать...

Ответить | Правка | Наверх | Cообщить модератору

132. "В Rust будет прекращена поддержка старых Linux-систем"  +1 +/
Сообщение от Zenitur (ok), 02-Авг-22, 13:40 
Ну я в своей SLES 11 обновил компилятор до GCC 11. Там не надо пол-системы обновлять - достаточно gmp, mpc и mpfr, опционально isl. Вот пакеты:

https://download.opensuse.org/repositories/home:/linux4human.../

А вот GTK 3 я не собирал. Перешёл с фокса на Palemoon - он норм работает на старых дистрах. Сборку я делал сам, а так официальный билд требует что-то вроде Glibc 2.17 и Glib 2.30.

P.S. Щас SteamOS 2 мучаю (Debian 8), тут разработка прекратилась буквально в одном шаге до внедрения glvnd. Меса и драйвер NVIDIA уже переведены на эту либу, осталось только дождаться драйвера NVIDIA с поддержкой PRIME Offload... Я обновил иксы с 1.20.0 до 1.20.7, и дрова с 415 до 435 - и теперь всё пашет, я играю в стиме и через протон + DXVK.

В качестве браузера Palemoon. Думаю хром собрать, но вот только на Raspbian 8 (на базе всё того же Jessie) с этим были проблемы. Говорят, под Deb 8 невозможно собрать новый хром в принципе, там 58-я версия что ли последняя. Почему - не знаю.

Ответить | Правка | Наверх | Cообщить модератору

204. "В Rust будет прекращена поддержка старых Linux-систем"  +1 +/
Сообщение от забей (?), 02-Авг-22, 19:22 
на 16.04 собирается 90тый и все... под 9 дебиан аналогично...

я под 9 пробую 102-фокс - пока нифига не выходит каменный цветок...

Ответить | Правка | Наверх | Cообщить модератору

81. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (81), 02-Авг-22, 12:01 
> Rust
> Glibc

Причем тут C? Он же небезопасный.

Ответить | Правка | Наверх | Cообщить модератору

82. "В Rust будет прекращена поддержка старых Linux-систем"  +1 +/
Сообщение от Аноним (28), 02-Авг-22, 12:08 
Срочно надо написать Gliberust
Ответить | Правка | Наверх | Cообщить модератору

86. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (81), 02-Авг-22, 12:25 
> Gliberust

GnuLiberust.а

Любые совпадения случайны, никого не хотел обидеть

Ответить | Правка | Наверх | Cообщить модератору

151. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (138), 02-Авг-22, 14:12 
Они уже на Pythorust переписали
Ответить | Правка | К родителю #82 | Наверх | Cообщить модератору

88. "В Rust будет прекращена поддержка старых Linux-систем"  –1 +/
Сообщение от Анончик (?), 02-Авг-22, 12:28 
Раст написан на си. Так что вся эта безопасность - просто сказки.
Ответить | Правка | К родителю #81 | Наверх | Cообщить модератору

97. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (81), 02-Авг-22, 12:39 
Не знаток истории rust... ", но осуждаю"

В начале его написали на ocaml, и он имел сборщик мусора.

В данный момент он переобулся.
А агрессивный маркетинг воюет с тем из чего начинался (например, сборщик мусора), и с чем работает (небезопасный [lib]C)

Ответить | Правка | Наверх | Cообщить модератору

129. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от burjui (ok), 02-Авг-22, 13:23 
По-вашему получается, что "маркетинг" С воюет с ассемблером. При чём тут вообще маркетинг?
Ответить | Правка | Наверх | Cообщить модератору

131. "В Rust будет прекращена поддержка старых Linux-систем"  –1 +/
Сообщение от Аноним (81), 02-Авг-22, 13:31 
> ассемблером

ещё приписывает свои домыслы

Ответить | Правка | Наверх | Cообщить модератору

158. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от burjui (ok), 02-Авг-22, 14:25 
Это логическое развитие мысли. Сам подумай: зачем придумали C, когда был ассемблер? Чтобы упростить разработку. В случае с Rust то же самое. Получается, если Rust воюет с C, то C воюет с ассемблером. Или "это другое"?
Ответить | Правка | Наверх | Cообщить модератору

162. "В Rust будет прекращена поддержка старых Linux-систем"  –1 +/
Сообщение от Аноним (81), 02-Авг-22, 14:34 
> Это логическое развитие мысли.

Ты хочешь поговорить об этом?

Ответить | Правка | Наверх | Cообщить модератору

176. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (176), 02-Авг-22, 15:45 
Да, это правда. Лучшее - враг хорошего.
Ответить | Правка | К родителю #158 | Наверх | Cообщить модератору

196. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (22), 02-Авг-22, 17:06 
Про Си, наверное, так же говорили.
Ответить | Правка | Наверх | Cообщить модератору

315. "В Rust будет прекращена поддержка старых Linux-систем"  –2 +/
Сообщение от Аноним (-), 06-Авг-22, 00:07 
> Это логическое развитие мысли. Сам подумай: зачем придумали C, когда был ассемблер?
> Чтобы упростить разработку. В случае с Rust то же самое. Получается,
> если Rust воюет с C, то C воюет с ассемблером. Или
> "это другое"?

Вообще-то си придумали потому что
1) В ассемблере вообще нет средств структурирования программы и данных по сути. Хруст если и внес какие-то улучшения в этом аспекте, то и дров наломал не меньше, добавив закорюк и костылей.
2) У асемблера ключевой минус - программы не портабельны. А писать программу 5 раз заново на 5 разных архитектур... ну... э... не прикольно от слова совсем. Хруст в этом аспекте скорее регресс внес: С есть под почти все что шевелится, хруст - ну, скомпиль им прошивку вон тому 6502 или 8051, а куле, на си так можно было. Второй кстати до сих пор активно применяется, он педальный но его растащили на цитаты чипмейкеры.

Ответить | Правка | К родителю #158 | Наверх | Cообщить модератору

327. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от burjui (ok), 08-Авг-22, 13:11 
> прошивку вон тому 6502 или 8051, а куле, на си так
> можно было. Второй кстати до сих пор активно применяется, он педальный
> но его растащили на цитаты чипмейкеры.

Если протрёшь окно криокамеры, увидишь много интересного - например, Cortex-M, которые в 2022 г. уже в каждой дырке затычка. Под них можно писать на асме, C, C++, Rust, Pascal, Forth, Scheme, Python, Java, Lua... Прошивай хоть до посинения. И с отладкой там всё прекрасно, а у STM32 - ещё и с документацией. У Nordic Semiconductors в серии NRF - уже полноценные Cortex-M со встроенной радиопериферией и протоколами Bluetooth, Zigbee и пр. И это только вершина айсберга. Потом ещё RISC-V попрёт на рынки, поддержка которого уже есть везде, включая Rust.

6502 и 8051 - это конечно хорошо, чтобы поностальгировать, но, мягко говоря, не актуально. А если начистоту, то это уже окаменевшее говно мамонта. Кто сегодня в здравом уме будет писать под 8-битный камень? Какой смысл?

Ответить | Правка | Наверх | Cообщить модератору

106. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (22), 02-Авг-22, 12:59 
Вообще изначально всё написано на ассемблере.
Ответить | Правка | К родителю #88 | Наверх | Cообщить модератору

91. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (-), 02-Авг-22, 12:33 
>минимальные требования к Glibc будут подняты с версии 2.11 до 2.17

Я тоже удивлён. В зависимостях у Раста GNU libc?

Ответить | Правка | К родителю #81 | Наверх | Cообщить модератору

110. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Варенье (?), 02-Авг-22, 13:03 
Да:
❯ nm -D target/release/parser
                 U abort@GLIBC_2.2.5
                 U accept4@GLIBC_2.10
                 U bcmp@GLIBC_2.2.5
                 U bind@GLIBC_2.2.5
                 U calloc@GLIBC_2.2.5
                 U ceil@GLIBC_2.2.5
<...>

Так же и у Go, если не выставить CGO_ENABLED=0:
❯ nm -D server
                 U abort@GLIBC_2.2.5
00000000005886a0 T _cgo_panic
0000000000463c60 T _cgo_topofstack
00000000005886e0 T crosscall2
                 U __errno_location@GLIBC_2.2.5
                 U fprintf@GLIBC_2.2.5
                 U fputc@GLIBC_2.2.5
                 U free@GLIBC_2.2.5

Ответить | Правка | Наверх | Cообщить модератору

113. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от fi (ok), 02-Авг-22, 13:05 
Хороший вопрос!

я на собеседовании всегда задаю этот вопрос: "зачем в системе libc?"  - некоторые вспоминают :DDD

Ответить | Правка | К родителю #91 | Наверх | Cообщить модератору

114. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от burjui (ok), 02-Авг-22, 13:07 
При том, что:
1. Всем нужна совместимость с C, потому что на нём написана туева хуча уже работающих библиотек.
2. Rust разрабатывается не фанатиками с Опеннета, поэтому не запрещает вызывать небезопасный код - блоки unsafe именно для этого и предназначены. Т.к. весь остальной код по определению не может нагадить в память, сразу видно, где искать причины багов, связанных с памятью - в блоках unsafe.
Ответить | Правка | К родителю #81 | Наверх | Cообщить модератору

115. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (115), 02-Авг-22, 13:08 
Ах, эти фантазии, каждый раз умиляют.
Ответить | Правка | Наверх | Cообщить модератору

145. "В Rust будет прекращена поддержка старых Linux-систем"  –1 +/
Сообщение от burjui (ok), 02-Авг-22, 14:07 
А фантазии-то в чём?
Ответить | Правка | Наверх | Cообщить модератору

127. "В Rust будет прекращена поддержка старых Linux-систем"  –1 +/
Сообщение от Аноним (81), 02-Авг-22, 13:22 
> совместимость с C

glibc - это не совместимость, а необходимая зависимость (для std)

> не запрещает вызывать небезопасный код

"Не запрещает" до такой степени, что без небезопасных вызовов (lib)С функций ничего не работает.

Типичный "не фанатик с Опеннета", который подменяет понятия: совместимость-зависимость, "не запрещает" - "обязывает"

Ответить | Правка | К родителю #114 | Наверх | Cообщить модератору

144. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от burjui (ok), 02-Авг-22, 14:05 
>glibc - это не совместимость, а необходимая зависимость (для std)

Хотя бы потому, что по умолчанию используется системный аллокатор (malloc/free). И что в этом такого?

>"Не запрещает" до такой степени, что без небезопасных вызовов (lib)С функций ничего не работает.

Вообще-то, на Rust можно писать под Cortex-M* без использования сишных либ. Всё, включая обработчики прерываний, можно писать на Rust.

>Типичный "не фанатик с Опеннета", который подменяет понятия: совместимость-зависимость, "не запрещает" - "обязывает"

Типичный фанатик с Опеннета, которому лишь бы докопаться до чего-то, даже когда причин нет. Сегодня ему привязка к libc покоя не даёт, а завтра он начнёт ныть, что Rust дёргает syscall'ы вместо написания своей ОС.

Ответить | Правка | Наверх | Cообщить модератору

159. "В Rust будет прекращена поддержка старых Linux-систем"  –1 +/
Сообщение от Аноним (81), 02-Авг-22, 14:28 
> на Rust можно писать под ...

Говорят, на питоне тоже пишут. И?

> Сегодня ему привязка к libc покоя не даёт

Си покоя не дает фанатикам rust'а.
И когда их тыкаешь на зависимость _стандартного_ rust от _стандартной_ библиотеки Си, то у них начинаются, то что ты демонстрируешь своим поведением: я - не я, зависимость - не зависимость, это нехорошие сишники подбросили.

Ответить | Правка | Наверх | Cообщить модератору

161. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от burjui (ok), 02-Авг-22, 14:34 
Ты - наркоман, или с рождения с логикой не дружишь?

>Говорят, на питоне тоже пишут. И?

Что "и"? Причём здесь Python?

>И когда их тыкаешь на зависимость _стандартного_ rust от _стандартной_ библиотеки Си, то у них начинаются

Где я говорил, что это не зависимость? Кому C покоя не даёт? В Rust community никто в другие ЯП говном не бросается, в отличие от макак с Опеннета. Это вам Rust так покоя не даёт, что вы в каждую новость прибегаете, спустив штаны.

Ответить | Правка | Наверх | Cообщить модератору

168. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (81), 02-Авг-22, 14:46 
> Где я говорил... ?

Когда начал подменять понятия зависимость-совместимость. Чем это отличается от "я - не я"?

> Это вам Rust так покоя не даёт

Любое действие есть взаимодействие. Это Си вам покоя не дает.

Это вы зафлудили новости свои rust'ом, своими намерениями что-то сделать (угрозами?), а не совершенными действиями и случившимися событиями. Хорошо хоть что эта "новость о намерениях" без обязательных трех абзацев.

"Наша" реакция - это всего лишь следствие "вашего" беспокойства.

Ответить | Правка | Наверх | Cообщить модератору

172. "В Rust будет прекращена поддержка старых Linux-систем"  –1 +/
Сообщение от burjui (ok), 02-Авг-22, 15:19 
> Когда начал подменять понятия зависимость-совместимость. Чем это отличается от "я - не
> я"?

Я сказал, что зависимость от libc нужна для совместимости с C. Где здесь подмена понятий? Ты понимаешь смысл написанного, или просто реагируешь на отдельные слова? Про системный аллокатор читал?

> Это вы зафлудили новости свои rust'ом, своими намерениями что-то сделать (угрозами?), а
> не совершенными действиями и случившимися событиями. Хорошо хоть что эта "новость
> о намерениях" без обязательных трех абзацев.

Открываем главную страницу OpenNET и ищем слово "Rust". Не находим. Следующие 20 новостей - 1 новость про Rust. Ещё 20 - 1. Ещё 20 - 1. Ещё 20 - ни одной. Ещё 20 - ни одной. Ещё 20 - 1.

Открываем "мини-новости". Первая страница - 1 новость про Rust (ещё одна с упоминанием). Следующие 20 новостей - ни одной. Ещё 20 - ни одной. Ещё 20 - ни одной. Ещё 20 - 1 новость. Ещё 20 - ни одной.

ОЙ ЗАФЛУДИЛИ!!111

Вот из недавнего:
https://www.opennet.ru/opennews/art.shtml?num=57539

Никаких "угроз" (чему, настроению хейтерков?) - взяли, и сделали. Так всё равно в комментах нашлись недовольные. Вам не угодишь.

Ответить | Правка | Наверх | Cообщить модератору

174. "В Rust будет прекращена поддержка старых Linux-систем"  +1 +/
Сообщение от Аноним (81), 02-Авг-22, 15:28 
> Открываем главную страницу OpenNET и ищем слово ...

Теперь тоже самое сделай по другим языкам: c, c++, d, nim, ocaml и тд.

В сумме наберется столько же, сколько про rust? Хоть одно новость про _намерение_ стандартизировать c++23?

Ответить | Правка | Наверх | Cообщить модератору

190. "В Rust будет прекращена поддержка старых Linux-систем"  +2 +/
Сообщение от Аноним (182), 02-Авг-22, 16:17 
Да он фанатик не трать время.  
Ответить | Правка | Наверх | Cообщить модератору

191. "В Rust будет прекращена поддержка старых Linux-систем"  +1 +/
Сообщение от burjui (ok), 02-Авг-22, 16:28 
Во-первых, новые версии Rust выходят гораздо быстрее, поэтому новостей больше.
Во-вторых, видимо, другие языки настолько всем интересны, что аж некому писать новости.
В-третьих, нет ничего плохого в новостях о намерениях. Я предпочитаю узнавать о подобных вещах до того, как они станут стандартом де-факто или де-юре, чтобы была возможность поучаствовать в обсуждении. Во всяком случае, в Rust высказаться по теме может каждый, кому есть, что сказать - достаточно быть зарегистрированным на соответствующем форуме (internals.rust-lang.org). Вот ты возьми и напиши о намерении стандартизировать C++23, если тебе это интересно, многим интересно будет почитать, что их ждёт в ближайшем будущем. Возможно, и у них есть возможность повлиять на процесс, я не в курсе.
Ответить | Правка | К родителю #174 | Наверх | Cообщить модератору

230. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (105), 04-Авг-22, 13:43 
> Во-вторых, видимо, другие языки настолько всем интересны, что аж некому писать новости.

Возможно. Но скорее всего идет подогрев заинтересованных лиц писать про rust.

Ответить | Правка | Наверх | Cообщить модератору

246. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от burjui (ok), 04-Авг-22, 15:53 
А ещё тебя соседи облучают через розетку, да?
Ответить | Правка | Наверх | Cообщить модератору

255. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (105), 04-Авг-22, 16:24 
У тебя, я так понимаю, все авторы пишут бесплатно и безкорыстно, а журналюги верх безкорыстия и бесплатности.
Ответить | Правка | Наверх | Cообщить модератору

130. "В Rust будет прекращена поддержка старых Linux-систем"  +2 +/
Сообщение от Аноним (130), 02-Авг-22, 13:23 
> В частности, поддержка старых Glibc требует использования старого инструментария

А вот скажите, какая шмонька постоянно курочит API Glibc?
Что такого прорывного появляется, что нужно ломать базовое API?

Ответить | Правка | Наверх | Cообщить модератору

136. "В Rust будет прекращена поддержка старых Linux-систем"  +2 +/
Сообщение от Zenitur (ok), 02-Авг-22, 13:51 
Там понимаешь, если делать билд со старым Glibc, то всё будет работать во всех новых Glibc. А если делать билд с новым Glibc, то со старыми Glibc данный билд работать не будет.

Есть такие термины "прямая совместимость" и "обратная совместимость". Так вот, Glibc обладает обратной совместимостью. А "прямая совместимость", это когда ещё и сборки, слинкованные с новым Glibc, будут работать со старыми Glibc.

Ещё по-моему можно указывать параметры при сборке, чтобы ограничиваться, скажем, вызовами исключительно Glibc 2.3, не выше. Например когда я общался с ребятами из Unigine, я им сказал, что Valley хочет уж слишком новый Glibc, которого у меня не было. Они как-то это поправили, теперь сборка хочет Glibc 2.3.

Ответить | Правка | Наверх | Cообщить модератору

141. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (141), 02-Авг-22, 14:04 
А это не вопрос к базовому API, т.к. есть стандарт POSIX (в котором почти всё API описано)... это вопрос к системам сборки. Если кратко - проект у glibc хреново написан. Лично видел проверки типа "подходят gcc с версиями 3.[3-9] или 4.*". А сейчас на дворе уже двухзначные версии ;)

Проверку тоже добавляли не от хорошей жизни (видимо код старым компилятором не компилировался), но добавили её как смогли... ибо autotools м shell.

Ответить | Правка | К родителю #130 | Наверх | Cообщить модератору

219. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (105), 03-Авг-22, 14:21 
В тех версиях компилятор gcc ломал ABI.

Вот эта проверка и стоит. С тех пор ничего не менялось.

Ответить | Правка | Наверх | Cообщить модератору

143. "В Rust будет прекращена поддержка старых Linux-систем"  +1 +/
Сообщение от Аноним (143), 02-Авг-22, 14:04 
Какая-то истеричная ненависть коллективного разума Опеннета к Расту, да и другим современным вещам прям так и прёт. И ведь не по технической части часто критикуют, а по какой-то такой что "смузи", "хипстеры". Как будто тут одни старички 60+ лет сидят, критикуют "распутную" молодёжь...
Ответить | Правка | Наверх | Cообщить модератору

166. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (22), 02-Авг-22, 14:40 
Здешний коллективный разум сишечку едва осилил, и теперь считает её божественным языком.
Про смузи и хипстеров вообще забавно, да: про них уже, наверное, даже в КВН не шутят.
Ответить | Правка | Наверх | Cообщить модератору

167. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Аноним (105), 02-Авг-22, 14:45 
> "смузи", "хипстеры"

Это отношение к разработке. Когда работает на одной конкретной платформе (контеёнере), и пересобрать чере какое-то время не получится, ибо истема сборки вытаскивает пакеты из инета.

Ответить | Правка | К родителю #143 | Наверх | Cообщить модератору

147. "В Rust будет прекращена поддержка старых Linux-систем"  –1 +/
Сообщение от Zenitur (ok), 02-Авг-22, 14:09 
В принципе, блин, могу закинуть на свой личный OBS-репозиторий (ссылку на который я публиковал выше по треду) пакетики с Rust. Пусть собираются, подтягивая новые версии из официальной openSUSE-репо (с разницей лишь в том, что в последней создаются сборки для SLES 15). Кому-то реально нужна поддержка Linux 2.6.32 и Glibc 2.11?
Ответить | Правка | Наверх | Cообщить модератору

154. "В Rust будет прекращена поддержка старых Linux-систем"  +1 +/
Сообщение от Аноним (138), 02-Авг-22, 14:17 
Rust был неплохим языком, но он устарел и уже не актуален. Все кто идет в ногу с прогрессом переходят на Carbon.
Ответить | Правка | Наверх | Cообщить модератору

177. "В Rust будет прекращена поддержка старых Linux-систем"  +1 +/
Сообщение от InuYasha (??), 02-Авг-22, 15:53 
Каждый раз теперь вспоминаю: увидел однажды репортах про "очередную хрень от Собякина", где репортёрша чётко выговорила "ноГА В НОгу со временем...". Так доставило! :))
Ответить | Правка | Наверх | Cообщить модератору

209. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Онаним (?), 02-Авг-22, 20:37 
А, то есть там на замену новая, ещё более самая-самая лучшая однодневочка поспевает?
Ответить | Правка | Наверх | Cообщить модератору

208. "В Rust будет прекращена поддержка старых Linux-систем"  +2 +/
Сообщение от Онаним (?), 02-Авг-22, 20:08 
Очень хорошо. Можно ещё сразу поддержку новых Linux-систем прекратить?
Ответить | Правка | Наверх | Cообщить модератору

221. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Janis (?), 03-Авг-22, 18:31 
Жду реакции Торвальдса на это. Надеюсь,найдутся люди, которые начнут развитие ядра Линукс без Раста!
Ответить | Правка | Наверх | Cообщить модератору

265. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Вы забыли заполнить поле Name (?), 04-Авг-22, 21:37 
> Жду реакции Торвальдса на это. Надеюсь,найдутся люди, которые начнут развитие ядра Линукс
> без Раста!

Он уже не тот. Раньше всех неугодных материл и жесты им показывал. А что теперь? Молчит в тряпочку под угрозой расправы. Плюс не будет он гадить в кормящие руки.

Ответить | Правка | Наверх | Cообщить модератору

319. "В Rust будет прекращена поддержка старых Linux-систем"  –1 +/
Сообщение от Аноним (-), 06-Авг-22, 00:16 
Опять тут какие-то шестерки с своими проекциями повылезли. Сказал бы корпоративные, но по спичу больше похоже на слугу мафиози каких-то.
Ответить | Правка | Наверх | Cообщить модератору

223. "В Rust будет прекращена поддержка старых Linux-систем"  +/
Сообщение от Grishow Wise (ok), 03-Авг-22, 19:27 
Не убудет, мы Си учили.
Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру