The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Решение проблем с некорректно установленными пакетами в Debian и Ubuntu
После обновления ОС и установки gnome столкнулся с проблемой:

   dpkg: ../../src/packages.c:191: process_queue: Assertion 'dependtry <= 4' failed

Соотвественно пакеты больше не ставились и не обновлялись. Погуглив решил
проблему следующим образом:

   sudo dpkg -l | grep -v ^ii

dpkg -l выводит список установленных пакетов, 
grep -v ^ii - оставляет в выводе только неправильно установленные пакеты. 
После получения списка таких пакетов, удалил первый из списка неправильно
установленный пакет командой

   sudo dpkg -purge remove имя_пакета

После вышеуказанных манипуляций проблема ушла.
 
15.09.2008 , Автор: Okulov Vitaliy , Источник: http://vokulov.ru/2008/09/13/dpkg-e...
Ключи: dpkg, debian, linux, packet
Раздел:    Корень / Администратору / Система / Linux специфика / Установка и работа с пакетами программ в Linux

Обсуждение [ RSS ]
  • 1.1, User294 (ok), 02:27, 16/09/2008 [ответить]  
  • +/
    >    dpkg: ../../src/packages.c:191: process_queue: Assertion 'dependtry <= 4' failed

    Мне кажется что по поводу такой проблемы корректное решение - наколотить баг про такую ругань. Ну не должен пакетный манагер ТАК ругаться при инсталле пакетов. Это по сути внутренняя ошибка. Если пакетному манагеру что-то не нравится - пусть изволит сказать что и где не так. Не в плане строки кода а в плане названия пакета и конкретного описания проблемы. То что потанцевав с бубном можно проблему обойти - это хорошо.Но плохо то что проблема (состоящая в левой ругани из-за по сути внутренней ошибки) никуда от этого не денется.Лечить надо причины, а не следствия.

     
     
  • 2.3, Аноним (3), 12:45, 16/09/2008 [^] [^^] [^^^] [ответить]  
  • +/
    http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=349442
     
     
  • 3.5, User294 (ok), 14:39, 16/09/2008 [^] [^^] [^^^] [ответить]  
  • +/
    >http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=349442

    А там написано: Fixed in version dpkg/1.13.20

    У меня только 1 вопрос: где вы такую хламежную версию взяли?!В попавшихся под руку дебианах он был как минимум версии .25 а в убунте и вовсем .14.х :)

     
     
  • 4.6, Аноним (3), 14:48, 16/09/2008 [^] [^^] [^^^] [ответить]  
  • +/
    sudo dpkg --version
    Debian 'dpkg' package management program version 1.14.22 (i386).
     
     
  • 5.7, User294 (ok), 15:04, 16/09/2008 [^] [^^] [^^^] [ответить]  
  • +/
    >Debian 'dpkg' package management program version 1.14.22 (i386).

    А это откуда такой?

    И что, он все-равно страдает вон той граблей? Баг приведенный выше помечен как исправленый в версии 1.13.20 и закрыт (что логично). Соответственно от более новых версий не ожидается что они будут страдать этим багом. Если все-таки страдают, нет более новых исправленых версий и на это нет другого бага, может его все-таки стоит завести?Проверив ессно что у вас последняя возможная версия и что никто не чинил это в более свежих версиях чтобы не создавать дупы багов (с этим у дебиана и убунты вообще душно - стоит только завести баг как его тут же обзовут дупом, потому что почти все возможные :D баги у них уже и так есть).

     

  • 1.2, Евгений (??), 11:02, 16/09/2008 [ответить]  
  • +/
    > sudo dpkg -l | grep -v ^ii

    Эта команда выдаёт гораздо больше, чем все неправильные пакеты.

    Правильнее делать sudo dpkg --configure -a -D0777
    Будут показаны все цепочки зависимостей. Берём самые длинные цепочки и смотрим, какой пакет в конце. Вот он и проблемный. Удаляем и радуемся.

     
     
  • 2.4, Аноним (3), 12:46, 16/09/2008 [^] [^^] [^^^] [ответить]  
  • +/
    Главное, что пакет не установлен корректно. А на каком этапе при установке сломалось - неважно.
     

     Добавить комментарий
    Имя:
    E-Mail:
    Заголовок:
    Текст:




    Спонсоры:
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2021 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру