The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Установка Adobe Сreative Suite 4 в Wine
Инструкция по установке Adobe CS 4 под управлением Wine 1.1.26 в Ubuntu 9.04

Устанавливаем инструменты для сборки:

   sudo aptitude install build-essential checkinstall

Создаем резервную копию конфигурации wine:

   mv ~/.wine ~/.wineBACKUP

Удаляем ранее установленную старую версию wine:

   sudo aptitude remove wine

Добавляем Launchpad PPA репозиторий с новейшими версиями Wine:

   sudo sh -c "echo 'deb http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu jaunty main' >> /etc/apt/sources.list"
   sudo sh -c "echo 'deb-src http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu jaunty main' >> /etc/apt/sources.list"

Добавляем ключи, которыми подписаны пакеты:

   sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys F9CB8DB0

Обновляем информацию о содержимом репозиториев:

   sudo apt-get update

Устанавливаем зависимости, необходимые для пересборки пакета с Wine:

   sudo apt-get build-dep wine

Создаем директорию для сборки и переходим в нее:

   mkdir ~/source/
   cd ~/source/

Загружаем исходные тексты wine и переходим в рабочую директорию:

   apt-get source wine
   cd wine*

Загружаем и применяем дополнительные патчи, необходимые для установки Adobe CS4:

   wget http://bugs2.winehq.org/attachment.cgi?id=22139 -O pseudo_start_msi_MTA_thread.diff
   patch -p1 < pseudo_start_msi_MTA_thread.diff

Собираем Wine из исходных текстов:

   ./configure
   make -j3 depend && make -j3

Формируем пакет для Ubuntu:

   sudo checkinstall

Загружаем winetricks и инициируем загрузку дополнительных модулей, необходимых
для установки и работы Adobe CS4:

   wget http://www.kegel.com/wine/winetricks
   chmod a+x winetricks
   sudo mv winetricks /usr/local/bin/
   winetricks msxml6 gdiplus gecko vcrun2005 ie6 corefonts fontsmooth-rgb

Загружаем из сети недостающую библиотеку atmlib.dll (находим от куда качать через поиск в Google):

   mv atmlib.dll ~/.wine/drive_c/windows/system32/

Запускаем конфигуратор Wine и переходим в секцию накопителей (вкладка Drives),
удаляем диск Z:, который указывает на корень ФС.
Затем добавляем диск, указывающий на источник установки, например на корень
инсталляционного CD/DVD/

Переходим в каталог с установочным образом Adobe CS4 и запускаем процесс установки:

   cd /media/cdrom0/Adobe\ CS4/
   wine Setup.exe

Следуем инструкциям на экране, выбрав параметры установки по умолчанию. Если
кнопка "Next" не нажимается
мышью, на нее следует переместить фокус через нажатие клавиши Tab и нажать Enter.
В момент установки Illustrator может произойти крах, но после нажатия "Ok" установка продолжится.
 
03.09.2009 , Источник: http://www.sucka.net/2009/08/instal...
Ключи: wine, adobe, photoshop, install / Лицензия: CC-BY
Раздел:    Корень / Пользователю / Wine

Обсуждение [ Линейный режим | Показать все | RSS ]
  • 1.1, Filosof (?), 19:58, 03/09/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    это надо как-то переименовать в "установку Вайн для продвинутых" -:)
    Вообще - сойдёт. Щас нашему дезайнеру ссылку дам
     
  • 1.2, Vcoder (?), 09:14, 04/09/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Поясните пожалуйста. Может я чего не понимаю, но... Фотошоп - это ведь очень дорогая программа. По сравнению с ним винда стоит вообще копейки. Если очень нужен именно фотошоп (гимп не подходит) - то зачем тратить кучу сил на обеспечение его работы в линухе? Почему бы не заюзать нативную ОСь (винду то есть)? Для чего тратить время разработчиков вайна на обеспечение работы фотошопа? Почему бы не направить эти человекоресурсы на добавление в гимп той функциональности, из-за которой люди выбирают фотошоп?
     
     
  • 2.3, аноним (?), 10:02, 04/09/2009 [^] [^^] [^^^] [ответить]  
  • +/
    >Фотошоп - это ведь очень дорогая программа

    всего лишь несколько сотен. зарплата за месяц или даже меньше, у кого как

    >По сравнению с ним винда стоит вообще копейки.

    не копейки, если говорить об ultimate, но дешевле, это верно
    макось ещё дешевле, если не считать железо

    >Почему бы не заюзать винду?

    осведомитесь о значении слова "линуксоид". вопросы тут же исчезнут

    >Для чего тратить время разработчиков вайна на обеспечение работы фотошопа?
    >Почему бы не направить эти человекоресурсы на добавление в гимп той функциональности

    между вайном и гимпом почти никакой связи. вайн пилится, гимп пилится
    недавно вышел первый тестовый снапшот версии 2.8

     
     
  • 3.5, Vcoder (?), 10:14, 05/09/2009 [^] [^^] [^^^] [ответить]  
  • +/
    > между вайном и гимпом почти никакой связи

    А я и не проводил связь между вайном и гимпом. Я проводил связь между вайном и фотошопом. Поиск по опеннету по запросу "wine photoshop" как бы символизирует.

    Нет, серьёзно: зачем использовать линукс, если всё равно приходится использовать виндовые, да к тому же и отнюдь недешёвые, программы?

    Нет, даже не так, а вот так:
    Зачем тратить усилия на обеспечение работы в линухе дорогих виндовых программ? Не лучше ли потратить эти усилия на создание или улучшение свободных аналогов этих программ?

    Речь о "правильном" использовании, когда софт честно покупается. Я всячески одобряю использование линукса и СПО вообще, но я не вижу смысла использовать линукс там, где основными рабочими программами будут такие, как к примеру фотошоп, автокад и т.п.

     

  • 1.4, Hook (??), 10:18, 04/09/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Фотошоп не нужен, вот Lightroom - да... За статью - спасибо.
     
  • 1.6, sashok (?), 17:35, 05/09/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    не работает. ошибка при установке, правда брал CS4 русский
     
  • 1.9, Designer (?), 23:05, 06/09/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Данная установка является бредом- в фотошопе под вайном невозможно проверить цвета,они банально не совпадут даже если будет задан пантон и еще около сотни крупных косяков, завязанных на систему.
    Если у кого зреют нездоровые мысли использования фотошопа на linux, то пишите петицию в адобе. :)
     
     
  • 2.10, test (??), 10:03, 07/09/2009 [^] [^^] [^^^] [ответить]  
  • +/
    В лучшем случае (хоть ответят) тебя пошлют (культурно конечно), а быстрее всего даже и не станут отвлекаться на какую-то петицию.
     
  • 2.12, Valik (?), 12:03, 07/09/2009 [^] [^^] [^^^] [ответить]  
  • +/
    а это для тех, кто иначе кроп картинки не умеет делать ничем, кроме как CS4 :)
     
     
  • 3.15, Анонимуз (?), 11:39, 09/09/2009 [^] [^^] [^^^] [ответить]  
  • +/
    Это да. Фотошоп для кропа и убирания красных глаз - наш выбор :-D
     

  • 1.11, Vyacheslav (??), 11:46, 07/09/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Предлагаю изменить название статьи с "Установка Adobe Сreative Suite 4 в Wine"
    на "Установка Adobe Photoshop CS4 в Wine", тк
    в Сreative Suite 4 кроме Adobe Photoshop есть еще не мало программ, которые явно не работают и не будут работать, да и даже элементарно запускаться под wine.
     
  • 1.13, Filosof (?), 19:55, 07/09/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    народ, вы гоните!
    Адоб не так мало денег отвалил Вайну за обеспечение максимальной совместимости линуха с фотожабой(првада тогда ещё cs2). И оно где надо отлично работает. Потому "зачем" - это не вопрос! Про софт сказано верно. Винда таки дешевле. Однако с виндой тоже бывают косяки. И поддержка оси пусть даже через костыль - очень правильно, на мой взгляд.
    Статья - можно сказать для тех, кто знает, что жаба работает, но запустить так и не смог.
    У ня дизайнер чудно под вайном и CS3 портабл юзал. И корел... Кста, более свежие версии этого софта даже лучше работают чем старые...

    И да, я юзаю пиратку, ибо гимпом дезигнер не смог удовлитворится, а бабок на лицензию нет. А вот Корел он чудесно заменил inkscape'ом

     
     
  • 2.14, Александр (??), 12:32, 08/09/2009 [^] [^^] [^^^] [ответить]  
  • +/
    корел-просто чудо профи программа :) если бы у вас действительно был дезигнер вы бы знали слово иллюстратор,а в кореле мальчики и девочки друг другу визитки рисуют
     
     
  • 3.16, убий сибя ап стену (?), 12:38, 09/09/2009 [^] [^^] [^^^] [ответить]  
  • +/
    знаток 8)
     

  • 1.17, Anton (??), 15:46, 28/09/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    есть одна засада, первая установка прерывается и программа установки пишет: что мол не удалось фотошоп установить.
    Последующие запуски установки проводят к зацикливанию команды в терминале: "fixme:shdocvw:InPlaceActiveObject_TranslateAccelerator (0x147b20)->(0x132088)"
    ну соответственно виснет программа установки.
    подобная фигня случалась на разных версиях wine
    я юзаю uubuntu jaunty 9.04
    Все делал по гайду
    Может кто-нибудь подскажет что бы это могло означать.

    ссылка на скриншот http://xmages.net/show.php/511655_.png.html

     
  • 1.18, Константин (??), 21:37, 04/03/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    я хочу еще дописать что кроме Илюстратора и Фотошопа, аналоги которых существуют под линуксом, то есть у Адоба замечательная программа Адобе Флеш аналога которого нет под Линух, в связи с этим прошу помощи в установке, потому что у меня не получилось делал все по гайду, а так как я только начал общатся с линуксом то я еще много чего не понимаю. У кого есть возможность, желание и время прошу помощи.
     


     Добавить комментарий
    Имя:
    E-Mail:
    Заголовок:
    Текст:




    Спонсоры:
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2020 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру