The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Конвертация Chrome-дополнения для запуска в Firefox
Для установки в Firefox браузерных дополнений на базе API WebExtension,
подготовленных только для Chrome или Opera, можно использовать дополнение
Foxified (https://github.com/Noitidart/Chrome-Store-Foxified). Проблема в том,
что Foxified не может быть запущен, начиная с Firefox 57, в котором была
прекращена поддержка XUL/XPCOM.

В качестве обходного пути предлагается параллельно с основной актуальной
версией Firefox установить Firefox 56 и запустить в нём Foxified.

Перед началом работы следует зарегистрироваться в каталоге дополнений Mozilla
AMO (https://addons.mozilla.org) или войти в существующую учётную запись для
последующего формирования цифровой подписи.

Далее нужно скопировать URL Chrome-дополнения из Chrome WebStore и добавить его
через меню "add to firefox, available on chrome" в Foxified. После этого во
вкладке "chrome store foxified" нужно принять соглашение  Mozilla AMO. После
завершения преобразования в верхнем правом углу появится кнопка "add" с
предложением установить дополнение.

После этого переходим на страницу about:debugging  и активируем режим отладки
дополнений ("enable add-on debugging"). Находим в списке дополнений
преобразованное дополнение и определяем его идентификатор
(Extension ID), заданный в форме "*@chrome-store-foxified-*".

Закрываем Firefox 56 и находим в каталоге с дополнениями Firefox
(/.mozilla/firefox/*/extensions) xpi-файл с найденным идентификатором.
Запускаем актуальный Firefox и устанавливаем полученный xpi-файл через кнопку с
шестерёнкой в менеджере дополнений (about:addons), выбрав в меню "Install
Add-on from File".
 
05.03.2020 , Источник: https://github.com/Noitidart/Chrome...
Ключи: chrome, firefox, extention, webextention, convert / Лицензия: CC-BY
Раздел:    Корень / Пользователю / Работа с Web и Ftp

Обсуждение [ RSS ]
  • 1.1, Аноним (1), 10:58, 05/03/2020 [ответить]  
  • +/
    > В качестве обходного пути предлагается параллельно с основной актуальной

    версией Firefox установить Firefox 56 и запустить в нём Foxified.

    Какой-то цирк.

     
  • 1.2, Аноним (2), 18:38, 05/03/2020 [ответить]  
  • +/
    пожалуй я не знаю настолько нужных дополнений
     
  • 1.3, О (?), 06:59, 09/03/2020 [ответить]  
  • +/
    То есть нужно спалить неподдерживаемому расширению учетку мозиллы и потом на время о нем забыть?
     
     
  • 2.4, X86 (ok), 08:37, 28/03/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Расширению надо спалить учетку для этого расширения
     

  • 1.5, mandms (?), 18:03, 28/03/2020 [ответить]  
  • +/
    Делал плагин для Firefox 57+, Кто пробовал кто скажет насколько легко Firefox плагин перенести в Chrome?
     
     
  • 2.6, Аноним (6), 01:28, 13/05/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Для хромого можно воспользоваться полифиллом для Web Extension API, только на днях собирал расширение, полёт нормальный

    https://github.com/mozilla/webextension-polyfill

     

     Добавить комментарий
    Имя:
    E-Mail:
    Заголовок:
    Текст:




    Спонсоры:
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2020 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру