The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Вышел релиз языка программирования Ruby 1.8.7 и фреймворка Ruby on Rails 2.1.

01.06.2008 20:23

Через шесть месяцев после выхода фреймворка для создания web-приложений Ruby on Rails 2.0 вышла новая версия - Ruby on Rails 2.1. Из нововведений стоит отметить:

  • поддержку часовых поясов;
  • «грязные» объекты;
  • зависимости от gem-ов;
  • именованные рамки;
  • миграции, датированные по UTC;
  • улучшенное кеширование.

Почти одновременно был выпущен релиз языка программирования Ruby 1.8.7, в котором кроме исправления ошибок, проведена работа нацеленная на увеличение производительности. Кроме того, в новую версию были портированы некоторые улучшения из экспериментальной ветки Ruby 1.9.

  1. Главная ссылка к новости (http://weblog.rubyonrails.org/...)
  2. OpenNews: Вышел релиз Ruby on Rails 2.0
  3. OpenNews: Первый релиз в новой экспериментальной ветке Ruby 1.9
  4. Ruby 1.8.7 Changelog
  5. Changes since the 1.8.6 release - новшества
Автор новости: ufaweb
Тип: Программы
Короткая ссылка: https://opennet.ru/16231-ruby
Ключевые слова: ruby, ror
При перепечатке указание ссылки на opennet.ru обязательно
Обсуждение (4) RSS
  • 1, Mikhailov Anatoly (?), 14:33, 27/11/2008 [ответить]  
  • +/
    http://railsgeek.com/2008/11/27/ubuntu-8-10-downgrade-ruby-1-8-7-to-1-8-6
     
     
  • 2, Andrey Mitrofanov (?), 15:43, 27/11/2008 [^] [^^] [^^^] [ответить]  
  • +/
    >railsgeek.com/2008/11/27/ubuntu-8-10-downgrade-ruby-1-8-7-to-1-8-6

    Для сведения: эта новость, про выход rails 2.1 была --
    01.06.2008 20:23

    ...меня смутило только то, что на днях уже была --
    24.11.2008 12:59  Опубликован релиз web-фреймворка Ruby on Rails 2.2

    Но, да 2.2: видимо, ещё нет в репозитариях, 1.8.7 уже кое-где может и быть...
    Вот в Debian lenny -- 2.1.0 и 1.8.7.72.

    В каком 1.8.7.NN починили и починили ли эту проблему, если знаете?

    ----
    И вообще - сейчас по ссылке из ссылки написано
    "We recommend Ruby 1.8.7 for use with Rails. Ruby 1.8.6, 1.8.5, 1.8.4 and 1.8.2 are still usable too, but version 1.8.3 is not.",
    а по ссылке непосредственно -
    "We recommend Ruby 1.8.6 for use with Rails. Ruby 1.8.7, 1.8.5, 1.8.4 and 1.8.2 are still usable too, but version 1.8.3 is not. Ruby 1.8.7 still has some bugs to straighten out.".

    Хотелось бы восстановить %) целостную картину мира. Кто кого обманывает, где чего починили, кто кого сломал, пытается сломать и пр.?

     
  • 3, Andrey Mitrofanov (?), 16:26, 27/11/2008 [^] [^^] [^^^] [ответить]  
  • +/
    "As you may know Ruby 1.8.7 don't compatable with Rails" <--> "Ruby 1.8.7 breaks backward compatibility and is only compatible with Rails 2.1 and later,"

    Увлекательно - не то слово. :)

    Видимо, всё-таки имеется в виду установка "старого" ruby со "старым" rails -- вместо "штатных" новых в составе _новой_ ubuntu -- для _приложений_ ещё не мигрировавших (ещё не или не совместимых) на rails 2.1 или выше.

     
     
  • 4, Mikhailov Anatoly (?), 18:44, 27/11/2008 [^] [^^] [^^^] [ответить]  
  • +/
    Буквально за 2 часа разработчики Rails изменили свое решение по поводу совместимости версии Ruby для своего фреймворка. Что ж будем ждать, когда Radiant и прочее будут нормально работать с Ruby 1.8.7

    >"As you may know Ruby 1.8.7 don't compatable with Rails" <--> "Ruby 1.8.7 breaks backward compatibility and is only compatible with Rails 2.1 and later,"
    >
    >Увлекательно - не то слово. :)
    >
    >Видимо, всё-таки имеется в виду установка "старого" ruby со "старым" rails --
    >вместо "штатных" новых в составе _новой_ ubuntu -- для _приложений_ ещё
    >не мигрировавших (ещё не или не совместимых) на rails 2.1 или
    >выше.

     
     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2020 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру